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About This Guide
This manual introduces you to the GNOME graphical desktop environment as imple-
mented in openSUSE and shows you how to configure it to meet your personal needs
and preferences. It also introduces you to several programs and services, including office
programs such as OpenOffice.org, Web browsers, file managers, scanning tools, and
image editing tools. It is intended for users who have some experience using a graphical
desktop environment such as Macintosh*, Windows*, or other Linux desktops.

This guide contains the following parts:

• Part I, “GNOME Desktop” (page 1)

• Part II, “Office and Collaboration” (page 101)

• Part III, “Internet” (page 169)

• Part IV, “Multimedia” (page 181)

• Appendix C, Getting to Know Linux Software (page 223)

1 Audience
This guide is intended for users of the GNOME desktop.

2 Feedback
We want to hear your comments and suggestions about this manual and the other doc-
umentation included with this product. Please use the User Comments feature at the
bottom of each page of the online documentation, or go to http://www.novell
.com/documentation/feedback.html and enter your comments there.

http://www.novell.com/documentation/feedback.html
http://www.novell.com/documentation/feedback.html


3 Documentation Updates
For the latest version of this documentation, see the http://www.novell.com/
documentation/opensuse102Web site.

4 Additional Documentation
There are other manuals available on this product. If you want to have a look at the
other end user documentation for openSUSE, the followingmanualsmight be interesting:

Start-Up
Guides you through the installation and basic configuration of your system. For
newcomers, the manual also introduces basic Linux concepts such as the file system,
the user concept and access permissions and gives an overview of the features
openSUSE offers to support mobile working. Provides help and advice in trou-
bleshooting.

KDE User Guide
This manual introduces the KDE desktop of openSUSE and a variety of applications
you will encounter when working with the KDE desktop. It guides you through
using these applications and helps you perform key tasks. It is intended mainly for
end users who want to make efficient use of applications running on the KDE
desktop.

openSUSE also comes with a comprehensive manual for system administrators and
home users with basic system administration knowledge. Check out Reference for ad-
vanced system administration tasks and a general understanding of openSUSE.

For an overview of all manuals shipped with openSUSE, refer to http://www
.novell.com/documentation/opensuse102/, where you can also download
the manuals. You can also access the information online in the Help Center of your
desktop.
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5 Documentation Conventions
The following typographical conventions are used in this manual:

• /etc/passwd: filenames and directory names

• placeholder: replace placeholder with the actual value

• PATH: the environment variable PATH

• ls, --help: commands, options, and parameters

• user: users or groups

• Alt, Alt + F1: a key to press or a key combination; keys are shown in uppercase as
on a keyboard

• File, File→ Save As: menu items, buttons

• Dancing Penguins (Chapter Penguins, ↑Reference): This is a reference to a chapter
in another book.

6 About the Making of This Manual
This book is written in Novdoc, a subset of DocBook (see http://www.docbook
.org). The XML source files were validated by xmllint, processed by xsltproc,
and converted into HTML using a customized version of Norman Walsh's stylesheets.

About This Guide ix

http://www.docbook.org
http://www.docbook.org




Part I. GNOME Desktop





1Getting Started with the
GNOME Desktop
This chapter assists you in becoming familiar with the conventions, layout, and common
tasks of the GNOME desktop as implemented in SUSE® Linux*.

• Section 1.1, “Logging in and Selecting a Desktop” (page 4)

• Section 1.2, “Logging Out” (page 6)

• Section 1.3, “Desktop Basics” (page 6)

• Section 1.4, “Using the Main Menu” (page 10)

• Section 1.5, “Accessing Folders and Files” (page 14)

• Section 1.6, “Opening or Creating Documents with OpenOffice.org” (page 30)

• Section 1.7, “Exploring the Internet” (page 30)

• Section 1.8, “E-mail and Calendering” (page 30)

• Section 1.9, “Moving Text between Applications” (page 31)

• Section 1.10, “Other Useful Programs” (page 31)

• Section 1.11, “Obtaining Software Updates” (page 32)

Getting Started with the GNOME Desktop 3



1.1 Logging in and Selecting a
Desktop

When you start your system, you are prompted to enter your username and password.
This is the username and password you created during installation. If you did not install
the system, check with your system administrator for the username and password.

The login has three menu items:

• Login Prompt: Enter your username and password to log in.

• Session: Specify the desktop to run during your session. If other desktops are
installed, they appear in the list.

• Actions: Perform a system action, such as shut down the computer, reboot the
computer, or configure the Login Manager.

• Section 1.1.1, “What Is a Session?” (page 4)

• Section 1.1.2, “Switching Desktops” (page 5)

• Section 1.1.3, “Locking Your Screen” (page 5)

1.1.1 What Is a Session?
A session is the period of time from when you log in to when you log out. The login
screen offers several login options. For example, you can select the language of your
session so that text that appears in the interface is presented in that language.

After your username and password are authenticated, the Session Manager starts. The
Session Manager lets you save certain settings for each session. It also lets you save
the state of your most recent session and return to that session the next time you log in.

The Session Manager can save and restore the following settings:

• Appearance and behavior settings, such as fonts, colors, and mouse settings.

• Applications that you were running. such as a file manager or an OpenOffice.org
program.
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TIP

You cannot save and restore applications that Session Manager does not
manage. For example, if you start the vi editor from the command line in
a terminal window, Session Manager cannot restore your editing session.

For information on configuring session preferences, see Section 2.4.8, “Managing
Sessions” (page 90).

1.1.2 Switching Desktops
If you installed both the GNOME and the KDE desktops, use the following instructions
to switch desktops.

1 Click Computer→ Logout→ Ok.

In KDE, click N→ Logout→ Logout.

2 On the login screen, click Session.

3 Select the desktop you want (GNOME or KDE), then click OK.

4 Type your username, then press Enter.

5 Type your password, then press Enter.

1.1.3 Locking Your Screen
To lock the screen, you can do either of the following:

• Click Computer→ Lock Screen.

• If the Lock button is present on a panel, click it.

To add the Lock button to a panel, right-click the panel and then click Add to Panel
→ Actions→ Lock.
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When you lock your screen, the screen saver starts. To lock your screen correctly, you
must have a screen saver enabled. To unlock the screen, move your mouse to display
the locked screen dialog. Enter your username and password, then press Enter.

For information on configuring your screen saver, see Section 2.2.5, “Configuring the
Screen Saver” (page 69).

1.2 Logging Out
When you are finished using the computer, click Computer→ Logout. Then select one
of the following:

• Log out

Logs you out of the current session and returns you to the Login dialog.

• Shut down

Logs you out of the current session, then turns off the computer.

• Restart the computer

Logs you out of the current session, then restarts the computer.

• Suspend the computer

Saves the current memory contents to disk and shuts down the computer. When
you restart, the saved memory content is loaded and you can resume where you
left off.

1.3 Desktop Basics
Aswith other common desktop products, themain components of the GNOMEdesktop
are icons that link to files, folders, or programs, as well as the panel at the bottom of
the screen (similar to the Task Bar in Windows). Double-click an icon to start its asso-
ciated program. Right-click an icon to access additional menus and options. You can
also right-click any empty space on the desktop to access additional menus for config-
uring or managing the desktop itself.
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By default, the desktop features two key icons: your personal Home folder, and a trash
can for deleted items. Other icons representing devices on your computer, such as CD
drives, might also be present on the desktop. If you double-click your Home folder, the
Nautilus file manager starts and displays the contents of your home directory. For more
information about using Nautilus, see Section 1.5.1, “Managing Folders and Files with
the File Manager” (page 14).

Right-clicking an icon displays a menu offering file operations, like copying, cutting,
or renaming. Selecting Properties from the menu displays a configuration dialog. The
title of an icon as well as the icon itself can be changed with Select Custom Icon. The
Emblems tab lets you add graphical descriptive symbols to the icon. The Permissions
tab lets you set access permissions for the selected files. The Notes tab lets you manage
comments. The menu for the trash can additionally features the Empty Trash option,
which deletes its contents.

A link is a special type of file that points to another file or folder. When you perform
an action on a link, the action is performed on the file or folder the link points to. When
you delete a link, you delete only the link file, not the file that the link points to.

To create a link on the desktop to a folder or a file, access the object in question in File
Manager by right-clicking the object and then clickingMake Link. Drag the link from
the File Manager window and drop it onto the desktop.

• Section 1.3.1, “Default Desktop Icons” (page 7)

• Section 1.3.2, “Desktop Menu” (page 8)

• Section 1.3.3, “Bottom Panel” (page 8)

• Section 1.3.4, “Adding Applets and Applications to the Panel” (page 9)

1.3.1 Default Desktop Icons
To remove an icon from the desktop, simply drag it onto the trash can. However, be
careful with this option—if you move folder or file icons to the trash can, the actual
data is deleted. If the icons only represent links to a file or to a directory, only the links
are deleted.
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NOTE

You cannot move the Home icon to the trash.

1.3.2 Desktop Menu
Right-clicking an empty spot on the desktop displays a menu with various options.
Click Create Folder to create a new folder. Create a launcher icon for an application
with Create Launcher. Provide the name of the application and the command for
starting it, then select an icon to represent it. You can also change the desktop back-
ground and align desktop icons.

1.3.3 Bottom Panel
The desktop includes a panel across the bottom of the screen. The bottom panel contains
the Computer menu (similar to the Start menu in Windows) and the icons of all appli-
cations currently running. You can also add applications and applets to the panel for
easy access. If you click the name of a program in the taskbar, the program's window
is moved to the foreground. If the program is already in the foreground, a mouse click
minimizes it. Clicking a minimized application reopens the respective window.

Figure 1.1 GNOME Bottom Panel

The Show Desktop icon is on the right side of the bottom panel. This icon minimizes
all programwindows and displays the desktop. Or, if all windows are alreadyminimized,
it opens them up again.

If you right-click an empty spot in the panel, a menu opens, offering the options listed
in the following table:
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Table 1.1 Panel Menu Options

DescriptionOption

Opens a menu list of applications and applets that can be
added to the panel.

Add to Panel

Modifies the properties for this panel.Properties

Removes the panel from the desktop. All of the panel settings
are lost.

Delete This Panel

Creates a new panel and adds it to the desktop.New Panel

Opens the Help Center.Help

Opens information about the panel application.About Panels

1.3.4 Adding Applets and Applications to
the Panel

You can add applications and applets to the bottom panel for quick access. An applet
is a small program, while an application is usually a more robust stand-alone program.
Adding an applet puts useful utilities where you can easily access them.

The GNOME desktop comes with many applets. You can see a complete list by right-
clicking the bottom panel and selecting Add to Panel. Some useful applets include the
following:
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Table 1.2 Some Useful Applets

DescriptionApplet

Look up a word in an online dictionary.Dictionary Lookup

Terminate an application. This is especially useful if you
want to terminate an application that is no longer respond-
ing.

Force Quit

Find files, folders, and documents on the computer.Search for Files

Create, display, and manage sticky notes on your desk-
top.

Sticky Notes

Access programs from a menu like the one in previous
versions of GNOME. This is especially useful for people
who are used to earlier versions of GNOME.

Traditional Main Menu

Increase or decrease the sound volume.Volume Control

Display current weather information for a specified city.Weather Report

Access additional work areas, calledworkspaces, through
virtual desktops. For example, you can open applications

Workspace Switcher

in different workspaces and use them on their own
desktops without the clutter from other applications.

1.4 Using the Main Menu
Open the main menu by clicking Computer on the far left of the bottom panel. Com-
monly used applications appear in the main menu. A search field lets you quickly search
for applications and files. You can access additional applications, listed in categories,
by clickingMore Applications.
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Figure 1.2 Main Menu

The main menu contains several elements. Each of these elements is described in the
following sections.

• Section 1.4.1, “Search Bar” (page 11)

• Section 1.4.2, “Show Menu” (page 11)

• Section 1.4.3, “System” (page 13)

• Section 1.4.4, “Status” (page 13)

1.4.1 Search Bar
The search bar helps you find applications and files on your system. For more informa-
tion about using the GNOME desktop’s search function, see Section 1.5.3, “Finding
Files on Your Computer” (page 21).

1.4.2 Show Menu
You can determine which icons appear in the main menu by clicking the Show menu.
There are three available views:

• Section “Favorite Applications” (page 12)
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• Section “Recently Used Applications” (page 12)

• Section “Recent Documents” (page 13)

Favorite Applications
By default, the Favorite Applications menu shows icons for several commonly used
applications. Use this view to show the applications you use most often.

To add an item to your Favorite Applications:

1 Click ComputerMore Applications.

2 Right-click the application you want to add.

3 Select Add to Favorites.

The selected application is added to your Favorite Applications.

To remove an item from your Favorite Applications:

1 Click Computer.

2 Make sure that your Favorite Applications appear in the main menu.

If Favorite Applications does not appear in the Show menu, click the menu and
select Favorite Applications.

3 Right-click the item you want to remove.

4 Select Remove from Favorites.

The removed application no longer appears in your Favorite Applications.

Recently Used Applications
Recently Used Applications shows the last several applications you have started. Use
this view to quickly find applications you have used recently.
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Recent Documents
Recent Documents shows the last several documents you have opened. Use this view
to quickly locate the documents you worked on most recently.

1.4.3 System
System provides shortcuts to several system applications.

Table 1.3 System Shortcuts

DescriptionApplication

Opens the Help Center, which provides online documentation for
your system.

Help

Helps you customize and configure your system. For more infor-
mation, see Chapter 2, Customizing Your Settings (page 35).

Control Center

Opens the Software Installer, which guides you through the process
of installing new software.

Install Software

Locks your system so nobody can access it while you are away.
Enter your password to unlock the system.

Lock Screen

Opens the Log Out dialog, where you can log out, shut down or
restart your system, or suspend the computer.

Log Out

1.4.4 Status
Status displays information about your hard drive and network connection, including
the amount of available space on your hard disk and the type of network connection
you are using.
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1.5 Accessing Folders and Files
You can access folders and files on your computer and on a network.

• Section 1.5.1, “Managing Folders and Files with the File Manager” (page 14)

• Section 1.5.2, “Accessing Floppy Disks, CDs, or DVDs” (page 20)

• Section 1.5.3, “Finding Files on Your Computer” (page 21)

• Section 1.5.4, “Accessing Files on the Network” (page 25)

1.5.1 Managing Folders and Files with the
File Manager

Use the File Manager to create and view folders and documents, run scripts, and create
CDs of your data. In addition, the File Manager provides support for Web and file
viewing.

You can open the File Manager in the following ways:

• Click Computer→ Home Folder

• Double-click your Home directory icon on the desktop.

• Click Computer→ More Applications→ File Manager.
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Figure 1.3 File Manager

You can change to the browser mode by right-clicking the folder, then clicking Browse
Folder. This gives you a familiar view with a location window that shows the current
path and buttons for common functions. This applies to the current FileManager window.

Figure 1.4 File Manager in Browser Mode
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Some simple shortcuts for navigating in the File Manager include the following:

Table 1.4 File Manager Navigation Shortcuts

DescriptionShortcut

Opens the parent folder.<— or Alt + ↑

Selects an item.↑ or ↓

Opens an item.Alt + ↓, or Enter

Opens an item and closes the current folder.Shift + Alt + ↓

Opens the parent folder and closes the current
folder.

Shift + Alt + ↑

Closes all parent folders.Shift + Ctrl +W

Opens a location by specifying a path or URL.Ctrl + L

Opens your home directory.Alt + Home

For more information, click Help→ Contents in the File Manager.

You can change the File Manager preferences by clicking Edit→ Preferences. The
configurable preferences are organized on five tabs:

• Section “Views” (page 17)

• Section “Behavior” (page 18)

• Section “Display” (page 19)

• Section “List Columns” (page 19)

• Section “Preview” (page 19)
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Views
To configure the appearance of the File Manager, click Edit→ Preferences→ Views,
then select from the following options:

Table 1.5 File Manager Views Options

DescriptionOptionSection

Determines whether new folders are dis-
played as icons or as a list.

View new folders usingDefault
View

Sets the order items are listed in. Items can
be listed by name, size, type, modification
date, or emblems.

Arrange items

Places this folder at the top of the list, if
this check box is selected (the default).

Sort folder before files

Shows hidden files and backup files in
your directories. If this check box is not

Show hidden and backup
files

selected (the default), hidden and backup
files do not appear.

Sets the size of items that appear in the
File Manager.

Default zoom levelIcon View
Defaults

Displays items closer together.Use compact layout

Displays icon captions next to the icons,
rather than under them.

Text beside icons

Determines the size of items that appear
in the list view.

Default zoom levelList View
Defaults

When selected, displays on folders in the
tree in the side pane.

Show only foldersTree View
Defaults
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Behavior
To configure the behavior of the File Manager, click Edit→ Preferences→ Behavior,
then select from the following options:

Table 1.6 File Manager Behavior Options

DescriptionOption

Performs the default action for an item
when you click the item. If this option is

Single Click to Activate Item

selected and you point to an item, the title
of the item is underlined.

Performs the default action for an item
when you double-click the item.

Double Click to Activate Items

Opens the File Manager in Browser mode
whenever you open it.

Always Open in Browser Windows

Runs an executable file when you click
the file. An executable file is a text file
than can execute (that is, a shell script).

Run Executable Files When They Are
Clicked

Displays the contents of an executable file
when you click the file.

View Executable Files When They Are
Clicked

Displays a dialog when you click an exe-
cutable file. The dialog asks whether you
want to execute the file or display the file.

Ask Each Time

Displays a confirmation message before
the Trash is emptied or before files are
deleted.

Ask Before Emptying Trash or Deleting
Files

Adds aDeletemenu item to the Editmenu
and the pop-up menu that is displayed

Include aDelete Command That Bypass-
es Trash

when you right-click a file, folder, or
desktop object. When you select an item
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DescriptionOption

and click Delete, the item is immediately
deleted from your file system.

Display
To configure the way icon captions and dates appear in the File Manager, click Edit→
Preferences→ Display, then select from the following options:

Table 1.7 File Manager Display Options

DescriptionOption

Sets the order of information to appear
beneath icon names. You can set three

Icon captions

information types, in the order that they
appear.

Configures the date format.Date

List Columns
To configure the columns that appear in the File Manager, as well as the order in which
they appear, click Edit→ Preferences→ List.

Select the columns that you want to appear. To change the order, clickMove Up or
Move Down.

Preview
To configure how file previews appear in the File Manager and whether or not folders
show the number of items they contain, click Edit→ Preferences, then set the following
options:
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Table 1.8 File Manager Preview Options

DescriptionOption

Specifies when to preview the content of
text files in the icons that represent the
files.

Show text in icons

Specifies when to show thumbnails of
image files in the icons that represent the
files.

Show thumbnails

Specifies the maximum file size for files
represented by thumbnails.

Only for files smaller than

Specifies when to preview sound files.Preview sound files

Specifies when to show the number of
files contained in folders. In the Icon

Count number of items

view, you might need to increase your
zoom level to see the number.

1.5.2 Accessing Floppy Disks, CDs, or DVDs
To access floppy disks, CDs, or DVDs, insert the medium into the appropriate drive.
For several types of removable media, a File Manager window pops up automatically
when the media is inserted or attached to the computer. If File Manager does not open,
double-click the icon for that drive to view the contents.

WARNING

Do not simply remove disks from the drive after using them. Floppy disks, CDs,
and DVDs must always be unmounted from the system first. Close all File
Manager sessions still accessing the medium, then right-click the icon for the
medium and select Eject from the menu. Then safely remove the floppy disk
or CD when the tray opens automatically.
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Floppy disks can also be formatted by clicking Computer→ More Applicatiodns→
System→ Floppy Formatter. In the Floppy Formatter dialog, select the density of the
floppy disk and the file system settings: Linux native (ext2), the file system for Linux,
or DOS (FAT) to use the floppy with Windows systems.

1.5.3 Finding Files on Your Computer
To locate files on your computer, clickComputer, enter your search terms in the Search
field, then press Enter. The results are displayed in the Desktop Search dialog box.

Figure 1.5 Desktop Search Dialog Box

You can use the results lists to open a file, forward it via e-mail, or display it in the file
manager. Simply right-click an item in the results list and select the option you want.
The options available for an item in the results list depend on the type of file it is.
Clicking a file in the list displays a preview of the file and information such as the title,
path, and when the file was last modified or accessed.
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Use the Search menu to limit your search to files in a specific location, such as your
address book or Web pages, or to display only a specific type of file in your results list.
The Sortmenu lets you sort the items in your results list according to name, relevance,
or the date the file was last modified.

You can also access Desktop Search by clicking Computer→ More Applications→

System→ Beagle Search Tool pressing F12, or clicking on the bottom panel.

Search Tips
• You can use both upper and lowercase letters in search terms. Searches are not case
sensitive by default.

To perform a case sensitive search, put double quotation marks (“) around the word
you want to match exactly. For example, if you use “APPLE” in a search, apple
would be ignored.

• To search for optional terms, use OR (for example, apples OR oranges).

IMPORTANT

The OR is case-sensitive when used to indicate optional search terms.

• To exclude search terms, use a minus sign (-) in front of the term you want to ex-
clude (for example, apples -oranges would find results containing apples but not
oranges).

• To search for an exact phrase or word, put quotation marks (“) around the phrase
or word.

• Common words such as “a,” “the,” and “is” are ignored.

• The base form of a search term is used when searching (for example, a search for
“driving” will match “drive,” “drives,” and “driven”).
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Performing a Property Search
By default, the Beagle search tool looks for search terms in the text of documents and
in their properties. To search for a word in a particular property, use
property_keyword:query. For example, author:john searches for files that
have “john” listed in the Author property.

Table 1.9 Supported Property Keywords

PropertyKeyword

Album of the mediaalbum

Artistartist

Author of the contentauthor

User commentscomment

Creator of the contentcreator

File extension (for example, extension:jpeg or ext:mp3).
Use extension:or ext: to search in files with no extension.

extension or ext

E-mail sender namemailfrom

E-mail sender addressmailfromaddr

Mailing list IDmailinglist

E-mail recipient namemailto

E-mail recipient addressmailtoaddr

FSpot and Digikam image tagstag

Titletitle
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Property searches follow the rules mentioned in Section “Search Tips” (page 22). You
can use property searches as an exclusion query or OR query, and phrases can be used
as query. For example, the following line will search for all PDF or HTML documents
containing the word “apple” whose author property contains “john” and whose title
does not contain the word “oranges.”
apple ext:pdf OR ext:html author:john -title:oranges

Setting Search and Indexing Preferences
Use the Search Preferences dialog box to set search and indexing preferences. To open
Search Preferences, click Computer→More Applications→ Beagle Settings. You can
also click Search→ Preferences in the Desktop Search dialog box.

On the Search tabbed page, click Start search & indexing services automatically to
start the search daemon when you log in (this is selected by default). You can also
choose the keystrokes that will display the Desktop Search window by specifying any
combination of Ctrl, Alt, and a function key. F12 is the default keystroke.

On the Indexing tabbed page, you can choose to index your home directory (selected
by default), to not index your home directory, and to add additional directories to index.
Make sure you have rights to the directories you add. You can also specify resources
that you don’t want indexed (see Section “Preventing Files and Directories from Being
Indexed” (page 24) for more information).

Preventing Files and Directories from Being Indexed
Use the Search Preferences dialog box to specify resources that you don’t want indexed.
These resources can include directories, patterns, mail folders, or types of objects.

1 Click Computer→ More Applications→ System→ Search Settings.

2 On the Indexing tabbed page, click Add in the Privacy section.

3 Select a resource to exclude from indexing, then specify the path to the resource.

4 Click OK twice.
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1.5.4 Accessing Files on the Network
This chapter helps you access network resources using the following tasks:

• Section “Connecting to Your Network” (page 25)

• Section “Managing Network Connections” (page 27)

• Section “Accessing Network Shares” (page 28)

• Section “Sharing Directories from Your Computer” (page 29)

Connecting to Your Network
You can connect to a network with wired and wireless connections. To view your net-
work connection status, click Computer. In the Status area of the main menu, The Net-
work Connections icon shows your network connection status. For example, in the
following figure, the computer is connected to a wired network using an Ethernet con-
nection.

Figure 1.6 Network Connections Icon in the Main Menu

Click on the icon to get information about your connection, such as IP address, gateway
address, and similar details.
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Connecting to a Wired Connection

1 Make sure that an Ethernet cable is connected to your computer's network inter-
face card.

2 Click theNetwork Connections icon on themain panel, then clickEthernet: eth0.

After a wired network connection is established, theNetwork Connections icon changes
to show your connection type.

A connection to the network is confirmed whenWired is listed next to the Network
menu item. You can also confirm connectivity by clicking the Network Connections
icon. If connected, the Connection Information window displays your IP address and
other details about your connection.

Connecting to a Wireless Connection

1 Make sure that your computer contains a wireless network interface card.

2 Click the Network icon on the main menu, then clickWireless: <device>.

The Network Connections icon changes to a wireless signal strength bar, and any de-
tected wireless networks are displayed in the Network Connections menu.

If your network name is displayed, select the network name from the Network Connec-
tions menu. After you are connected, the Network icon shows that you have a wireless
connection.

If you do not see your wireless network name in the Network Connections menu:

1 Click the Network icon on the main panel, then click Other.

2 In the Specify an ESSID dialog, type the wireless network name in the ESSID:
field.

3 (Conditional) If the wireless network is encrypted, click Show Encryption Key
to display the Encryption Key field.

4 Type the encryption code, then click OK.
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Your wireless network's name should now appear in the Network Connections
menu.

5 Select the wireless network's name.

Upon connection, the Network icon turns blue.

You can also confirm connection by clicking theNetwork icon and viewingConnection
Information. If connected, your IP address and other details are displayed in the Con-
nection Information dialog.

Managing Network Connections
The Network icon lets you monitor, manage, and configure your network connections.
Clicking the icon opens a window that displays which network connection is active, if
you have more than one network device in your computer.

For example, if your laptop computer is configured to use a wireless port and a port for
a network cable, you will see two network connections in the list.

If you are connected to the network via a cable and need to switch to use your wireless,
simply click theNetwork icon and then clickWireless: eth1. This switches your network
connection and acquires a new IP address, if needed.

IMPORTANT

Prior to making the change, you should save any data, because the change in
services might require that certain applications or services be restarted.

Using the menu, you can view connection informations such as the IP address being
used and your hardware address.

If you need to update or make changes to your network settings, click Computer→
Control Panel→ Network Card. This launches the Network Card Setup wizard, which
steps you through the configuration process. Using this option requires you to provide
the password for root.
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Accessing Network Shares
Other network devices, like workstations and servers, can be set up to share some or
all of their resources. Typically, files and folders are marked to let remote users access
them. These are called network shares. If your system is configured to access network
shares, you can use Nautilus File Manager to access them.

To access network shares, double-click Computer→Home Folder, then click Network
Servers. The window displays the network shares that you can access. Double-click
the network resource that you want to access. You might be required to authenticate to
the resource by providing a username and password.

To access NFS shares, double-click the UNIX Network icon. A list of UNIX shares
available to you is displayed.

To access Windows shares, double-click theWindows Network icon. The Windows
shares available to you are displayed.

Figure 1.7 Workgroups on a Windows Network

Adding a Network Place

1 Click Computer→ Home Folder→ File→ Connect to Server.

2 Specify the name youwant displayed for this link and its URL, then clickConnect.

An icon for the network place is added to the desktop.
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Sharing Directories from Your Computer
You can make directories on your computer available to other users on your network.

Enabling Sharing

Use YaST to enable sharing on your computer. In order to enable sharing, you must
have root privileges and be a member of a workgroup or domain.

1 Click Computer→ More Applications→ System→ YaST.

2 In YaST, click Network Services→ Windows Domain Membership.

3 In the Windows Domain Membership module, click Allow Users To Share Their
Directories.

4 Click Finish.

Sharing a Directory

If directory sharing is enabled on your computer, use the following steps to configure
a directory to be shared.

1 Open the File Manager and browse to the directory you want to share.

2 Right-click the folder for the directory you want to share, then click Sharing
Options.

3 Select the Share this folder check box, then type the name you want to use for
this share.

4 If you want other users to be able to copy files to your shared directory, select
the Allow other people to write in this folder check box.

5 (Optional) Type a comment, if desired.

6 Click Create Share.
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1.6 Opening or Creating Documents
with OpenOffice.org

For creating and editing documents, OpenOffice.org is installed with the GNOME
desktop. OpenOffice.org is a complete set of office tools that can both read and save
Microsoft Office file formats. OpenOffice.org has a word processor, a spreadsheet, a
data base, a drawing tool, and a presentation program. To get started, click Computer
→ OpenOffice.org Writer or select an OpenOffice.org module by clicking Computer
→ More Applications→ Office, then select the module you want to open.

A number of sample documents and templates are included with OpenOffice.org. You
can access the templates by clicking File→ New→ Templates. In addition, you can
use wizards, which guide you through the creation of letters and other typical documents.

For a more in-depth introduction to OpenOffice.org, see Chapter 3, The OpenOffice.org
Office Suite (page 103) or view the help in any OpenOffice.org program.

1.7 Exploring the Internet
The GNOME Desktop includes Firefox, a Mozilla* based Web browser. You can start
it by clicking Computer→ Firefox.

You can type an address into the location bar at the top or click links in a page to move
to different pages, just like in any other Web browser.

For more information, see Chapter 7, Browsing with Firefox (page 171).

1.8 E-mail and Calendering
Novell Evolution seamlessly combines e-mail, a calendar, an address book, and a task
list in one easy-to-use application. With its extensive support for communications and
data interchange standards, Evolution can work with existing corporate networks and
applications, including Microsoft Exchange.

To start Evolution, click Computer→ More Applications→ Office→ Evolution.
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The first time you start it, Evolution prompts you with a few questions as it sets up a
mail account and helps you import mail from your old mail client. Then it shows you
how many new messages you have and lists upcoming appointments and tasks, as well
as the current weather and news from news feeds. The calendar, address book, and mail
tools are available in the shortcut bar on the left.

For more information, see Chapter 4, Evolution: E-Mail and Calendaring (page 137).

1.9 Moving Text between Applications
To copy text between applications, select the text and then move the mouse cursor to
the position where you want the text copied. Click the center button on the mouse or
the scroll wheel to copy the text.

When copying information between programs, you must keep the source program open
and paste the text before closing it. When a program closes, any content from that ap-
plication that is on the clipboard is lost.

1.10 Other Useful Programs
In addition to the programs already discussed, like applets you can add to a panel, the
system also includes additional programs, organized in categories in the Application
Browser. To access the programs, open the Application Browser by clicking Comput-
erMore Applications, then browse through the categories to see which applications are
available. Categories include the following:

Table 1.10 Applications

Types of ProgramsCategory

Newly installed applicationsNew Applica-
tions

Applications for browsing files and other usesApplications

Web development, MONO documentation, sharing files between
computers

Development
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Types of ProgramsCategory

Educational games and applicationsEdutainment

Card games, arcade favorites, and puzzlesGames

Image viewers and editors, drawing programs, photo browsers,
scanning programs

Graphics

Applications for browsing the Internet and your computer’s file
system

Internet

Music players, CD database, video editors, CD and DVD burners,
volume controllers, and other audio and video applications

Multimedia

Word processors and text editors, spreadsheets, presentation soft-
ware, database software, project management utilities, PDF reader,
personal information managers, calendars

Office

Applications for configuring and managing your systemSystem

System customization, search configuration, calculators, and other
tools

Utilities

Following chapters in this guide describe some of themore commonly used applications.

1.11 Obtaining Software Updates
Novell offers important updates and enhancements that help protect your computer and
ensure that it runs smoothly through ZENworks®. The Software Update feature is de-
signed to help youmanage the software you have on your computer and to install, update,
and remove programs without your having to track dependencies and resolve conflicts.
Contact your system administrator for more information about how your company is
disseminating updates.
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To access the update tool, click Computer→More Applications→ System→ Update
Software.

If updates are available, the ZEN Update icon appears in the notification area of the
bottom panel. In this case, click the icon to access the update tool.
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2Customizing Your Settings
You can change the way the GNOME desktop looks and behaves to suit your own
personal tastes and needs. Some of the settings you might want to change include:

• Keyboard and mouse configuration (see Section 2.1.4, “Modifying Keyboard
Preferences” (page 38) and Section 2.1.6, “Configuring the Mouse” (page 43))

• Desktop background (see Section 2.2.1, “Changing the Desktop Background”
(page 50))

• Screen saver (see Section 2.2.5, “Configuring the Screen Saver” (page 69))

• Password (see Section 2.3.3, “Changing Your Password” (page 78))

• Sounds (see Section 2.4.9, “Setting Sound Preferences” (page 95))

These settings and others can be changed in the Control Center. To access the Control
Center, click Computer→ Control Center. The Control Center is divided into the fol-
lowing four categories:

• Section 2.1, “Hardware” (page 36)

• Section 2.2, “Look and Feel” (page 50)

• Section 2.3, “Personal” (page 74)

• Section 2.4, “System” (page 80)
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Figure 2.1 GNOME Control Center

Some settings require that you use the YaSTControl Center. These administrator settings
includes most of the hardware, the graphical user interface, Internet access, security
settings, user administration, software installation, and system updates and information.
You need the root password to access the YaST Control Center.

For information on configuring administrator settings, see Using YaST to Configure
the SUSE Linux Enterprise Desktop [http://www.novell.com/
documentation/nld/nld_deployment/data/bsj9luh.html] in theDe-
ployment Guide.

2.1 Hardware
Hardware settings include the following:

• Section 2.1.1, “Configuring Bluetooth Services” (page 37)
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• Section 2.1.2, “Configuring Your DSL Connection” (page 37)

• Section 2.1.3, “Configuring Your Graphics Card and Monitor” (page 38)

• Section 2.1.4, “Modifying Keyboard Preferences” (page 38)

• Section 2.1.5, “Configuring a Modem” (page 42)

• Section 2.1.6, “Configuring the Mouse” (page 43)

• Section 2.1.7, “Configuring a Network Card” (page 46)

• Section 2.1.8, “Installing and Configuring Printers” (page 47)

• Section 2.1.9, “Configuring Removable Drives and Media” (page 47)

• Section 2.1.10, “Configuring a Scanner” (page 48)

• Section 2.1.11, “Specifying Screen Resolution Settings” (page 49)

2.1.1 Configuring Bluetooth Services
Bluetooth services enable you to connect wireless devices such as mobile phones and
personal data assistants (PDAs) to your computer. Bluetooth wireless support includes
automatic recognition of Bluetooth-enabled devices via the YaST central configuration
and administration tool. ClickComputer→Control Center→Hardware→ Bluetooth,
then set the configuration options that are appropriate for your device.

NOTE

Root privileges are required for configuring Bluetooth services.

2.1.2 Configuring Your DSL Connection
If you connect to a network over a DSL Connection, use this option to configure your
connection. The DSL connection is configured in YaST.
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NOTE

Root privileges are required for configuring your DSL Connection.

1 Click Computer→ Control Center→ Hardware→ DSL.

2 Enter the root password.

YaST opens.

3 Follow the instructions in YaST to configure DSL.

2.1.3 Configuring Your Graphics Card and
Monitor

Your graphics card was configured for your monitor during installation. If you ever
need to change these settings, click Computer→ Control Center→ Hardware→
Graphics Card and Monitor, then set the appropriate options for your monitor.

NOTE

Graphics card configuration is done in YaST2 and requires root privileges.

2.1.4 Modifying Keyboard Preferences
Use the Keyboard Preferences tool to modify the autorepeat preferences for your key-
board and to configure typing break settings.

Click Computer→ Control Center→ Hardware→ Keyboard.

You can set the following preferences:

• Keyboard

• Typing Break

• Layouts
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• Layout Options

Configuring Keyboard Preferences
Use the Keyboard tabbed page to set general keyboard preferences.

Figure 2.2 Keyboard Preferences Dialog—Keyboard Page

You can modify any of the following keyboard preferences:

Table 2.1 Keyboard Preferences

DescriptionOption

Enables keyboard repeat. The action associated with
a key is performed repeatedly when you press and

Key Presses Repeat When
Key is Held Down

hold that key. For example, if you press and hold a
character key, the character is typed repeatedly.

Use theDelay option to select the delay from the time
you press a key to the time that the action repeats.

Use the Speed option to set the speed at which the
action is repeated.
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DescriptionOption

Lets the cursor blink in fields and text boxes.Cursor Blinks in Text Boxes
and Fields

Use the slider to specify the speed at which the cursor
blinks.

The test area is an interactive interface that lets you
see how the keyboard settings affect the display as

Type to Test Settings

you type. Type text in the test area to test the effect
of your settings.

Click the Accessibility button to start the Keyboard accessibility preference tool.

Configuring Keyboard Layout Preferences
Use the Layouts tabbed page to set your keyboard layout.

Figure 2.3 Keyboard Preferences Dialog—Layouts Page

Select your keyboard model from the drop-down list, then use the navigational buttons
to add or remove the selected layout to or from the list of available layouts.

You can select different layouts to suit different locales.
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Click the Accessibility button to start the Keyboard accessibility preference tool.

Configuring Keyboard Layout Options
Use the Layout Options tabbed page to set your keyboard layout options.

Figure 2.4 Keyboard Preferences Dialog—Layout Options Page

Select an option from the list of available layout options and click Add to add the option
or Remove to remove it.

Click the Accessibility button to start the Keyboard accessibility preference tool.

Configuring Typing Break Preferences
Use the Typing Break tabbed page to set typing break preferences.
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Figure 2.5 Keyboard Preferences Dialog—Typing Break Page

You can modify any of the following typing break preferences:

Table 2.2 Typing Break Preferences

DescriptionOption

Locks the screen when you are due a typing break.Lock Screen to Enforce Typing
Break

Lets you specify how long you can work before a
typing break occurs.

Work Interval Lasts

Lets you specify the length of your typing breaks.Break Interval Lasts

Lets you postpone typing breaks.Allow Postponing of Breaks

Click the Accessibility button to start the Keyboard accessibility preference tool.

2.1.5 Configuring a Modem
If you connect to a network over a modem, use this option to configure your modem.
The modem is configured in YaST.
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NOTE

Root privileges are required for configuring your modem.

1 Click Computer→ Control Center→ Hardware→ Modem.

2 Enter the root password.

YaST opens.

3 Follow the instructions in YaST to configure the modem.

2.1.6 Configuring the Mouse
Use the Mouse Preference tool to configure your mouse for right-hand use or for left-
hand use. You can also specify the speed and sensitivity of mouse movement.

Click Computer→ Control Panel→ Hardware→ Mouse.

You can customize the settings for the Mouse Preference tool in the following areas:

• Buttons

• Cursors

• Motion

Configuring Button Preferences
Use the Buttons tabbed page to specify whether the mouse buttons are configured for
left-hand use. You can also specify the delay between clicks for a double-click.

Customizing Your Settings 43



Figure 2.6 Mouse Preferences Dialog—Buttons Page

The following table lists the mouse button preferences you can modify.

Table 2.3 Mouse Button Preferences

DescriptionOption

Configures your mouse for left-hand use, swapping the functions
of the left mouse button.

Left-handed
Mouse

Use the slider to specify the amount of time that can pass between
clicks when you double-click. If the interval between the first

Timeout

and second clicks exceeds the time that is specified here, the ac-
tion is not interpreted as a double-click.

Configuring Pointer Preferences
Use the Cursors tabbed page to set your mouse pointer preferences.
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Figure 2.7 Mouse Preferences Dialog—Pointers Page

The following table lists the mouse pointer preferences you can modify.

Table 2.4 Mouse Pointer Preferences

DescriptionOption

Displays the available cursor themes.Cursor Theme

Enables a mouse pointer animation when you
press and release Ctrl. This feature can help
you locate the mouse pointer.

Highlight the Pointer When You
Press Ctrl

Configuring Motion Preferences
Use the Motion tabbed page to set your preferences for mouse movement.
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Figure 2.8 Mouse Preferences Dialog—Motion Page

The following table lists the mouse motion preferences you can modify.

Table 2.5 Mouse Motion Preferences

DescriptionOption

Use the slider to specify the speed at which your mouse pointer
moves on your screen when you move your mouse.

Acceleration

Use the slider to specify how sensitive your mouse pointer is to
movements of your mouse.

Sensitivity

Use the slider to specify the distance that you must move an item
before the move action is interpreted as a drag and drop action.

Threshold

2.1.7 Configuring a Network Card
If you connect to a network over a network card, use this option to configure your
connection. The network card is configured in YaST.
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NOTE

Root privileges are required for configuring your network card.

1 Click Computer→ Control Center→ Hardware→ Network Card.

2 Enter the root password.

YaST opens.

3 Follow the instructions in YaST to configure the network card.

2.1.8 Installing and Configuring Printers
Use the Printers module to install and configure printers.

To start the Printers module, click Computer→ Control Center→ Hardware→
Printers.

Figure 2.9 Printers Dialog

2.1.9 Configuring Removable Drives and
Media

You can use a wide variety of removable drives and media, including storage devices,
cameras, scanners, and more. The configurations for many of these devices are set up
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automatically during installation. To change the configuration for a drive or other re-
movable device, clickComputer→Control Center→Hardware→ Removable Drives
and Media.

Some of the possible configuration settings include:

• What happens when a blank CD is inserted in the CD drive

• What happens when an audio CD is inserted in the drive

• Whether images are automatically imported from a digital camera when it is attached
to the computer

• Whether removable storage devices are mounted when they are plugged in to the
computer

• Whether PDAs are automatically synced when attached to the computer

In general, you do not need to change the settings that are already configured unless
you want to change the behavior when a device is connected or if you want to connect
a new device that is not yet configured. If you attach a device for the first time and it
behaves in an unexpected or undesired way, check the Removable Drives and Media
settings.

2.1.10 Configuring a Scanner
The Scanner configuration enables you to attach and configure a scanner, or to remove
an already-attached scanner.

NOTE

Scanner configuration is done in YaST2 and requires root privileges.

To open YaST2 and configure a scanner, click Computer→ Control Center→ Hard-
ware→ Scanner. Refer to the instructions on the Scanner Configuration screen for
information about the available options.
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2.1.11 Specifying Screen Resolution Settings
Use this module to specify the resolution settings for your screen, including Resolution
and Refresh Rate.

Click Computer→ Control Center→ Hardware→ Screen Resolution.

Figure 2.10 Screen Resolution Preferences Dialog

The following table lists the screen resolution preferences you can modify.

Table 2.6 Screen Resolution Preferences

DescriptionOption

Select the resolution (in pixels) to use for the
screen.

Resolution

Select the refresh rate to use for the screen.Refresh Rate

Select the rotation mode for your screen if you use
a nonstandard monitor.

Rotation

Makes the screen resolution settings the default
settings only for the computer that you are logged
in to.

Make Default for This Computer
Only
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If you cannot find a setting you want, you might need to use the Administrator Settings
to reconfigure your graphics card and monitor settings. See Configuring the Graphics
Card and Monitor [http://www.novell.com/documentation/nld/nld
_deployment/data/bsj9mwg.html#bsmqn45] in the Deployment Guide for
more information.

2.2 Look and Feel
Look and Feel settings include the following:

• Section 2.2.1, “Changing the Desktop Background” (page 50)

• Section 2.2.2, “Configuring Desktop Effects” (page 53)

• Section 2.2.3, “Configuring Fonts” (page 65)

• Section 2.2.4, “Configuring Menus and Toolbars” (page 67)

• Section 2.2.5, “Configuring the Screen Saver” (page 69)

• Section 2.2.6, “Choosing a Theme” (page 70)

• Section 2.2.7, “Customizing Window Behavior” (page 73)

2.2.1 Changing the Desktop Background
The desktop background is the image or color that is applied to your desktop. You can
customize the desktop background in the following ways:

• Select an image for the desktop background. The image is superimposed on the
desktop background color. The desktop background color is visible if you select a
transparent image or if the image does not cover the entire desktop.

• Select a color for the desktop background. You can select a solid color or create a
gradient effect with two colors. A gradient effect is a visual effect where one color
blends gradually into another color.
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To change the desktop preferences:

1 Click Computer→ Control Center→ Look and Feel→ Desktop Background.

2 Set the desktop preferences the way that you want them.

The following settings can be changed:

Table 2.7 Background Preferences

DescriptionOption

Displays an image of your choice on the desktop.Desktop Wallpa-
per

Determines what processing steps should be applied to the
selected image to adapt it optimally to the current screen

Style

resolution. To specify how to display the image, select one
of the following options from the Style drop-down list:

• Centered: Displays the image in the middle of the
desktop.

• Fill Screen: Enlarges the image to cover the desktop
and maintains the relative dimensions of the image.

• Scaled: Enlarges the image until the image meets
the screen edges andmaintains the relative dimensions
of the image.

• Tiled: Repeats the image over the entire screen.

Opens a dialog where you can select an image file to use
as the background picture.

Add Wallpaper

Removes a Desktop Wallpaper after you select it and then
click Remove.

Remove
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DescriptionOption

Lets you specify a color scheme using the options in the
Desktop Color drop-down list and the color selector but-

Desktop Colors

tons. You can specify a color scheme using any of the
following options:

• Solid Color specifies a single color for the desktop
background.

To select a color, click Color. In the Pick a Color dia-
log, select a color and then click OK

• Horizontal Gradient creates a gradient effect from the
left screen edge to the right screen edge.

Click Left Color to display the Pick a Color dialog,
then select the color that you want to appear at the left
edge.

Click Right Color, then select the color that you want
to appear at the right edge.

• Vertical Gradient creates a gradient effect from the
top screen edge to the bottom screen edge.

Click Top Color to display the Pick a Color dialog,
then select the color that you want to appear at the top
edge.

ClickBottomColor, then select the color that you want
to appear at the bottom edge.

3 When you are satisfied with your choices, click Close.

Your desktop immediately changes to show the new settings.
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2.2.2 Configuring Desktop Effects
Xgl is a new Xserver architecture that lets you turn your desktop into a rotating 3-D
cube, tile windows so they don’t overlap, and switch tasks while viewing live thumbnails.
You can enable translucent or transparent windows, zoom in and out of the desktop
screen, and perform other window effects such as shadows, fading, and transformations.
You can also configure windows to snap to other windows and screen edges when they
are moved.

Figure 2.11 3-D Desktop

Enabling Desktop Effects
To enable Xgl, you need a graphics adapter capable of providing 3-D support and the
graphics driver that Linux uses to operate the graphics adapter. This driver must be able
to handle OpenGL (or 3-D) requests from the Linux kernel. For a list of supported
adapters, see the/etc/X11/xgl-hardware-list file that is included with the
openSUSE installation. This file will tell you which graphics cards are known to work
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with Xgl, which cards do not work with Xgl, and which cards might work with Xgl but
are not supported (because they are either too slow or contain toomany known defects).

Your screen resolution must be within the 1024x768 to 1920x2000 range, and your
color depth must be set at 24-bit. 3-D acceleration must also be enabled. Use SaX2 to
change your graphic card and monitor properties if necessary.

1 Click Computer→ Control Center.

2 Click Desktop Effects in the Look and Feel group.

The Desktop Effects tool analyzes your system and tries to determine whether
or not you can run Xgl. If it finds anything wrong, it will advise you on what
actions you can take. For example, you might be advised to change your screen
resolution or color depth, or to activate 3-D acceleration. Follow the onscreen
prompts to configure your system for Xgl.

3 Click Enable Desktop Effects.

4 Type the root password, then click Continue.

5 Click OK to log out of your session, then type your username and password to
log back in.
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The default desktop effects are now enabled. For example, windows “wobble”
when they first appear and when you move them, widows fade away when you
close them, and dragging a window to the far right of the screen rotates the
desktop cube. To change any of these effects, see Section “Modifying Desktop
Effects” (page 55).

You can also enable Xgl by running the following command as root:

gnome-xgl-switch --enable-xgl

To disable Xgl, click Disable Desktop Effects in the Desktop Effects Settings dialog
box, or run the following command as root:

gnome-xgl-switch --disable-xgl

Modifying Desktop Effects
Use the Desktop Effects Settings tool to enable or disable specific desktop effects, or
to change the keystrokes or mouse actions used to control those effects.

1 Click Computer→ Control Center.

2 Click Desktop Effects in the Look and Feel group.

3 Choose from the following options:

• Section “Window Effects” (page 56)

• Section “Desktop Cube” (page 57)

• Section “Other Features” (page 59)

4 Click Close.

You can also use gconf-editor to change Xgl settings.

1 Click Computer→ More Applications→ System→ GNOME Configuration
Editor or press Alt+F2 and enter gconf-editor.
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2 Navigate to the apps/compiz/general and apps/compiz/plugins
registry folders and make the changes you want.

3 Click File→ Quit to close the Configuration Editor.

Window Effects

Use the options on this tabbed page to specify what happens when you move windows,
how window transitions appear, and to change window opacity.

Figure 2.12 Window Effects Tabbed Page

Moving Windows
By default, windows appear distorted (wobbly) as youmoved or resize them, giving
the impression that the window is more fluid than rigid. If you want window edges
to stick (snap) to other windows and workspace edges when you hold down the
Shift key while moving the window, both theWindows wobble while they’re being
moved andWindow edges stick to other windows when you hold down “Shift” op-
tions must be selected.

You can also choose to make windows transparent when you move them.
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Window Transitions
These options lets you add a fade-in and fade-out effect to windows and menus
when you open and close them. Windows will also shrink smoothly onto the task
bar when they are minimized and will grow smoothly back to their normal size
when they are reopened.

Translucent Windows
This options lets you use the scroll wheel to change how transparent a window
appears onscreen. Select Use scroll wheel plus these modifiers to change window
opacity, then select the button or combination of buttons you want to use. Select a
window, hold down the button or buttons you selected, then scroll the mouse wheel
up or down to change the transparency of the window.

Figure 2.13 Translucent Window

Desktop Cube

Use the options on this tabbed page to specify how many sides your desktop cube has,
which keystroke and mouse button combination you can use to drag the cube, and to
configure edge flipping.
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Figure 2.14 Desktop Cube Tabbed Page

Desktop Cube
By default, this option gives you four desktops on the faces of a virtual cube that
you can rotate to access another desktop. This provides extra space in which to ar-
range open applications and windows. For example, you can put an editor on one
desktop, some shells on another, and your e-mail application and Web browser on
the third desktop. Using Ctrl+Alt+Left arrow and Ctrl+Alt+Right arrow, you can
rotate the cube to access the programs running in the selected desktop and avoid
windows piled on top of each other on one desktop.

Dragging a window to the edge of the screen will rotate the cube and place the
window on the new desktop. To rotate the cube manually in 3-D, press Ctrl+Alt,
left-click the desktop, then drag the mouse pointer. Ctrl+Alt+Shift+Left or Right
arrow lets you rotate the cube while taking the currently selected windowwith you.

Use the options underDrag the cube with the mouse by using to change the default
keystrokes used to rotate the cube.

For information on how to add an image behind your cube, see Section “Displaying
a Skydome Image Behind the Cube ” (page 64).
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Edge Flipping
If edge flipping is enabled, the desktop cube rotates to the next face when you bump
the mouse pointer to the edge of the screen. You can choose to always enable edge
flipping or to enable edge flipping only when you drag a window or icon to the
edge of the desktop.

Use the slider bar at the bottom of the tabbed window to specify how long (in mi-
croseconds) it takes to rotate the cube after you bump the edge of the desktop with
a window or the mouse pointer.

Other Features

Use the options on this tabbed page to configure window tiling, zooming, and water
effects.

Figure 2.15 Other Features Tabbed Page

Window Picker
This option lets you tile (or scale) the windows on your desktop so that you can
see what windows you have open and select a specific one. This also provides you
with a snapshot of all applications open on your desktop. Pressing Ctrl+Alt+Up
arrow shrinks all windows and rearranges them on the screen so that they do not
overlap. Selecting a window with the mouse causes all windows to return to their
original size and position, with the selected window on top.
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To change the keystrokes used to tile windows, click the box to the right of Acti-
vate/deactivate when I type untilNew accelerator appears. Then press the keystrokes
you want to use. These new keystrokes will appear in the box.

You can also choose to tile windows by moving the mouse pointer to the top left
(default), top right, bottom left, or bottom right of the screen.

Figure 2.16 Application Tiling

Zoom
These options give you the ability to zoom in and out of areas on your screen, which
significantly improves desktop accessibility to visually impaired users or to anyone
who wants to see a part of the screen displayed in a larger size.

By default, pressing the Super key (theWindows key)+Button 3 (if you have a two
button mouse, press the left and right buttons simultaneously) zooms in on part to
the desktop. You can move the mouse while holding those buttons down to see
other parts of the screen. You can also press the Super key and use the scroll wheel
on the mouse to manually zoom in and out of the desktop.
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You can choose to deactivate any of these options, or to change the zoom keystrokes.

Water Effect
This option creates a ripple effect on your screen when you hold down the specified
key or key combination (Ctrl+Super by default) and move the mouse pointer. You
can also enable or disable a rain effect when you press Shift+F9. To change the
keystrokes used to enable and disable the rain effect, click the box to the right of
Activate/deactivate rain when I type until New accelerator appears. Then press the
keystrokes you want to use. These new keystrokes will appear in the box.

Use the slider bar at the bottom of the tabbed window to specify the intensity of
the rain effect.

Figure 2.17 Water Effect

Xgl Shortcuts
The following table contains a list of the default keystrokes and mouse movements you
can use to perform desktop effects. To change any of these shortcuts, see Section
“Modifying Desktop Effects” (page 55).
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Table 2.8 Desktop Effects Shortcuts

ShortcutEffect

Shift+F9Activate or deactivate rain effect

Ctrl+Super key (Windows key) andmove
mouse pointer

Create ripples with mouse pointer

Ctrl+Alt+Down arrow (use the Left and
Right arrows to scroll)

Panoramic view of all desktop cubes

Ctrl+Alt+Left or Right arrow or drag a
window to the edge of the screen

Rotate desktop cube

Ctrl+Alt+left-click desktop and dragRotate desktop cube manually

Ctrl+Alt+Shift+Left or Right arrowRotate desktop cube while keeping the
current active window with you

Alt+TabSwitch windows (thumbnail view)

Ctrl+Alt+Up arrow or move mouse
pointer to the top left corner of the screen

Tile windows

Left-click window and dragWobbly window

Super key (Windows key)+Button 3Zoom once

Super key (Windows key)+scroll mouse
up

Zoom in manually

Super key (Windows key)+scroll mouse
down

Zoom out manually

More Desktop Effects
Here are some other things you can do with Xgl:
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• Section “Switching Tasks” (page 63)

• Section “Unfolding the Cube ” (page 63)

• Section “Displaying a Skydome Image Behind the Cube ” (page 64)

Switching Tasks

Press Alt+Tab to display a thumbnail view of all windows open on your desktop.While
holding the the Alt key down, press Tab to cycle through the list of windows. The cur-
rently highlighted windowwill appear in focus. Release the keys to access that window.

Figure 2.18 Thumbnail View

Unfolding the Cube

Press Ctrl+Alt+Down arrow to unfold the desktop cube, opening a panoramic view of
all your desktops. Your desktop cube is laid out like a film strip on your screen, and
you can use the Left and Right arrows to select a different screen. This is similar to the
switcher feature (Alt+Tab), but lets you view a thumbnail of your entire desktop instead
of only your active windows.
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Figure 2.19 Panoramic View of All Desktop Cubes

Displaying a Skydome Image Behind the Cube

You can add background wallpaper (also known as a skydome image) that is visible
when you rotate or unfold the desktop cube.

1 Click Computer→ More Applications→ System→ GNOME Configuration
Editor or press Alt+F2 and enter gconf-editor.

2 Navigate to the apps/compiz/plugins/cube/screen0/options
registry folder.

3 Scroll down the list on the right side of the Configuration Editor and select sky-
dome.

4 Double-click skydome_image and specify the path to the skydome image you
want to display behind the cube.
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Skydome imagesmust be in.png format. The suggested image sizes for skydome
images are 1024 x 1024, 1024 x 2048, 1024 x 4096, 2048 x 1024, 2048 x 2048,
2048 x 4096, 4096 x 1024, 4096 x 2048, and 4096 x 4096.

5 (Optional) Select skydome_animated to make it look like you are moving around
the cube when you use your mouse to rotate the cube.

6 Click OK.

7 Click File→ Quit to close the Configuration Editor.

Figure 2.20 Skydome Image

2.2.3 Configuring Fonts
Use the Font Preferences dialog to select the fonts to use in your applications, windows,
terminals, and desktop. To open the Font Preferences dialog, clickComputer→Control
Center→ Look and Feel→ Fonts.
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Figure 2.21 Font Preferences Dialog

The upper part of the dialog shows the fonts selected for applications, documents, the
desktop, window titles, and a fixed-width font for terminals. Click one of the buttons
to open a selection dialog where you can set the font family, style, and size.

To specify how to render fonts on your screen, select one of the following options:

• Monochrome: Renders fonts in black and white only. The edges of characters
might appear jagged in some cases because the characters are not antialiased. An-
tialiasing is an effect that is applied to the edges of characters to make the characters
look smoother.

• Best Shapes: Antialiases fonts where possible. Use this option for standard
Cathode Ray Tube (CRT) monitors.

• Best Contrast: Adjusts fonts to give the sharpest possible contrast and antialiases
fonts so that characters have smooth edges. This option might enhance the accessi-
bility of the GNOME Desktop to users with visual impairments.

• Subpixel Smoothing (LCDs): Uses techniques that exploit the shape of individ-
ual Liquid Crystal Display (LCD) pixels to render fonts smoothly. Use this option
for LCD or flat-screen displays.
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Click Details to specify further details of how to render fonts on your screen:

• Resolution (Dots Per Inch): Use the spin box to specify the resolution to use
when your screen renders fonts.

• Smoothing: Select one of the options to specify how to antialias fonts.

• Hinting: Select one of the options to specify how to apply hinting to improves
the quality of fonts at small sizes and at low screen resolutions.

• Subpixel Order: Select one of the options to specify the subpixel color order
for your fonts. Use this option for LCD or flat-screen displays.

2.2.4 Configuring Menus and Toolbars
You can configure the appearance and behavior of menus and toolbars. ClickComputer
→ Control Center→ Look and Feel→ Menus & Toolbars.

Showing Icons in Menus
If you want icons to appear in menus, select Show icons in menus. Not all menu items
have icons.

Defining New Keyboard Shortcuts
If you want to be able to define new keyboard shortcuts for menu items, select Enable
menu accelerators. When this option is enabled, you can change an application shortcut
key by placing the mouse pointer over the menu item you want to change, then pressing
the new key combination. To remove a shortcut key combination, place the mouse
pointer over the menu item, then press <— or Del.
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IMPORTANT

If you assign a new keyboard combination, you are not warned if you select a
combination that was previously assigned to something else. The previous as-
signment is removed and replaced by the new one. There is no automatic way
to restore the original, default keyboard shortcut for a command. You must
manually reassign the keyboard shortcut.

This feature does not maintain shortcuts that are normally assigned to all ap-
plications, such as Ctrl + C for copy. This might lead to inconsistencies in your
GNOME applications.

Making Toolbars Detachable
If you want to be able to move toolbars to other locations on the screen, clickDetachable
toolbars. When this option is enabled, a handle displays on the left side of the toolbars
in your applications. To move a toolbar, click and hold on the handle, then drag the
toolbar to the new location.

Configuring Placement of Toolbar Button Labels
Select one of the following options to specify how toolbar button labels display in your
GNOME-compliant applications:

Text below icons: Displays icon labels below the icons for each button.

Text beside icons: Displays icons on the toolbar, with text beside the most important
icons.

Icons only: Displays icons only, without any text labels.

Text only: Displays text labels on each button, without icons.

A preview of the selected option appears in theMenu and Toolbar Preferences dialog.
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2.2.5 Configuring the Screen Saver
A screen saver is a program that blanks the screen or displays graphics when the com-
puter is not used for a specified amount of time. Originally, screen savers protected
monitors from having images burned into them. Now they are used primarily for enter-
tainment or security.

To configure a screen saver, click Computer→ Control Center→ Look and Feel→
Screensaver.

Figure 2.22 Screensaver Preferences Dialog

You can select from Random (random selection of screen savers from a custom-defined
list), Blank Screen, or a selection of installed screen savers.

Select a screen saver from the list to choose it. The currently selected screen saver is
displayed in the small preview window. Specify the amount of time that the screen is
to be idle before the screen saver is activated, and whether the screen is locked when
the screen saver is activated.
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2.2.6 Choosing a Theme
A theme is a group of coordinated settings that specifies the visual appearance of a part
of the desktop. You can choose themes to change the appearance of the desktop. Use
the Theme Preferences tool to select from a list of preinstalled themes. The list of
available themes includes several themes for users with accessibility requirements.

To choose a theme, click Computer→ Control Center→ Look and Feel→ Theme.

A theme contains settings that affect different parts of the desktop, as follows:

• Controls

The controls setting for a theme determines the visual appearance of windows,
panels, and applets. It also determines the visual appearance of the GNOME-com-
pliant interface items that appear on windows, panels, and applets, such as menus,
icons, and buttons. Some of the controls setting options that are available are de-
signed for special accessibility needs. You can select an option for the controls
setting in the Controls tabbed page of the Theme Details tool.

• Window frame

The window frame setting for a theme determines the appearance of the frames
around windows only. You can select an option for the window frame setting in
the Window Border tabbed page of the Theme Details tool.

• Icon

The icon setting for a theme determines the appearance of the icons on panels and
the desktop background. You can select an option for the icon setting in the Icons
tabbed page of the Theme Details tool.

The color settings for the desktop and applications are controlled using themes. You
can choose from a variety of preinstalled themes. Selecting a style from the list overview
applies it automatically. Details opens another dialog where you can customize the
style of single desktop elements, like window content, window borders, and icons.
Making changes and leaving the dialog by clickingClose switches the theme to Custom
Theme. Click Save Theme to save your modified theme under a custom name. The In-
ternet and other sources provide many additional themes for GNOME as .tar.gz
files. Install these with the Install theme.

70 GNOME User Guide



Creating a Custom Theme
The themes that are listed in the Theme Preferences tool are different combinations of
controls options, window frame options, and icon options. You can create a custom
theme that uses different combinations of options.

1 Click → Computer→ Control Center→ Look and Feel→ Theme.

2 Select a theme from the list of themes, then click Theme Details.

3 Select the controls option that you want to use in the custom theme from the list
in the Controls tabbed page.

4 Click theWindow Border tab, then select the window frame option that you want
to use in the custom theme.

5 Click the Icons tab, then select the icons option that you want to use in the custom
theme.

6 Click Close→ Save Theme.

A Save Theme to Disk dialog is displayed.

7 Type a name and a short description for the custom theme in the dialog, then
click Save.

The custom theme now appears in your list of available themes.

Installing a New Theme
You can add a theme to the list of available themes. The new theme must be an archive
file that is tarred and zipped (a .tar.gz file).

1 Click Computer→ Control Center→ Look and Feel→ Theme.

2 Click Install Theme.

3 Specify the location of the theme archive file in the Location field, then click
OK.
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You can also click Browse to browse for the file.

4 Click Install to install the new theme.

Installing a New Theme Option
You can install new controls options, window frame options, or icons options. You can
find many controls options on the Internet.

1 Click Computer→ Control Center→ Look and Feel→ Theme.

2 Click Theme Details, then click the tab for the type of theme you want to install.

For example, to install an icons option, click the Icons tab.

3 Click Install Theme.

4 Specify the location of the theme archive file in the Location field, then click
OK.

5 Click Install to install the new theme option.

Deleting a Theme Option
You can delete controls options, window frame options, or icons options.

1 Click Computer→ Control Center→ Look and Feel→ Theme.

2 Click Theme Details, then click the tab for the type of option you want to delete.

3 Click Go To Theme Folder.

A File Manager window opens on the default option folder.

4 Use the File Manager window to delete the option.
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2.2.7 Customizing Window Behavior
Use the Window Preferences tool to customize window behavior for the desktop. You
can determine how a window reacts to contact with the mouse pointer or to double-
clicks on its titlebar, and you can define which key to hold for moving an application
window.

To customize window behavior, click Computer→ Control Center→ Look and Feel
→ Windows.

Figure 2.23 Window Preferences Dialog

When several application windows populate the desktop, the active one by default is
the one last clicked. Change this behavior by activating Select WindowsWhen theMouse
Moves over Them. If desired, activateRaise SelectedWindow after an Interval and adjust
the latency time with the slider. This raises a windows a short time after the window
receives focus.

Application windows can be shaded (rolled up) by double-clicking the title bar, leaving
only the title bar visible. This saves space on the desktop and is the default behavior.
It is also possible to set windows to maximize when the title bar is double-clicked.

Using the radio buttons, select a modifier key to press for moving a window (Ctrl, Alt,
Hyper, or the Windows logo key).
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2.3 Personal
Personal settings include the following:

• Section 2.3.1, “Configuring Keyboard Accessibility Settings” (page 74)

• Section 2.3.2, “Configuring Assistive Technology Support” (page 77)

• Section 2.3.3, “Changing Your Password” (page 78)

• Section 2.3.4, “Managing Keyrings” (page 78)

• Section 2.3.5, “Customizing Keyboard Shortcuts” (page 79)

2.3.1 Configuring Keyboard Accessibility
Settings

GNOME provides keyboard settings designed to help users with motion impairments
use the GNOME desktop. Some of the available settings include:

• How long a key is pressed and held before being recognized as valid input

• Whether the keyboard can be used as a mouse

• Whether key combinations that use Alt, Control, and Shift can be duplicated with
“sticky keys”

To configure keyboard accessibility settings, click Computer→ Control Center→
Personal→ Accessibility.

The module consists of the three tabs: Basic, Filters, andMouse Keys. Before modifying
settings, activate Enable Keyboard Accessibility Features.
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Figure 2.24 Keyboard Accessibility Preferences Dialog

Features (Basic Tab)
The keyboard accessibility functions can be deactivated automatically after a certain
time. Set an appropriate time limit (measured in seconds) with the slider. The system
can additionally provide audible feedback when the keyboard accessibility functions
are activated and deactivated.

Enable Sticky Keys (Basic Tab)
Some keyboard shortcuts require that one key (a modifier key) is kept pressed constantly
(this applies to Alt, Ctrl, and Shift) while the rest of the shortcut is typed. When sticky
keys are used, the system regards those keys as staying pressed after being pressed
once. For an audible feedback generated each time a modifier key is pressed, activate
Beepwhen the modifier is pressed. IfDisable If Two Keys Pressed Together is selected,
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the keys do not “stick” anymore when two keys are pressed simultaneously. The system
then assumes that the keyboard shortcut has been completely entered.

Enable Repeat Keys (Basic Tab)
ActivateRepeat Keys to make settings with sliders forDelay and Speed. This determines
how long a key must be pressed for the automatic keyboard repeat function to be acti-
vated and at what speed the characters are then typed.

Test the effect of the settings in the field at the bottom of the dialog. Select parameters
that reflect your normal typing habits.

Enable Slow Keys (Filters Tab)
To prevent accidental typing, set a minimum time limit that a key must be pressed and
held before it is recognized as valid input by the system. Also determine whether audible
feedback should be provided for keypress events, accepted keypresses, and the rejection
of a keypress.

Enable Bounce Keys (Filters Tab)
To prevent double typing, set a minimum time limit for accepting two subsequent
keypress events of the same key as the input of two individual characters. If desired,
activate audible feedback upon rejection of a keypress event.

Toggle Keys (Filters Tab)
You can request audible feedback from the system when a keycap modifier key is
pressed.

Mouse Keys Tab
Activates the keyboard mouse; the mouse pointer is controlled with the arrow keys of
the number pad. Use the sliders to set the maximum speed of the mouse pointer, the
acceleration time until the maximum speed is reached, and the latency between the
pressing of a key and the cursor movement.
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2.3.2 Configuring Assistive Technology
Support

Several assistive technologies are included for users with special needs:

• Screen reader

• Screen magnifier

• On-screen keyboard

To configure assistive technology options, click Computer→ Control Center→ Per-
sonal→ Assistive Technology Preferences. To enable the technologies, first select
Enable Assistive Technologies and then select the technologies you want to enable every
time you log in.

Figure 2.25 Assistive Technology Preferences Dialog

The gok package must be installed in order to get on-screen keyboard support, and the
gnopernicus and gnome-mag packages must be installed in order to get screenreading
and magnifying capabilities.

If these packages are not installed on your system (they are installed by default during
installation), install them with the following procedure:
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1 Click Computer→ More Applications→ System→ YaST.

2 Type the root password, then click OK.

3 Click Software→ Install and Remove Software.

4 Select Selection from the Filter drop-down menu, then select Accessibility from
the Selection list.

5 Select gok, gnopernicus, and gnome-mag from the Package list

6 Click Accept.

7 Insert the CD you are prompted for, then click OK.

8 Click Cancel→ Close after the package installation is complete.

2.3.3 Changing Your Password
For security reasons, it is a good idea to change your password from time to time. To
change your password:

1 Click Computer→ Control Center→ Personal→ Change Password.

2 Type your old (current) password.

3 Type your new password.

4 Confirm your new password by typing it again, then click OK.

2.3.4 Managing Keyrings
GNOMEKeyringManager provides an interface for viewing secrets stored in keyrings
on your computer. Secrets include such items as:

• Passwords

• Wireless credentials
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• Certificates

• Credentials for logging in to another computer

Most users should never use Keyring Manager because secrets are managed by the ap-
plications that create them. A few users might find it necessary to use KeyringManager
to delete a secret.

To delete a secret:

1 Open Keyring Manager by clicking Computer→ Control Center→ Personal
→ Keyring Manager.

2 In the list of keyrings on the left side of Keyring Manager, click Default.

3 Click the secret you want to delete in the list in the top right area of Keyring
Manager.

4 Click KeyringDelete Keyring.

The secret is removed from the list.

2.3.5 Customizing Keyboard Shortcuts
A keyboard shortcut is a key or combination of keys that provides an alternative to
standard ways of performing an action. You can customize the keyboard shortcuts for
a number of actions.

To open the Keyboard Shortcuts tool, click Computer→ Control Center→ Personal
→ Shortcuts.
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Figure 2.26 Keyboard Shortcuts Dialog

To change the shortcut keys for an action, select the action and then press the keys you
want to associate with the action. To disable the shortcut keys for an action, click the
shortcut for the action, then press Backspace.

2.4 System
System settings include the following:

• Section 2.4.1, “Configuring Date and Time” (page 81)

• Section 2.4.2, “Configuring Streaming Audio and Video” (page 81)

• Section 2.4.3, “Configuring Language Settings” (page 81)

• Section 2.4.4, “Configuring Network Proxies” (page 82)

• Section 2.4.5, “Configuring Power Management” (page 84)

• Section 2.4.6, “Setting Preferred Applications” (page 89)

• Section 2.4.7, “Configuring Search with Beagle Settings” (page 90)
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• Section 2.4.8, “Managing Sessions” (page 90)

• Section 2.4.9, “Setting Sound Preferences” (page 95)

• Section 2.4.10, “Managing Users and Groups” (page 99)

• Section 2.4.11, “Configuring Administrative Settings with YaST” (page 99)

2.4.1 Configuring Date and Time
To change your date and time configuration, for example to change your time zone or
the way the date and time are displayed, click Computer→ Control Center→ System
→ Date and Time. This opens the YaST Date and Time module, which requires root
privileges. Enter the root password and follow the instructions on the YaST pages.

2.4.2 Configuring Streaming Audio and
Video

The GStreamer Properties application lets you set which audio and video plug-ins you
want to use for streaming multimedia. To open this application, click Computer→
Control Center→ System→ GStreamer Properties.

In most cases, you should use the default selections. However, if you want to select
other plug-ins, select the plug-in you want from the menus. The Audio tab lists the plug-
ins for audio input and output. The Video tab lists the video plug-ins.

Click Close when you are finished. The system is immediately configured to use the
selected plug-ins.

2.4.3 Configuring Language Settings
openSUSE can be configured to use any of many languages. The language setting de-
termines the language of dialogs and menus, and can also determine the keyboard and
clock layout.

You can set the following language settings:
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• Primary language

• Whether the keyboard language setting should depend on the primary language

• Whether the time zone should depend on the primary language

• Secondary languages

NOTE

You must have administrator (root) privileges to configure language settings.

To configure your language settings:

1 Click Computer→ Control Center→ System→ Language.

2 (Conditional) If you are not logged in as root or a user with administrator privi-
leges, enter the root password.

If you do not know the root password, contact your system administrator. You
cannot continue without the root password.

3 Specify the primary language, whether you want to adapt the keyboard layout
or time zone to the primary language, and any secondary languages you need to
support on the computer.

4 Click Accept.

The language configuration settings are written to several configuration files.
This process can take a few minutes. The new settings take effect immediately
after they are written to the configuration files.

2.4.4 Configuring Network Proxies
The Network Proxy Configuration tool lets you configure how your system connects
to the Internet. You can configure the desktop to connect to a proxy server and specify
the details of the server. A proxy server is a server that intercepts requests to another
server and fulfills the request itself, if it can. You can specify the Domain Name Service
(DNS) name or the Internet Protocol (IP) address of the proxy server. A DNS name is
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a unique alphabetic identifier for a computer on a network. An IP address is a unique
numeric identifier for a computer on a network.

Click Computer→ Control Center→ System→ Network Proxies.

Figure 2.27 Network Proxy Configuration Dialog

The following table lists the Internet connection options that you can modify.

Table 2.9 Internet Connection Options

DescriptionOption

Connects directly to the Internet, without a proxy
server.

Direct Internet connection

Connects to the Internet through a proxy server and
lets you configure the proxy server manually.

Manual proxy configuration

The DNS name or IP address of the proxy server to
use when you request a HTTP service. Specify the

HTTP proxy

port number of the HTTP service on the proxy server
in the Port box.
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DescriptionOption

The DNS name or IP address of the proxy server to
use when you request a Secure HTTP service. Spec-

Secure HTTP proxy

ify the port number of the Secure HTTP service on
the proxy server in the Port box.

The DNS name or IP address of the proxy server to
use when you request an FTP service. Specify the

FTP proxy

port number of the FTP service on the proxy server
in the Port box.

The DNS name or IP address of the Socks host to
use. Specify the port number for the Socks protocol
on the proxy server in the Port spin box.

Socks host

Connects to the Internet through a proxy server and
lets you configure the proxy server automatically.

Automatic proxy configura-
tion

The URL that contains the information required to
configure the proxy server automatically.

Autoconfiguration URL

2.4.5 Configuring Power Management
The Power Management module lets you manage your system’s power-saving options.
It is especially useful for extending the life of a laptop’s battery charge. However,
several options also help to save electricity when you are using a computer that is
plugged in to an electricity source.

Click Computer→ Control Center→ System→ Power Management.
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Specifying Sleep Mode Times
Sleep mode shuts down the computer when it is unused for a specified amount of time.
Whether you are using battery or AC power, you can specify the amount of time that
the computer remains unused before it is put to sleep.You can also put the computer’s
display to sleep without shutting down the computer, saving the power required by the
display.

Sleep mode is especially important when the computer is operating under battery
power. Both the screen and the computer draw power from the battery, so you can save
a significant amount of battery power by shutting down one or both. It is common to
put the display to sleep after a shorter period of time. Then, if the computer remains
unused for an additional amount of time, it is also put to sleep.

To specify your computer’s sleep settings:

1 Click Computer→ Control Center→ System→ Power Management.

2 Click the tab for the type of power you are using.

If your computer uses AC power, click Running on AC.

If your computer runs on battery power, click Running on Battery.

If your computer operates on both AC and battery power, you can configure the
settings on both tabs. The settings you choose are in effect no matter which
power source you use.

3 Use the sliders to set the amount of inactive time that passes before the display
and computer go into sleep mode.

When the display is in sleep mode, the computer continues to run. When the
computer is in sleep mode, power to the display and hard disk is shut off and the
computer uses only the power needed to maintain the contents of RAM.

4 (Conditional) If the computer is a laptop, set the actions you want taken when
the laptop lid is closed.

The following actions are available:

Do nothing: The laptop continues to run normally when the lid is closed.
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Blank screen: The screen is blanked, reducing power consumption.

Suspend: Suspend mode turns off power-consuming computer components
such as the display and the hard drive without saving the contents of RAM. Any
unsaved data is lost.

Hibernate: Hibernate mode saves all contents of RAM to the hard disk before
shutting off power to the system. When you start the system again, the saved
data is put back into RAM, restoring your computer to the state it was in before
it shut off. Hibernate requires an amount of free hard disk space equal to the
amount of RAM installed on the computer.

5 (Conditional) If you configure how a laptop manages battery power, configure
the action you want taken if battery power reaches a critical level.

The available options are:

Do nothing: The computer does not shut down or automatically go into any
kind of power-saving mode.

Suspend: Suspend mode turns off power-consuming computer components
such as the display and the hard drive without saving the contents of RAM. Any
unsaved data is lost.

Hibernate: The computer saves the contents of RAM to the hard disk, then
shuts down. When you turn the computer on again, the saved data is put back
into RAM, restoring your computer to the state it was in before it shut off. Hiber-
nate requires an amount of free hard disk space equal to the amount of RAM in-
stalled on the computer.

Shut down: The computer turns off without saving anything. All unsaved
data is lost.

Choose the option you prefer by selecting it from the menu. If you have sufficient
free disk space, Hibernate is the best choice.

6 (Optional) If you want power management to prefer power savings over perfor-
mance, select the check box for that option.

If the check box is selected, the performance of some power-consuming features,
such as the display, is reduced slightly to reduce power consumption.
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7 Click Close.

The options you selected go into effect immediately.

Setting General Power Options
To set general power options, click Computer→ Control Center→ System→ Power
Management, then click the General tab. On this tab, you can choose:

• The sleep type to use when the computer is inactive

• The action to take when the power button is pressed

• How and when the Power icon displays

The available options are:

Table 2.10 General Power Management Options

OptionsSetting

Sleep type when inac-
tive

• Do nothing

The computer does not shut down or automatically go
into any kind of power-saving mode.

• Suspend

Suspend mode turns off power-consuming computer
components such as the display and the hard drive
without saving the contents of RAM. Any unsaved
data is lost.

• Hibernate

The computer saves the contents of RAM to the hard
disk, then shuts down. When you turn the computer
on again, the saved data is put back into RAM, restor-
ing your computer to the state it was in before it shut
off. Hibernate requires an amount of free hard disk
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OptionsSetting

space equal to the amount of RAM installed on the
computer.

When power button is
pressed

• Ask me

Displays a prompt asking what action to take.

• Suspend

Turns off power-consuming components but continues
to use enough power to maintain the contents of RAM.

• Hibernate

Saves the contents of RAM to the hard disk and shuts
down.

• Shutdown

Shuts down the computer without saving the contents
of RAM.

Determines how the power icon is displayed in the task
panel. The options are:

Notification area

• Never display icon

• Only display when battery level is critical

• Only display when charging or discharging

• Only display when battery present

• Always display icon
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2.4.6 Setting Preferred Applications
The Preferred Applications module allows you to specify which applications to use for
various common tasks:

To change any of these settings:

1 Click Computer→ Control Center→ System→ Preferred Applications.

2 Click the tab for the type of application you want to set.

The following list shows the options and default settings.

• Web browser

Default: Firefox

• Mail reader

Default: Evolution

• Terminal

GNOME Terminal

3 Select one of the available from the applications from the Choosemenu or enter
the command used to start the application.

4 Click Close.

The changes take effect immediately.
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2.4.7 Configuring Search with Beagle
Settings

Beagle is the search engine used on the GNOME Desktop. By default, Beagle is con-
figured to start automatically and index your home directory. If you want to change
these settings, specify the number of results displayed after a search or change the
Beagle privacy settings, clickComputer→Control Center→ System→ Search Settings.

2.4.8 Managing Sessions
This module lets you manage your sessions. A session occurs between the time that
you log in to the desktop environment and the time that you log out. You can set session
preferences and specify which applications to start when you begin a session. You can
configure sessions to save the state of applications and then restore the state when you
start another session.

You can also use this preference tool to manage multiple sessions. For example, you
might have a mobile session which starts applications you use most frequently when
traveling, a demo session that starts applications used to present a demonstration or
slide show to a customer, and a work session that uses a different set of applications
when you are working in the office.

Click Computer→ Control Center→ System→ Sessions.

This module consists of three tabbed pages:

• Session Options: Lets you manage multiple sessions and set preferences for the
current session.

• Current Session: Lets you specify startup order values and select restart styles
for the session-managed applications in your current session.

• Startup Programs: Lets you specify non-session-managed startup applications,
which start automatically when you start a session.
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Setting Session Preferences
Use the Session Options tabbed page to manage multiple sessions and set preferences
for the current session.

Figure 2.28 Sessions Dialog—Session Options Page

The following table lists the session options that you can modify.

Table 2.11 Session Preferences for Current Session

DescriptionOption

Displays a splash screen when you start a session.Show Splash Screen on Login

Displays a confirmation dialog when you end a
session.

Ask on Logout

Automatically saves the current state of your
session. The session manager saves the session-

Automatically Save Changes to
Session

managed applications that are open and the set-
tings associated with the session-managed appli-
cations. The next time you start a session, the
applications start automatically with the saved
settings.
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DescriptionOption

If you do not select this option, the Logout Con-
firmation dialog displays a Save Current Setup
option when you end your session.

Lets youmanagemultiple sessions in the desktop,
as follows:

Sessions

• To create a new session, click Add. The Add
a New Session dialog is displayed, letting
you specify a name for your session.

• To change the name of a session, select the
session and then click Edit. The Edit Ses-
sion Name dialog is displayed, letting you
specify a new name for your session.

• To delete a session, select the session and
then click Delete.

Setting Session Properties
Use the Current Session tabbed page to specify startup order values and to choose restart
styles for the session-managed applications in your current session.
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Figure 2.29 Sessions Dialog—Current Session Page

The following table lists the session properties that you can configure.

Table 2.12 Session Properties for Session-Managed Applications

DescriptionOption

Specifies the order in which the session manager starts session-managed
startup applications. The session manager starts applications with lower
order values first. The default value is 50.

Order

To set the startup order of an application, select the application in the table.
Use the Order box to specify the startup order value.

Determines the restart style of an application. To select a restart style for
an application, select the application in the table and then select one of
the following styles:

Style

• Normal: Starts automatically when you start a session. Use the
kill command to terminate applications with this restart style during
a session.

• Restart: Restarts automatically when you close or terminate the
application. Select this style for an application if it must run continu-
ously during your session. To terminate an application with this restart
style, select the application in the table and then click Remove.
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DescriptionOption

• Trash: Does not start when you start a session.

• Settings: Starts automaticallywhen you start a session. Applications
with this style usually have a low startup order and store your confi-
guration settings for GNOME and session-managed applications.

Deletes the selected application from the list. The application is removed
from the session manager and closed. Applications that you delete are not
started the next time you start a session.

Remove

Applies changes made to the startup order and the restart style.Apply

Configuring Startup Applications
Use the Startup Programs tabbed page to specify non-session-managed startup applica-
tions.

Figure 2.30 Sessions Dialog—Startup Programs Page

Startup applications are applications that start automatically when you begin a session.
You specify the commands that run these applications and the commands execute auto-
matically when you log in.
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You can also start session-managed applications automatically. For more information,
see Section “Setting Session Preferences” (page 91).

To add a startup application, click Add. The Add Startup Program dialog is displayed.
Specify the command to start the application in the Startup Command field. If you
specify more than one startup application, use theOrder box to specify the startup order
of the each application.

To edit a startup application, select the startup application and then click Edit. The Edit
Startup Program dialog is displayed. Modify the command and the startup order for the
startup application.

To delete a startup application, select the startup application and then click Delete.

To disable a startup application, select the startup application and then click Disable.

2.4.9 Setting Sound Preferences
The Sound Preferences tool lets you control when the sound server starts. You can also
specify which sounds to play when particular events occur.

Click Computer→ Control Center→ System→ Sound to open the Sound Preferences
tool.

Setting Sound Devices
Use the Devices tab to configure the application to use for various types of sounds.
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Figure 2.31 Sound Preferences Dialog—Devices Page

Click the drop-down list for each type of sound and select the application to use. In
most cases, Autodetect is the best choice, unless you want to use a specific application.

Setting General Sound Preferences
Use the Sounds tab to specify when to launch the sound server. You can also enable
sound event functions.
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Figure 2.32 Sound Preferences Dialog—General Page

Click Enable software sound mixing (ESD) to start the sound server when you start a
session. When the sound server is active, the desktop can play sounds.

Click Play system sounds to play sounds when particular events occur in the desktop.

Finally, select the sound to play at each of the specified events.
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Setting System Beep Preferences
Some applications play a beep sound to indicate a keyboard input error. Use the System
Beep tab to set preferences for the system beep.

Figure 2.33 Sound Preferences Dialog—System Beep Page
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2.4.10 Managing Users and Groups
Use the User Management tool to manage users and groups, including user and group
names, group membership, password and password encryption, and other options.

ClickComputer→Control Center→ System→UserManagement. TheUserManage-
ment tool opens the User and Group Administration module in YaST.

NOTE

Root privileges are required to manage users and groups.

Follow the directions in YaST for information on changing settings.

2.4.11 Configuring Administrative Settings
with YaST

For your convenience, YaST is available from the Control Panel as well as the Appli-
cations menu. For information about using YaST see the Reference manual that came
with your distribution of openSUSE.

Customizing Your Settings 99





Part II. Office and Collaboration





3The OpenOffice.org Office
Suite
OpenOffice.org is a powerful open-source office suite that provides tools for all types
of office tasks, such as writing texts, working with spreadsheets, or creating graphics
and presentations. With OpenOffice.org, you can use the same data across different
computing platforms. You can also open and edit files in other formats, including Mi-
crosoft Office, then save them back to this format, if needed. This chapter covers infor-
mation about the Novell® edition of OpenOffice.org and some of the key features you
should be aware of when getting started with the suite.

• Section 3.1, “Understanding OpenOffice.org” (page 104)

• Section 3.2, “Word Processing with Writer” (page 113)

• Section 3.3, “Using Spreadsheets with Calc” (page 124)

• Section 3.4, “Using Presentations with Impress” (page 126)

• Section 3.5, “Using Databases with Base” (page 129)

• Section 3.6, “Creating Graphics with Draw” (page 133)

• Section 3.7, “Creating Mathematical Formulas with Math” (page 134)

• Section 3.8, “Finding Help and Information About OpenOffice.org” (page 134)

OpenOffice.org consists of several application modules (subprograms), which are de-
signed to interact with each other. They are listed in Table 3.1, “The OpenOffice.org
Application Modules” (page 104). A full description of each module is available in the
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online help, described in Section 3.8, “Finding Help and Information About OpenOf-
fice.org” (page 134).

Table 3.1 The OpenOffice.org Application Modules

PurposeModule

Word processor application moduleWriter

Spreadsheet application moduleCalc

Presentation application moduleImpress

Database application moduleBase

Application module for drawing vector graphicsDraw

Application module for generating mathematical formulasMath

The appearance of the application varies depending on the desktop or windowmanager
you use. Regardless of the appearance, the basic layout and functions are the same.

3.1 Understanding OpenOffice.org
This section contains information that applies to all of the application modules in
OpenOffice.org. Module-specific information can be found in the sections relating to
each module.

• Section 3.1.1, “Using the Standard Edition of OpenOffice.org” (page 105)

• Section 3.1.2, “Compatibility with Other Office Applications” (page 105)

• Section 3.1.3, “Starting OpenOffice.org” (page 107)

• Section 3.1.4, “Improving OpenOffice.org Load Time” (page 108)

• Section 3.1.5, “Customizing OpenOffice.org” (page 108)

• Section 3.1.6, “Finding Templates” (page 112)
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3.1.1 Using the Standard Edition of
OpenOffice.org

You can use the standard edition of OpenOffice.org rather than the Novell edition. If
you install the latest version of OpenOffice.org, all of your Novell Edition files remain
compatible. However, the standard edition does not contain enhancements made in the
Novell edition.

3.1.2 Compatibility with Other Office
Applications

OpenOffice.org can work with documents, spreadsheets, presentations, and databases
in many other formats, includingMicrosoft Office. They can be seamlessly opened like
other files and saved back to the original format. Because the Microsoft formats are
proprietary and the specifications are not available to other applications, there are occa-
sionally formatting issues. If you have problems with your documents, consider opening
them in the original application and resaving in an open format such as RTF for text
documents or CSV for spreadsheets.

TIP

For good information about migrating from other office suites to OpenOf-
fice.org, refer to the OpenOffice.org Migration Guide [http://
documentation.openoffice.org/manuals/oooauthors2/
0600MG-MigrationGuide.pdf].

Converting Documents to the OpenOffice.org Format
OpenOffice.org can read, edit, and save documents in a number of formats. It is not
necessary to convert files from those formats to the OpenOffice.org format to use those
files. However, if you want to convert the files, you can do so. To convert a number of
documents, such as when first switching to OpenOffice.org, do the following:

1 Select File→ Wizard→ Document Converter.

2 Choose the file format from which to convert.
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There are several StarOffice and Microsoft Office formats available.

3 Click Next.

4 Specify where OpenOffice.org should look for templates and documents to
convert and in which directory the converted files should be placed.

IMPORTANT

Documents from a Windows partition are usually in a subdirectory of
/windows.

5 Make sure that all other settings are appropriate, then click Next.

6 Review the summary of the actions to perform, then start the conversion by
clicking Convert.

The amount of time needed for the conversion depends on the number of files
and their complexity. For most documents, conversion does not take very long.

Sharing Files with Users of Other Office Suites
OpenOffice.org is available for a number of operating systems. This makes it an excellent
tool when a group of users frequently need to share files and do not use the same system
on their computers.

When sharing documents with others, you have several options.

If the recipient needs to be able to edit the file: Save the document in the format
the other user needs. For example, to save as a Microsoft Word file, click File→ Save
As, then select the Microsoft Word file type for the version of Word the other user
needs.

If the recipient only needs to read the document: Export the document to a PDF
file with File→ Export as PDF. PDF files can be read on any platform using a viewer
like Adobe Acrobat Reader.

If you want to share a document for editing: Use one of the standard document
formats. The default formats comply with the OASIS standard XML format, making
them compatible with a number of applications. TXT and RTF formats, although limited
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in formatting, might be a good option for text documents. CSV is useful for spreadsheets.
OpenOffice.org might also offer your recipient's preferred format, especiallyMicrosoft
formats.

If you want to e-mail a document as a PDF: Click File→ Send→ Document as
PDF Attachment.Your default e-mail program opens with the file attached.

If you want to e-mail a document to a Microsoft Word user: Click File→ Send
→ Document as MS-Doc Attachment. Your default e-mail program opens with the file
attached.

3.1.3 Starting OpenOffice.org
1 Start the application in one of the following ways:

•
On the menu bar, click .

This opens Writer. To open a different module, click File→ New from the
newly opened Writer document, then choose the module you want to open.

• From the Computer menu, click Computer→More Applications→ Office,
then click the name of the OpenOffice.org module you want to start.

• In a terminal window, enter ooffice. The OpenOffice.org window opens.
Click File→ New, then choose the module you want to open.

2 Select the module you want to open.

If any OpenOffice.org application is open, you can open any of the other applications
by clicking File→ New→ Name of Application.
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3.1.4 Improving OpenOffice.org Load Time
To speed up the load time of OpenOffice.org by preloading the application at system
startup:

1 Click Tools→ Options→ Memory.

2 Select Start at Startup.

The next time you restart your system, OpenOffice.org will preload. When you open
an OpenOffice.org application module, it will open faster.

3.1.5 Customizing OpenOffice.org
You can customize OpenOffice.org to best suit your needs and working style. Toolbars,
menus, and keyboard shortcuts can all be reconfigured to help you more quickly access
the features you use the most. You can also assign macros to application events if you
want specific actions to occur when those events take place. For example, if you always
work with a specific spreadsheet, you can create a macro that opens the spreadsheet
and assign it to the Start Application event.

This section contains simple, generic instructions for customizing your environment.
The changes you make are effective immediately, so you can see if the changes are
what you wanted and go back and modify them if they weren’t. See the OpenOffice.org
help files for detailed instructions.

Customizing Toolbars
Use the Customize dialog to modify OpenOffice.org toolbars.

1 Click the arrow icon at the end of any toolbar.

2 Click Customize Toolbar.

3 Select the toolbar you want to customize.

4 Select the check boxes next to the commands you want to appear on the toolbar,
and deselect the check boxes next to the commands you don’t want to appear.
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5 Select whether to save your customized toolbar in the OpenOffice.org module
you are using or in the document.

• OpenOffice.org module

The customized toolbar is used whenever you open that module.

• Document filename

The customized toolbar is used whenever you open that document.

6 Repeat to customize additional toolbars.

7 Click OK.

You can quickly choose the buttons that appear on a particular toolbar.

1 Click the arrow icon at the end of the toolbar you want to change.

2 Click Visible Buttons to display a list of buttons.

3 Select the buttons in the list that appears to enable (check) or disable (uncheck)
them.

Customizing Menus
You can add or delete items from current menus, reorganize menus, and even create
new menus.

1 Click Tools→ Customize→ Menu.

2 Select the menu you want to change, or click New to create a new menu.

Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete menu items as desired.

4 Click OK.
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Customizing Keyboard Shortcuts
You can reassign currently assigned keyboard shortcuts and assign new shortcuts to
frequently used functions.

1 Click Tools→ Customize→ Keyboard.

2 Select the keys you want to assign to a function, or select the function and assign
the keys or key combinations.

Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete keyboard shortcuts as desired.

4 Click OK.

Customizing Events
OpenOffice.org also provides ways to assign macros to events such as application
startup or the saving of a document. The assigned macro runs automatically whenever
the selected event occurs.

1 Click Tools→ Customize→ Events.

2 Select the event you want to change.

Click Help for more information about the options in the Customize dialog box.

3 Assign or remove macros for the selected event.

4 Click OK.

Changing the Global Settings
Global settings can be changed in any OpenOffice.org application by clicking Tools
→ Options on the menu bar. This opens the window shown in the figure below. A tree
structure is used to display categories of settings.
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Figure 3.1 The Options Window

The following table lists the settings categories along with a brief description of each
category:

Table 3.2 Global Setting Categories

DescriptionSettings Category

Various basic settings, including your user data (such as your
address and e-mail), important paths, and settings for printers
and external programs.

OpenOffice.org

Includes the settings related to the opening and saving of sev-
eral file types. There is a dialog for general settings and several

Load/Save

special dialogs to define how external formats should be han-
dled.

Covers the various settings related to languages and writing
aids, such as your locale and spell checker settings. This is also
the place to enable support for Asian languages.

Language Settings

Includes the dialogs to configure any proxies and to change
settings related to search engines.

Internet

Configures the global word processing options, such as the
basic fonts and layout that Writer should use.

Text Document
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DescriptionSettings Category

Changes the settings related to the HTML authoring features
of OpenOffice.org.

HTML Document

Changes the settings for Calc, such as those related to sort lists
and grids.

Spreadsheet

Changes the settings that should apply to all presentations. For
example, you can specify the measurement unit for the grid
used to arrange elements.

Presentation

Includes the settings related to the vector drawing module,
such as the drawing scale, grid properties, and some print op-
tions.

Drawing

Provides a single dialog to set special print options for formu-
las.

Formula

Defines the default colors used for newly created charts.Chart

Defines how external data sources should be accessed.Data Sources

IMPORTANT

All settings listed in the table are applied globally. They are used as defaults
for every new document you create.

3.1.6 Finding Templates
Templates greatly enhance the use of OpenOffice.org by simplifying formatting tasks
for a variety of different types of documents. OpenOffice.org comes with a few tem-
plates, and you can find additional templates on the Internet. You can also create your
own. Creating templates is beyond the scope of this guide, but detailed instructions are
found in the OpenOffice.org help system and in other documents and tutorials available
online.
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In addition to templates, you can find other extras and add-ins online. The following
table lists a few of the prominent places where you can find templates and other extras.
(BecauseWeb sites often close or their content changes, the information in the following
table might not be current when you read it.)

Table 3.3 Where to Find OpenOffice.org Templates and Extras

What You Can FindLocation

Templates for Calc spreadsheets, CD
cases, seed packets, fax cover sheets, and
more

OpenOffice.org documentation Web site
[http://documentation
.openoffice.org/Samples
_Templates/User/template_2
_x/index.html]

Templates for many types of labelsWorldlabel.com [http://www
.worldlabel.com/Pages/
openoffice-template.htm]

For more information about templates, see Section 3.2.4, “Using Templates to Format
Documents” (page 119) and Section 3.3.2, “Using Templates in Calc” (page 125).

3.2 Word Processing with Writer
OpenOffice.org Writer is a full-featured word processor with page and text formatting
capabilities. Its interface is similar to interfaces for other major word processors, and
it includes some features that are usually found only in expensive desktop publishing
applications.

This section highlights a few key features of Writer. For more information about these
features and for complete instructions for usingWriter, look at the OpenOffice.org help
or any of the sources listed in Section 3.8, “Finding Help and Information About
OpenOffice.org” (page 134).
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NOTE

Much of the information in this section can also be applied to other OpenOf-
fice.org modules. For example, other modules use styles similarly to how they
are used in Writer.

• Section 3.2.1, “Creating a New Document” (page 114)

• Section 3.2.2, “Sharing Documents with Other Word Processors” (page 115)

• Section 3.2.3, “Formatting with Styles” (page 116)

• Section 3.2.4, “Using Templates to Format Documents” (page 119)

• Section 3.2.5, “Working with Large Documents” (page 120)

• Section 3.2.6, “Using Writer as an HTML Editor” (page 123)

3.2.1 Creating a New Document
There are two ways to create a new document:

To create a document from scratch, click File→ New→ Text Document.

To use a standard format and predefined elements for your own documents, try a wizard.
Wizards are small utilities that let you make some basic decisions then produce a ready-
made document from a template. For example, to create a business letter, click File→
Wizards→ Letter. Using the wizard's dialogs, easily create a basic document using a
standard format. A sample wizard dialog is shown in Figure 3.2, “An OpenOffice.org
Wizard” (page 115).
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Figure 3.2 An OpenOffice.org Wizard

Enter text in the document window as desired. Use the Formatting toolbar or the Format
menu to adjust the appearance of the document. Use theFilemenu or the relevant buttons
in the toolbar to print and save your document. With the options under Insert, add extra
items to your document, such as a table, picture, or chart.

3.2.2 Sharing Documents with Other Word
Processors

You can use Writer to edit documents created in a variety of other word processors.
For example, you can import a Microsoft Word document, edit it, and save it again as
aWord document. MostWord documents can be imported into OpenOffice.org without
any problem. Formatting, fonts, and all other aspects of the document remain intact.
However, some very complex documents—such as documents containing complicated
tables, Word macros, or unusual fonts or formatting—might require some editing after
being imported. OpenOffice.org can also save inmany popular word processing formats.
Likewise, documents created in OpenOffice.org and saved asWord files can be opened
in Microsoft Word without any trouble.

So, if you use OpenOffice.org in an environment where you frequently share documents
with Word users, you should have little or no trouble exchanging document files. Just
open the files, edit them, and save them as Word files.
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3.2.3 Formatting with Styles
OpenOffice.org uses styles for applying consistent formatting to various elements in a
document. The following types of styles are available:

Table 3.4 About the Types of Styles

What it DoesType of Style

Applies standardized formatting to the various types of
paragraphs in your document. For example, apply a paragraph

Paragraph

style to a first-level heading to set the font and font size,
spacing above and below the heading, location of the heading,
and other formatting specifications.

Applies standardized formatting for types of text. For exam-
ple, if you want emphasized text to appear in italics, you can

Character

create an emphasis style that italicizes selected text when
you apply the style to it.

Applies standardized formatting to frames. For example, if
your document uses sidebars, you can create frames with

Frame

specified graphics, borders, location, and other formatting
so that all of your sidebars have a consistent appearance.

Applies standardized formatting to a specified type of page.
For example, if every page of your document contains a

Page

header and footer except for the first page, you can use a first
page style that disables headers and footers. You can also
use different page styles for left and right pages so that you
have bigger margins on the insides of pages and your page
numbers appear on an outside corner.

Applies standardized formatting to specified list types. For
example, you can define a checklist with square check boxes

List

and a bullet list with round bullets, then easily apply the
correct style when creating your lists.
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Opening the Styles and Formatting Window
The Styles and Formatting window (called the Stylist in earlier versions of OpenOf-
fice.org), is a versatile formatting tool for applying styles to text, paragraphs, pages,
frames, and lists. To open this window, click Format→ Styles and Formatting.
OpenOffice.org comes with several predefined styles. You can use these styles as they
are, modify them, or create new styles.

TIP

By default, the Styles and Formatting window is a floating window; that is, it
opens in its own window that you can place anywhere on the screen. If you
use styles extensively, you might find it helpful to dock the window so that it
always present in the same part of the Writer interface. To dock the Styles and
Formatting window, press Ctrl while you double-click on a gray area in the
window. This tip applies to some other windows in OpenOffice.org as well, in-
cluding the Navigator.

Applying a Style
To apply a style, select the element you want to apply the style to, and then double-
click the style in the Styles and Formatting window. For example, to apply a style to a
paragraph, place the cursor anywhere in that paragraph and double-click the desired
style.

Using Styles Versus Using Formatting Buttons and
Menu Options
Using styles rather than the Format menu options and buttons helps give your pages,
paragraphs, texts, and lists a more consistent look and makes it easier to change your
formatting. For example, if you emphasize text by selecting it and clicking the Bold
button, then later decide you want emphasized text to be italicized, you need to find all
of your bolded text and manually change it to italics. If you use a character style, you
only need to change the style from bold to italics and all text that has been formatted
with that style automatically changes from bold to italics.

Text formatted with a menu option or button overrides any styles you have applied. If
you use the Bold button to format some text and an emphasis style to format other text,
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then changing the style does not change the text that you formatted with the button,
even if you later apply the style to the text you bolded with the button. You must man-
ually unbold the text and then apply the style.

Likewise, if you manually format your paragraphs using Format→ Paragraph, it is
easy to end up with inconsistent paragraph formatting. This is especially true if you
copy and paste paragraphs from other documents with different formatting.

Changing a Style
Styles are powerful because you can change formatting throughout a document by
changing a style, rather than applying the change separately everywhere you want to
apply the new formatting.

1 In the Styles and Formatting window, right-click the style you want to change.

2 ClickModify.

3 Change the settings for the selected style.

For information about the available settings, refer to the OpenOffice.org online
help.

4 Click OK.

Creating a Style
OpenOffice.org comes with a collection of styles to suit many users’ needs. However,
most users eventually need a style that does not yet exist. To create a new style:

1 Right-click in any empty space in the Styles and Formatting window.

Make sure you are in the list of styles for the type of style you want to create.
For example, if you are creating a character style, make sure you are in the
character style list.

2 Click New.

3 Click OK.
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4 Name your style and choose the settings you want applied with that style.

For details about the style options available in any tab, click that tab and then
click Help.

3.2.4 Using Templates to Format Documents
Most word processor users create more than one kind of document. For example, you
might write letters, memos, and reports, all of which look different and require different
styles. If you create a template for each of your document types, the styles you need
for each document are always readily available.

Creating a template requires a little bit of up-front planning. You need to determine
what you want the document to look like so you can create the styles you need in that
template. You can always change your template, but a little planning can save you a
lot of time later.

NOTE

You can convert Microsoft Word templates like you would any other Word
document. See Section “Converting Documents to the OpenOffice.org Format”
(page 105) for information.

A detailed explanation of templates is beyond the scope of this section. However, more
information is found in the help system, and detailed how-tos are found at the
OpenOffice.org Documentation page [http://documentation.openoffice
.org/HOW_TO/index.html].

Creating a Template
A template is a text document containing only the styles and content that you want to
appear in every document, such as your address information and letterhead on a letter.
When a document is created or opened with the template, the styles are automatically
applied to that document.
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To create a template:

1 Click File→ New→ Text Document.

2 Create the styles and content that you want to use in any document that uses this
template.

3 Click File→ Templates→ Save.

4 Specify a name for the template.

5 In the Categories box, click the category you want to place the template in.

The category is the folder where the template is stored.

6 Click OK.

3.2.5 Working with Large Documents
You can useWriter to work on large documents. Large documents can be either a single
file or a collection of files assembled into a single document.

Navigating in Large Documents
The Navigator tool displays information about the contents of a document. It also lets
you quickly jump to different elements. For example, you can use the Navigator to get
a quick overview of all images included in the document.

To open the Navigator, click Edit→ Navigator. The elements listed in the Navigator
vary according to the document loaded in Writer.
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Figure 3.3 Navigator Tool in Writer

Click an item in the Navigator to jump to that item in the document.

Creating a Single Document from Multiple
Documents
If you are working with a very large document, such as a book, you might find it easier
to manage the book with a master document, rather than keeping the book in a single
file. A master document enables you to quickly apply formatting changes to a large
document or to jump to each subdocument for editing.

A master document is a Writer document that serves as a container for individual
Writer files. You can maintain chapters or other subdocuments as individual files col-
lected in the master document. Master documents are also useful if multiple people are
working on a document. You can separate each person’s portion of the document into
subdocuments collected in a master document, allowing multiple writers to work on
their subdocuments at the same time without fear of overwriting other people’s work.
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NOTE

If you are coming to OpenOffice.org from Microsoft Word, you might be ner-
vous about using master documents because the master document feature in
Word has a reputation for corrupting documents. This problem does not exist
in OpenOffice.org Writer, so you can safely use master documents to manage
your projects.

To create a master document:

1 Click New→ Master Document.

or

Open an existing document and click File→ Send→ Create Master Document.

2 Insert subdocuments.

3 Click FileSave.

The OpenOffice.org help files contain more complete information about working with
master documents. Look for the topic entitled “Using Master Documents and Subdoc-
uments.”

TIP

The styles from all of your subdocuments are imported into the master docu-
ment. To ensure that formatting is consistent throughout your master document,
you should use the same template for each subdocument. Doing so is not
mandatory; however, if subdocuments are formatted differently, you will
probably need to do some reformatting to successfully bring subdocuments
into the master document without creating inconsistencies. For example, if two
documents imported into your master document include different styles with
the same name, the master document will use the formatting specified for that
style in the first document you import.
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3.2.6 Using Writer as an HTML Editor
In addition to being a full-featured word processor, Writer also functions as an HTML
editor. Writer includes HTML tags that can be applied as you would any other style in
a Writer document. You can view the document as it will appear online, or you can
directly edit the HTML code.

Creating an HTML Document
1 Click File→ New→ HTML Document.

2 Click the arrow at the bottom of the Formatting and Styles window.

3 Select HTML Styles.

4 Create your HTML document, using the styles to tag your text.

5 Click FileSave As.

6 Select the location where you want to save your file, name the file, and select
HTML Document (.html) from the Filter list.

7 Click OK.

If you prefer to edit HTML code directly, or if you want to see the HTML code created
when you edited the HTML file as a Writer document, click View→ HTML Source.
In HTML Source mode, the Formatting and Styles list is no longer available.

NOTE

The first time you switch to HTML Source mode, you are prompted to save the
file as HTML, if you have not already done so.
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3.3 Using Spreadsheets with Calc
Calc is the OpenOffice.org spreadsheet application. Create a new spreadsheet with File
→ New→ Spreadsheet or open one with File→ Open. Calc can read and save in Mi-
crosoft Excel's format, so it is easy to exchange spreadsheets with Excel users.

NOTE

Calc can process many VBA macros in Excel documents; however, support for
VBA macros is not yet complete. When opening an Excel spreadsheet that
makes heavy use of macros, you might discover that some do not work.

In the spreadsheet cells, enter fixed data or formulas. A formula can manipulate data
from other cells to generate a value for the cell in which it is inserted. You can also
create charts from cell values.

• Section 3.3.1, “Using Formatting and Styles in Calc” (page 124)

• Section 3.3.2, “Using Templates in Calc” (page 125)

3.3.1 Using Formatting and Styles in Calc
Calc comes with a few built-in cell and page styles to improve the appearance of your
spreadsheets and reports. Although these built-in styles are adequate for many uses,
you will probably find it useful to create styles for your own frequently used formatting
preferences.

Creating a Style
1 Click Format→ Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click in the Formatting and Styles window, then click New.

4 Specify a name for your style and use the various tabs to set the desired formatting
options.
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5 Click OK.

Modifying a Style
1 Click Format→ Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click the name of the style you want to change, then clickModify.

4 Change the desired formatting options.

5 Click OK.

3.3.2 Using Templates in Calc
If you use different styles for different types of spreadsheets, you can use templates to
save your styles for each spreadsheet type. Then, when you create a particular type of
spreadsheet, open the applicable template and the styles you need for that template are
available in the Formatting and Styles window.

A detailed explanation of templates is beyond the scope of this section. However, more
information is found in the help system and detailed how-tos are found at the OpenOf-
fice.org Documentation page [http://documentation.openoffice.org/
HOW_TO/index.html].

Creating a Template
ACalc template is a spreadsheet that contains styles and content that you want to appear
in every spreadsheet created with that template, such as headings or other cell styles.
When a spreadsheet is created or opened with the template, the styles are automatically
applied to that spreadsheet.
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To create a template:

1 Click File→ New→ Spreadsheet.

2 Create the styles and content that you want to use in any spreadsheet that uses
this template.

3 Click File→ Templates→ Save.

4 Specify a name for the template.

5 In the Categories box, click the category you want to place the template in.

The category is the folder where the template is stored.

6 Click OK.

3.4 Using Presentations with Impress
Use OpenOffice.org Impress to create presentations for screen display or printing, such
as slide shows or transparencies. If you have used other presentation software, you can
move comfortably to Impress, which works very similarly to other presentation software.

Impress can open and save Microsoft Powerpoint presentations, which means you can
exchange presentations with Powerpoint users, as long as you save your presentations
in Powerpoint format.

• Section 3.4.1, “Creating a Presentation” (page 126)

• Section 3.4.2, “Using Master Pages” (page 127)

3.4.1 Creating a Presentation
1 Click File→ New→ Presentation.

2 Select the option to use for creating the presentation.
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There are two ways to create a presentation:

• Create an empty presentation

Opens Impress with a blank slide. Use this option to create a new presentation
from scratch, without any preformatted slides.

• Create a presentation from a template

Opens Impress with your choice of template. Use this option to create a new
presentationwith a predesignedOpenOffice.org template or a template you’ve
created or installed yourself, such as your company’s presentation template.
Impress uses styles and templates the same way other OpenOffice.org mod-
ules do. See Section 3.2.4, “Using Templates to Format Documents”
(page 119) for more information about templates.

3.4.2 Using Master Pages
Master pages give your presentation a consistent look by defining the way each slide
looks, what fonts are used, and other graphical elements. Impress uses two types of
master pages:

• Slide master

Contains elements that appear on all slides. For example, you might want your
company logo to appear in the same place on every slide. The slide master also
determines the text formatting style for the heading and outline of every slide that
uses that master page, as well as any information you want to appear in a header
or footer.

• Notes master

Determines the formatting and appearance of the notes in your presentation.
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Creating a Slide Master
Impress comes with a collection of preformatted master pages. Eventually, most users
will want to customize their presentations by creating their own slide masters.

1 Start Impress, then create a new empty presentation.

2 Click View→ Master→ Slide Master.

This opens the current slide master in Master View.

3 Right-click the left-hand panel, then click New Master.

4 Edit the slide master until it has the desired look.

5 Click Close Master View or View→ Normal to return to Normal View.

TIP

When you have created all of the slide masters you want to use in your presen-
tations, you can save them in an Impress template. Then, any time you want
to create presentations that use those slide masters, open a new presentation
with your template.

Applying a Slide Master
Slide masters can be applied to selected slides or to all slides in the presentation.

1 Open your presentation, then click View→ Master→ Slide Master.

2 (Optional) If you want to apply the slide master to multiple slides, but not to all
slides, select the slides that you want to use that slide master.

To select multiple slides, in the Slides Pane, Control-click on the slides you want
to use that slide master.

3 In the Task Pane, right-click the master page you want to apply.

If you do not see the Task Pane, click View→ Task Pane.
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4 Apply the slide master by clicking one of the following:.

• Apply to All Slides

Applies the selected slide master to all slides in the presentation.

• Apply to Selected Slides

Applies the selected slide master to the current slide, or to any slides you
select before applying the slide master. For example, if you want to apply a
different slide master to the first slide in a presentation, select that slide, then
change to Master View and apply a slide master to that slide.

3.5 Using Databases with Base
OpenOffice 2.0 introduces a new databasemodule, Base. Use Base to design a database
to store many different kinds of information, from a simple address book or recipe file
to a sophisticated document management system.

Tables, forms, queries, and reports can be createdmanually or using convenient wizards.
For example, the Table Wizard contains a number of common fields for business and
personal use. Databases created in Base can be used as data sources, such as when
creating form letters.

It is beyond the scope of this document to detail database design with Base. More infor-
mation can be found at the sources listed in Section 3.8, “Finding Help and Information
About OpenOffice.org” (page 134).

3.5.1 Creating a Database Using Predefined
Options

Base comes with several predefined database fields to help you create a database. The
steps in this section are specific to creating an address book using predefined fields,
but it should be easy to follow them to use the predefined fields for any of the built-in
database options.
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The process for creating a database can be broken into several subprocesses:

• Section “Creating the Database” (page 130)

• Section “Setting Up the Database Table” (page 130)

• Section “Creating a Form” (page 131)

• Section “Modifying the Form” (page 132)

• Section “What’s Next?” (page 132)

Creating the Database
First, create the database.

1 Click File→ New→ Database.

2 Select Create a new database, then click Next.

3 Click Yes, register the database for me to make your database information
available to other OpenOffice.org modules, select both check boxes in the bottom
half of the dialog, then click Finish.

4 Browse to the directory where you want to save the database, specify a name for
the database, then click OK.

Setting Up the Database Table
Next, define the fields you want to use in your database table.

1 In the Table Wizard, click Personal.

The Sample tables list changes to show the predefined tables for personal use.
If you had clicked Business, the list would contain predefined business tables.

2 In the Sample tables list, click Addresses.

The available fields for the predefined address book appear in the Available
fields menu.
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3 In the Available fields menu, click the fields you want to use in your address
book.

You can select one item at a time, or you can shift-click multiple items to select
them.

4 Click the single right-arrow to move the selected items to the Selected fields
menu.

Tomove all available fields to the Selected fieldsmenu, click the double right-
arrow.

5 Use the up-arrow and down-arrow to adjust the order of the selected fields.

The fields appear in the table and forms in the order in which they are listed.

6 Click Next.

7 Make sure each of the fields is defined correctly.

You can change the field name, type, whether the entry is required, and the
maximum length of the field (the number of characters that can be entered in
that field. For this example, leave the settings as they are.

8 Click Next.

9 ClickCreate a primary key, click Automatically add a primary key, click Auto
value, then click Next.

10 Accept the default name for the table, selectCreate a form based on this table,
then click Finish.

Creating a Form
Next, create the form to use when entering data into your address book.

1 In the Form Wizard, click the double right-arrow to move all available fields to
the Fields in the form list, then click Next twice.

2 Select how you want to arrange your form, then click Next.
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3 Select the option to use the form to display all data and leave all of the check
boxes empty, then click Next.

4 Apply a style and field border, then click Next.

For this example, accept the default selections.

5 Name the form, select theModify the form option, then click Finish.

Modifying the Form
After the form has been defined, you can modify the appearance of the form to suit
your preferences.

1 Close the form that opened when you finished the previous step.

2 In the main window for your database, right-click the form you want to modify
(there should be only one option), then click Edit.

3 Arrange the fields on the form by dragging them to their new locations.

For example, move the First Name field so it appears to the right of the Last
Name field, and then adjust the locations of the other fields to suit your preference.

4 When you have finished modifying the form, save it and close it.

What’s Next?
After you have created your database tables and forms, you are ready to enter your data.
You can also design queries and reports to help sort and display the data.

Refer to OpenOffice.org online help and other sources listed in Section 3.8, “Finding
Help and Information About OpenOffice.org” (page 134) for additional information
about Base.
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3.6 Creating Graphics with Draw
Use OpenOffice.org Draw to create graphics and diagrams. You can save your drawings
in today’s most common formats and import them into any application that lets you
import graphics, including the other OpenOffice.org modules. You can also create Flash
versions of your drawings.

The OpenOffice.org documentation contains complete instructions on using Draw. See
Section 3.8, “Finding Help and Information About OpenOffice.org” (page 134) for more
information.

To use a Draw graphic in a document:

1 Open Draw, then create the graphic.

2 Save the graphic.

3 Copy the graphic and paste it into the document, or insert the graphic directly
from the document.

One particularly useful feature of Draw is the ability to open it from other OpenOf-
fice.org modules so you can create a drawing that is automatically imported into your
document.

1 From an OpenOffice.org module (for example, from Writer), click Insert→
Object→ OLE Object→ OpenOffice.org 2.0 Drawing→ OK.

This opens Draw.

2 Create your drawing.

3 Click in your document, outside the Draw frame.

The drawing is automatically inserted into your document.
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3.7 Creating Mathematical Formulas
with Math

It is usually difficult to include complex mathematical formulas in your documents.
The OpenOffice.org Math equation editor lets you create formulas using operators,
functions, and formatting assistants. You can then save those formulas as objects that
can be imported into other documents. Math functions can be inserted into other
OpenOffice.org documents like any other graphic object.

NOTE

Math is not a calculator. The functions it creates are graphical objects. Even if
they are imported into Calc, these functions cannot be evaluated.

3.8 Finding Help and Information
About OpenOffice.org

OpenOffice.org contains extensive online help. In addition, a large community of users
and developers support it. As a result, it is seldom hard to find help or information about
using the OpenOffice.org. The following table shows some of the places where you
can go for additional information. (Because Web sites often close or their content
changes, the information in the following table might not be current when you read it.)

Table 3.5 Where to Get Information About OpenOffice.org

What You Can FindLocation

Extensive help on performing any task in
OpenOffice.org

OpenOffice.org online help menu

Manuals, tutorials, user and developer
forums, users@openoffice.org mailing
list, FAQs, and much more

Official OpenOffice.org support page
[http://support.openoffice
.org/index.html]
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What You Can FindLocation

Information about migrating to OpenOf-
fice.org from other office suites, including
Microsoft Office

OpenOffice.org Migration Guide
[oooauthors.org/en/authors/
userguide2/migration/
OtherMSOFiles_25_June_PK
.sxw]

Books, news, tips and tricksTaming OpenOffice.org [http://www
.taming-openoffice-org.com/
]

Extensive information about creating and
using macros

OpenOffice.org Macros [http://www
.pitonyak.org/oo.php]
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4Evolution: E-Mail and
Calendaring
Evolution™makes the tasks of storing, organizing, and retrieving your personal infor-
mation easy, so you can work and communicate more effectively with others. It’s a
highly evolved groupware program, an integral part of the Internet-connected desktop.

Evolution can help you work in a group by handling e-mail, address, and other contact
information, and one or more calendars. It can do that on one or several computers,
connected directly or over a network, for one person or for large groups.

With Evolution, you can accomplish your most common daily tasks quickly. For exam-
ple, it takes only one or two clicks to enter appointment or contact information sent to
you by e-mail, or to send e-mail to a contact or appointment. People who get lots of e-
mail will appreciate advanced features like search folders, which let you save searches
as though they were ordinary e-mail folders.

This chapter introduces you to Evolution and helps you get started using it. For complete
information, refer to the Evolution documentation.

• Section 4.1, “Starting Evolution for the First Time” (page 138)

• Section 4.2, “Using Evolution: An Overview” (page 149)
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4.1 Starting Evolution for the First
Time

Start the Evolution client by clicking Computer→ More Applications→ Office→
Evolution, or by typing evolution in a terminal window.

4.1.1 Using the Setup Assistant
The first time you run Evolution, it creates a directory called .evolution in your
home directory, where it stores all of its local data. Then, it opens a Setup Assistant to
help you set up e-mail accounts and import data from other applications.

Using the Setup Assistant takes two to five minutes.

Later on, if you want to change this account, or if you want to create a new one, click
Edit→ Preferences, then clickMail Accounts. Select the account you want to change,
then click Edit. Alternately, add a new account by clicking Add.

The Setup Assistant helps you provide the information Evolution needs to get started.

• Section “Defining Your Identity” (page 138)

• Section “Receiving Mail” (page 139)

• Section “Receiving Mail Options” (page 142)

• Section “Sending Mail” (page 147)

• Section “Account Management” (page 148)

• Section “Time Zone” (page 148)

• Section “Importing Mail (Optional)” (page 149)

Defining Your Identity
The Identity window is the first step in the assistant.
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Here, you enter some basic personal information. You can define multiple identities
later by clicking Edit→ Preferences, then clickingMail Accounts.

When the First-Run Assistant starts, the Welcome page is displayed. Click Forward to
proceed to the Identity window.

1 Type your full name in the Full Name field.

2 Type your e-mail address in the E-Mail Address field.

3 (Optional) Select if this account is your default account.

4 (Optional) Type a reply to address in the Reply-To field.

Use this field if you want replies to e-mails sent to a different address.

5 (Optional) Type your organization name in the Organization field.

This is the company where you work, or the organization you represent when
you send e-mail.

6 Click Forward.

Receiving Mail
The Receiving E-mail option lets you determine where you get your e-mail.

You need to specify the type of server you want to receive mail with. If you are unsure
about the type of server to choose, ask your system administrator or ISP.

• Select a server type in the Server Type list.

The following a list of server types that are available:

Novell GroupWise: Select this option if you connect to Novell GroupWise®.
Novell GroupWise keeps e-mail, calendar, and contact information on the server.

Microsoft Exchange: Available only if you have installed the Connector for
Microsoft* Exchange. It allows you to connect to a Microsoft Exchange 2000
or 2003 server, which stores e-mail, calendar, and contact information on the
server.
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IMAP: Keeps the e-mail on your server so you can access your e-mail from
multiple systems.

IMAP4rev1: Keeps the e-mail on your server so you can access your e-mail
from multiple systems.

POP: Downloads your e-mail to your hard disk for permanent storage, freeing
up space on the e-mail server.

USENETNews: Connects to the news server and downloads a list of available
news digests.

Local Delivery: Choose this option if you want to move e-mail from the spool
(the location where mail waits for delivery) and store it in your home directory.
You need to provide the path to the mail spool you want to use. If you want to
leave e-mail in your system’s spool files, choose the Standard Unix Mbox Spool
option instead.

MH Format Mail Directories: If you download your e-mail using mh or an-
other MH-style program, you should use this option. You need to provide the
path to the mail directory you want to use.

Maildir FormatMail Directories: If you download your e-mail using Qmail
or another maildir-style program, you should use this option. You need to provide
the path to the mail directory you want to use.

Standard Unix Mbox Spool or Directory: If you want to read and store e-
mail in the mail spool on your local system, choose this option. You need to
provide the path to the mail spool you want to use.

None: Select this if you do not plan to check e-mail with this account. If you
select this, there are no configuration options.

Remote Configuration Options

If you selected Novell GroupWise, IMAP, POP, or USENET News as your server, you
need to specify additional information.

1 Type the hostname of your e-mail server in the Hostname field.

If you don’t know the hostname, contact your administrator.
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2 Type your username for the account in the Username field.

3 Select to use a secure (SSL) connection.

If your server supports secure connections, you should enable this security option.
If you are unsure if your server supports a secure connection, contact your system
administrator.

4 Select your authentication type in the Authentication list.

or

Click Check for Supported Types to have Evolution check for supported types.
Some servers do not announce the authentication mechanisms they support, so
clicking this button is not a guarantee that available mechanisms actually work.

If you are unsure what authentication type you need, contact your system admin-
istrator.

5 Select if you want Evolution to remember your password.

6 Click Forward.

7 (Conditional) If you chose Microsoft Exchange, provide your username in the
Username field and your Outlook Web Access (OWA) URL in the OWA Url
field. OWA URL and user names should be entered as in OWA. If the mail box
path is different from the username, OWA path should include mail box path
also. You should see something similar to this: http://<server name>/ex-
change/<mail box path>

When you have finished, continue with Section “Receiving Mail Options” (page 142).

Local Configuration Options

If you selected Local Delivery, MH-Format Mail Directories, Maildir-Format Mail
Directories, or Standard Unix Mbox Spool or Directory, you must specify the path to
the local files in the path field. Continue with Section “Receiving Mail Options”
(page 142).
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Receiving Mail Options
After you have selected a mail delivery mechanism, you can set some preferences for
its behavior.

• Section “Novell GroupWise Receiving Options” (page 142)

• Section “Microsoft Exchange Receiving Options” (page 143)

• Section “IMAP and IMAP4rev1 Receiving Options” (page 144)

• Section “POP Receiving Options” (page 145)

• Section “USENET News Receiving Options” (page 145)

• Section “Local Delivery Receiving Options” (page 146)

• Section “MH-Format Mail Directories Receiving Options” (page 146)

• Section “Maildir-Format Mail Directories Receiving Options” (page 146)

• Section “Standard Unix Mbox Spool or Directory Receiving Options” (page 147)

Novell GroupWise Receiving Options

If you select Novell GroupWise as your receiving server type, you need to specify the
following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Select if you want to check for new messages in all folders.

3 Select if you want to apply filters to new messages in the Inbox on the server.

4 Select if you want to check new messages for junk content.

5 Select if you want to only check for junk messages in the Inbox folder.
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6 Select if you want to automatically synchronize remote mail locally.

7 Type your Post Office Agent SOAP port in the Post Office Agent SOAP Port
field.

If you are unsure what your Post Office Agent SOAP port is, contact your system
administrator.

8 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 147).

Microsoft Exchange Receiving Options

If you select Microsoft Exchange as your receiving server type, you need to specify the
following options.

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Specify the Global Catalog server name in theGlobal Catalog Server Name field.

The Global Catalog Server contains the user information for users. If you are
unsure what your Global Catalog server name is, contact your system adminis-
trator.

3 Select if you want to limit the number of Global Address Lists (GAL).

The GAL contains a list of all e-mail addresses. If you select this option, you
need to specify the maximum number of responses.

4 Select if you want the password expire warning period.

If you select this option, you need to specify how often Evolution should send
the password expire message.

5 Select if you want to automatically synchronize remote mail locally.

6 Click Forward.
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When you have finished, continue with Section “Sending Mail” (page 147).

IMAP and IMAP4rev1 Receiving Options

If you select IMAP or IMAP4rev1 as your receiving server type, you need to specify
the following options:

1 Select if you want Evolution to automatically check for new mail.

If you select this option, you need to specify how often Evolution should check
for new messages.

2 Select if you want Evolution to use custom commands to connect to Evolution.

If you select this option, specify the custom command you want Evolution to
use.

3 Select if you want Evolution to show only subscribed folders.

Subscribed folders are folders that you have chosen to receive mail from by
subscribing to them.

4 Select if you want Evolution to override server-supplied folder namespaces.

By choosing this option you can rename the folders that the server provides. If
you select this option, you need to specify the namespace to use.

5 Select if you want to apply filters to new messages in the Inbox.

6 Select if you want to check new messages for junk content.

7 Select if you want to check for junk messages in the Inbox folder.

8 Select if you want to automatically synchronize remote mail locally.

9 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 147).
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POP Receiving Options

If you select POP as your receiving server type, you need to specify the following op-
tions:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to leave messages on the server.

3 Select if you want to disable support for all POP3 extensions (support for POP3).

4 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 147).

USENET News Receiving Options

If you select USENET News as your receiving server type, you need to specify the
following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to show folders in short notation.

For example, comp.os.linux would appear as c.o.linux.

3 Select if you want to show relative folder names in the subscription dialog box.

If you select to show relative folder names in the subscription page, only the
name of the folder is displayed. For example the folder evolution.mail would
appear as evolution.

4 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 147).
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Local Delivery Receiving Options

If you select Local Delivery as your receiving server type, you need to specify the fol-
lowing options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 147).

MH-Format Mail Directories Receiving Options

If you select MH-Format Mail Directories as your receiving server type, you need to
specify the following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to user the .folders summary file.

3 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 147).

Maildir-Format Mail Directories Receiving Options

If you select Maildir-Format Mail Directories as your receiving server type, you need
to specify the following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to apply filters to new messages in the Inbox.

3 Click Forward.
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When you have finished, continue with Section “Sending Mail” (page 147).

Standard Unix Mbox Spool or Directory Receiving Options

If you select Standard Unix Mbox Spool or Directory as your receiving server type,
you need to specify the following options:

1 Select if you want Evolution to automatically check for new mail.If you select
this option, you need to specify how often Evolution should check for new mes-
sages.

2 Select if you want to apply filters to new messages in the Inbox.

3 Select if you want to store status headers in Elm, Pine, and Mutt formats.

4 Click Forward.

When you have finished, continue with Section “Sending Mail” (page 147) Section
“Sending Mail” (page 147).

Sending Mail
Now that you have entered information about how you plan to get mail, Evolution needs
to know about how you want to send it.

• Select a server type from the Server Type list.

The following server types are available:

Sendmail: Uses the Sendmail program to send mail from your system. Send-
mail is more flexible, but is not as easy to configure, so you should select this
option only if you know how to set up a Sendmail service.

SMTP: Sends mail using an outbound mail server. This is the most common
choice for sending mail. If you choose SMTP, there are additional configuration
options.

SMTP Configuration

1 Type the host address in the Host field.
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If you are unsure what your host address is, contact your system administrator.

2 Select if your server requires authentication.

If you selected that your server requires authentication, you need to provide the
following information:

a Select your authentication type in the Authentication list.

or

Click Check for Supported Types to have Evolution check for supported
types. Some servers do not announce the authentication mechanisms they
support, so clicking this button is not a guarantee that available mechanisms
actually work.

b Type your username in the Username field.

c Select if you want Evolution to remember your password.

3 Select if you use a secure connection (SSL).

4 Click Forward.

Continue with Section “Account Management” (page 148).

Account Management
Now that you have finished the e-mail configuration process you need to give the account
a name. The name can be any name you prefer. Type your account name on the Name
field, then click Forward.

Continue with Section “Time Zone” (page 148).

Time Zone
In this step, you need to select your time zone either on the map or select from the time
zone drop-down list.
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When you have finished, click Forward, then click Apply. Evolution opens with your
new account created.

If youwant to import e-mail from another e-mail client, continuewith Section “Importing
Mail (Optional)” (page 149). If not, skip to Section 4.2, “Using Evolution: AnOverview”
(page 149).

Importing Mail (Optional)
If Evolution finds e-mail or address files from another application, it offers to import
them.

Microsoft Outlook* and versions of Outlook Express after version 4, use proprietary
formats that Evolution cannot read or import. To import information, you might want
to use the Export tool under Windows*.

Before importing e-mail fromNetscape*, make sure you have selected File→Compact
All Folders. If you don’t, Evolution will import and undelete the messages in your Trash
folders.

NOTE

Evolution uses standard file types for e-mail and calendar information, so you
can copy those files from your ~/.evolution directory. The file formats
used are mbox for e-mail and iCal for calendar information.

Contacts files are stored in a database, but can be saved as a standard vCard*.
To export contact data, open your contacts tool and select the contacts you
want to export (press Ctrl + A to select them all). Click File → Save as VCard.

4.2 Using Evolution: An Overview
Now that the first-run configuration has finished, you’re ready to begin using Evolution.
Here’s a quick explanation of what’s happening in your main Evolution window.
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Figure 4.1 Evolution Window

Menu Bar
The menu bar gives you access to nearly all of Evolution features.

Folder List
The folder list gives you a list of the available folders for each account. To see the
contents of a folder, click the folder name and the contents are displayed in the e-mail
list.

Toolbar
The toolbar gives you fast and easy access to the frequently used features in each
component.
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Search Tool
The search tool lets you search your e-mail, contacts, calendar, and tasks to easily find
what you’re looking for.

Message List
The message list displays a list of e-mail that you have received. To view an e-mail in
the preview pane, click the e-mail in the e-mail list.

Shortcut Buttons
The shortcut bar lets you switch between folders and between Evolution tools. At the
bottom of the shortcut bar there are buttons that let you switch tools, and above that is
a list of all the available folders for the current tool. If you have the Evolution Connector
for Microsoft Exchange installed, you have an Exchange button in addition to buttons
for the other tools.

Status Bar
The status bar periodically displays a message, or tells you the progress of a task. This
most often happens when you’re checking or sending e-mail. These progress queues
are shown in the previous figure. The Online/Offline indicator is here, too, in the lower
left of the window.

Preview Pane
The preview pane displays the contents of the e-mail that is selected in the e-mail list.

4.2.1 The Menu Bar
The menu bar’s contents always provide all the possible actions for any given view of
your data. If you’re looking at your Inbox, most of the menu items relate to e-mail.
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Some content relates to other components of Evolution and some, especially those in
the File menu, relates to the application as a whole.

File: Anything related to a file or to the operations of the application usually falls
under this menu, such as creating things, saving them to disk, printing them, and quitting
the program itself.

Edit: Holds useful tools that help you edit text and move it around. Lets you access
the settings and configuration options in the Edit menu.

View: Lets you decide how Evolution should look. Some of the features control the
appearance of Evolution as a whole, and others the way a particular kind of information
appears.

Folder: Holds actions that can be performed on folders. You can find things like
copy, rename, delete, and so on.

Message: Holds actions that can be applied to a message. If there is only one target
for the action, such as replying to a message, you can normally find it in the Message
menu.

Search: Lets you search for messages, or for phrases within a message. You can also
see previous searches you have made. In addition to the Search menu, there is a text
entry box in the toolbar that you can use to search for messages. You can also create a
search folder from a search.

Help: Opens the Evolution Help files.

4.2.2 The Shortcut Bar
Evolution’s most important job is to give you access to your information and help you
use it quickly. One way it does that is through the shortcut bar, which is the column on
the left side of the main window. The buttons, such as Mail and Contacts, are the
shortcuts. Above them is a list of folders for the current Evolution tool.
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The folder list organizes your e-mail, calendars, contact lists, and task lists in a tree,
similar to a file tree. Most people find one to four folders at the base of the tree, depend-
ing on the tool and their system configuration. Each Evolution tool has at least one,
called On This Computer, for local information. For example, the folder list for the e-
mail tool shows any remote e-mail storage you have set up, plus local folders and search
folders.

If you get large amounts of e-mail, you might want more folders than just your Inbox.
You can create multiple calendar, task, or contacts folders.

To create a new folder:

1 Click Folder→ New.

2 Type the name of the folder in the Folder Name field.

3 Select the location of the new folder.

4 Click OK.

Folder Management
Right-click a folder or subfolder to display a menu with the following options:

Copy: Copies the folder to a different location. When you select this item, Evolution
offers a choice of locations to copy the folder to.

Move: Moves the folder to another location.

Mark Messages As Read: Marks all the messages in the folder as read.

New Folder: Creates another folder in the same location.

Delete: Deletes the folder and all its contents.

Rename: Lets you change the name of the folder.

Disable: Disables the account.
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Properties: Checks the number of total and unread messages in a folder, and, for
remote folders, lets you select whether to copy the folder to your local system for offline
operation.

You can also rearrange folders and messages by dragging and dropping them.

Any time new e-mail arrives in a e-mail folder, that folder label is displayed in bold
text, along with the number of new messages in that folder.

4.2.3 E-Mail
Evolution e-mail is like other e-mail programs in several ways:

• It can send and receive e-mail in HTML or as plain text, and makes it easy to send
and receive multiple file attachments.

• It supports multiple e-mail sources, including IMAP, POP3, and local mbox or mh
spools and files created by other e-mail programs.

• It can sort and organize your e-mail in a wide variety of ways with folders,
searches, and filters.

• It lets you guard your privacy with encryption.

However, Evolution has some important differences from other e-mail programs. First,
it’s built to handle very large amounts of e-mail. The junk e-mail, message filtering
and searching functions were built for speed and efficiency. There’s also the search
folder, an advanced organizational feature not found in some e-mail clients. If you get
a lot of e-mail, or if you keep every message you get in case you need to refer to it later,
you’ll find this feature especially useful. Here’s a quick explanation of what’s happening
in your main Evolution e-mail window.

Message List
The message list displays all the e-mails that you have. This includes all your read and
unread messages, and e-mail that is flagged to be deleted.
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Preview Pane
This is where your e-mail is displayed.

If you find the preview pane too small, you can resize the pane, enlarge the whole
window, or double-click the message in the message list to have it open in a new win-
dow. To change the size of a pane, drag the divider between the two panes.

As with folders, you can right-click messages in the message list and get a menu of
possible actions, including moving or deleting them, creating filters or search folders
based on them, and marking them as junk mail.

Most of the e-mail-related actions you want to perform are listed in the Actions menu
in the menu bar. The most frequently used ones, like Reply and Forward, also appear
as buttons in the toolbar. Most of them are also located in the right-click menu and as
keyboard shortcuts.

4.2.4 The Calendar
To begin using the calendar, click Calendar in the shortcut bar. By default, the calendar
shows today’s schedule on a ruled background. At the upper right, there’s a monthly
calendar you can use to switch days. Below that, there’s a Task list, where you can keep
a list of tasks separate from your calendar appointments.

Appointment List
The appointment list displays all your scheduled appointments.

Month Pane
The month pane is a small view of a calendar month. To display additional months,
drag the column border to the left. You can also select a range of days in the month
pane to display a custom range of days in the appointment list.
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Task List
Tasks are distinct from appointments because they generally don’t have times associated
with them. You can see a larger view of your task list by clicking Tasks in the shortcut
bar.

4.2.5 The Contacts Tool
The Evolution contacts tool can handle all of the functions of an address book or phone
book. However, it’s easier to update Evolution than it is to change an actual paper book,
in part because Evolution can synchronize with PalmOS* devices and use LDAP direc-
tories on a network.

Another advantage of the Evolution contacts tool is its integration with the rest of the
application. For example, you can right-click on an e-mail address in Evolution mail
to instantly create a contact entry.

To use the contacts tool, clickContacts in the shortcut bar. By default, the display shows
all your contacts in alphabetical order, in a minicard view. You can select other views
from the Viewmenu, and adjust the width of the columns by clicking and dragging the
gray column dividers.

The largest section of the contacts display shows a list of individual contacts. You can
also search the contacts in the same way that you search e-mail folders, using the search
tool on the right side of the toolbar.
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5Instant Messaging with Gaim
Use Gaim to use all of your instant messaging accounts from a single instant messaging
client. Gaim supports all of the most popular instant messaging protocols, so you can
log in to all of your accounts at once and chat live with your contacts in one tabbed in-
terface, regardless of which IM system they use.

This chapter explains the Gaim options you need to know about to set up Gaim and
communicate with your contacts. It does not explain all of Gaim’s features and options.
For more information, open Gaim, then click Help→ Online Help or press F1.

• Section 5.1, “Supported Protocols” (page 157)

• Section 5.2, “Setting Up an Account” (page 158)

• Section 5.3, “Managing Your Buddy List” (page 159)

• Section 5.4, “Chatting” (page 160)

5.1 Supported Protocols
Gaim supports the following instant messaging protocols:

• AIM/ICQ

• Gadu-Gadu

• GroupWise
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• IRC

• Jabber

• MSN

• Napster

• Yahoo

• Zephyr

5.2 Setting Up an Account
To use Gaim, you must already have accounts on the systems you want to use. For ex-
ample, to use Gaim for your AIM account, you must first have an AIM account. Once
you have those accounts, set them up in the Gaim Add Account dialog.

1 Start Gaim by clicking Computer→ More Applications→ Communicate→
Gaim.

2 Click Accounts→ Add to open the Add Account dialog.

The first time you run Gaim, or any subsequent times you start Gaim when you
don’t have any accounts set up, the Add Account dialog opens automatically.

3 Choose the protocol you want to set up.

TheAdd Account dialog differs for each protocol, depending onwhat setup options
are available for that protocol.

4 Enter the setup options for the chosen protocol.

Typical options include your account name and password. Your protocol might
support additional options, such as a buddy icon, alias, login options, or others.

5 Click Save.

6 Repeat Step 2 to Step 5 for each additional protocol.
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Once an account is added, you can log in to that account by entering your account name
and password in the Gaim Login dialog.

5.3 Managing Your Buddy List
Use the Buddy List to manage your contacts, also known as buddies. You can add and
remove buddies from your Buddy List, and you can organize your buddies in groups
so they are easy to find.

5.3.1 Displaying Buddies in the Buddy List
Once your accounts are set up, all buddies who are online appear in your Buddy List.
If you also want your buddies who are not online to appear in the Buddy List, click
Buddies → Show Offline Buddies.

5.3.2 Adding a Buddy
To add a buddy to your Buddy List, click Buddies→ Add Buddy, then enter the infor-
mation about that buddy.

NOTE

For some protocols, you cannot add a buddy in the Gaim interface. You must
use the client for those protocols if you want to add to your buddy list. After
you have added a buddy in the protocol’s client, that buddy appears in your
Gaim Buddy List.

5.3.3 Removing a Buddy
To remove a buddy, right-click on that buddy’s name in the Buddy List, then click Re-
move.
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5.4 Chatting
To open a chat session, double-click a buddy name in the Buddy List. The Chat screen
opens. Type your message, then press Enter to send it.

Each chat session you open appears as a tab in the Chat screen. Click on a buddy’s tab
to chat with that buddy. Close a chat session by closing the tab for that buddy.
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6Using Voice over IP with Ekiga
Modern telecommunicationmeans far more than just doing a phone call. It is also about
exchanging text messages and sometimes even video conferencing. Roaming enables
you to be reachable under one phone number all across the world. Ekiga brings these
features to your Linux desktop allowing you to communicate over broadband Internet.

Before you start, make sure the following requirements are met:

• Your sound card is properly configured.

• A headset or a microphone and speakers are attached to your computer.

• For dialing in to regular phone networks you have created a SIP account. For a list
of providers refer to http://www.voipproviderslist.com/. Free trials
are provided by http://www.voipbuster.com.

• For video conferencing you have attached a Web cam to your computer.

6.1 Configuring Ekiga
On first start, Ekiga comes up with a configuration assistant that requests you to enter
all data needed to configure your instance of Ekiga. To configure Ekiga, proceed as
follows:
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1 Enter your user name (name and surname).

2 Enter your ekiga.net account data or choose not to sign up to ekiga.net.

To add other accounts later on, configure them using Edit→ Accounts.

3 Determine your connection type.

4 Determine the type of firewall to use to enable you to perform calls with Ekiga.

5 Choose the audio manager to use. Accept the default setting ALSA, as other sound
systems like OSS are not available on openSUSE.

6 Choose the audio input and output devices and test your settings.

7 Accept the video manager selection, V4L.

8 Choose the video input device and test your settings.

9 Check the summary of your settings and apply them.

Ekiga allows you to maintain multiple accounts. To configure an additional account,
proceed as follows:

1 Open Edit→ Accounts and select Add.

2 Choose an Account Name.

3 Select an appropriate Protocol depending on what type of account you use.
Normally, you would select SIP here.

4 Enter Registrar, User and Password according to the data provided by your
provider.

5 Leave the configuration dialog with OK and activate the account.

The status of your account displayed in the Ekiga main window changes to
Registered.
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6.2 The Ekiga User Interface
All functions of Ekiga are available via the menu bar. Shortcuts to the most important
functions are provided bymeans of a toolbar to the left and by special key combinations.

Figure 6.1 Ekiga User Interface

The user interface has different modes. To switch between views, use View→ View
Mode and View→ Control Panel or select the view mode icon on the left side of the
GUI and the different tabs at the bottom. The Full View is shown in Figure 6.1, “Ekiga
User Interface” (page 163). All icons in the toolbar provide a tool tip that is activated
on hovering over the icon with your mouse pointer.

At the bottom of the user interface, several tabs provide the functionality for Dialpad,
Audio, Video and Statistics. Some settings like the Audio settings may only be changed
during a phone call.
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Many of functions of Ekiga are available via keyboard shortcuts. Table 6.1, “Keyboard
Shortcuts for Ekiga” (page 164) summarizes the most important ones.

Table 6.1 Keyboard Shortcuts for Ekiga

DescriptionCtrl Sequence

Initiate a call with the current number.Ctrl + O

Hang up.Ctrl + D

Hold the current call.Ctrl + G

Transfer the current call to another party.Ctrl + T

Save the current picture to hard disk.Ctrl + S

Close the Ekiga user interface.Ctrl +W

Quit Ekiga.Ctrl + Q

Start the Accounts manager.Ctrl + E

Open the Ekiga Preferences overview. This dialog al-
lows you to do some fine-tuning to your Ekiga settings.

Ctrl + P

Zoom in to the picture of the Web cam.Ctrl + +

Zoom out or the picture of the Web cam.Ctrl + -

Return to the normal size of the Web cam display.Ctrl + =

Use full screen for the Web cam.Ctrl + F

Display the history of your calls.Ctrl + H
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6.3 Making a Call
Once Ekiga is configured appropriately, making a call is straightforward.

1 Start Ekiga using the menu or the command line.

2 Enter the SIP address of the other party at the SIP address prompt. The address
should look like sip:username@domainname or username@hostname
for direct local calls or likeusername@sipserver oruserid@sipserver
for proxied calls or calls using the service of a SIP provider. If you have a SIP
provider that accepts real phone calls, you may just enter the number like
sip:<call number>

3 Click Call or type Ctrl + O and wait for the other party to pick up the phone.

4 Once you are done or wish to end the call, click Hang up or type Ctrl + D.

If you need to tweak the sound parameters during a call, click View→ View Mode→
Full View to show four tabs holding more options. The second one holds the Audio
options for Playback level and Recording level. Use the sliders to adjust both volumes
to fit your needs.

6.4 Answering a Call
Ekiga can receive calls in two different ways. First, the user may be called directly with
sip:user@host. Alternatively, make your calls via a SIP provider. Most SIP
providers enable you to get calls from a normal land line to your VoIP account. Depend-
ing on the mode Ekiga is run, there are several ways in which you would notice an in-
coming call:

Normal Application
Incoming calls can only be received and answered if Ekiga is already running. You
hear the ring sound on your headset or your speakers. If Ekiga is not running, the
call cannot be received.
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Panel Applet
Normally, the Ekiga panel applet would run silently without giving any notice of
its existence. This changes as soon as a call comes in. The main window of Ekiga
opens and you hear a ring sound on your headset or speakers.

Once you have noticed an incoming call, just click Accept to pick up the phone and
start talking. If you do not want to accept this call, click Reject. It is also possible to
transfer the call to another SIP address.

6.5 Using the Address Book
Ekiga offers to manage your SIP contacts. Start the address book with Tools→ Address
book. An empty list window opens. To add a contact, First select Personal with your
mouse. Then right-click into the address window and selectNewContact. Alternatively,
just press Ctrl→ N.

The following entries need to be made for a valid contact:

Name
Enter the name of your contact. This may be a full name, but you can also use a
nickname here.

SIP Address
Enter a valid SIP address for your contact.

Email
Enter the e-mail address of your contact for your own reference.

Speed Dial
With a Speed Dial you may access often used numbers more easily. However,
this is optional as well.

Categories
Add your own categories if you have many different contacts.

Local Address Book
By default, you have a local address book with the name Personal available. If you
need more address books, create them with File→ New Address Book or use the
keyboard shortcut Ctrl + B.
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To call any contact from the address book, double-click this contact with the mouse.
The call will be directly initiated.

6.6 For More Information
The official home page of Ekiga is http://www.ekiga.org/. This site offers the
frequently asked questions as well as a more detailed documentation.

For information about the support of the H323 teleconferencing protocol in Linux, see
http://www.openh323.org/. This is also a good starting point when searching
for projects supporting VoIP.

If you intend to set up your private telephone network, you might be interested in the
PBX software Asterisk http://www.asterisk.org/. Information about this
project can also be found at http://www.voip-info.org/wiki-Asterisk.
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Part III. Internet





7Browsing with Firefox
Included with your openSUSE™ is the Mozilla Firefox Web browser. With features
like tabs, pop-up window blocking, and download and image management, Firefox
combines the latest Web technologies. You can view more than one Web page in a
single window. You can suppress annoying advertisements and disable images that
only slow you down. Its easy access to different search engines helps you find the in-
formation you need. Start the program from themainmenu or by entering the command
firefox. The main program features are described in the following sections.

7.1 Navigating Web Sites
Firefox has much the same look and feel as other browsers. It is shown in Figure 7.1,
“The BrowserWindow of Firefox” (page 172). The navigation toolbar includesForward
and Back and a location bar for a Web address. Bookmarks are also available for quick
access. For more information about the various Firefox features, use the Help menu.
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Figure 7.1 The Browser Window of Firefox

7.1.1 Tabbed Browsing
If you often use more than oneWeb page at a time, tabbed browsing may make it easier
to switch between them. Load Web sites in separate tabs within one window.

To open a new tab, select File→ New Tab. This opens an empty tab in the Firefox
window. Alternatively, right-click a link and select Open link in new tab. Right-click
the tab itself to access more tab options. You can create a new tab, reload one or all
existing tabs, or close them. You can also change the sequence of the tabs by dragging
and dropping them on a requested position.
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7.1.2 Using the Sidebar
Use the left side of your browser window for viewing bookmarks or the browsing his-
tory. Extensions may add new ways to use the sidebar as well. To display the Sidebar,
select View→ Sidebar and select the desired contents.

7.2 Finding Information
There are two ways to find information in Firefox: the search bar and the find bar. The
search bar looks for pages while the find bar looks for things on the current page.

7.2.1 Finding Information on the Web
Firefox has a search bar that can access different engines, like Google, Yahoo, or
Amazon. For example, if you want to find information about openSUSE using the
current engine, click in the search bar, type openSUSE, and hit Enter. The results appear
in your window. To choose your search engine, click the icon in the search bar. A menu
opens with a list of available search engines.

7.2.2 Installing a Different Search Engine
If you favorite search engine is not listed, Firefox gives you the possibility to configure
it. Try the following steps:

1 Establish an Internet connection first.

2 Click in the search bar on the icon.

3 Select Add Engines from the menu.

4 Firefox displays a Web page with available search engines. It is also sorted by
categories. You can choose from Wikipdedia, Leo, and others. Click the desired
search plug-in.

5 Install your search plug-in with Ok or abort with Cancel.
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7.2.3 Searching in the Current Page
To search inside a Web page, click Edit→ Find in This Page or press Ctrl + F. The
find bar opens. Usually, it is displayed at the bottom of a window. Type your query in
the input field. Firefox finds the first occurence of this phrase. You can find other oc-
curences of the phrase by pressing F3 or Find Next button in the find bar. You can also
highlight all occurences by pressing the Highlight all button.

7.3 Managing Bookmarks
Bookmarks offer a convenient way of saving links to your favorite Web sites. To add
the current Web site to your list of bookmarks, click Bookmarks→ Bookmark This
Page. If your browser currently displays multiple Web sites on tabs, only the URL on
the currently selected tab is added to your list of bookmarks.

When adding a bookmark, you can specify an alternative name for the bookmark and
select a folder where Firefox should store it. To bookmark Web sites on multiple tabs,
select Bookmark All Tabs. Firefox creates a new folder that includes bookmarks of each
site displayed on each tab. To remove a Web site from the bookmarks list, click Book-
marks, right-click the bookmark in the list, then click Delete.

7.3.1 Using the Bookmark Manager
The bookmark manager can be used to manage the properties (name and address loca-
tion) for each bookmark and organize the bookmarks into folders and sections. It resem-
bles Figure 7.2, “Using the Firefox Bookmark Manager” (page 175).
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Figure 7.2 Using the Firefox Bookmark Manager

To open the bookmark manager, click Bookmark→ Manage Bookmarks. A window
opens and displays your bookmarks. WithNew Folder, create a new folder with a name
and a description. If you need a new bookmark, click New Bookmark. This lets you
insert the name, location, keywords, and also a description. The keyword is a shortcut
to your bookmark. If you need your newly created bookmark in the sidebar, check Load
this bookmark in the sidebar.

7.3.2 Importing Bookmarks from Other
Browsers

If you used a different browser in the past, you probably want to use your preferences
and bookmarks in Firefox, too. At the moment, you can import from Netscape 4.x, 6,
7, Mozilla 1.x, and Opera.

To import your settings, click File→ Import. Select the browser from which to import
settings. After you clickNext, your settings are imported. Find your imported bookmarks
in a newly created folder, beginning with From.
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7.3.3 Live Bookmarks
Live bookmarks display headlines in your bookmark menu and keep you up to date
with the latest news. This enables you to save time with one glance at your favorite
sites.

Many sites and blogs support this format. AWeb site indicates this by showing an orange
icon in the right part of the location bar. Click it and choose Add NAMEOF THE FEED
as Live Bookmark. A dialog box opens where you can select the name and location of
your live bookmark. Confirm with Add.

Some sites do not tell Firefox that they support a news feed, although they actually do.
To add a live bookmark manually, you need the URL of the feed. Do the following:

Procedure 7.1 Adding a Live Bookmark Manually

1 Open the bookmark manager with Bookmarks→ Manage Bookmarks. A new
window opens.

2 Select File→ New Live Bookmark. A dialog box opens.

3 Insert a name for the live bookmark and add your URL in the Feed Location, for
example,http://www.novell.com/newsfeeds/rss/coolsolutions
.xml. Firefox updates your live bookmarks.

4 Close your bookmark manager.

7.4 Using the Download Manager
With the help of the download manager, keep track of your current and past downloads.
To open the download manager, click Tools→ Downloads. Firefox opens a window
with your downloads. While downloading a file, see a progress bar and the current file.
If necessary, pause a download and resume it later. To open a downloaded file, click
Open. With Remove, remove it from the list. If you need information about the file,
right-click the filename and choose Properties.
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If you need further control of the download manager, open the configuration window
from Edit→ Preferences and go to the Downloads tab. Here, determine the download
folder, how the manager behaves, and some configuration of file types.

7.5 Customizing Firefox
Firefox can be customized extensively. You can install extensions, change themes, and
add smart keywords for your online searches.

7.5.1 Extensions
Mozilla Firefox is a multifunctional application, which means that you can download
and install add-ons, known as extensions. For example, add a new download manager
and mouse gestures. This has the advantage that Firefox itself stays small and unbloated.

To add an extension, click Tools→ Extensions. In the bottom-right corner, click Get
More Extensions to open theMozilla extensions updateWeb page where you can choose
from a variety of available extensions. Click the extension to install then click the install
link to download and install it. When you restart Firefox, the new extension is functional.
You can also look at the various extensions at http://addons.mozilla.org/
.

Figure 7.3 Installing Firefox Extensions
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7.5.2 Changing Themes
If you do not like the standard look and feel of Firefox, install a new theme. Themes
do not change the functionality, only the appearance of the browser. When installing a
theme, Firefox asks for confirmation first. Allow the installation or cancel it. After a
successful installation, you can enable the new theme.

1 Click Tools→ Themes.

2 In the new dialog that appears, click Get More Themes. If you already installed
a theme, find it in the list, as in Figure 7.4, “Installing Firefox Themes” (page 178).

Figure 7.4 Installing Firefox Themes

3 Anewwindow appears with theWeb sitehttps://addons.mozilla.org.

4 Choose a theme and click Install Now.

5 Confirm the download and installation.

6 After downloading the theme, a dialog appears and informs you about your list
of themes. Activate the new theme with Use Theme.

7 Close the window and restart Firefox.
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If a theme is installed, you can always switch to a different theme without restarting
by clicking Tools→ Themes then Use Theme. If you do not use a theme anymore, you
can delete it in the same dialog with Uninstall.

7.5.3 Adding Smart Keywords to Your
Online Searches

Searching the Internet is one of the main tasks a browser can perform for you. Firefox
lets you define your own smart keywords: abbreviations to use as a “command” for
searching the Web. For example, if you use Wikipedia often, use a smart keyword to
simplify this task:

1 Go to http://en.wikipedia.org.

2 After Firefox displays the Web page, see the search text field. Right-click it then
choose Add a Keyword for this Search from the menu that opens.

3 The Add Bookmark dialog appears. In Name, name this Web page, for example,
Wikipedia (en).

4 For Keyword, enter your abbreviation of this Web page, for example, wiki.

5 With Create in, choose the location of the entry in your bookmarks section. You
can put it into Quick Searches, but any other level is also appropriate.

6 Finalize with Add.

You have successfully generated a new keyword. Whenever you need to look into
Wikipedia, you do not have to use the entire URL. Just type wiki Linux to view an
entry about Linux.
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7.6 Printing from Firefox
Configure the way Firefox prints the content it displays using the Page Setup dialog.
Click File→ Page Setup then go to the Format & Options tab to select the orientation
of your print jobs. You can scale or make it adjust automatically. To print a background,
select Print Background (colors & images). Click theMargins & Header/Footer tab
to adjust margins and select what to include in the headers and footers.

After you configured your settings, print a Web page with File→ Print. Select the
printer or a file in which to save the output. With Properties, set the paper size, specify
the print command, choose grayscale or color, and determine themargins.When satisfied
with your settings, approve with Print.

7.7 For More Information
Get more information about Firefox from the official home page at http://www
.mozilla.com/firefox/. Refer to the integrated help to find out more about
certain options or features.
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8Managing Your Digital Image
Collection
f-spot is a management tool for your collection of digital images tailored for the GNOME
desktop. It allows you to assign different tags to your images in order to categorize
them and offers various neat image editing options.

The first time you run f-spot, tell it where to find the images to import to your f-spot
collection. If you already have a collection of images stored on your hard drive, enter
the path to the respective directory and optionally include subfolders. f-spot imports
these images into its database.

TIP

If all the images you are importing belong to the same category, you can attach
the appropriate tag on import. Select Attach Tag and choose the matching tag
from the drop down menu.

Figure 8.1 Importing Images to f-spot
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f-spot's main window is divided into three main areas. Categories, tags, and detailed
information for the selected images are displayed in a sidebar to the left and a thumbnails
of all images bearing the selected tag or category or, if none is selected, the entire col-
lection is displayed in the right part of the window.

Figure 8.2 f-spot Main Window

A menu bar right at the top of the window allows you to access the main menus. A
toolbar below offers several different functions depicted by a matching icon:

Table 8.1 f-spot Toolbar

DescriptionIcon

Use this shortcut to change an image's orientation.Rotate (Left or Right)

The Browse mode allows you to view and search you en-
tire collection or tagged subsets of it. You can also use the
time line to search images by creation date.

Browse

This mode allows you to select one image and do some
basic image processing. Details are available in Sec-
tion 8.6, “Basic Image Processing with f-spot” (page 189).

Edit Image
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DescriptionIcon

Switch to fullscreen display mode.Fullscreen

Start a slide show.Slideshow

8.1 Downloading Pictures from Your
Camera

Import new images from your digital camera connected to the USB port of your com-
puter using FileImport from Camera. The type of camera is detected automatically.

Figure 8.3 Import from Camera
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f-spot launches a preview window displaying all the images that are available for
download from camera. The files are copied to the target directory specified via Copy
Files to. If Import files after copy is selected, all images copied from camera are auto-
matically imported to f-spot's database. Tagging can be done on import, if you select
the appropriate tag with Select Tags. If you do not want to import all images on your
camera to your database, just deselect the unwanted one in the preview window.

8.2 Getting Information
Once you select an image, some basic statistical information on this image is displayed
in the lower left part of the window. This includes the filename, its version (copy or
original image), the date of creation, its size and the exposure which was used in creating
this particular image. View the EXIF data associated with the image file withViewEXIF
Data.

8.3 Managing Tags
Use tags to categorize any of your images to create manageable subsets of your collec-
tion. If, for example, you would like to get some sort of order in your collection of
portrait shots of your loved ones, proceed like this:

1 Select the Browse mode of f-spot.

2 In the left frame of the f-spot window, select the People category, right-click it,
then choose Create New Tag. The new tags then appear as subcategories below
the People category:

a Create a new tag called Friends.

b Create a new tag called Family.

3 Now attach tags to images or groups of selected images. Right-click an image,
choose Attach Tag, and select the appropriate tag for this image. To attach a tag
to a group of images, click the first one then press Shift and select the other ones
without releasing the Shift key. Right-click for the tag menu and select the
matching category.
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After the images have been categorized, you can browse your collection by tag. Just
check People→ Family and the displayed collection is limited to the images tagged
Family. Searching your collection by tag is also possible through Find→ Find by
Tag. The result of your search is displayed in the thumbnail overview window.

Removing tags from single images or groups of images works similarly to attaching
them. The tag editing functions are also accessible via the Tags menu in the top menu
bar.

8.4 Search and Find
Asmentioned in Section 8.3, “Managing Tags” (page 186), tags can be used as a means
to find certain images. Another way, which is quite unique to f-spot, is to use the
Timeline below the toolbar. By dragging the little frame along this time line, limit the
images displayed in the thumbnail overview to those taken in the selected time frame.
f-spot starts with a sensibly chosen default time line, but you can always edit the time
span by moving the sliders to the right and left ends of the time line.

8.5 Exporting Image Collections
f-spot offers a range of different export functions for your collections under FileExport.
Probably the most often used of these are Export to Web Gallery and Export to CD.

To export a selection of images to a web gallery, proceed as follows:

1 Select the images to export.

2 Click File→ Export→ Export to Web Gallery and select a gallery to which to
export your images or add a new one. f-spot establishes a connection to the Web
location entered for your web gallery. Select the album to which to export the
images and decide whether to scale the images automatically and export titles
and comments.
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Figure 8.4 Exporting Images to a Web Gallery

To export a selection of images to CD, proceed as follows:

1 Select the images to export.

2 Click File→ Export→ Export to CD and click OK.

f-spot copies the files and opens the CD writing dialog. Assign a name to your
image disk and determine the writing speed. ClickWrite to start the CD writing
process.

Figure 8.5 Exporting Images to a CD
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8.6 Basic Image Processing with f-spot
f-spot offers several very basic image editing functionalities. Enter the edit mode of f-
spot by clicking the Edit Image icon in the toolbar or by double-clicking the image to
edit. Switch images using the arrow keys at the bottom right. Choose from the following
edit functions:

Table 8.2 f-spot Edit Functions

DescriptionFunction

Access this function with Edit→ Sharp-
en. Adjust the values for Amount, Radius,

Sharpen

and Threshold to your needs and click
OK.

To crop the image to a selection you
made, either choose a fixed ratio crop or

Crop Image

the No Constraint option from the drop-
down menu at the bottom left, select the
region to crop, and click the scissor icon
next to the ratio menu.

In a portrait shot, select the eye region of
the face and click the red eye icon.

Red Eye Reduction

View the histogram used in the creation
of the shot and correct exposure and color
temperature if necessary.

Adjust Color

TIP

Professional image editing can be done with the GIMP. More information about
The GIMP can be found in Chapter 9, Manipulating Graphics with The GIMP
(page 191).
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9Manipulating Graphics with
The GIMP
The GIMP (The GNU Image Manipulation Program) is a program for creating and
editing pixel graphics. In most aspects, its features are comparable to those of Adobe
Photoshop and other commercial programs. Use it to resize and retouch photographs,
design graphics for Web pages, make covers for your custom CDs, or almost any other
graphics project. It meets the needs of both amateurs and professionals.

Like many other Linux programs, The GIMP is developed as a cooperative effort of
developers worldwide who volunteer their time and code to the project. The program
is under constant development, so the version included in your system may vary
slightly from the version discussed here. The layout of the individual windows and
window sections is especially likely to vary.

The GIMP is an extremely complex program. Only a small range of features, tools, and
menu items are discussed in this chapter. See Section 9.6, “For More Information”
(page 199) for ideas of where to find more information about the program.

9.1 Graphics Formats
There are twomain formats for graphics—pixel and vector. The GIMPworks only with
pixel graphics, which is the normal format for photographs and scanned images. Pixel
graphics consist of small blocks of color that together create the entire image. The files
can easily become quite large because of this. It is also not possible to increase the size
of a pixel image without losing quality.
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Unlike pixel graphics, vector graphics do not store information for all individual pixels.
Instead, they store information about how image points, lines, or areas are grouped to-
gether. Vector images can also be scaled very easily. The drawing application of
OpenOffice.org, for example, uses this format.

9.2 Starting The GIMP
Start The GIMP from the main menu. Alternatively, enter gimp & in a command line.

9.2.1 Initial Configuration
When starting The GIMP for the first time, a configuration wizard opens for preparatory
configuration. The default settings are acceptable for most purposes. Press Continue in
each dialog unless you are familiar with the settings and prefer another setup.

9.2.2 The Default Windows
Three windows appear by default. They can be arranged on the screen and, except the
toolbox, closed if no longer needed. Closing the toolbox closes the application. In the
default configuration, The GIMP saves your window layout when you exit. Dialogs
left open reappear when you next start the program.

The Toolbox
The main window of The GIMP, shown in Figure 9.1, “TheMainWindow” (page 193),
contains the main controls of the application. Closing it exits the application. At the
very top, the menu bar offers access to file functions, extensions, and help. Below that,
find icons for the various tools. Hover the mouse over an icon to display information
about it.
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Figure 9.1 The Main Window

The current foreground and background color are shown in two overlapping boxes. The
default colors are black for the foreground and white for the background. Click the box
to open a color selection dialog. Swap the foreground and background color with the
bent arrow symbol to the upper right of the boxes. Use the black and white symbol to
the lower left to reset the colors to the default.

To the right, the current brush, pattern, and gradient are shown. Click the displayed one
to access the selection dialog. The lower portion of the window allows configuration
of various options for the current tool.
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Layers, Channels, Paths, Undo
In the first section, use the drop-down box to select the image to which the tabs refer.
By clicking Auto, control whether the active image is chosen automatically. By default,
Auto is enabled.

Layers shows the different layers in the current images and can be used to manipulate
the layers. Channels shows and can manipulate the color channels of the image.

Paths are a vector-based method of selecting parts of an image. They can also be used
for drawing. Paths shows the paths available for an image and provides access to path
functions. Undo shows a limited history of modifications made to the current image.

9.3 Getting Started
Although The GIMP can be a bit overwhelming for new users, most quickly find it
easy to use once they work out a few basics. Crucial basic functions are creating,
opening, and saving images.

9.3.1 Creating a New Image
To create a new image, select File→ New or press Ctrl + N. This opens a dialog in
which to make settings for the new image. If desired, select a predefined setting called
a Template. To create a custom template, select File→ Dialogs→ Templates and use
the controls offered by the window that opens.

In the Image Size section, set the size of the image to create in pixels or another unit.
Click the unit to select another unit from the list of available units. The ratio between
pixels and a unit is set inResolution, which appears when theAdvanced Options section
is open. A resolution of 72 pixels per inch corresponds to common screen display. It is
sufficient for Web page graphics. A higher resolution should be used for images to
print. For most printers, a resolution of 300 pixels per inch results in an acceptable
quality.
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In Colorspace, select whether the image should be in color (RGB) orGrayscale. Select
the Fill Type for the new image. Foreground Color and Background Color use the
colors selected in the toolbox.White uses a white background in the image. Transparent
creates a clear image. Transparency is represented by a gray checkerboard pattern. Enter
a comment for the new image in Comment.

When the settings meet your needs, press OK. To restore the default settings, press
Reset. Pressing Cancel aborts creation of a new image.

9.3.2 Opening an Existing Image
To open an existing image, select File→ Open or press Ctrl + O. In the dialog that
opens, select the desired file. You can also press Ctrl + L and type directly the URI of
the desired image. Then click Open to open the selected image or press Cancel to skip
opening an image.

9.3.3 Scanning an Image
Instead of opening an existing image or creating a new one, you can scan one. To scan
directly from The GIMP, make sure that the package xsane is installed. To open the
scanning dialog, select File→ Acquire→ XSane: scanning device.

Create a preview when the object to scan is smaller than the total scanning area. Press
Acquire preview in the Preview dialog to create a preview. If you want to scan only
part of the area, select the desired rectangular part with the mouse.

In the xsane dialog, select whether to scan a grayscale or color image and the required
scan resolution. The higher the resolution, the better the quality of the scanned image
is. However, this also results in a correspondingly larger file and the scanning process
can take a very long time at higher resolutions. The size of the final image (both in
pixels and bytes) is shown in the lower part of the dialog.

In the xsane dialog, use the sliders to set desired gamma, brightness, and contrast values.
Changes are visible in the preview immediately. Once all settings have been made,
click Scan to scan the image.
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9.3.4 The Image Window
The new, opened, or scanned image appears in its own window. The menu bar in the
top of the window provides access to all image functions. Alternatively, access the
menu by right-clicking the image or clicking the small arrow button in the left corner
of the rulers.

File offers the standard file options, such as Save and Print. Close closes the current
image. Quit closes the entire application.

With the items in the Viewmenu, control the display of the image and the image window.
New View opens a second display window of the current image. Changes made in one
view are reflected in all other views of that image. Alternate views are useful for mag-
nifying a part of an image for manipulation while seeing the complete image in another
view. Adjust the magnification level of the current window with Zoom. When Shrink
Wrap is selected, the image window is resized to fit the current image display exactly.

9.4 Saving Images
No image function is as important as File→ Save. It is better to save too often than too
rarely. Use File→ Save as to save the image with a new filename. It is a good idea to
save image stages under different names or make backups in another directory so you
can easily restore a previous state.

When saving for the first time or using Save as, a dialog opens in which to specify the
filename and type. Enter the filename in the field at the top. For Save in folder, select
the directory in which to save the file from a list of commonly used directories. To use
a different directory or create a new one, open Browse for other folders. It is recom-
mended to leave Select File Type set to By Extension. With that setting, The GIMP de-
termines the file type based on the extension appended to the filename. The following
file types are frequently useful:

XCF
This is the native format of the application. It saves all layer and path information
along with the image itself. Even if you need an image in another format, it is
usually a good idea to save a copy as XCF to simplify future modifications.
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PAT
This is the format used for The GIMP patterns. Saving an image in this format en-
ables using the image as a fill pattern in The GIMP.

JPG
JPG or JPEG is a common format for photographs and Web page graphics without
transparency. Its compressionmethod enables reduction of file sizes, but information
is lost when compressing. It may be a good idea to use the preview option when
adjusting the compression level. Levels of 85% to 75% often result in an acceptable
image quality with reasonable compression. Saving a backup in a lossless format,
like XCF, is also recommended. If editing an image, save only the finished image
as JPG. Repeatedly loading a JPG then saving can quickly result in poor image
quality.

GIF
Although very popular in the past for graphics with transparency, GIF is less often
used now because of license issues. GIF is also used for animated images. The
format can only save indexed images. The file size can often be quite small if only
a few colors are used.

PNG
With its support for transparency, lossless compression, free availability, and in-
creasing browser support, PNG is replacing GIF as the preferred format for Web
graphics with transparency. An added advantage is that PNG offers partial trans-
parency, which is not offered byGIF. This enables smoother transitions from colored
areas to transparent areas (antialiasing).

To save the image in the chosen format, press Save. To abort, pressCancel. If the image
has features that cannot be saved in the chosen format, a dialog appears with choices
for resolving the situation. Choosing Export, if offered, normally gives the desired re-
sults. A window then opens with the options of the format. Reasonable default values
are provided.
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9.5 Printing Images
To print an image, selectFile→ Print from the imagemenu. If your printer is configured
in the system, it should appear in the list. In some cases, it may be necessary to select
an appropriate driver with Setup Printer. Select the appropriate paper size withMedia
Size and the type inMedia Type. Other settings are available in the Image / Output
Settings tab.

Figure 9.2 The Print Dialog

In the bottom portion of the window, adjust the image size. Press Use Original Image
Size to take these settings from the image itself. This is recommended if you set an ap-
propriate print size and resolution in the image. Adjust the image's position on the page
with the fields in Position or by dragging the image in Preview.
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When satisfied with the settings, press Print. To save the settings for future use, instead
use Print and Save Settings. Cancel aborts printing.

9.6 For More Information
The following resources are useful for users of The Gimp, even if some of them apply
to older versions.

• Help provides access to the internal help system. This documentation is also
available in HTML and PDF formats at http://docs.gimp.org.

• Many tutorials explaining basic or advanced image manipulation techniques with
The GIMP are available at http://gimp.org/tutorials/.

• The GIMPUser Group offers an informativeWeb site athttp://gug.sunsite
.dk.

• http://www.gimp.org is the official home page of The GIMP.

• Grokking the GIMP by Carey Bunks is an excellent book based on an older version
of The GIMP. Although some aspects of the program have changed, it can provide
excellent guidance for image manipulation. An online version is available at
http://gimp-savvy.com/BOOK/.
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10Playing and Managing Your
Music with Helix Banshee
Helix* Banshee™ is a GNOME music management and playback application that lets
you import CDs, sync your music collection to an iPod*, play music directly from an
iPod, create playlists with songs from your library, and create audio andMP3 CDs from
subsets of your library.

To access Helix Banshee, click Computer→ Helix Banshee Music Player.

The first time you open Helix Banshee, you are prompted to accept a license agreement,
after which you are prompted to import music. Choose an import source, such as your
home directory, a local folder, or a local file, then click Import Music Source.

Figure 10.1 Import Music Library

After successfully importing your music, your library is displayed.
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Figure 10.2 Helix Banshee Library

10.1 Managing Your Library
You can use the library to do a variety of things, including playing, organizing, and
importingmusic. You can also view a variety of information about your music collection,
including playback statistics (when a song was last played and how many times).

10.1.1 Playing Your Music

To play a song, simply select the song in the library and click the Play button ( ).

Use the buttons on the upper left corner ( ) to pause a song or play the next

or previous song. Use to adjust the volume. You can also use the items on the
Playback menu to repeat or shuffle songs.
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Helix Banshee also has an integrated CD player. When you insert a music CD, your
CD title appears in the left panel. Select the title and click the Play button to play your
full CD.

10.1.2 Organizing Your Music
To create a new playlist, clickMusic→ New Playlist (or press Ctrl +N). A new playlist
is displayed in the left panel. Double-click New Playlist and enter the name you want.
You can drag and drop songs from one playlist to another, or use the options on the
Edit menu to remove or delete songs and rename or delete playlists.You can sort a
playlist by clicking the title of the column. Click the column again to reverse the sort.
You can also right-clickMusic Library, then click Sort Playlists.

You can edit the name of the artist, album, and title, as well as the track number and
track count. Simply select a song, then click Edit→ Edit Song Metadata. You can also
rate your music, which gives you the option to only play songs with a certain rating,
by selecting the number of stars you want to assign in the Rating field.

Figure 10.3 Editing Song Dialog Box

If you want to set all fields in a group to the same value, select multiple songs in a
playlist, then click Edit→ Edit Song Metadata. Make the changes you want, then click
Copy all common fields. You can also use the Back and Forward buttons to cycle
through the selected songs.
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Figure 10.4 Editing Multiple Songs Dialog Box

Click the Details tab to view detailed information about the selected song, including
when a song was last played, when the song was imported, how long the song is, and
how many times the song has been played.

10.1.3 Creating Smart Playlists
You can create playlists that automatically add and remove songs based on criteria you
specify. For example, a smart playlist can contain songs you rated as five stars but that
you haven’t listened to for six months. Another smart playlist can contain all songs
published in 2006 that you have labeled with the Classical genre.

Helix Banshee automatically updates all smart playlists when a change is made to your
music library. If you import new songs, Helix Banshee checks to see if they match any
of your available smart playlists. When applicable, Helix Banshee also updates your
smart playlists if you just listened to a song or updated a song’s metadata.

The first time you create a smart playlist, you need to enable the plug-in. You can then
create a new smart playlist, choose from a list of predefined smart playlists, or create
a smart playlist based on a current search.
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Enabling the Smart Playlist Plug-In
1 In Helix Banshee, click Edit→ Plugins.

2 Select the check box to the right of Smart Playlists in the left column.

3 Click Close.

Creating a Smart Playlist
1 In Helix Banshee, clickMusic→ New Smart Playlist.

2 Specify a name for the smart playlist, then select the criteria for songs in this
playlist to match.
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Use the plus and minus symbols to add or remove criteria. To use an already
defined smart playlist, click Predefined Smart Playlists, then select the playlist
you want.

3 Click Save.

The smart playlist is added to your music library.

Creating a Smart Playlist from a Search
You can create a smart playlist based on search criteria. For example, if you search for
all songs in your music library by a certain artist, Helix Banshee can create a smart
playlist in which all songs by that artist are selected.

1 In Helix Banshee, clickMusic→ New Smart Playlist from Search.

2 Specify a name for the smart playlist, then specify the search criteria you want.
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Use the plus and minus symbols to add or remove criteria. To use an already
defined smart playlist, click Predefined Smart Playlists, then select the playlist
you want.

3 Click Save.

The smart playlist is added to your music library.

10.1.4 Importing Music
Helix Banshee can import music from a file, folder, or CD.

1 In Helix Banshee, clickMusic→ Import Music.

2 Select an import source.

3 Click Import Music Source.

To rip music from a CD to your music collection:

1 Insert a CD into your CD or DVD drive.

Helix Banshee automatically lists the CD as a playlist in the left menu.
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2 Click the playlist, then click Import CD in the upper right corner.

Figure 10.5 Import CD

10.2 Using Helix Banshee with Your
iPod

To play music from your iPod, simply plug your iPod into your system. Your iPod ap-
pears in the left panel in Helix Banshee. Select the song you want to hear, then click
the Play button.

Figure 10.6 iPod List in Helix Banshee

When the iPod is selected in the left panel, information about your iPod is displayed at
the bottom left, including disk usage and Sync, Properties, and Eject buttons.
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Figure 10.7 iPod Buttons in Helix Banshee

There are three ways to manage the music on your iPod:

• Manually: Browse your iPod and drag music between your library and the iPod.

• Automatically sync: Automatically copies everything in your library to the
iPod.

• Automatic merge: All the music on your iPod that is not in your library is
downloaded to your library, and all the music that is in your library and not in your
iPod is uploaded to your iPod.

Use the iPod Properties dialog box to rename your iPod, and to view vital statistics.
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Figure 10.8 Helix Banshee iPod Properties

10.3 Creating Audio and MP3 CDs
1 Insert a blank CD in your CD or DVD drive.

2 Select the songs you want to burn, then click theWrite CD button in the upper
right side of Helix Banshee.

3 Specify the disk options you want, then clickWrite.

For example, click Eject disk after writing if you want Helix Banshee to eject
your CD when the writing is completed.
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10.4 Sharing Your Music
You can automatically update your online Audioscrobbler [http://www.last.fm]
profile with the music you listen to in Helix Banshee. This lets others see what you are
listening to, and gives you access to charts detailing your listening history. If you join
groups such as the Banshee Group [http://www.last.fm/group/Banshee],
you can also see what other people are listening to.

1 In Helix Banshee, clickMusic→ Audioscrobbler→ Configure.

2 If you have already registered with Last.fm [http://www.last.fm], click
Enable song reporting and specify your Last.fm username and password.

If you have not previously registered with Last.fm, clickCreate an account. This
opens the Last.fm Web site where you can register. Click Enable song reporting
and specify your Last.fm username and password.

3 Click Close.

Helix Banshee starts reporting with the next song you play.
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10.5 Configuring Preferences
You can configure Helix Banshee preferences by clicking Edit→ Preferences. The
Preferences dialog box contains the following options:

Music Library: Lets you specify a music folder location. This location is used when
you import music. Click Copy files to music folder when importing to place a copy of
the files you import in your Helix Banshee music folder.

CD Importing: Lets you determine encoding profiles for CD ripping. Select the
output format you want, then click Edit to configure advanced options for that format.

Figure 10.9 Helix Banshee Preferences Dialog Box
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11Burning CDs and DVDs
GNOMEuses the Nautilus file manager to burn CDs andDVDs. To burn a CD or DVD:

1 Click Computer→ More Applications→ Multimedia→ GNOME CD/DVD
Creator or insert a blank disc and clickMake Data CD. or Make Audio CD.

2 Copy the files you want to put on the CD or DVD into the CD/DVD Creator
window.
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3 ClickWrite to Disc.

4 Modify information in the Write to Disc dialog or accept the defaults, then click
Write.

The files are burned on the disc. This could take a few minutes, depending on
the amount of data being burned and the speed of your burner.

You can use the Helix Banshee music player to burn audio and MP3 CDs, as explained
in Section 10.3, “Creating Audio and MP3 CDs” (page 210).
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AFinding the Information You
Need
To support you in your everyday work with openSUSE™ and to help you explore your
Linux system, Novell and the open source community at large have created a wealth
of information. We have compiled relevant information and made it available to you
in various formats. You can access detailed documentation provided with your product
as well as additional information over the Internet.

A.1 Included Documentation
There are several places where you can find online documentation shipped with your
product. The GNOME desktop includes a help center that offers a wide range of online
documentation for your openSUSE. There, you can access openSUSE-specific informa-
tion as well as application descriptions provided by the open source community.

When installing new software with YaST, the software documentation is installed au-
tomatically in most cases and usually appears in the help center of your desktop.
However, some applications, such as TheGIMP,may have different online help packages
that can be installed separately with YaST and do not integrate into the help center.



A.2 Additional Resources and More
Information

You can also access the specific manuals and documentation delivered with your
product on the Internet at http://www.novell.com/documentation/
opensuse102.

If you are searching for additional information, you can also refer to the following In-
ternet sites:

• SUSE Support Database [http://en.opensuse.org/SDB:SDB]

• Novell Technical Support Knowledgebase [http://www.novell.com/
support/]

• Product Support Community Resources [http://support.novell.com/
forums/index.html]

• GNOME Documentation Web site [http://www.gnome.org/learn/]

In addition, general-purpose search engines are often helpful. For example, you might
try the search terms Linux CD-RW help or OpenOffice file conversion
problem if you were having trouble with the CD burning or with OpenOffice.org file
conversion. Google™ also has a specific Linux search engine [http://www.google
.com/linux] that you might find useful.
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BMoving from Windows to
Linux
If you are coming from Microsoft Windows, take a look at how familiar elements of
Windows translate to openSUSE™. After logging in, you will notice that the desktop
has a familiar layout and recognizable icons, many of them similar to theWindows and
Macintosh desktops.

Figure B.1 GNOME Desktop



B.1 Starting Applications from the
Main Menu

Similar to the Start menu on Windows, you can access all the programs installed on
your system from the main menu. To open the menu click Computer in the left corner
of the panel. The function-oriented menu structure makes it easy to find the right appli-
cation for your purpose even if you do not know the application names yet. Find more
information about the main menu in Section 1.4, “Using the Main Menu” (page 10).

Figure B.2 Main Menu in GNOME

Alternatively, you can also start programs from the command line. Click Computer→
More Applications→ System→Gnome Terminal to open a dialog where you can enter
a command to start the application. The name of the command is often (but not always)
the application name written in lowercase.

B.2 Managing Files
To start the File Manager, click Computer→ Home Folder. or click your home folder
icon on the desktop.
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Figure B.3 File Manager

For more information about the File Manager, see Section 1.5.1, “Managing Folders
and Files with the File Manager” (page 14).

B.3 Using the Command Line
To run commands in a command line environment, similar to a command prompt on
Windows, click Computer→ More Applications→ System→ Gnome Terminal.

Figure B.4 Windows Command Prompt and Terminal
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B.4 Customizing Your Desktop
To change to the way your GNOME desktops looks and behaves, click Computer→
Control Center. Some of the settings you might want to change include the desktop
background, screen saver, keyboard and mouse configuration, sounds, and file associa-
tions.

Figure B.5 GNOME Control Center

For more information, see Chapter 2, Customizing Your Settings (page 35).
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B.5 Switching between Applications
Similar to the taskbar onWindows, the bottom panel in GNOME lets you easily switch
between open windows. Unlike Windows, GNOME lets you set up multiple desktops
where each one can run different programs. Switch between them with a single click.

B.6 Accessing Network Resources
From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
openSUSE offers various different ways of accessing and creating network-shared re-
sources. Given that the network structure and the configuration of your computer allow
for it, you can easily browse your network for shared resources and services with the
file manager.

Figure B.6 GNOME Network Browsing

To learn more about the various possibilities of accessing network resources, refer to
Section 1.5.4, “Accessing Files on the Network” (page 25).
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CGetting to Know Linux
Software
Linux comes with a wealth of applications, often offering more than one solution to
specific needs. The difficulty is finding the application that suits your needs best. The
next few sections introduce some of the most powerful Linux counterparts of common
Windows software. Each section is dedicated to one particular field of application and
presents an overview of the Windows applications and Linux equivalents for several
tasks. Below each table, find further information about the Linux applications with
links to more information. This list is by no means complete, because software devel-
opment is an evolutionary process and new applications are being created every minute.

TIP: Missing Applications

Not all applications mentioned below are installed on your system by default
and some may not be shipped with your product. If the application you want
to use is missing, ask your system administrator. If the application is provided
by your product, you can install it with YaST. Use the search function of the
YaST software management tool to find the package names.

C.1 Office
This section features the most popular and powerful Linux office and business software
solutions. These include office suites, databases, accounting software, and project
management software.



Table C.1 Office Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

OpenOffice.org, StarOffice,
KOffice

MS Office, StarOffice,
OpenOffice.org

Office Suite

OpenOffice.org/StarOffice
Writer, KWord

MS Word, StarOf-
fice/OpenOffice.org Writer,
WordPerfect

Word Processor

OpenOffice.org/StarOfficeCalc,
Gnumeric, KSpread

MS Excel, StarOf-
fice/OpenOffice.org Calc

Spreadsheet

OpenOffice.org/StarOffice Im-
press, KPresenter

MS PowerPoint, StarOf-
fice/OpenOffice.org Impress

Presentation

OpenOffice.org Calc, Kst, Gnu-
plot, Grace (Xmgr), LabPlot

MS Excel, MicroCall OriginData Plotting

OpenOffice.org Base, Rekall,
kexi, Mergeant, PostgreSQL

MS Access, OpenOffice.org
Base

Local Database

GnuCash, moneyplex, KMy-
Money

MSMoney, Quicken,money-
plex

FinancialAccount-
ing

Planner, TaskjugglerMS ProjectProject Manage-
ment

VYM (View Your Mind), Free
Mind, KDissert

MindManager, Free MindMind Mapping

FreeMind
FreeMind helps you to visualize your thoughts by creating and editing a mind map.
You can easily copy nodes or the style of nodes and paste texts from sources such
as HTML, RTF, and mails. The mind maps can be exported into various formats,
such as HTML and XML. For more information, refer to http://freemind
.sourceforge.net/wiki/index.php/Main_Page.
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GnuCash
GnuCash is a software tool to control both your personal and business finances.
Keep track of income and expenses and manage your bank accounts and stock
portfolios all using one piece of software. Learnmore about GnuCash at http://
www.gnucash.org.

Gnumeric
Gnumeric is a spreadsheet solution for the GNOME desktop environment. Find
more information about Gnumeric at http://www.gnumeric.org.

Gnuplot
Gnuplot is a very powerful and portable command line–controlled data plotting
software. It is also available for MacOS and Windows platforms. Plots created by
Gnuplot can be exported to various formats, such as PostScript, PDF, and SVG,
allowing you to process these plots easily. Find more information about Gnuplot
at http://www.gnuplot.info/index.html.

Grace
Grace is a very mature 2D plotting tool for almost all flavors of Unix including
Linux. Create and edit plots with a graphical user interface. Grace supports an un-
limited number of graphs per plot. Its export formats include JPEG, PNG, SVG,
PDF, PS, and EPS. Find more information at http://plasma-gate
.weizmann.ac.il/Grace/.

Kdissert
Kdissert is an application for structuring ideas and concepts, mostly aimed at stu-
dents but also helpful for teachers, decision makers, engineers, and businessmen.
Ideas are first laid down on a canvas then associated into a tree. You can generate
various outputs from the mind map, such as PDF files, text documents (also for
OpenOffice.org Writer), and HTML files. Find more information at http://
freehackers.org/~tnagy/kdissert/.

Kexi
See KOffice (page 226).

KMyMoney
KMyMoney is a personal finance manager for KDE. It enables users of open source
operating systems to keep track of their personal finances by providing a broad
array of financial features and tools. Learn more about KMyMoney at http://
kmymoney2.sourceforge.net.
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KOffice
KOffice is an integrated office suite for the KDE desktop. It comes with various
modules like word processing (KWord), spreadsheets (KSpread), presentations
(KPresenter), several image processing applications (Kivio, Karbon14, Krita), a
database front-end (Kexi), and many more. Find more information about KOffice
at http://www.koffice.org/.

KPresenter
See KOffice (page 226).

Kst
Kst is a KDE application for real-time data viewing and plotting with basic data
analysis functionality. Kst contains many powerful built-in features, such as robust
plotting of live streaming data, and is expandable with plug-ins and extensions.
Find more about Kst at http://kst.kde.org/.

KWord
See KOffice (page 226).

LabPlot
LabPlot is a program for creating and managing two or three-dimensional data
plots. Graphs can be produced both from data and functions and one plot might
include multiple graphs. It also offers various data analysis methods. Find more
information about LabPlot at http://labplot.sourceforge.net/.

Mergeant
Mergeant is a database front-end for the GNOME desktop. Find more information
at http://www.gnome-db.org.

moneyplex
moneyplex is a tool to control your finances. All tasks from managing incoming
resources and expenses and monitoring your stock portfolio to online transactions
via the HBCI standard are handled by moneyplex. Keep track of your financial
transactions over time using various analysis options. Because this tool is also
available for Windows, users can migrate very easily without having to learn a
whole new application interface. Find more information about moneyplex at
http://www.matrica.de.

OpenOffice.org
OpenOffice.org is the open source equivalent of MS Office. It is a very powerful
office suite including a word processor (Write), a spreadsheet (Calc), a database
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manager (Base), a presentation manager (Impress), a drawing program (Draw),
and a formula editor for generating mathematical equations and formulas (Math).
Users familiar with the MS Office family of applications find a very similar appli-
cation interface and all the functionality to which they are accustomed. Because
OpenOffice.org is capable of importing data from MS Office applications, the
transition from one office suite to the other is very smooth. A Windows version of
OpenOffice.org even exists, enabling Windows users to switch to an open source
alternative while still usingWindows. Findmore information about OpenOffice.org
at http://www.openoffice.org/ and read our OpenOffice.org chapter for
a short introduction to the office suite.

Planner
Planner is a project management tool for the GNOME desktop aiming to provide
functionality similar to the project management tools used underWindows. Among
its various features are Gantt charting abilities and different kinds of views of tasks
and resources. Find more information about Planner at http://www.imendio
.com/projects/planner/.

PostgreSQL
PostgreSQL is an object-relational database management system that supports an
extended subset of the SQL standard, including transactions, foreign keys, sub-
queries, triggers, and user-defined types and functions. Find more information
about PostgreSQL at http://www.postgresql.org/.

Rekall
Rekall is a tool for manipulating databases. Supported databases include MySQL,
PostgreSQL, XBase with XBSQL, IBM DB2, and ODBC. Use Rekall to generate
different sorts of reports and forms, design database queries, or import and export
data to various formats. Find more information about Rekall at http://www
.thekompany.com/products/rekall/.

StarOffice
StarOffice is a proprietary version of OpenOffice.org and is distributed by Sun
Microsystems. It is available on multiple platforms includingWindows and Solaris.
It includes certain advanced features not available with the free version (OpenOf-
fice.org). Find more information about StarOffice at http://www.sun.com/
software/star/staroffice/.
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Taskjuggler
Taskjuggler is a lean, but very powerful project management software. Take control
of your projects using the Gantt charting features or by generating all kinds of reports
(in XML, HTML, or CSV format). Those users who are not comfortable with
controlling applications from the command line can use a graphical front-end to
Taskjuggler. Find more information about Taskjuggler at http://www
.taskjuggler.org.

VYM (View Your Mind)
VYM is a software for visualizing your thoughts by creating and manipulating
mind maps. Most manipulations do not require more than one mouse click.
Branches can be inserted, deleted, and reordered very easily. VYM also offers a
set of flags allowing you to mark certain parts of the map (important, time critical,
etc.). Links, notes, and images can be added to a mind map as well. VYM mind
maps use an XML format, allowing you to export your mindmaps to HTML easily.
Find more information about VYM at http://www.insilmaril.de/vym.

C.2 Network
The following section features various Linux applications for networking purposes.
Get to know the most popular Linux browsers and e-mail and chat clients.

Table C.2 Network Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

Konqueror, Firefox, Opera,
Epiphany

Internet Explorer, Firefox,
Opera

Web Browser

Evolution, Kontact,Mozilla
Thunderbird

MS Outlook, Lotus Notes,
Mozilla Thunderbird

E-Mail Client/Personal
InformationManagement

Gaim, Kopete, Konversa-
tion, XChat

MSN,AIM,YahooMessen-
ger, XChat, Gaim

Instant Messaging/IRC
Clients

GnomeMeeting/EkigaNetMeetingConferencing (Video and
Audio)
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Linux ApplicationWindows ApplicationTask

Ekiga, SkypeX-LiteVoice over IP

gftp, kbearleechftp, wsftpFTP Clients

Epiphany
Epiphany is a lean, but powerful Web browser for the GNOME desktop. Many of
its features and extensions resemble Firefox. Findmore information about Epiphany
at http://www.gnome.org/projects/epiphany/.

Evolution
Evolution is personal information management software for the GNOME desktop
combining mail, calendar, and address book functionality. It offers advanced e-
mail filter and search options, provides sync functionality for Palm devices, and
allows you to run Evolution as an Exchange or GroupWise client to integrate better
into heterogeneous environments. Find more information about Evolution at
http://www.gnome.org/projects/evolution/

Firefox
Firefox is the youngest member of the Mozilla browser family. It runs on various
platforms, including Linux, MacOS, andWindows. Its main features include built-
in customizable searches, pop-up blocking, RSS news feeds, passwordmanagement,
tabbed browsing, and some advanced security and privacy options. Firefox is very
flexible, allowing you to customize almost anything you want (searches, toolbars,
skins, buttons, etc.). Neat add-ons and extensions can be downloaded from the
Firefox Web site (https://addons.update.mozilla.org/
?application=firefox). Findmore information about Firefox at http://
www.mozilla.org/products/firefox/. You can also read our introduc-
tion to using Firefox in Chapter 7, Browsing with Firefox (page 171).

Gaim
Gaim is a smart instant messenger program supporting multiple protocols, such as
AIM and ICQ (Oscar protocol), MSNMessenger, Yahoo!, IRC, Jabber, SILC, and
GroupWise Messenger. It is possible to log in to different accounts on different
IM networks and chat on different channels simultaneously. Gaim also exists in a
Windows version. Find more information about Gaim at http://gaim
.sourceforge.net/about.php.
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gftp
gftp is an FTP client using the GTK toolkit. Its features include simultaneous
downloads, resume of interrupted file transfers, file transfer queues, download of
entire directories, FTP proxy support, remote directory caching, passive and non-
passive file transfers, and drag and drop support. Find more information at
http://gftp.seul.org.

GnomeMeeting/Ekiga
GnomeMeeting (recently renamed Ekiga) is the open source equivalent of Mi-
crosoft's NetMeeting. It features LDAP and ILS support for address lookup and
integrates with Evolution to share the address data stored there. GnomeMeeting/Eki-
ga supports PC-to-phone calls, allowing you to call another party with just your
computer, sound card, and microphone without any additional hardware. Find more
information about GnomeMeeting/Ekiga at http://www.ekiga.org.

kbear
KBear is a KDE FTP client with the ability to have concurrent connections to
multiple hosts, three separate viewmodes, support for multiple protocols (like FTP
and SFTP), a site manager plug-in, firewall support, logging capabilities, and much
more. Find more information at http://sourceforge.net/projects/
kbear.

Konqueror
Konqueror is a multitalented application created by the KDE developers. It acts as
file manager and document viewer, but is also a very powerful and highly customiz-
able Web browser. It supports the current Web standards, such as CSS(2), Java
applets, JavaScript and Netscape plug-ins (Flash and RealVideo), DOM, and SSL.
It offers neat helpers like an integrated search bar and supports tabbed browsing.
Bookmarks can be imported from various otherWeb browsers, like Internet Explor-
er, Mozilla, and Opera. Find more information about Konqueror at http://www
.konqueror.org/. You can also read our chapter about Konqueror as a Web
browser.

Kontact
Kontact is the KDE personal information management suite. It includes e-mail,
calendar, address book, and Palm sync functionalities. Like Evolution, it can act
as an Exchange or GroupWise client. Kontact combines several stand-alone KDE
applications (KMail, KAddressbook, KOrganizer, and KPilot) to form an entity
providing all the PIM functionality you need. Find more information about Kontact
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at http://www.kontact.org/. You can also read our introduction to using
Kontact in our Kontact chapter.

Konversation
Konversation is an easy-to-use IRC client for KDE. Its features include support
for SSL connections, strikeout, multichannel joins, away and unaway messages,
ignore list functionality, Unicode, autoconnect to a server, optional time stamps in
chat windows, and configurable background colors. Find more information about
Konversation at http://konversation.kde.org.

Kopete
Kopete is a very intuitive and easy-to-use instant messenger tool supporting proto-
cols including IRC, ICQ, AIM, GroupWise Messenger, Yahoo, MSN, Gadu-Gadu,
Lotus Sametime, SMSmessages, and Jabber. Find more information about Kopete
at http://kopete.kde.org/. You can also read an introduction to using
Kopete in our Kopete chapter.

Ekiga
Ekiga is a smart and lean Voice over IP client using the SIP protocol to establish
calls. Find more information at http://www.gnomemeeting.org/. You
can also read our Linphone chapter.

Mozilla Thunderbird
Thunderbird is an e-mail client application that comes as part of the Mozilla suite.
It is also available for Microsoft Windows and MacOS, which facilitates the tran-
sition from one of these operating systems to Linux. Find more information about
Mozilla Thunderbird at http://www.mozilla.org/products/
thunderbird/.

Opera
Opera is a powerful Web browser with neat add-ons like an optional e-mail client
and a chat module. Opera offers pop-up blocking, RSS feeds, built-in and customiz-
able searches, a password manager, and tabbed browsing. The main functionalities
are easily reached through their respective panels. Because this tool is also available
for Windows, it allows a much easier transition to Linux for those who have been
using it under Windows. Find more information about Opera at http://www
.opera.com/.
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Skype
Skype is an application for several platforms (Linux, Windows, Mac Os X) that
can be used for phone calls over the Internet with a good sound quality and with
end-to-end encryption. When using Skype, configuring the firewall or router is not
necessary. For more information, refer to http://www.skype.com/
products/.

XChat
XChat is an IRC client that runs on most Linux and UNIX platforms as well as
under Windows and MacOS X. Find more information about XChat at http://
www.xchat.org/.

C.3 Multimedia
The following section introduces the most popular multimedia applications for Linux.
Get to know media players, sound editing solutions, and video editing tools.

Table C.3 Multimedia Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KsCD, Grip, Helix BansheeCD Player,Winamp,Windows
Media Player

Audio CD Player

K3bNero, Roxio Easy CD CreatorCD Burner

kaudiocreator, Sound Juicer,
Helix Banshee

WMPlayerCD Ripper

amaroK,XMMS,Rhythmbox,
Helix Banshee

Winamp, Windows Media
Player, iTunes

Audio Player

Kaffeine, MPlayer, Xine,
XMMS, Totem, RealPlayer

Winamp, Windows Media
Player

Video Player

AudacitySoundForge, Cooledit, Auda-
city

Audio Editor
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Linux ApplicationWindows ApplicationTask

alsamixer, Kmixsndvol32Sound Mixer

LilyPond, MusE, Noteedit,
Rosegarden

Finale, SmartScore, SibeliusMusic Notation

MainActor, KinoWindows Movie Maker,
Adobe Premiere,Media Studio
Pro, MainActor

Video Creator and
Editor

xawtv (analog), motv (ana-
log), xawtv4, tvtime, kdetv,
zapping, Kaffeine

AVerTV, PowerVCR 3.0,
CinePlayer DVR

TV Viewer

amaroK
The amaroK media player handles various audio formats and plays the streaming
audio broadcasts of radio stations on the Internet. The program handles all file
types supported by the sound server acting as a back-end—currently aRts or
GStreamer. Find more information about amaroK at http://amarok.kde
.org/. You can also read our amaroK chapter.

Audacity
Audacity is a powerful, free sound editing tool. Record, edit, and play any Ogg
Vorbis or WAV file. Mix tracks, apply effects to them, and export the results to
WAV or Ogg Vorbis. Find more information about Audacity at http://
audacity.sourceforge.net/.

Helix Banshee
Helix Banshee is a music management and playback application for the GNOME
desktop. With Helix Banshee, import CDs, sync your music collection to an iPod,
play music directly from an iPod, create playlists with songs from your library, and
create audio and MP3 CDs from subsets of your library. For more information,
refer to GNOME User Guide.

Grip
Grip provides CD player functionalities for the GNOMEdesktop. It supports CDDB
lookups for track and album data. Find more information at http://www
.nostatic.org/grip/.
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Kaffeine
Kaffeine is a versatile multimedia application supporting a wide range of audio
and video formats including Ogg Vorbis, WMV, MOV, and AVI. Import and edit
play lists of various types, create screen shots, and savemedia streams to your local
hard disk. Find more information about Kaffeine at http://kaffeine
.sourceforge.net/.

KAudiocreator
KAudioCreator is a lean CD ripper application. If configured accordingly, KAu-
dioCreator also generates playlist files for your selection that can be used by players
like amaroK, XMMS, or Helix Banshee. Read more about using KAudioCreator
in KDE User Guide or go to http://www.icefox.net/programs/
?program=KAudioCreator.

kdetv
A TV viewer and recorder application for the KDE desktop supporting analog TV.
Find more information about kdetv at http://www.kdetv.org/.

KsCD
KsCD is a neat little CD player application for the KDE desktop. Its user interface
very much resembles that of a normal hardware CD player, guaranteeing ease of
use. KsCD supports CDDB, enabling you to get any track and album information
from the Internet or your local file system. Find more information at http://
docs.kde.org/en/3.3/kdemultimedia/kscd/.

K3b
K3b is a multitalented media creation tool. Create data, audio, or video CD and
DVD projects by dragging and dropping. Find more information about K3b at
http://www.k3b.org/. You can also refer to our K3b chapter.

LilyPond
LilyPond is a free music sheet editor. Because the input format is text-based, you
can use any text editor to create note sheets. Users do not need to tackle any format-
ting or notation issues, like spacing, line-breaking, or polyphonic collisions. All
these issues are automatically resolved by LilyPond. It supports many special nota-
tions like chord names and tablatures. The output can be exported to PNG, TeX,
PDF, PostScript, and MIDI. Find more information about LilyPond at http://
lilypond.org/web/.
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MainActor
MainActor is a fully fledged video authoring software. Because there is aWindows
version of MainActor, transition from Windows is easy. Find more information
about MainActor at http://www.mainactor.com/.

MPlayer
MPlayer is a movie player that runs on several systems. Find more information
about MPlayer at http://www.mplayerhq.hu/homepage/design7/
info.html.

MusE
MusE's goal is to be a complete multitrack virtual studio for Linux. Find more in-
formation about MusE at http://www.muse-sequencer.org/index
.php.

Noteedit
Noteedit is a powerful score editor for Linux. Use it to create sheets of notes and
to export and import scores to and from many formats, such as MIDI, MusicXML
and LilyPond. Find more information about Noteedit at http://developer
.berlios.de/projects/noteedit/.

Rhythmbox
Rhythmbox is a powerful, multitalented media player for the GNOME desktop. It
allows you to organize and browse your music collection using playlists and even
supports Internet radio. Find more information about Rhythmbox at http://www
.gnome.org/projects/rhythmbox/.

Rosegarden
Rosegarden is a free music composition and editing environment. It features an
audio and MIDI sequencer and a score editor. Find more information about
Rosegarden at http://rosegardenmusic.com/.

Sound Juicer
Sound Juicer is a lean CD ripper application for the GNOME desktop. Find more
information about Sound Juicer at http://www.burtonini.com/blog/
computers/sound-juicer.

Totem
Totem is a movie player application for the GNOME desktop. It supports Shoutcast,
m3u, asx, SMIL, and ra playlists, lets you use keyboard controls, and plays a wide
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range of audio and video formats. Find more information about Totem at http://
www.gnome.org/projects/totem/.

tvtime
tvtime is a lean TV viewer application supporting analog TV. Findmore information
about tvtime, including a comprehensive usage guide, at http://tvtime
.sourceforge.net/.

xawtv and motv
xawtv is a TV viewer and recorder application supporting analog TV. motv is ba-
sically the same as xawtv, but with a slightly different user interface. Find more
information about the xawtv project athttp://linux.bytesex.org/xawtv/
.

xawtv4
xawtv4 is a successor of the xawtv application. It supports both analog and digital
audio and video broadcasts. For more information, refer to http://linux
.bytesex.org/xawtv/.

Xine
Xine is a multimedia player that plays CDs, DVDs, and VCDs. It interprets many
multimedia formats. For more information, refer to http://xinehq.de/.

XMMS
XMMS is the traditional choice for multimedia playback. It is focused on music
playback, offering support for CD playback and Ogg Vorbis files. Users ofWinamp
should find XMMS comfortable because of its similarity. Find more information
about XMMS at http://www.xmms.org/.

zapping
A TV viewer and recorder application for the GNOME desktop supporting analog
TV. Findmore information about Zapping athttp://zapping.sourceforge
.net/cgi-bin/view/Main/WebHome.

C.4 Graphics
The following section presents some of the Linux software solutions for graphics work.
These include simple drawing applications as well as fully-fledged image editing tools
and powerful rendering and animation programs.
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Table C.4 Graphics Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KolourPaintMS PaintSimple Graphic Edit-
ing

The GIMP, KritaAdobe Photoshop, Paint Shop
Pro, Corel PhotoPaint, The
GIMP

Professional Graphic
Editing

OpenOffice.org Draw,
Inkscape, Dia

Adobe Illustrator, CorelDraw,
OpenOffice.org Draw, Free-
hand

Creating Vector
Graphics

Inkscape, Dia, KivioWebDraw, Freehand, Adobe
Illustrator

SVG Editing

POV-Ray, Blender,
KPovmodeler

3D Studio MAX, Maya, POV-
Ray, Blender

Creating 3D Graphics

Digikam, f-spotSoftware provided by the cam-
era manufacturer

Managing Digital Pho-
tographs

Vuescan, The GIMPVuescanScanning

gwenview, gThumb, Eye
of Gnome, f-spot

ACDSeeImage Viewing

Blender
Blender is a powerful rendering and animation tool available on many platforms,
including Windows, MacOS, and Linux. Find more information about Blender at
http://www.blender3d.com/.

Dia
Dia is a Linux application aiming to be the Linux equivalent of Visio. It supports
many types of special diagrams, such as network or UML charts. Export formats
include SVG, PNG, and EPS. To support your own custom diagram types, provide
the new shapes in a special XML format. Find more information about Dia at
http://www.gnome.org/projects/dia/.
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Digikam
Digikam is a smart digital photo management tool for the KDE desktop. Importing
and organizing your digital images is a matter of a few clicks. Create albums, add
tags to spare you from copying images around different subdirectories, and eventu-
ally export your images to your ownWeb site. Findmore information about Digikam
at http://www.digikam.org/. You can also refer to our Digikam chapter.

Eye of Gnome (eog)
Eye of Gnome is an image viewer application for the GNOME desktop. Find more
information at http://www.gnome.org/gnome-office/eog.shtml.

f-spot
f-spot is a flexible digital photograph management tool for the GNOME desktop.
It lets you create and manage albums and supports various export options like
HTML pages or burning of image archives to CD. You can also use it as an image
viewer on the command line. Find more information about f-spot at http://www
.gnome.org/projects/f-spot/. You can also refer to our chapter in
GNOME User Guide.

gThumb
gThumb is an image viewer, browser, and organizer for the GNOME desktop. It
supports the import of your digital images via gphoto2, allows you to carry out
basic transformation and modifications, and lets you tag your images to create al-
bums matching certain categories. Find more information about gThumb at
http://gthumb.sourceforge.net/.

Gwenview
Gwenview is a simple image viewer for KDE. It features a folder tree window and
a file list window that provides easy navigation of your file hierarchy. Find more
information at http://gwenview.sourceforge.net/home/.

Inkscape
Inkscape is a free SVG editor. Users of Adobe Illustrator, Corel Draw, and Visio
can find a similar range of features and a familiar user interface in Inkscape. Among
its features, find SVG-to-PNG export, layering, transforms, gradients, and grouping
of objects. Find more information about Inkscape at http://www.inkscape
.org/.
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Kivio
Kivio is a flow-charting application that integrates into the KOffice suite. Former
users of Visio find a familiar look and feel in Kivio. Find more information about
Kivio at http://www.koffice.org/kivio/.

KolourPaint
KolourPaint is an easy-to-use paint program for the KDE desktop. You can use it
for tasks such as painting or drawing diagrams and editing screen shots, photos,
and icons. For more information, refer to http://kolourpaint
.sourceforge.net/.

KPovmodeler
KPovmodeler is a POV-Ray front-end that integrates with the KDE desktop.
KPovmodeler saves users from needing a detailed knowledge of POV-Ray scripting
by translating the POV-Ray language in an easy-to-understand tree view. Native
POV-Ray scripts can be imported to KPovmodeler as well. Find more information
at http://www.kpovmodeler.org.

Krita
Krita is KOffice's answer to Adobe Photoshop and The GIMP. It can be used for
pixel-based image creation and editing. Its features include many of the advanced
image editing capabilities you would normally expect with Adobe Photoshop or
The GIMP. Find more information at http://www.koffice.org/krita.

OpenOffice.org Draw
See OpenOffice.org (page 226).

POV-Ray
The Persistence of Vision Raytracer creates three-dimensional, photo-realistic im-
ages using a rendering technique called ray tracing. Because there is a Windows
version of POV-Ray, it does not take much for Windows users to switch to the
Linux version of this application. Find more information about POV-Ray at
http://www.povray.org/.

The GIMP
The GIMP is the open source alternative to Adobe Photoshop. Its feature list rivals
that of Photoshop, so it is well suited for professional image manipulation. There
is even aWindows version of GIMP available. Find more information at http://
www.gimp.org/. You can also refer to our GIMP chapter.
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VueScan
VueScan is a scanning software available for several platforms. You can install it
parallel to your vendor's scanner software. It supports the scanner's special hardware,
like batch scanning, autofocus, infrared channels for dust and scratch suppression,
and multiscan to reduce scanner noise in the dark areas of slides. It features simple
and accurate color correction from color negatives. Find out more at http://
www.hamrick.com/index.html.

C.5 System and File Management
The following section provides an overview of Linux tools for system and file manage-
ment. Get to know text and source code editors, backup solutions, and archiving tools.

Table C.5 System and File Management Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

Konqueror, NautilusWindows ExplorerFile Manager

kate, GEdit, (X)Emacs,
vim

NotePad, WordPad,
(X)Emacs

Text Editor

ScribusAdobe DistillerPDF Creator

Adobe Reader, Evince,
KPDF, Xpdf

Adobe ReaderPDF Viewer

GOCRRecognita, FineReaderText Recognition

zip, tar, gzip, bzip2, etc.zip, rar, arj, lha, etc.Command Line Pack
Programs

Ark, File RollerWinZipGUI Based Pack Pro-
grams

YaST, GNU PartedPowerQuest, Acronis, Parti-
tion Commander

Hard Disk Partitioner
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Linux ApplicationWindows ApplicationTask

KDar, taper, dumpntbackup, VeritasBackup Software

Adobe Reader
Adobe Reader for Linux is the exact counterpart of theWindows andMac versions
of this application. The look and feel on Linux are the same as on other platforms.
The other parts of the Adobe Acrobat suite have not been ported to Linux. Find
more information at http://www.adobe.com/products/acrobat/
readermain.html.

Ark
Ark is a GUI-based pack program for the KDE desktop. It supports common formats,
such as zip, tar.gz, tar.bz2, lha, and rar. You can view, select, pack, and
unpack single files within an archive. Due to Ark's integration with Konqueror,
you can also trigger actions (such as unpacking an archive) from the context menu
in the file manager, similar to WinZip. For a short introduction to using Ark, refer
to our KDE Desktop chapter.

dump
The dump package contains both dump and restore. dump examines files in a file
system, determines which ones need to be backed up, and copies those files to a
specified disk, tape, or other storage medium. The restore command performs the
inverse function of dump—it can restore a full backup of a file system. Find more
information at http://dump.sourceforge.net/.

Evince
Evince is a document viewer for PDF and PostScript formats for the GNOME
desktop. Find more information at http://www.gnome.org/projects/
evince/.

File Roller
File Roller is a GUI-based pack program for the GNOME desktop. It provides
features similar to Ark's. For more information, refer to http://fileroller
.sourceforge.net/home.html.
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GEdit
GEdit is the official text editor of the GNOME desktop. It provides features similar
to Kate's. Find more information at http://www.gnome.org/projects/
gedit/.

GNU Parted
GNU Parted is a command line tool for creating, destroying, resizing, checking,
and copying partitions and the file systems on them. If you need to create space
for new operating systems, use this tool to reorganize disk usage and copy data
between different hard disks. Findmore information athttp://www.gnu.org/
software/parted/.

GOCR
GOCR is an OCR (optical character recognition) tool. It converts scanned images
of text into text files. Find more information at http://jocr.sourceforge
.net/.

gzip, tar, bzip2
There are plenty of packaging programs for reducing disk usage. In general, they
differ only in their pack algorithm. Linux can also handle the packaging formats
used on Windows. bzip2 is a bit more efficient than gzip, but needs more time,
depending on the pack algorithm. Find more information about gzip and tar in
our Shell chapter.

kate
Kate is part of the KDE suite. It has the ability to open several files at once either
locally or remotely. With syntax highlighting, project file creation, and external
scripts execution, it is a perfect tool for a programmer. Find more information at
http://kate.kde.org/.

KDar
KDar stands for KDE disk archiver and is a hardware-independent backup solution.
KDar uses catalogs (unlike tar), so it is possible to extract a single file without
reading the whole archive and it is also possible to create incremental backups.
KDar can split an archive into multiple slices and trigger the burning of a data CD
or DVD for each slice. Find more information about KDar at http://kdar
.sourceforge.net/.
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Konqueror
Konqueror is the default file manager for the KDE desktop, which can also be used
as aWeb browser, document and image viewer, and CD ripper. For an introduction
to using Konqueror as a file manager, seeKDEUser Guide. Find more information
about this multifunctional application at http://www.konqueror.org/.

KPDF
KPDF is a PDF viewing application for the KDE desktop. Its features include
searching the PDF and full screen reading mode like in Adobe Reader. Find more
information at http://kpdf.kde.org/.

Nautilus
Nautilus is the default file manager of the GNOME desktop. It can be used to create
folders and documents, display and manage your files and folders, run scripts, write
data to a CD, and open URI locations. For an introduction to using Nautilus as a
file manager, see theGNOMEUser Guide. Find information about Nautilus on the
Internet at http://www.gnome.org/projects/nautilus/.

taper
Taper is a backup and restore program that provides a friendly user interface to allow
backup and restoration of files to and from a tape drive. Alternatively, files can be
backed up to archive files. Recursively selected directories are supported. Find
more information at http://taper.sourceforge.net/.

vim
vim (vi improved) is a program similar to the text editor vi. Users may need time
to adjust to vim, because it distinguishes between commandmode and insert mode.
The basic features are the same as in all text editors. vim offers some unique options,
like macro recording, file format detection and conversion, and multiple buffers in
a screen. Find more information at http://www.vim.org/.

(X)Emacs
GNU Emacs and XEmacs are very professional editors. XEmacs is based on GNU
Emacs. To quote the GNU EmacsManual, “Emacs is the extensible, customizable,
self-documenting real-time display editor.” Both offer nearly the same functional-
ity with minor differences. Used by experienced developers, they are highly exten-
sible through the Emacs Lisp language. They support many languages, like Russian,
Greek, Japanese, Chinese, and Korean. Find more information at http://www
.xemacs.org/ and http://www.gnu.org/software/emacs/emacs
.html.
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Xpdf
Xpdf is lean PDF viewing suite for Linux and Unix platforms. It includes a viewer
application and some export plug-ins for PostScript or text formats. Find more in-
formation at http://www.foolabs.com/xpdf/.

C.6 Software Development
This section introduces Linux IDEs, toolkits, development tools, and versioning systems
for professional software development.

Table C.6 Development Software for Windows and Linux

Linux ApplicationWindows ApplicationTask

KDevelop, Eric, Eclipse,
MonoDevelop, Anjuta

Borland C++, Delphi, Visual
Studio, .NET

IntegratedDevelopment
Environments

Qt, GTK+MFC, Qt, GTK+Toolkits

GCCVisualStudioCompilers

GDB, valgrindVisual StudioDebugging Tools

Glade, Qt DesignerVisual Basic, Visual C++GUI Design

CVS, SubversionClearcase, Perforce, Source-
Safe

Versioning Systems

Anjuta
Anjuta is an IDE for GNOME/GTK+ application development. It includes an editor
with automated formatting, code completion, and highlighting. As well as GTK+,
it supports Perl, Pascal, and Java development. A GDB-based debugger is also in-
cluded. Findmore information aboutAnjuta athttp://anjuta.sourceforge
.net.

CVS
CVS, the Concurrent Versions System, is one of the most important version control
systems for open source. It is a front-end to the Revision Control System (RCS)
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included in the standard Linux distributions. Find more information at the home
page http://www.cvshome.org/.

Eclipse
The Eclipse Platform is designed for building integrated development environments
that can be extended with custom plug-ins. The base distribution also contains a
full-featured Java development environment. Find more information at http://
www.eclipse.org.

Eric
Eric is an IDE optimized for Python and Python-Qt development. Find more infor-
mation about Eric athttp://www.die-offenbachs.de/detlev/eric3
.html.

GCC
GCC is a compiler collection with front-ends for various programming languages.
Check out a complete list of features and find extensive documentation at http://
gcc.gnu.org.

GDB
GDB is a debugging tool for programs written in various programming languages.
Find more information about GDB at http://www.gnu.org/software/
gdb/gdb.html.

Glade
Glade is a user interface builder for GTK+ and GNOME development. As well as
GTK+ support, it offers support for C, C++, C#, Perl, Python, Java, and others.
Find more information about Glade at http://glade.gnome.org/.

GTK+
GTK+ is a multiplatform toolkit for creating graphical user interfaces. It is used
for all GNOME applications, The GIMP, and several others. GTK+ has been de-
signed to support a range of languages, not only C/C++. Originally it was written
for GIMP, hence the name “GIMP Toolkit.” Find more information at http://
www.gtk.org. Language bindings for GTK+ are summarized under http://
www.gtk.org/bindings.html.

KDevelop
KDevelop allows you to write programs for different languages (C/C++, Python,
Perl, etc.). It includes a documentation browser, a source code editor with syntax
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highlighting, a GUI for the compiler, and much more. Find more information at
http://www.kdevelop.org.

MonoDevelop
The Mono Project is an open development initiative that is working to develop an
open source Unix version of the .NET development platform. Its objective is to
enable Unix developers to build and deploy cross-platform .NET applications.
MonoDevelop complements theMono development with an IDE. Find more infor-
mation about MonoDevelop at http://www.monodevelop.com/.

Qt
Qt is a program library for developing applications with graphical user interfaces.
It allows you to develop professional programs rapidly. The Qt library is available
not only for Linux, but for a number of Unix flavors and even for Windows and
Macintosh. Thus it is possible to write programs that can be easily ported to those
platforms. Findmore information athttp://www.trolltech.com. Language
bindings for Qt development are summarized under http://developer.kde
.org/language-bindings/.

Qt Designer
Qt Designer is a user interface and form builder for Qt and KDE development. It
can be run as part of the KDevelop IDE or in stand-alone mode. QtDesigner can
be run under Windows and even integrates into the Visual Studio development
suite. Find more information about Qt Designer at http://www.trolltech
.com/products/qt/designer.html.

Subversion
Subversion does the same thing CVS does but hasmajor enhancements, likemoving,
renaming, and attaching meta information to files and directories. The Subversion
home page is http://subversion.tigris.org/.

Valgrind
Valgrind is a suite of programs for debugging and profiling x86 applications. Find
more information about Valgrind at http://valgrind.org/info/.
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DGNU Licenses
This appendix contains the GNUGeneral Public License and the GNU Free Documen-
tation License.

D.1 GNU General Public License
Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place - Suite 330,
Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document,
but changing it is not allowed.

D.1.1 Preamble
The licenses for most software are designed to take away your freedom to share and
change it. By contrast, the GNU General Public License is intended to guarantee your
freedom to share and change free software--to make sure the software is free for all its
users. This General Public License applies to most of the Free Software Foundation’s
software and to any other program whose authors commit to using it. (Some other Free
Software Foundation software is covered by the GNU Library General Public License
instead.) You can apply it to your programs, too.



When we speak of free software, we are referring to freedom, not price. Our General
Public Licenses are designed to make sure that you have the freedom to distribute copies
of free software (and charge for this service if you wish), that you receive source code
or can get it if you want it, that you can change the software or use pieces of it in new
free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you
these rights or to ask you to surrender the rights. These restrictions translate to certain
responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee,
you must give the recipients all the rights that you have. You must make sure that they,
too, receive or can get the source code. And you must show them these terms so they
know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this
license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone
understands that there is no warranty for this free software. If the software is modified
by someone else and passed on, we want its recipients to know that what they have is
not the original, so that any problems introduced by others will not reflect on the original
authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to
avoid the danger that redistributors of a free program will individually obtain patent
licenses, in effect making the program proprietary. To prevent this, we have made it
clear that any patent must be licensed for everyone’s free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.
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D.1.2 GNU GENERAL PUBLIC LICENSE TERMS
AND CONDITIONS FOR COPYING,
DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice placed
by the copyright holder saying it may be distributed under the terms of this General
Public License. The “Program”, below, refers to any such program or work, and a “work
based on the Program”means either the Program or any derivative work under copyright
law: that is to say, a work containing the Program or a portion of it, either verbatim or
with modifications and/or translated into another language. (Hereinafter, translation is
included without limitation in the term “modification”.) Each licensee is addressed as
“you”.

Activities other than copying, distribution and modification are not covered by this Li-
cense; they are outside its scope. The act of running the Program is not restricted, and
the output from the Program is covered only if its contents constitute a work based on
the Program (independent of having been made by running the Program). Whether that
is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program’s source code as
you receive it, in any medium, provided that you conspicuously and appropriately
publish on each copy an appropriate copyright notice and disclaimer of warranty; keep
intact all the notices that refer to this License and to the absence of any warranty; and
give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your
option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus
forming a work based on the Program, and copy and distribute such modifications or
work under the terms of Section 1 above, provided that you also meet all of these con-
ditions:

a) You must cause the modified files to carry prominent notices stating that you
changed the files and the date of any change.
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b) You must cause any work that you distribute or publish, that in whole or in part
contains or is derived from the Program or any part thereof, to be licensed as a whole
at no charge to all third parties under the terms of this License.

c) If the modified program normally reads commands interactively when run, you
must cause it, when started running for such interactive use in the most ordinary way,
to print or display an announcement including an appropriate copyright notice and a
notice that there is no warranty (or else, saying that you provide a warranty) and that
users may redistribute the program under these conditions, and telling the user how to
view a copy of this License. (Exception: if the Program itself is interactive but does not
normally print such an announcement, your work based on the Program is not required
to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of
that work are not derived from the Program, and can be reasonably considered indepen-
dent and separate works in themselves, then this License, and its terms, do not apply
to those sections when you distribute them as separate works. But when you distribute
the same sections as part of a whole which is a work based on the Program, the distri-
bution of the whole must be on the terms of this License, whose permissions for other
licensees extend to the entire whole, and thus to each and every part regardless of who
wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work
written entirely by you; rather, the intent is to exercise the right to control the distribution
of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Pro-
gram (or with a work based on the Program) on a volume of a storage or distribution
medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section
2) in object code or executable form under the terms of Sections 1 and 2 above provided
that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source code,
which must be distributed under the terms of Sections 1 and 2 above on a medium
customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third
party, for a charge no more than your cost of physically performing source distribution,
a complete machine-readable copy of the corresponding source code, to be distributed
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under the terms of Sections 1 and 2 above on a medium customarily used for software
interchange; or,

c) Accompany it with the information you received as to the offer to distribute
corresponding source code. (This alternative is allowed only for noncommercial distri-
bution and only if you received the program in object code or executable form with
such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifica-
tions to it. For an executable work, complete source code means all the source code for
all modules it contains, plus any associated interface definition files, plus the scripts
used to control compilation and installation of the executable. However, as a special
exception, the source code distributed need not include anything that is normally dis-
tributed (in either source or binary form) with the major components (compiler, kernel,
and so on) of the operating system on which the executable runs, unless that component
itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a
designated place, then offering equivalent access to copy the source code from the same
place counts as distribution of the source code, even though third parties are not com-
pelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as ex-
pressly provided under this License. Any attempt otherwise to copy, modify, sublicense
or distribute the Program is void, and will automatically terminate your rights under
this License. However, parties who have received copies, or rights, from you under this
License will not have their licenses terminated so long as such parties remain in full
compliance.

5. You are not required to accept this License, since you have not signed it. However,
nothing else grants you permission to modify or distribute the Program or its derivative
works. These actions are prohibited by law if you do not accept this License. Therefore,
by modifying or distributing the Program (or any work based on the Program), you in-
dicate your acceptance of this License to do so, and all its terms and conditions for
copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the
recipient automatically receives a license from the original licensor to copy, distribute
or modify the Program subject to these terms and conditions. You may not impose any
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further restrictions on the recipients’ exercise of the rights granted herein. You are not
responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or
for any other reason (not limited to patent issues), conditions are imposed on you
(whether by court order, agreement or otherwise) that contradict the conditions of this
License, they do not excuse you from the conditions of this License. If you cannot dis-
tribute so as to satisfy simultaneously your obligations under this License and any other
pertinent obligations, then as a consequence you may not distribute the Program at all.
For example, if a patent license would not permit royalty-free redistribution of the
Program by all those who receive copies directly or indirectly through you, then the
only way you could satisfy both it and this License would be to refrain entirely from
distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular cir-
cumstance, the balance of the section is intended to apply and the section as a whole is
intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other prop-
erty right claims or to contest validity of any such claims; this section has the sole
purpose of protecting the integrity of the free software distribution system, which is
implemented by public license practices.Many people havemade generous contributions
to the wide range of software distributed through that system in reliance on consistent
application of that system; it is up to the author/donor to decide if he or she is willing
to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence
of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either
by patents or by copyrighted interfaces, the original copyright holder who places the
Program under this License may add an explicit geographical distribution limitation
excluding those countries, so that distribution is permitted only in or among countries
not thus excluded. In such case, this License incorporates the limitation as if written in
the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the
General Public License from time to time. Such new versions will be similar in spirit
to the present version, but may differ in detail to address new problems or concerns.
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Each version is given a distinguishing version number. If the Program specifies a version
number of this License which applies to it and “any later version”, you have the option
of following the terms and conditions either of that version or of any later version
published by the Free Software Foundation. If the Program does not specify a version
number of this License, youmay choose any version ever published by the Free Software
Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose
distribution conditions are different, write to the author to ask for permission. For
software which is copyrighted by the Free Software Foundation, write to the Free
Software Foundation; we sometimes make exceptions for this. Our decision will be
guided by the two goals of preserving the free status of all derivatives of our free soft-
ware and of promoting the sharing and reuse of software generally.

NO WARRANTY
11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS
NOWARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY AP-
PLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE
COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM
“AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IM-
PLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIEDWARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE
ENTIRERISKASTOTHEQUALITYANDPERFORMANCEOFTHEPROGRAM
IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME
THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAWORAGREED
TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY
WHOMAYMODIFYAND/ORREDISTRIBUTETHEPROGRAMASPERMITTED
ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL,
SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF
THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT
LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR
LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE
PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH
HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES.
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END OF TERMS AND CONDITIONS

D.1.3 How to Apply These Terms to Your
New Programs

If you develop a new program, and you want it to be of the greatest possible use to the
public, the best way to achieve this is to make it free software which everyone can re-
distribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the
start of each source file to most effectively convey the exclusion of warranty; and each
file should have at least the “copyright” line and a pointer to where the full notice is
found.

one line to give the program’s name and an idea of what it does. Copyright (C) yyyy
name of author
This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an
interactive mode:
Gnomovision version 69, Copyright (C) year name of author
Gnomovision comes with ABSOLUTELY NO WARRANTY; for details
type `show w’. This is free software, and you are welcome
to redistribute it under certain conditions; type `show c’ 
for details.

The hypothetical commands `show w’ and `show c’ should show the appropriate parts
of the General Public License. Of course, the commands you use may be called some-
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thing other than `show w’ and `show c’; they could even be mouse-clicks or menu
items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if
any, to sign a “copyright disclaimer” for the program, if necessary. Here is a sample;
alter the names:
Yoyodyne, Inc., hereby disclaims all copyright
interest in the program `Gnomovision’
(which makes passes at compilers) written 
by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary
programs. If your program is a subroutine library, you may consider it more useful to
permit linking proprietary applications with the library. If this is what you want to do,
use the GNULesser General Public License [http://www.fsf.org/licenses/
lgpl.html] instead of this License.

D.2 GNU Free Documentation License
Version 1.2, November 2002

Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite
330, Boston, MA 02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document,
but changing it is not allowed.

D.2.1 PREAMBLE
The purpose of this License is to make a manual, textbook, or other functional and
useful document “free” in the sense of freedom: to assure everyone the effective freedom
to copy and redistribute it, with or without modifying it, either commercially or non-
commercially. Secondarily, this License preserves for the author and publisher a way
to get credit for their work, while not being considered responsible for modifications
made by others.
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This License is a kind of “copyleft”, which means that derivative works of the document
must themselves be free in the same sense. It complements the GNU General Public
License, which is a copyleft license designed for free software.

We have designed this License in order to use it for manuals for free software, because
free software needs free documentation: a free program should come with manuals
providing the same freedoms that the software does. But this License is not limited to
software manuals; it can be used for any textual work, regardless of subject matter or
whether it is published as a printed book. We recommend this License principally for
works whose purpose is instruction or reference.

D.2.2 APPLICABILITY AND DEFINITIONS
This License applies to anymanual or other work, in anymedium, that contains a notice
placed by the copyright holder saying it can be distributed under the terms of this Li-
cense. Such a notice grants a world-wide, royalty-free license, unlimited in duration,
to use that work under the conditions stated herein. The “Document”, below, refers to
any such manual or work. Any member of the public is a licensee, and is addressed as
“you”. You accept the license if you copy, modify or distribute the work in a way re-
quiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or
a portion of it, either copied verbatim, or with modifications and/or translated into an-
other language.

A “Secondary Section” is a named appendix or a front-matter section of the Document
that deals exclusively with the relationship of the publishers or authors of the Document
to the Document’s overall subject (or to related matters) and contains nothing that could
fall directly within that overall subject. (Thus, if the Document is in part a textbook of
mathematics, a Secondary Section may not explain any mathematics.) The relationship
could be a matter of historical connection with the subject or with related matters, or
of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated,
as being those of Invariant Sections, in the notice that says that the Document is released
under this License. If a section does not fit the above definition of Secondary then it is
not allowed to be designated as Invariant. The Document may contain zero Invariant
Sections. If the Document does not identify any Invariant Sections then there are none.
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The “Cover Texts” are certain short passages of text that are listed, as Front-Cover
Texts or Back-Cover Texts, in the notice that says that the Document is released under
this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may
be at most 25 words.

A “Transparent” copy of the Document means a machine-readable copy, represented
in a format whose specification is available to the general public, that is suitable for
revising the document straightforwardly with generic text editors or (for images com-
posed of pixels) generic paint programs or (for drawings) some widely available
drawing editor, and that is suitable for input to text formatters or for automatic translation
to a variety of formats suitable for input to text formatters. A copymade in an otherwise
Transparent file format whose markup, or absence of markup, has been arranged to
thwart or discourage subsequent modification by readers is not Transparent. An image
format is not Transparent if used for any substantial amount of text. A copy that is not
“Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without
markup, Texinfo input format, LaTeX input format, SGML or XML using a publicly
available DTD, and standard-conforming simple HTML, PostScript or PDF designed
for human modification. Examples of transparent image formats include PNG, XCF
and JPG. Opaque formats include proprietary formats that can be read and edited only
by proprietary word processors, SGML or XML for which the DTD and/or processing
tools are not generally available, and the machine-generated HTML, PostScript or PDF
produced by some word processors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following
pages as are needed to hold, legibly, the material this License requires to appear in the
title page. For works in formats which do not have any title page as such, “Title Page”
means the text near the most prominent appearance of the work’s title, preceding the
beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either
is precisely XYZ or contains XYZ in parentheses following text that translates XYZ
in another language. (Here XYZ stands for a specific section name mentioned below,
such as “Acknowledgements”, “Dedications”, “Endorsements”, or “History”.) To
“Preserve the Title” of such a section when you modify the Document means that it
remains a section “Entitled XYZ” according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that
this License applies to the Document. These Warranty Disclaimers are considered to
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be included by reference in this License, but only as regards disclaiming warranties:
any other implication that theseWarranty Disclaimers may have is void and has no effect
on the meaning of this License.

D.2.3 VERBATIM COPYING
You may copy and distribute the Document in any medium, either commercially or
noncommercially, provided that this License, the copyright notices, and the license
notice saying this License applies to the Document are reproduced in all copies, and
that you add no other conditions whatsoever to those of this License. You may not use
technical measures to obstruct or control the reading or further copying of the copies
you make or distribute. However, you may accept compensation in exchange for copies.
If you distribute a large enough number of copies you must also follow the conditions
in section 3.

Youmay also lend copies, under the same conditions stated above, and youmay publicly
display copies.

D.2.4 COPYING IN QUANTITY
If you publish printed copies (or copies in media that commonly have printed covers)
of the Document, numbering more than 100, and the Document’s license notice requires
Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all
these Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on the
back cover. Both covers must also clearly and legibly identify you as the publisher of
these copies. The front cover must present the full title with all words of the title
equally prominent and visible. You may add other material on the covers in addition.
Copying with changes limited to the covers, as long as they preserve the title of the
Document and satisfy these conditions, can be treated as verbatim copying in other re-
spects.

If the required texts for either cover are too voluminous to fit legibly, you should put
the first ones listed (as many as fit reasonably) on the actual cover, and continue the
rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100,
you must either include a machine-readable Transparent copy along with each Opaque
copy, or state in or with each Opaque copy a computer-network location from which
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the general network-using public has access to download using public-standard network
protocols a complete Transparent copy of the Document, free of added material. If you
use the latter option, youmust take reasonably prudent steps, when you begin distribution
of Opaque copies in quantity, to ensure that this Transparent copy will remain thus ac-
cessible at the stated location until at least one year after the last time you distribute an
Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before
redistributing any large number of copies, to give them a chance to provide you with
an updated version of the Document.

D.2.5 MODIFICATIONS
You may copy and distribute a Modified Version of the Document under the conditions
of sections 2 and 3 above, provided that you release the Modified Version under pre-
cisely this License, with the Modified Version filling the role of the Document, thus
licensing distribution and modification of the Modified Version to whoever possesses
a copy of it. In addition, you must do these things in the Modified Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the
Document, and from those of previous versions (which should, if there were any, be
listed in the History section of the Document). You may use the same title as a previous
version if the original publisher of that version gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for
authorship of the modifications in the Modified Version, together with at least five of
the principal authors of the Document (all of its principal authors, if it has fewer than
five), unless they release you from this requirement.

C. State on the Title page the name of the publisher of the Modified Version, as the
publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other
copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the public
permission to use the Modified Version under the terms of this License, in the form
shown in the Addendum below.
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G. Preserve in that license notice the full lists of Invariant Sections and required
Cover Texts given in the Document’s license notice.

H. Include an unaltered copy of this License.

I. Preserve the section Entitled “History”, Preserve its Title, and add to it an item
stating at least the title, year, new authors, and publisher of the Modified Version as
given on the Title Page. If there is no section Entitled “History” in the Document, create
one stating the title, year, authors, and publisher of the Document as given on its Title
Page, then add an item describing the Modified Version as stated in the previous sen-
tence.

J. Preserve the network location, if any, given in the Document for public access to
a Transparent copy of the Document, and likewise the network locations given in the
Document for previous versions it was based on. These may be placed in the “History”
section. You may omit a network location for a work that was published at least four
years before the Document itself, or if the original publisher of the version it refers to
gives permission.

K. For any section Entitled “Acknowledgements” or “Dedications”, Preserve the
Title of the section, and preserve in the section all the substance and tone of each of
the contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and
in their titles. Section numbers or the equivalent are not considered part of the section
titles.

M. Delete any section Entitled “Endorsements”. Such a section may not be included
in the Modified Version.

N. Do not retitle any existing section to be Entitled “Endorsements” or to conflict
in title with any Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify
as Secondary Sections and contain no material copied from the Document, you may at
your option designate some or all of these sections as invariant. To do this, add their
titles to the list of Invariant Sections in the Modified Version’s license notice. These
titles must be distinct from any other section titles.
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You may add a section Entitled “Endorsements”, provided it contains nothing but en-
dorsements of your Modified Version by various parties--for example, statements of
peer review or that the text has been approved by an organization as the authoritative
definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up
to 25 words as a Back-Cover Text, to the end of the list of Cover Texts in the Modified
Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be
added by (or through arrangements made by) any one entity. If the Document already
includes a cover text for the same cover, previously added by you or by arrangement
made by the same entity you are acting on behalf of, you may not add another; but you
may replace the old one, on explicit permission from the previous publisher that added
the old one.

The author(s) and publisher(s) of the Document do not by this License give permission
to use their names for publicity for or to assert or imply endorsement of any Modified
Version.

D.2.6 COMBINING DOCUMENTS
You may combine the Document with other documents released under this License,
under the terms defined in section 4 above for modified versions, provided that you
include in the combination all of the Invariant Sections of all of the original documents,
unmodified, and list them all as Invariant Sections of your combined work in its license
notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical
Invariant Sections may be replaced with a single copy. If there are multiple Invariant
Sections with the same name but different contents, make the title of each such section
unique by adding at the end of it, in parentheses, the name of the original author or
publisher of that section if known, or else a unique number. Make the same adjustment
to the section titles in the list of Invariant Sections in the license notice of the combined
work.

In the combination, you must combine any sections Entitled “History” in the various
original documents, forming one section Entitled “History”; likewise combine any
sections Entitled “Acknowledgements”, and any sections Entitled “Dedications”. You
must delete all sections Entitled “Endorsements”.
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D.2.7 COLLECTIONS OF DOCUMENTS
You may make a collection consisting of the Document and other documents released
under this License, and replace the individual copies of this License in the various
documents with a single copy that is included in the collection, provided that you follow
the rules of this License for verbatim copying of each of the documents in all other re-
spects.

Youmay extract a single document from such a collection, and distribute it individually
under this License, provided you insert a copy of this License into the extracted docu-
ment, and follow this License in all other respects regarding verbatim copying of that
document.

D.2.8 AGGREGATION WITH INDEPENDENT
WORKS

A compilation of the Document or its derivatives with other separate and independent
documents or works, in or on a volume of a storage or distribution medium, is called
an “aggregate” if the copyright resulting from the compilation is not used to limit the
legal rights of the compilation’s users beyond what the individual works permit. When
the Document is included in an aggregate, this License does not apply to the other works
in the aggregate which are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document,
then if the Document is less than one half of the entire aggregate, the Document’s
Cover Texts may be placed on covers that bracket the Document within the aggregate,
or the electronic equivalent of covers if the Document is in electronic form. Otherwise
they must appear on printed covers that bracket the whole aggregate.

D.2.9 TRANSLATION
Translation is considered a kind of modification, so you may distribute translations of
the Document under the terms of section 4. Replacing Invariant Sections with translations
requires special permission from their copyright holders, but youmay include translations
of some or all Invariant Sections in addition to the original versions of these Invariant
Sections. You may include a translation of this License, and all the license notices in
the Document, and any Warranty Disclaimers, provided that you also include the orig-
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inal English version of this License and the original versions of those notices and dis-
claimers. In case of a disagreement between the translation and the original version of
this License or a notice or disclaimer, the original version will prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or
“History”, the requirement (section 4) to Preserve its Title (section 1) will typically re-
quire changing the actual title.

D.2.10 TERMINATION
You may not copy, modify, sublicense, or distribute the Document except as expressly
provided for under this License. Any other attempt to copy, modify, sublicense or dis-
tribute the Document is void, and will automatically terminate your rights under this
License. However, parties who have received copies, or rights, from you under this
License will not have their licenses terminated so long as such parties remain in full
compliance.

D.2.11 FUTURE REVISIONS OF THIS LICENSE
The Free Software Foundation may publish new, revised versions of the GNU Free
Documentation License from time to time. Such new versions will be similar in spirit
to the present version, but may differ in detail to address new problems or concerns.
See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document
specifies that a particular numbered version of this License “or any later version” applies
to it, you have the option of following the terms and conditions either of that specified
version or of any later version that has been published (not as a draft) by the Free
Software Foundation. If the Document does not specify a version number of this License,
you may choose any version ever published (not as a draft) by the Free Software
Foundation.
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D.2.12 ADDENDUM: How to use this License
for your documents

To use this License in a document you have written, include a copy of the License in
the document and put the following copyright and license notices just after the title
page:
Copyright (c) YEAR YOUR NAME.
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2
or any later version published by the Free Software Foundation;
with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts.
A copy of the license is included in the section entitled “GNU
Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the
“with...Texts.” line with this:
with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the
three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releas-
ing these examples in parallel under your choice of free software license, such as the
GNU General Public License, to permit their use in free software.
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