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About This Guide

This manual introduces the KDE desktop of openSUSE® and a variety of applications
shipping with it. It guides you through using these applications and helps you perform
key tasks. It is intended mainly for end users who want to make efficient use of KDE
in everyday life.

KDE Desktop
Get to know your KDE desktop and learn how to cope with basic and daily tasks,
using the central KDE applications and some small utilities. Get an impression of
the numerous possibilities KDE offers to modify and individualize your desktop
according to your needs.

Office and Collaboration
Use the office and collaboration software openSUSE offers, such as the OpenOffi-
ce.org suite, several e-mailing and calendaring programs, and applications for
online conversations. Also find vital information concerning the management and
exchange of data on your system: how to share files on the network, how to effec-
tively search and encrypt data, and how to manage printers.

Internet
Find out how to use the Internet applications included in openSUSE, such as
Konqueror or the Firefox Web browser, a download manager, or a news feed reader.

Multimedia
Get to know applications for graphics manipulation, management of digital photo-
graphs, sound manipulation and editing, and for CD and DVD writers.

1 Feedback

We want to hear your comments and suggestions about this manual and the other
documentation included with this product. Please use the User Comments feature at
the bottom of each page of the online documentation and enter your comments there.



2 Additional Documentation

We provide HTML and PDF versions of our books in different languages. The following
manuals are available for openSUSE:

Start
Fiihrt Sie durch die Installation und die grundlegende Konfiguration Ihres Systems.
Fiir Neulinge behandelt das Handbuch auch grundlegende Linux-Konzepte, wie
zum Beispiel das Dateisystem, das Benutzerkonzept und Zugriffsberechtigungen
und bietet einen Uberblick iiber die Features von openSUSE fiir die Unterstiitzung
tragbarer Computer. Stellt Hilfe und Rat bei Problemlésungen bereit.

KDE Quick Start
Bietet eine kurze Einfithrung in den KDE-Desktop und einige wichtige Anwendun-
gen, die darauf ausgefiihrt werden.

KDE User Guide
Gibt eine Einfiihrung in den KDE-Desktop von openSUSE und in die verschiedenen
darin enthaltenen Anwendungen. Es begleitet Sie durch die Nutzung dieser
Anwendungen und hilft Ihnen bei der Erledigung von wichtigen Aufgaben. Es
richtet sich in erster Linie an Endbenutzer, die KDE effizient im Alltag nutzen
mochten.

GNOME Quick Start
Bietet eine kurze Einfiihrung in den GNOME-Desktop und einige wichtige
Anwendungen, die darauf ausgefiihrt werden.

GNOME User Guide
Stellt den GNOME-Desktop fiir openSUSE sowie eine vielzahl von Anwendungen
vor, die IThnen bei der Arbeit mit dem GNOME-Desktop begegnen. Es begleitet
Sie durch die Nutzung dieser Anwendungen und hilft Ihnen bei der Erledigung von
wichtigen Aufgaben. Es richtet sich in erster Linie an Endbenutzer, die den GNO-
ME-Desktop und darauf ausgefiihrte Anwendungen effizient im Alltag nutzen
mochten.

Referenz
Vermittelt Ihnen ein grundlegendes Verstdndnis von openSUSE und behandelt
erweiterte Aufgaben der Systemadministration. Es richtet sich in der Hauptsache
an Systemadministratoren und andere Benutzer mit Grundkenntnissen der Syste-
madministration. Es enthdlt ausfiihrliche Informationen iiber erweiterte Einsatzmog-
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lichkeiten, Administration Thres Systems, Interaktion von Schliisselsystemkompo-
nenten sowie die Einrichtung verschiedener Netzwerk- und Dateidienste, die
openSUSE bietet.

Novell AppArmor Quick Start
Unterstiitzt Sie beim Verstehen der Hauptkonzepte von Novell® AppArmor.

Novell AppArmor Administration Guide
Enthélt ausfiihrliche Informationen zur Verwendung von AppArmor in Ihrer
Umgebung.

Lessons For Lizards
Ein Community-Buchprojekt fiir die openSUSE-Distribution. Ein Snapshot des
von der Open Source-Community verfassten Handbuchs wird zusammen mit den
Novel/SUSE-Handbiichern verdffentlicht. Diese Lektionen wurden in Form eines
Kochbuchs verfasst und behandelten besondere und exotischere Themen als die
normalen Handbiicher. Weitere Informationen finden Sie unter http://
developer.novell.com/wiki/index.php/Lessons_for_Lizards.

Find HTML versions of the openSUSE manuals in your installed system under /usr/
share/doc/manual or in the help centers of your KDE or GNOME desktop. You
can also access the documentation on the Web at http://www.novell.com/
documentation/opensusel03/ where you can download PDF or HTML versions
of the manuals. For information where to find the books on the installation media, refer
to the Release Notes of this product, available in your installed system under /usr/
share/doc/release—-notes/.

3 Konventionen in der
Dokumentation

In diesem Handbuch werden folgende typografische Konventionen verwendet:
+ /etc/passwd: Dateinamen und Verzeichnisnamen
* Platzhalter: Ersetzen Sie P1atzhalter durch den tatsdchlichen Wert.

+ PATH: die Umgebungsvariable PATH

About This Guide
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* 1s, ——help: Befehle, Optionen und Parameter
* Benutzer: Benutzer oder Gruppen

+ Alt, Alt + F1: Eine Taste oder Tastenkombination. Tastennamen werden wie auf
der Tastatur in GroBSbuchstaben dargestellt.

* Datei, Datei > Speichern unter: Meniioptionen, Schaltflichen

 Tanzende Pinguine (Kapitel Pinguine, 1 Anderes Handbuch): Dies ist ein Verweis
auf ein Kapitel in einem anderen Handbuch.

4 About the Making of This Manual

This book is written in Novdoc, a subset of DocBook (see http://www.docbook
.org). The XML source files were validated by xm11int, processed by xsltproc,
and converted into HTML using a customized version of Norman Walsh's stylesheets.

5 Acknowledgments

With a lot of voluntary commitment, the developers of Linux cooperate on a global
scale to promote the development of Linux. We thank them for their efforts—this dis-
tribution would not exist without them. Furthermore, we thank Frank Zappa and Pawar.
Special thanks, of course, go to Linus Torvalds.

Have a lot of fun!

Your SUSE Team
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Getting Started with the KDE
Desktop

This chapter assists you in becoming familiar with the KDE desktop of your Linux
system and in performing basic tasks.

KDE stands for K Desktop Environment and is a graphical user interface that has many
applications designed to help you in your daily work. KDE also offers many choices
to modify your desktop according to your needs and wishes. Read more about configu-
ring your desktop in Kapitel 2, Customizing Your Settings (S. 51).

The following description is based on the default configuration of the KDE desktop
shipped with your product. If you or your system administrator has modified the defaults,
some aspects may be different, such as appearance or keyboard shortcuts.

1.1 Logging In and Selecting a
Desktop

If more than one user account is configured on your computer, usually all users must
authenticate—unless Auto Login is configured for a certain user. Auto login logs the
user in to the desktop environment automatically on boot. Enable or disable this feature
during installation or at any time using the YaST user management module. For more
information, see Abschnitt ,,Benutzerkonten verwalten“ (Kapitel 5, Verwalten von
Benutzern mit YaST, tStart).But if your computer is run in a network environment and
you are not the only person using the machine, you are usually prompted to enter your
username and password when you start your system. If you did not set up your system
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and your user account yourself, check with your system administrator for your username
and password.

The program managing the login process depends on the desktop environment installed
on your system. For KDE, it is KDM. If the GNOME desktop is additionally installed
on your system, it may be GDM.

As shown in Abbildung 1.1, ,,A KDM Login Screen® (S. 4), the default KDM login
screen provides input fields for username and password and the following menu items:

Session Type
Specifies the desktop to run when you log in. If desktops other than KDE are
installed, they appear in the list. Make changes only if you want to use a session
type other than your default (usually KDE). Future sessions are automatically of
the same type unless you change the session type manually.

System
Performs a system action, such as shutting down the computer or starting different
login actions. Remote Login enables you to log in on a remote machine.

To start a normal login, just enter your username and password.

Abbildung 1.1 A KDM Login Screen

SUSE Linux
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ANMERKUNG: Connecting to an Active Directory Server

To access shared network resources, you can also authenticate a KDE client
machine against an Active Directory server. For further details, refer to Kapitel 8,
Accessing Network Resources (S. 151). If your machine is configured for this kind
of authentication, the login screen also provides an additional field. In this case,
proceed as follows during login:

1. Select the domain from the list.
2. Enter your Windows* username.

3. Enter your Windows password and press Eingabetaste.

1.1.1 Controlling a Session

The Session Manager starts after your username and password are authenticated by the
login process. The Session Manager lets you save certain settings for each session. It
also lets you save the state of your most recent session and return to that state the next
time you log in.

The Session Manager can save and restore the following settings:

» Appearance and behavior settings, such as fonts, colors, and mouse settings.

+ Applications that you were running, such as a file manager or OpenOffice.org.

ANMERKUNG: Saving and Restoring Applications

You cannot save and restore applications that Session Manager does not
manage. For example, if you start the vi editor from the command line in
a terminal window, Session Manager cannot restore your editing session.

For information about configuring session preferences, see Adjusting the Session
Handling (S. 75).

Getting Started with the KDE Desktop



1.1.2 Switching Desktops

If you installed both the KDE and the GNOME desktops, use the following instructions
to switch desktops.

1 Ifyou are logged in to KDE, select Leave > Logout from the main menu. On the
following login screen, click Session Type.

2 Select the GNOME desktop.
3 Enter your username.

4 Enter your password. The GNOME desktop is started.

See GNOME User Guideathttp://www.novell.com/documentation/
opensusel03/ for more information about using the GNOME desktop.

5 To switch back to KDE again, click Desktop > Log Out on the panel of the
GNOME desktop then click OK. The session is closed and the login screen
reappears.

6 Before logging in again, click Session Type and select KDE in the login screen.
If you do not select a new session type, your next session will be of the same
type (GNOME) as the session before.

1.1.3 Locking Your Screen

To lock the screen, do either of the following;:
« From the main menu, select Leave > Lock.

+ Use the keyboard shortcut defined in the KDE control center. Usually, this is Strg
+Alt + L.

TIPP: Looking Up KDE Keyboard Shortcuts

If you are interested in other KDE keyboard shortcuts, look them up in the
KDE control center, described in Kapitel 2, Customizing Your Settings (S. 51).

KDE User Guide
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For a description of how to change KDE keyboard shortcuts, refer to
Modifying KDE Keyboard Shortcuts (S. 66).

* Click the Lock Session icon in the panel.

When you lock your screen, the screen saver starts. To unlock the screen, move your
mouse to display the locked screen dialog. Enter your username and password then
press Eingabetaste.

For information about configuring your screen saver, see Configuring the Screen Saver
(S. 56).

1.2 Logging Out

When you are finished using the computer, you can log out and leave the system running
or restart or shut down the computer. If your system provides power management, you
can also suspend the computer, making the next system start much faster than a com-

plete boot.

To log out and leave the system running, do one of the following:
+ From the main menu, select Leave > Logout.

+ Use the keyboard shortcut that is defined in the KDE control center. Usually, to
log out with confirmation, this is Strg + Alt + Entf. In the following dialog you still
have the choice to cancel the logout process. If you want to log out without any
confirmation, press Strg + Alt + Umschalttaste + Entf.

+ Click the Logout icon in the panel.

1.3 Desktop Components

The graphical desktop environment should not pose any problems for former Windows*
or Macintosh* users. The main components of the desktop are the icons on the desktop
and the panel at the bottom of the screen.

Getting Started with the KDE Desktop



Abbildung 1.2 An Example KDE Desktop
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Desktop icons represent files, directories, applications, functions, and removable media,
like CDs or DVDs.

The desktop has the following icons by default:

Trash
Contains files and folders that have been deleted. For information about using the
trash can, see Abschnitt 1.3.4, ,Managing the Trash Bin“ (S. 19).

My Computer
Displays information about hardware, network status, operating system, hard disks,
common folders, and removable devices. For more information, refer to
Abschnitt 1.3.3, ,,Accessing Removable Media“ (S. 17).

Network Browsing
Displays network services you can access. Some of the services might require
authentication. To learn more, refer to Kapitel 8, Accessing Network Resources
(S. 151).

Printer
Opens KJobViewer that displays print jobs you have sent to printers. See
Abschnitt 1.8.1, ,,Starting Print Jobs in KDE* (S. 31) for more information.

KDE User Guide



The panel (in KDE also called ,,Kicker®) is a bar, typically located at the top or the
bottom of the screen. It is designed to provide information about running applications
or the system and easy access to some important functions or applications. If you hold
your pointer over an icon, a short description is displayed.

Abbildung 1.3 KDE Panel (Kicker)
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The panel typically consists of the following areas:

Main Menu Icon
By default, the left end of the panel has an icon that opens the main menu (in KDE
also called K menu), similar to the start button on the MS Windows desktop. The
main menu has a well-ordered structure for accessing the main applications. It also
contains menu items for major functions like logging out or searching for applica-
tions. For more information, see Abschnitt 1.3.1, ,,Accessing the Main Menu*
(S. 10).

Quick Launcher
Next to the main menu icon, find the quick launcher. It holds some icons for the
most important functions or applications to enable you to start them without going
through the main menu.

Desktop Previewer
Next to the quick launcher, find the desktop previewer, which shows your different
desktops. These virtual desktops enable you to organize your work. If you use many
programs simultaneously, you might want to run some programs in one desktop
and other programs in the other desktop. To switch between desktops, click the
desktop symbol in the panel.

Taskbar
The taskbar is located next to the desktop previewer. By default, all started appli-
cations and open windows are displayed in the taskbar, which allows you to access
any application regardless of the currently active desktop. If you click a window
title in the taskbar, the application is moved to the foreground. If it is already in
the foreground, clicking minimizes the application.

Getting Started with the KDE Desktop
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System Tray
The rightmost part of the panel usually holds the system clock, the volume control,
and several other helper applications.

To learn how to configure the appearance and behavior of your desktop, including the
main menu, desktop icons, or the panel, refer to Abschnitt 2.1, ,,The KDE Control
Center” (S. 51).

1.3.1 Accessing the Main Menu

Open the main menu by hovering the mouse pointer over the icon to the far left of the
panel. Alternatively, press Alt + F1.

The main menu consists of the following elements: a search function at the top and
several tabs at the bottom, providing quick access to the key functions of the menu.
Additionally the menu displays your login name and the hostname of your computer
at the very bottom. This information is useful when you are logged in as a different
user or on a remote computer—it always shows you which system you are currently
working on.

Abbildung 1.4 KDE Main Menu
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The following tabs are available:

Favorites
Shows a default selection of key programs for quick access. You can modify the
selection and add or delete programs from the list as described in Changing the
SUSE Menu Style (S. 58).

History
Lists the most recently opened programs and files. To reopen a program or file,
just click the entry. To remove all recently used programs or files from the list,
right-click below the respective heading and select Clear Recently Used Applications
or Clear Recently Used Documents.

Computer
Gives quick access to some places often needed, such as important system folders
(home directory, network folders) and media devices. Also allows you to quickly
access system information and to change your system configuration with YaST, if
necessary.

Applications
Shows all applications installed on your system. The function-oriented menu
structure makes it easy to find the right application for your purpose even if you
do not know the application names yet. To navigate through the structure, click an
entry and use the arrow icons at the right or the left to switch back and forth. To
switch back to the top-level hierarchy from anywhere in the structure, just click
the tab's name or icon.

Leave
Shows several options for leaving the session:

Logout: Ends your current session and leaves your system running. If not confi-
gured otherwise in the KDE control center (see Adjusting the Session Handling
(S. 75), the session manager will restore the currently open windows by default
next time you log in to KDE.

Lock: Locks your screen and starts a screensaver. Access to the session can only
be regained with a password. To unlock, enter your normal login password. If you
leave your computer you can prevent unauthorized access by others by locking
your screen.

Getting Started with the KDE Desktop
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Switch User:  Starts a second session with a graphical user interface on your
machine. Your current session remains active while you are taken to the login
screen where you can log in as a different user. You can access the first session by
pressing Strg + Alt + F7. To access a new session, press F8 instead of F7. Additional
sessions can be accessed by pressing Strg + Alt + F9 to F12.

Shutdown Computer: Logs you out and turns your computer off.

Suspend Computer This menu item is only available if your computer provides
power management functionality. Pauses your computer without logging you out,
thus offering a very fast access to your session when you get back to your computer.

Restart Computer: Initiates the shutdown process and reboots your computer.
Instead of selecting the desired boot option in the boot manager, you can also select
the desired option directly—just click one of the option below Restart Computer.

Prozedur 1.1 Using the Main Menu Search Function

The search function in the main menu is partially based on Kerry/Beagle which is
also available as standalone search module (see Kapitel 10, Searching with Kerry
(S. 179)). You can restrict your search by combining certain search criteria as described
in the Search Quick Tips below the search field.

1 To start a search for any item in the main menu, just type one or several letters
from the search string you want to enter. Each character you enter narrows down
the search. The search results are shown directly below the search field. The
results are sorted by categories for better overview.
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2 Ifa search result suits your wishes, just click the entry to open the file or to start
an action or an application.

3 To extend the search, enter a search term in the search field and click Search
Index. The search is now extended to objects such as documents, e-mails, Web
histories, IM/ITC conversations, source code, images or music files.

For more detailed information about search options with Kerry/Beagle, refer to
Kapitel 10, Searching with Kerry (S. 179).

4 From the main menu, you can also search the Internet for a specific term. To do
so, enter the term in the search field and click Search Internet at the bottom.

1.3.2 Inserting or Connecting Removable
Media

If you insert or connect removable media to your computer (such as CD-ROMs, digital
cameras, or USB sticks), these are usually automatically detected. In KDE, a dialog
appears, showing the medium type detected and offering several options of what to do
with the new medium. The list of options depends on the type of medium inserted.

Getting Started with the KDE Desktop
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Abbildung 1.5 Automatic Detection of a USB Stick in KDE
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To view the data with a file manager, select Open in New Window and click OK. The
Konqueror file manager appears, showing the contents of the removable device.

Abbildung 1.6 Viewing the Contents of a USB Stick
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For the same action to be performed every time you insert a removable medium of that
type, activate Always do this for this type of media in the detection dialog before clicking
OK.

If you insert or connect a removable medium to the system that has been encrypted
with LUKS (Linux Unified Key Setup), KDE recognizes this and prompts for the
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password as shown in Abbildung 1.7, ,,Automatic Detection of an Encrypted USB
Stick™ (S. 15). Enter the password to access the encrypted medium.

Abbildung 1.7 Automatic Detection of an Encrypted USB Stick
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For information about encrypting removable media, refer to Abschnitt ,,Verschliisseln
des Inhalts von Wechselmedien* (Kapitel 40, Verschliisseln von Partitionen und
Dateien, tReferenz).

Prozedur 1.2 Configuring Removable Media Handling

In the autodetection dialog, you can also configure how KDE should handle several
types of removable media. For example, if you know that a certain type of medium
that you use often always contains photos, you can configure it to open an image
viewer application automatically:

1 In the autodetection dialog, click Configure.

2 A configuration dialog appears, showing a list of all available actions.

3 Click the Medium types drop-down list and select the type of medium for which
to configure a certain action. The list of available actions now only shows actions

applicable to the medium type selected.

4 Select the action to apply and click Toggle as Auto Action.

Getting Started with the KDE Desktop
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Abbildung 1.8 KDE Configuration Dialog for Removable Media
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5 Click the Advanced tab and make sure the Enable medium application autostart
after mount check box is selected.

6 Click OK to apply the changes and close the configuration dialog. Now every
time you insert a medium of this type, the configured action is executed automa-
tically and the autodetection dialog does not appear any more.

Prozedur 1.3 Restoring Default Media Handling Options

To reset the action assigned to the type of medium and restore the default options,
proceed as follows:

1 Start the KDE control center from the main menu by selecting Favorites > Con-
figure Desktop (Personal Settings).

2 In the left-hand navigation bar, click Peripherals > Storage Media. The configu-
ration dialog appears on the right.

3 Click Default and Apply. The next time you insert a medium, the autodetection
dialog appears again, leaving you the choice of what to do with the medium.

KDE User Guide



1.3.3 Accessing Removable Media

KDE offers several ways to access removable media at any time. Clicking My Computer
on the desktops opens a view as shown in Abbildung 1.9, ,My Computer® (S. 17).

Abbildung 1.9 My Computer
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If you start Konqueror as a file manager (see Abschnitt 1.4, ,Managing Folders and
Files with Konqueror® (S. 19)) and click Storage Media on the start window or enter
media: / in the location bar, Konqueror displays the storage devices as shown in
Abbildung 1.10, ,,Displaying Media in Konqueror* (S. 18).
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Abbildung 1.10 Displaying Media in Konqueror
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You can also name removable devices, such as USB sticks, with Konqueror. Right-
click the USB stick in Konqueror and select Properties. On the General tab, enter a
name in the input field and click OK. When inserting the stick the next time, Konqueror
displays the name of the stick.

A small green arrow indicates that a medium has been mounted (integrated into your
file system, which is necessary to access the data on the medium). In openSUSE, you
normally do not have to care about mounting removable devices because this is done
automatically by default.

ANMERKUNG: Removing Media Safely

If you want to remove or disconnect a medium from your computer, make
sure that the data on the medium is currently not accessed by any application
or user. Otherwise, you risk a loss of data. To safely remove the medium, pro-
ceed as follows:

1. Open a view that displays all removable media.

2. Right-click the medium to remove and select Safely Remove or Eject.
Safely Remove unmounts the medium after which you can disconnect the
medium from your computer. Eject automatically opens the CD or DVD
drive of your computer.
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1.3.4 Managing the Trash Bin

The trash bin is a directory for files marked for deletion. Drag icons from the file
manager or the desktop to the trash bin icon by keeping the left mouse button pressed.
Then release to drop them there. Alternatively, right-click an icon and select Move to
Trash from the menu. Click the trash bin icon to view its contents. You can retrieve an
item from the trash if desired.

Files removed with Delete are not moved to the trash bin, but deleted completely. To

delete the files in the trash bin completely, right-click the trash bin icon then click Empty
Trash Bin.

1.4 Managing Folders and Files with
Konqueror

Konqueror is a unified Web browser, file manager, document viewer, and image
viewer. The following sections cover using Konqueror for file management. For infor-
mation about Konqueror as a Web browser, see Kapitel 12, Browsing with Konqueror
(S.191).

Start Konqueror as a file manager by clicking the house icon in the panel. Konqueror
displays the contents of your home directory.

Abbildung 1.11 The File Manager Konqueror

Dokument Bearbeiten Ansicht Gehe zu Lesezeichen Extras Einstellungen Fenster Hilfe
QOO0 O sy k]
B Adresse: |3 fhomeftux T ¥, =

@ &y Persdnlicher Ordner| P 3 [ o

A\ } |7 \

4 Desktop
["JDocuments bin Desktop Documents public_html
& public_html

X

= Personlicher Ordrer (&

@ 4 Elemente - Keine Dateien - 4 Ordner

Getting Started with the KDE Desktop

19



20

The Konqueror file manager window consists of the following elements:

Menu Bar
The menu bar holds menu items for actions like copying, moving, or deleting files,
changing views, starting additional tools, defining your settings, and getting help.

Toolbar
The toolbar provides quick access to frequently used functions that can also be
accessed through the menu. If you hover the pointer over an icon, a short descrip-
tion is displayed. To the right, the toolbar features the Konqueror icon, which is
animated while a directory or Web page is loaded.

Location Bar
The location bar shows the path to the directory or file in your file system. You
can enter a path to a directory directly by typing it in or by clicking one of the
directories in the display field. Delete the contents of the line by clicking the black
symbol with a white X located left of the location bar. After typing an address,
press Eingabetaste or click Go to the right of the input line.

Unlike a Windows operating system, Linux does not use drive letters. In Windows,
you would address the floppy drive as 2 : \, Windows system data is under C: \,
and so on. In Linux, all files and directories are located in a tree-like structure. The
topmost directory is referred to as the file system root or just /. All other directories
can be accessed from it. In the following, find a short overview of the most
important directories in a Linux file system:

/home holds the private data of every user who has an account on your system.
The files located here can only be modified by their owner or the system adminis-
trator. Your e-mail directory is located here, for example.

ANMERKUNG: Home Directory in a Network Environment

If you are working in a network environment, your home directory may
not be called /home but can be mapped to any directory in the file system.

/media generally holds any type of drive except the hard drive of your system.
Your USB flash drive appears under /media once you have connected it, as do
your digital camera (if it uses USB) and DVD or CD drive.
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Under /usr/share/doc, find any kind of documentation on your Linux system
and the installed packages. The manual subdirectory holds a digital copy of this
manual as well as the other manuals and the release notes of the installed version
of your Linux system. The packages directory holds the documentation included
in the software packages.

/windows only appears if you have both Windows and Linux installed on your
system. It holds the MS Windows data.

Learn more about the Linux file system concept and find a more comprehensive
list of directories in Abschnitt ,,Das Linux-Dateisystem* (Kapitel 7, Grundlegende
Konzepte, 1 Start).

Navigation Panel
You can hide and show the navigation panel by pressing F9. The navigation panel
displays your information in a tree view. Determine which contents you want to
see by clicking one of the symbols in the tab at the left of the navigation panel. If
you hold your mouse pointer over an icon, a short description is displayed. For
example, you can show the file system as a tree starting at the root folder or at your
home folder.

Display Field
The display field shows the contents of the selected directory or file. In the View
menu, choose between different view modes to display the contents, such as Icon
View, Tree View, or Detailed List View. If you click a file, Konqueror shows a
preview of the contents or loads the file into an application for further processing.
If you hold the mouse pointer over the file, Konqueror shows a tool tip with detailed
information about the file, such as owner, permissions, or last modification date.

By default, Konqueror does not show any hidden files, which are often system files
that you usually do not want to access or see. In Linux, hidden files are indicated
by a dot in front. You can toggle the view to see or hide hidden files by selecting
View > Show Hidden Files.

1.4.1 Copying, Moving, or Deleting Files

For performing actions like copying, moving, or deleting files, you need appropriate
permissions to the folders and files involved in your action. Read more about changing
access permissions in Abschnitt 1.4.3, ,,Changing Access Permissions® (S. 23).
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TIPP: Selecting Objects in Konqueror

Clicking a file or a folder in Konqueror directly starts an action: a preview of
the file is displayed or the folder is opened. To former users of Windows, this
behavior may be rather unusual. If you just want to select one or several files
without any other action, press Strg then click the object. Alternatively, alter
your mouse settings in the KDE control center as described in Adjusting the
Mouse Settings (S. 65).

To copy or move a file or folder, proceed as follows:

1 Right-click the object and select Copy or Cut from the context menu. The object
is kept in the clipboard.

2 Navigate to your destination folder under which you want to insert the object.
Right-click the destination folder and select Paste. The object is copied or moved
there.

The quickest way to perform actions like copying or moving objects in Konqueror is
the drag-and-drop method. For instance, you can easily move objects from one window
to another by simply dragging them. When dropping the objects, you are asked whether
the objects should be moved or copied.

To delete a file or folder, proceed as follows:

+ Select the object and press Entf or right-click the file then select Move to Trash
from the context menu. The object is moved to the trash bin. If necessary, you can
restore the file or folder from there or delete it completely. See also Abschnitt 1.3.4,
»Managing the Trash Bin“ (S. 19).

+ To delete the object irretrievably, click Edit > Delete or press Umschalttaste + Entf.
If you want to add Delete to the context menu, configure this behavior in Konqueror
by clicking Settings > Configure Konqueror > Behavior and activating the respec-
tive check box.

1.4.2 Creating a New Folder

To create a new folder in Konqueror, proceed as follows:
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1 Right-click the folder to which to add a subfolder.
2 Select Create Folder.

3 Inthe New Folder dialog, enter a name for the new folder and click OK.

1.4.3 Changing Access Permissions

Because Linux is a multiuser system, every file in a Linux file system belongs to a user
and a group. All users, including the superuser, have their own home directories where
private data, like documents, bookmarks, or e-mail, are stored. Write access to these
home directories is strictly limited to the owner by default. As an owner of a file or
directory, you can change the access permissions to your files. For example, you can
protect files holding sensitive data against read access by other users and you can aut-
horize other users to write, read, or execute several of your files where appropriate.

Traditionally, three permission sets are defined for each file object on a Linux system.
These sets include the read (r), write (w), and execute (x) permissions for each of three
types of users—the file owner, the group, and other users. For more information about
the user concept of Linux, refer to Abschnitt ,,Dateizugriffsberechtigungen® (Kapitel 7,
Grundlegende Konzepte, 1Start). Instead of using the , traditional“ way to change access
permissions in a shell, you can also use the graphical user interface Konqueror provides.

To set permissions for a file, choose from the following options in Konqueror:

Forbidden
Users can see the filename in the file system but cannot open the file and read it.

Can Read
Users can open and read the file but cannot change it.

Can Read & Write
Users can open, read, and change the file.
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To set permissions for a folder, the following options are available in Konqueror:

Forbidden
Users can see the folder name in the file system but cannot open the folder.

Can View Content
Users can see the folder contents.

Can View & Modify Content
Users can see the folder contents and create new files or subfolders.

To change access permissions:

1 Open Konqueror and select the file or folder for which to change access permis-
sions.

2 Right-click the file and select Properties. A new dialog opens.

3 Click the Permissions tab. It shows the ownership of the file or folder in the
lower part. The upper part shows the current access permissions.

4 From the lists for Owner, Group, and Others, select the permissions to set for
the file or folder.

5 Click OK to apply the changes.

Apart from this traditional permission concept for file system objects, you can also use
access control lists (ACLs) with Konqueror. With ACLs, permissions can be defined
more flexibly than the traditional permission concept allows. They allow assigning
permissions to individual users or groups even if these do not correspond to the original
owner or the owning group. For more in-depth information about ACLs, refer to
Kapitel 17, Zugriffssteuerungslisten unter Linux (1 Referenz).

To grant certain users or groups access permission to a file or folder, proceed as fol-
lows:

1 Open Konqueror and select the file or folder for which to change access permis-
sions.

2 Open the Properties dialog for the file or folder and click the Permissions tab.
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3 Click Advanced Permissions. The following dialog shows the current permissions
for the object.

~Access
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4 Click Add Entry.

5 To grant a certain user access permission to the file or folder, select Named User
and select a user from the list.

To grant a certain group access permission to the file or folder, select Named
Group and select a group from the list.

6 In the Advanced Permissions dialog, the added user or group appears in the list
showing the current permissions. The green check marks in the columns r, w,
and x indicate that the user has read, write, and execute access to the file or folder.
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7 You can modify the access rights for the user by clicking the corresponding check
marks for this user in the column », w, or x.
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8 When all access permissions are set according to your wishes, click OK to close
the dialog.

9 Click OK to apply your changes and to close the Properties dialog.

1.4.4 Saving View Profiles

You can temporarily change the view of certain folders by selecting a different View
Mode in the View menu. To apply these changes to all folders, you can save your options
to a view profile. To do so, change the view according to your wishes and click Settings
> Configure View Profiles. Enter a name for the profile to save and click Save. The
view is changed for all folders and saved in this profile. You can now load this profile
at any time by clicking Settings > Load View Profile. By default, Konqueror contains
several view profiles designed for various tasks. You can also take one of these profiles
as a draft and modify it according to your needs.

1.4.5 Accessing Digital Cameras with
Konqueror

With Konqueror, you can also access your digital camera. Connect your camera to the
USB port. A camera icon should appear on the desktop. Click this icon to open the
camera in Konqueror. The camera can also be accessed by entering the URL camera:
/ in Konqueror. Navigate through the camera's directory structure until the files are
shown. Use the usual Konqueror file management features to copy the files as desired.

1.4.6 Viewing Images with Konqueror

You can also easily use Konqueror as image viewer. For a quick and comfortable
overview of all images in a directory, select the directory and click the /mage View icon
in the toolbar. Konqueror generates thumbnails and shows them on the left-hand side
of the window. Click a thumbnail to see the full-size view of the picture on the right-
hand side of the window. A number of additional icons appears in the toolbar for
navigating back and forth, zooming or rotating the pictures, or creating a slide show.
To toggle to ,,normal” view again, click Icon View or Tree View in the toolbar.
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Apart from this functionality, you can also create image galleries that show your images
in an album-like fashion. Open your image directory in Konqueror and click 7ools >
Create Image Gallery. A dialog opens where you can specify the background and
foreground colors, the page title, the location to save the gallery, and other settings.
Click OK to start the action. By default, a file called index .html is created. If you
click this file in Konqueror, your images are displayed in a miniaturized, organized
view. Click an image to access its full-size view.

Abbildung 1.12 Creating an Image Gallery with Konqueror
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For viewing your images, you can also use Gwenview. To start Gwenview, press Alt
+ F2 and enter gwenview. For further information about Gwenview, see the Gwenview
online help.

For downloading and editing photographs from digital cameras, you can use Digikam
as described in Kapitel 17, Managing Your Digital Image Collection (S. 233).

1.5 Accessing Network Resources

From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
openSUSE offers various different ways of accessing and creating network-shared
resources. Given that the network structure and the configuration of your computer
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allow for it, you can easily browse your network for shared resources and services with
your file manager, Konqueror.

To do so, click the Network Browsing icon on the desktop or start Konqueror and enter
remote: / in the location bar. The window displays the network share types that you
can access. Click a network resource type then click the network share to access. You
might be required to authenticate to the resource by providing a username and password.

Abbildung 1.13 Workgroups on a Windows Network
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1.6 Finding Data on your Computer
or in the File System

KDE provides more than one application for finding data on your computer or in the
file system. With Kerry, you can very easily search your personal information space
(usually your home folder) to find documents, e-mails, Web history, IM/ITC conversa-
tions, source code, images, music files, applications, and much more. For more infor-
mation, refer to Kapitel 10, Searching with Kerry (S. 179).

With KFind, you can locate files on your computer or in the file system using a variety
of search criteria, such as file content, dates, owner, or file size. Start it from the main
menu with Applications > Find Files/Folders. Alternatively, press Alt + F2 and enter
kfind.
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Abbildung 1.14 Finding Files with KFind
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1.6.1 Finding Files

To perform a search for certain filenames, proceed as follows:

1 Start KFind from the main menu or command line.

2 Click the Name/Location tab to perform a basic search.

3 Specify the name of the file to find in Named. You can use the following wild

cards:

Asterisk
The asterisk (*) stands for any number of missing characters (even zero).

For example, searching for marc* can find the files marc, marc.png, and
marc_must_not_read_this.kwd. Searching for mar*.kwd can find market-

place.kwd and marc_must_not_read_this.kwd.

Question Mark
The question mark (?) stands for exactly one character. For example, sear-

ching for mar ? can find marc, but marc? cannot find anything if your files
are named marc and marc.png. You can put as many question marks in the
search term as you want. It finds exactly that number of characters.

You can combine those two wild card symbols in any search term.
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4 Specity the folder to search in Look In or click Browse to find the folder you
want. Select Include Subfolders to also search all subfolders starting from your
specified folder.

5 Press Eingabetaste or click Find.

1.6.2 Performing an Advanced File Search

For a more detailed search, you can also specify further options, such as a text the file
to find must contain:

1 Start KFind from the main menu or the command line.

2 Click the Name/Location tab.

3 Specify the name of the file to find in Named.

4 Specify the folder in which to search in Look In or click Browse to find the folder.
5 Click the Contents tab.

6 In File Type, specify the type of file to find.

7 In Containing Text, enter the word or phrase the file you are searching for must
contain.

8 If you want to specify further options, click the Properties tab and choose the
options you want. If you hold the mouse pointer over the options or fields, a short
description is displayed.

9 Click Find to perform the search.

For detailed information about the search options available, refer to the KFind online
help.

For advanced searches, you may want to use search patterns or regular expressions.
KRegExpEditor offers search options based on regular expressions. You can install
KRegExpEditor with YaST as the package kdeut ils3-extra. For more information

30 KDE User Guide



about search patterns and the use of wild cards or regular expressions, refer to
Abschnitt ,, Verwenden der Bash-Shell“ (Kapitel 19, Arbeiten mit der Shell, 1 Referenz).

1.7 Moving Text between Applications

To copy text to the clipboard and insert it again, former MS Windows users automati-
cally try the keyboard shortcut Strg + C and Strg + V, which often works in Linux as
well. Copying and inserting texts is even easier in Linux: to copy a text to the clipboard,
just select the text with the mouse then move the mouse cursor to the position to which
to insert the text. Click the middle button on the mouse to insert the text (on a two-
button mouse, press both mouse buttons simultaneously).

With some applications, if a text is already selected in the application where you want
to insert the text, this method does not work because the text in the clipboard is over-
written by the other selected text. For such cases, the KDE application Klipper is very
useful. Klipper ,,remembers® the last entries you have moved to the clipboard. By
default, Klipper is started when KDE is loaded and appears as a clipboard icon in the
panel. To view the clipboard contents, click the Klipper icon. The most recent entry is
listed on top and is marked as active with a black check mark. If an extensive text was
copied to Klipper, only the first line of the text is displayed.

To copy an older text fragment from Klipper to an application, select it by clicking it,

move the mouse pointer to the target application, then middle-click. For further infor-
mation about Klipper, see the Klipper online help.

1.8 Printing

After having configured one or more printers with YaST as described in
Abschnitt ,,Einrichten eines Druckers* (Kapitel 2, Einrichten von Hardware-Kompo-
nenten mit YaST, 1Start), you can address them from any application.

1.8.1 Starting Print Jobs in KDE

In KDE, you usually start print jobs with KPrinter. This application is started automati-
cally each time you print from a KDE application. In the KPrinter dialog, choose a
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printer and edit the Properties of your print job, such as page orientation, pages per
sheet, and duplex printing.

TIPP: Sending Files to a Printer without Opening the Application

You can also start KPrinter manually by pressing Alt + F2 and entering
kprinter. This is useful if you want to print one or several files without starting
the application to view or edit the file. The KPrinter dialog then additionally
includes the Files tab, where you can determine the files to print. Either drag
them from the desktop and drop them into the list or use the file dialog to
locate them.

To specify the number of copies and various other options, click Expand at the bottom
left. The window then expands and shows three tabs: Copies, Advanced Options, and
Additional Tags. See Abbildung 1.15, ,,Starting a Print Job with KPrinter* (S. 32).

Abbildung 1.15 Starting a Print Job with KPrinter
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The Copies tab determines the page selection (all pages of the selected document, the
currently selected one, or a range) and the number of copies. You may also choose to
print only the even or only the odd numbered pages of the selected document. Use
Advanced Options to specify any additional information for the print job. Enter any
Billing information if needed or set a custom page label at the top and bottom of the
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page. The Job Priority can also be set here. The last tab, Additional Tags is rarely needed.
Once your print job has been filed, you can watch its progress using KJobViewer.

1.8.2 Monitoring Print Jobs in KDE

Start KJobViewer from the main menu or with k jobviewer from the command line.
A window like that in Abbildung 1.16, ,,Monitoring Print Jobs with KJobViewer®

(S. 33) opens, listing all the print jobs queued on your printer. As long as your print
job is not active, you can edit it. Do this using the entries of the Jobs menu.

Abbildung 1.16 Monitoring Print Jobs with KJobViewer
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If, for example, you want to check if you sent the correct document to the printer, you
can stop the job and resume it if you decide to print it. Remove your own print jobs
from the queue with Remove. To change the printer, select a different printer with Move
to Printer.

With Restart, reprint a document. To do this, select Filter > Toggle Completed Jobs,
select the desired document, and click Jobs > Restart. Clicking Jobs > Job IPP Report
shows the technical details of a job. Use Jobs > Increase Priority and Jobs > Decrease
Priority to set the priority, depending on how quickly you need the document.

Filter enables you to switch between various printers, toggle completed jobs, and limit
the view to your own print jobs by selecting Show Only User Jobs. The current user is
then displayed in the top right field.

Settings > Configure KJobViewer opens a configuration dialog. Here, determine the
maximum number of print jobs to display. Enter a number in the field or use the slider
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to the right to determine a value. Press OK to save the setting or Cancel to exit the
dialog without saving.

The icons in the toolbar correspond to the functions you can access by way of the menu.
Display a help text explaining the function by holding the mouse pointer over one of
the icons.

The job list consists of eight columns. The job ID is automatically assigned by the print
system to identify the various jobs. The next column contains the login of the user who
sent the job followed by the filename of the document. The status column indicates
whether a job is still in the queue, currently being printed, or already completed. Next,
the size of the document is displayed in kilobytes and number of pages. The default
priority of 50 can be increased or reduced if necessary. Billing information can be cost
centers or other company-specific information. If you right-click a job in the list, the
Jobs menu opens under the mouse pointer, allowing you to select an action. Only a few
functions are available for completed jobs. If you activate Keep window permanent,
KJobViewer opens automatically the next time you log in.

1.9 Managing Internet Connections

To surf the Internet or send and receive e-mail messages, you must have configured an
Internet connection with YaST. Depending on your environment, in YaST select whether
to use NetworkManager. In KDE, you can then establish Internet connections with
NetworkManager or Klnternet.

For a list of criteria that help you to decide whether to use NetworkManager refer to
Kapitel 10, Verwalten der Netzwerkverbindungen mit NetworkManager (1 Start) and
Abschnitt ,, Integration in unterschiedlichen Betriebsumgebungen® (Kapitel 9, Mobile
Computernutzung mit Linux, 1Start).

FIXME - check and replace with appropriate file

1.9.1 Kinternet

If you do not use NetworkManager and do use KDE, manage your Internet connections
with Klnternet. If KInternet is not installed by default, install the package kinternet
with YaST. The program checks whether an Internet connection can be established. If
this is possible, the KInternet icon, a plug, automatically appears in the right section of
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the KDE panel. Depending on the state of the network connection, the panel icon
changes appearance:

&=

Currently there is no connection to the Internet.

The connection is being established or terminated.

s

The connection has been established.

ﬁﬁiﬂ

Data is being transmitted to or from the Internet.

So

An error has occurred. If a connection has already been configured with YaST, use
View Log to identify the reason for the error. Access the menu by right-clicking
the KlInternet icon.

g

The connection is not yet active, but will be established as soon as a request is
made.

Right-click the KInternet panel icon to access its configuration menu. Start the YaST
configuration dialog with Settings > Configure with YaST. After entering the root
password, YaST starts. Depending on the access type, start the modem, ISDN, network,
or DSL configuration of YaST.

If you are using an ISDN connection and selected Channel Bundling in YaST, add a
second ISDN channel to an existing connection with Add link. This doubles the transfer
rate (although at a higher price). Activate channel bundling if you need to download
large files. The activated channel bundling is evident from the red plus symbol at the
top left corner of the Klnternet icon.

If your computer has more than one network device and you have configured all of
them with YaST, you can use the Klnternet option Interface to switch between these
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interfaces. You must have selected User Controlled device activation in the appropriate
YaST network dialog to do this. If you have multiple providers as well, choose them
using Provider in Kinternet. Providers are also set in YaST.

To establish Internet connections automatically, use dial on demand (DoD). If this
mode is selected, KInternet automatically connects to your Internet service provider
(ISP) as soon as a request is submitted. After a certain time-out, the connection is ter-
minated. A DoD connection is evident from the blue D at the bottom right corner of
the Klnternet icon.

WARNUNG: Cost Control

Note that DoD only makes sense if you have a flat rate Internet account. If that
is not the case, connecting and disconnecting all the time can become very
costly.

To use a wireless network card as your connection to the Internet, configure it using
YaST as described in Referenz and make sure that the device activation in YaST is set
to User Controlled. As soon as the interface is configured, you can use Klnternet to
control your wireless network connection, just as you would for normal network inter-
faces.

To access the WLAN functionality of Klnternet, right-click the icon to open the menu.
Select Wireless Connection and a window showing two tabs opens. First, scan for sui-
table wireless networks to which to connect. Select the tab Scan for Wireless Networks
and start the scan with Start Scan. For Klnternet to continuously scan the network
environment, also select Auto Refresh. Activate acoustic feedback for each connection
found with Acoustic Scan. Any connection found is displayed in the list window. Select
one and click Connect to connect to the selected network. If additional configuration
efforts are needed to connect to the selected network, click Start YaST to launch the
YaST network module for wireless network devices.

The Current Connection tab allows you to monitor the state of your current wireless
connection. The left-hand view of this tab offers a summary of all connection parameters
for network address and ESSID, signal quality, signal and noise level, channel frequency
and speed, and encryption parameters, such as type of encryption and key length. Select
any of these parameters in the tree structure and see the details displayed in the right
part of the window.
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1.10 Exploring the Internet

In KDE, the default Web browser is Konqueror. To start Konqueror, click the Konqueror
icon on the panel or press Alt + F2 and enter konqueror. Learn more about Konqueror
as a Web browser in Kapitel 12, Browsing with Konqueror (S. 191).

In addition to Konqueror, you can use a Mozilla-based browser, Firefox. Start Firefox
from the main menu or by pressing Alt + F2 and entering £ irefox. You can type an
address into the location bar at the top or click links in a page to move to different pages,
just like in any other Web browser. For more information about Firefox, see Kapitel 13,
Browsing with Firefox (S. 199) .

1.11 E-Mail and Scheduling

KMail is an e-mail client that supports e-mail protocols like POP3 and IMAP. It also
has multiple e-mail account support, powerful filters, PGP/GnuPG privacy, and online
attachments. Start KMail from the main menu or press Alt + F2 and enter kmail.

Kontact is a personal information management (PIM) tool that combines well-known
applications like KMail, KOrganizer, and KAddressBook into a single interface. This
lets you have easy access to your e-mail, calendar, address book, and other PIM func-
tionality. To start Kontact, press Alt + F2 and enter kont act. For detailed information
about using Kontact, see Kapitel 4, Kontact: E-Mailing and Calendaring (S. 115).

1.12 Opening or Creating Documents
with OpenOffice.org

The office suite OpenOffice.org offers a complete set of office tools including a word
processor, spreadsheet, presentation, vector drawing, and database components.
Because OpenOffice.org is available for a number of operating systems, you can use
the same data across different computing platforms. You can also open and edit files
in Microsoft Office formats then save them back to this format, if needed.

To start OpenOffice.org, press Alt + F2 and enter OOo or click the Office icon on the
desktop.
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For an introduction to OpenOffice.org, see Chapter 3, The OpenOlffice.org Olfice Suite
(page 81) or view the help in an OpenOffice.org program.

1.13 Managing Passwords with
KWallet Manager

Remembering all the passwords for protected resources to which you need to log in
can be problematic. KWallet remembers them for you. It collects all passwords and
stores them in an encrypted file. With a single master password, open your wallet to
view, search, delete, or create entries. Normally you do not need to insert an entry
manually. KDE recognizes if a resource requires authentication and KWallet starts
automatically.

WICHTIG: Protect Your KWallet Password

If you forget your KWallet password, it cannot be recovered. Furthermore,
anyone who knows your password can obtain all information contained in the
wallet.

1.13.1 Starting KWallet

When KWallet starts for the first time (for example, when you access a Web site where
you must enter a password to log in), a dialog appears with the welcome screen.
Choose between Basic setup (recommended) and Advanced setup. If you choose Basic
setup, in the next screen you can choose whether to store personal information. Some
KDE applications, such as Konqueror or KMail, can use the wallet system to store Web
form data and cookies. Select Yes, I wish to use the KDE wallet to store my personal
information to activate KWallet and leave with Finish.

If you choose Advanced setup, you have an additional security level screen. The default
settings are generally acceptable for most users, but others may wish to change them.
Automatically close idle wallets closes wallets after a period of inactivity. To separate
network passwords and local passwords, activate Store network passwords and local
passwords in separate wallet files. Close with Finish.
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You can alter the settings at any time by right-clicking the KWallet icon in the panel
and selecting Configure Wallet. A dialog box opens where you can select several options.
By default, all passwords are stored in one wallet, kdewallet, but you can also add new
wallets. Once configured, KWallet appears in the panel.

1.13.2 The KWallet Manager

To store data in your wallet or view its contents, click the KWallet icon in the panel.
A dialog box opens, showing the wallets that are accessible on your system. Click the
wallet to open. A window prompts for your password.

After a successful login, the KWallet Manager window opens. It is divided into four
different parts: the top left part displays a summary, the top right part displays subfolders,
the lower left part shows a list with folder entries, and the lower right part shows the
contents of a selected entry.

In the KWallet Manager, you can change your master password for KWallet at any
time with File > Change Password.

Abbildung 1.17 The KWallet Manager Window
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You can add or delete folders. Selecting a folder updates the folder entry list and the
summary display. Selecting a folder entry updates the entry contents pane and allows
you to edit that entry. Entries can also be created or deleted using the context menu for
the folder contents.
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1.13.3 Copying Your Wallet to Another
Computer

For the most part, KWallet resides silently in the panel and is automatically activated

if needed. However, you can copy your wallet files to another computer (for example,
your laptop). To simplify this task, wallets can be dragged from the manager window

to a file browser window. This let you easily package a new wallet for transfer to another
environment. For example, a new wallet could be created and copied onto a removable
flash memory device. Important passwords could be transferred there, so you have them
available in other locations.

1.14 Controlling Your Desktop's
Power Management with
KPowersave

KPowersave is a small panel applet which allows you to control all power management
functions supported by your system with just a few clicks on the desktop. You can track
power consumption and CPU frequency, choose another power management scheme
to match the tasks your system is facing, and send your system into suspend or standby
state by just clicking the applet.

1.14.1 Tracking the Current State

For a quick check of how your system is doing and which power management measures
have been taken, left-click the KPowersave panel icon.
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Abbildung 1.18 Tracking the Current Power Management State
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Apart from telling you at which speed your CPU or CPUs are running, KPowersave
provides detailed information on the power saving mode your system is in:

Current Scheme
Power management settings can be tied in to certain requirements your system
needs to meet. This is done by assigning schemes.

Set brightness supported
Some hardware supports the dimming of your monitor's brightness as a means to
save power.

1.14.2 Suspending Your Computer

Whenever you need to cut down power consumption and you do not need to run your
system continuously, consider using one of the three suspend modes supported by
openSUSE:

Suspend to Disk
All your data and the session data is saved to disk before the system is laid to rest.
It is thus protected against data loss should you loose power in the meantime.
Waking the system up again is much faster than booting it from scratch.
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Suspend to RAM
All your data and the session data is saved to RAM. Bringing the system up again
is faster than restoring a session from disk.

Standby
Your data is written to RAM, the display is shut down, but the system keeps running.

Whether all of these are available or just one or two depends on the capabilities of your
hardware. To trigger your system to enter one of these modes, right-click the panel icon
and select the respective option.

1.14.3 Saving Power by Using Schemes

Power management schemes let you adjust various power management parameters to
the requirements of certain typical situations you are facing when using your machine.
KPowersave ships with a set of four preconfigured schemes which you can adjust to
your needs. To switch schemes with KPowersave just right-click the panel icon and
select Set Active Scheme. The following schemes are available:

Performance
Keep your machine running with full power and full speed to achieve maximum
performance.

Acoustic
Apply any measure that makes sure your machine runs as quietly as possible.

Presentation
Disable any display power management and screen savers to make sure that your
presentation is not interrupted by a blanked display or such like.

Powersave

Apply aggressive power management methods to make sure that your machine
runs as long as possible when put on battery power instead of AC power.

1.14.4 Configuring Notifications

KPowersave provides various types of feedback upon certain events. To open the
notification configuration dialog, either right-click the panel icon and select Configure
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Notifications or select Configure KPowersave > General Settings > Configure Notifica-
tions.

Abbildung 1.19 Configuring KPowersave Notifications
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KPowersave supports several different types of notifications that can be associated with
different events. The most prominent of them are:

Sounds
Select one of the KDE system sounds to be played.

Logging
Specify the full path to a file where KPowersave should log to.

Program Execution
Specify the full command for a program that should be executed.
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Message Windows
Have KPowersave throw a pop-up window.

Passive Windows
Have KPowersave throw a passive window that does not pull focus.

Basically, there are two different ways to configure KPowersave notifications. Either
use the Quick Controls to toggle the notification status of multiple events at once or
use the Actions settings to configure them one by one.

1.14.5 Configuring KPowersave

The KPowersave settings dialog comprises two different groups of settings:

Scheme Settings
Detailed configuration for all power management schemes supported by KPower-
save.

General Settings
Miscellaneous options related to KPowersave's behavior, such as screen locking,
auto-suspend, notification and autostart behavior.

Configuring Schemes

Power saving schemes in KPowersave offer controls to:
+ Enable or disable a screen saver
+ Enable or disable display power management
+ Change the brightness of your display to reduce power consumption
+ Enable or disable auto-suspend of your machine
+ Enable or disable notifications KPowersave events

You can modify any of the preconfigured schemes, but you cannot delete them or add
new ones.

To configure a KPowersave scheme, proceed as follows:
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1 Right-click the panel icon and select Configure KPowersave > Scheme Settings.
2 Select the scheme you want to modify.

3 Open the Screen Saver and DPMS tab and determine whether your scheme
requires specific tuning of the screen saver settings. If using your machine in
presentation mode, you should consider disabling the screen saver altogether. If
you want your display to automatically enter powersaving modes after a certain
period of time, activate Enable specific display power management and enter the
number of minutes after which the display should use power management.

4 If your display hardware supports reducing the brightness for power saving rea-
sons, open the Brightness tab, select Enable scheme specific Brightness settings
and set the brightness value.

5 Ifyou want your machine to automatically suspend (to disk) after a certain period
of time, open the Autosuspend tab, select Enable autosuspend and determine
when the machine should automatically enter suspend. To avoid problems with
applications whose state cannot be properly restored when your session is resu-
med, maintain a blacklist of these applications via Edit Blacklist. If any of these
applications is running, KPowersave does not automatically suspend your desktop.

6 If you want KPowersave to work quietly, turn of notifications for powersave
events by entering the Miscellaneous tab and selecting Disable Notifications.

7 Click OK to apply your settings and leave the configuration dialog.

Configuring General Settings

If you want the screen to be locked before the system enters suspend or standby, activate
the Lock Screen control and choose a screen saver. A locked screen might keep unaut-
horized users off this machine.

If you want your machine to enter suspend after a certain period of idleness, be aware
that several applications can cause problems with auto-suspend. Use a black list to keep
KPowersave from triggering a suspend action when one or more of the listed applications
are running.

Getting Started with the KDE Desktop

45



To configure notifications, select Configure Notifications and proceed as described
above. The dialog described here is exactly the same as if you had right-clicked the
panel icon and selected Configure Notifications.

To configure KPowersave to be automatically started on login, select KPowersave
starts automatically on login. If you select Never ask me again on exit, you will not be
asked whether KPowersave should be automatically started when you exit a session
that had not previously included KPowersave in the list of tasks to be started automati-
cally.

1.15 Displaying, Decompressing, and
Creating Archives

To save space on the hard disk, use a packer that compresses files and directories to a
fraction of their original size. The application Ark can be used to manage such archives.
It supports common formats, such as zip, tar.gz, tar.bz2, 1ha,and rar.

Start Ark from the main menu or from the command line with ark. If you already have
some compressed files, move these from an open Konqueror window to the Ark window
to view the contents of the archive. To view an integrated preview of the archive in
Konqueror, right-click the archive in Konqueror and select Preview in Archiver.
Alternatively, select File > Open in Ark to open the file directly.

Abbildung 1.20 Ark: File Archive Preview
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Once you have opened an archive, perform various actions. Action offers options such
as Add File, Add Folder, Delete, Extract, View, Edit With, and Open With.

To create a new archive, select File > New. Enter the name of the new archive in the
dialog that opens and specify the format using Filfer. After confirming with Save or by
pressing Enter, Ark opens an empty window. You can drag and drop files and directories
from the file manager into this window. As the final step, Ark compresses everything
into the previously selected archive format. For more information about Ark, select
Help > Ark Handbook.

1.16 Taking Screen Shots

With KSnapshot, you can create snapshots of your screen or individual application
windows. Start the program from the main menu or by pressing Alt + F2 and entering
ksnapshot. The KSnapshot dialog consists of two parts. The upper area (Current
Snapshot) contains a preview of the current screen and three buttons for creating and
saving the screen shots. The lower area contains further options for the actual creation
of the screen shot.

Abbildung 1.21 KSnapshot
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To take a screen shot, use Snapshot Delay to determine the time (in seconds) to wait
between clicking New Snapshot and the actual creation of the screen shot. If Only Grab
the Window Containing the Pointer is selected, only the window containing the pointer
is saved. To save the screen shot, click Save Snapshot and designate the directory and
filename for the image in the subsequent dialog. Click Print Snapshot to print the screen
shot.

You can also use The GIMP to take screen shots. To open The GIMP, press Alt + F2
and enter gimp. When you run GIMP for the first time, it installs some files in your
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home directory and displays dialogs that give you the opportunity to adapt it to your
environment. For information about using The GIMP, refer to Kapitel 16, Manipulating
Graphics with The GIMP (S. 217) or see its help. You may need to install the help with
YaST (kdeutils3—-extra).

1.17 Viewing PDF Files with KPDF

PDF is probably one of more important document formats. KPDF is a KDE program
that can view and print them.

Start KPDF by pressing Alt + F2 and entering kpd £. Load a PDF file with File > Open.
KPDF displays it in its main window. On the left side, there is a sidebar with thumbnails
and a contents view. Thumbnails give an overview of the page. The contents view
contains bookmarks to navigate in your document. Sometimes it is empty, meaning
bookmarks are not supported by this PDF.

To view two pages in the main window, select View > Two Pages. The view depends
on what last two options you activate in the View menu.

Another nice option is to select the area in which you are interested with the select tool
from the toolbar. Draw a rectangle and choose from the pop-up menu whether you need
the selected area as text or as a graphic. It is copied to the clipboard. You can even save
the area to a file.

1.18 Controlling Sound with KMix

YaST identifies and configures the sound cards of your computer automatically.
Otherwise, start the YaST Hardware module and configure the sound card manually.
When your sound card has been configured, you can control the volume and balance
of the sound with a mixer.

TIPP: Starting the Mixer

If the mixer icon (a loudspeaker symbol) is not visible in the panel of your
desktop, press Alt + F2 and enter kmix or start the mixer from the main menu.
You usually find it under Volume Control.
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By default, clicking the KMix icon in the system tray shows the master controller with
which to increase or decrease the overall volume. To switch off the sound, click the
green LED, which darkens when it is muted. Toggle this option by clicking the LED
again. To fine-tune your sound settings for several channels, right-click the KMix icon
and select Show Mixer Window. In the main window, you can configure Qutput, Input,
and Switches. Each of the devices featured there has its own context menu that is opened
by right-clicking the device icon. You can mute or hide each one of them separately.
For further information about KMix, refer to the online help.

Abbildung 1.22 The KMix Mixer
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1.19 Obtaining Software Updates

When you connect to the Internet, the openSUSE Updater automatically checks whether
software updates for your system are available. An openSUSE Updater applet in the
system tray of your panel informs you about the availability of updates and lets you
easily install them with just a few clicks. The applet icon changes color and appearance
depending on the availability of updates for your system. For detailed information about
how to install software updates with openSUSE Updater and how to configure openSUSE
Updater, refer to Abschnitt ,,Halten Sie Thr System auf dem neuesten Stand* (Kapitel 3,
Installieren bzw. Entfernen von Software, 1Start).
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1.20 For More Information

As well as the applications described here for getting started, KDE can run a lot of other
applications. Find detailed information about many important applications in the other

parts of this manual.

+ To learn more about KDE and KDE applications, also refertohttp: //www . kde
.org/ and http://www.kde—-apps.org/.

+ To report bugs or add feature requests, go to http://bugs.kde.org/.
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Customizing Your Settings

You can change the way your KDE desktop looks and behaves to suit your own personal
tastes and needs. There are several ways to influence the look and feel of the KDE
desktop depending on the scope of changes to make. For users, the following options
are available:

+ To change the appearance or behavior of individual desktop objects only, you can
usually access a configuration dialog by right-clicking the object.

+ To change the overall appearance and behavior of your KDE desktop, use the
KDE control center. It offers access to numerous configuration modules and dialogs,
some of which can also be accessed via the context menu of individual desktop
objects.

2.1 The KDE Control Center

The KDE control center is the central place for users to change the overall appearance
and behavior of nearly any component of the KDE desktop. Start the control center
from the main menu by selecting Favorites > Personal Settings or press Alt + F2 and
enter kcontrol.

Customizing Your Settings
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TIPP: Starting Individual Modules

You can also start individual modules of the KDE control center from the shell

or by adding a special applet to your panel.

To start modules from a shell, enter kcmshell —-1ist to get a list of all
modules available. Then enter kcmshell module name to startthe desired

module.

Alternatively, add the Settings applet to your panel according to the description

in Abschnitt 2.4, ,Configuring the Panel” (S. 60).

The sidebar provides different categories with a subset of settings each. Click a category
icon to explore the possibilities provided there. You can always return to the higher-
level category by clicking Back. For an overview of all categories, switch to a tree view.

Change the view by selecting View > Mode > Tree View.

Clicking an item displays the corresponding settings on the right. Change the settings
as desired. No changes take effect until you click Apply. If you have changed an option
then decide that you want to leave the settings as they were, click Reset to discard the
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changes. Reset all items on the page to the default values by clicking Default. Changing
some settings may require root permissions. Log in as root if prompted to do so.

The following list introduces the major categories and highlights the most important
settings you can change there. Detailed information about the settings of each category
is provided by the Help button on each page of settings or in the help center.

Appearance & Themes
Holds settings for the desktop background, the screen saver, and the fonts appearing
on the desktop. You can modify themes, window decorations, and styles of desktop
elements, such as buttons, menus, and scroll bars. Cursor behavior and the splash
screen that appears on KDE start-up can also be influenced here.

Desktop
Holds settings that allow you to increase or decrease the number of virtual desktops
and to control panel options such as size, position, length, and appearance of the
panel. You can also change the main menu here. In the taskbar section, configure
taskbar options such as whether to show windows from all desktops on the taskbar.
Two further sections allow you to control the behavior of windows.

Internet & Network
Lets you define Bluetooth options and preferences such as time-out values for
certain connections. You can also share your desktop, enable or disable file sharing,
and set options for local network browsing and proxy servers. The behavior of
Konqueror as a Web browser can be modified here.

KDE Components
With the Component Chooser, change the default e-mail client, text editor, messen-
ger, terminal, and Web browser. Whenever a KDE application needs to start an
application of these types, it always calls the default component set here. Configure
options for your desktop search with Kerry Beagle® here, for example, which
directories to index. If needed, change the default file associations to identify a file
type and start an appropriate application. Set options for Konqueror as a file
manager. Define how KDE handles sessions on login or shutdown and modify your
spell checking options here.

Peripherals
Holds options for devices such as digital cameras, displays, joysticks, keyboards,
mouses, OBEX devices, printers, remote controls, and removable media like CD-
ROMs or USB sticks. For example, you can add your camera model and define

Customizing Your Settings

53



54

the type of port by which it is connected to your computer or modify keyboard and
mouse settings, such as repeat delay, single or double clicking options, and double-
click intervals. You can assign default actions to certain types of removable media
(for example, always start KsCD when detecting an audio CD) and configure
printers.

Regional & Accessibility
Define country and language-specific options here, such as currency, number and
date format, and keyboard layouts for different languages between which you can
switch. You can also view and modify the predefined KDE shortcuts (for example,
Alt + Strg + L to lock the screen). This category also offers accessibility options
for handicapped users, such as sound and keyboard options and mouse gestures.

Security & Privacy
Go here to change your password, set options for KWallet (the KDE password
management tool), configure encryption for KDE, or manage private data such as
recently opened documents, recently visited Web sites, cookies, and the contents
of the clipboard.

Sound & Multimedia
Holds options for configuring the system bell and system notifications and the
encoding and device settings for audio CDs.

System Administration
Use this category to configure the appearance and behavior of the KDE login
manager (KDM) or to change the default paths to some important directories for
your data: Desktop, Autostart, and Documents. You can also install personal
or systemwide fonts here.

In the following sections, find examples of how to configure some aspects of your KDE
desktop that you might want to customize.

2.2 Configuring Desktop Objects

Your KDE desktop comes with a predefined set of desktop icons. By adding various
objects such as folders, files, or links, you can create additional icons on your desktop
and arrange them as you like.
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Prozedur 2.1 Creating and Arranging Desktop Icons

1 To add a new desktop object, for example, from the main menu or the Konqueror
file manager, select an entry and drag it onto the desktop. A context menu appears
from which to choose whether to copy, move, or create a link to the object.

Suchen: ||

4 Andiese Stelle verschieben Umschalt

") An diese Stelle kopieren strg
3 Hiermitverknitpfen Strg+Umschalt
3 Abbrechen Esc

Eavortan Anwendungen Computer | Veilaut | Verlassen

Benutzertest an aol0009-xp-fr1 openSUSE’

2 To add a new desktop object, you can also right-click an empty space on the
desktop and select Create New. From the submenu, choose the type of object to
create on the desktop: a folder, one of several types of files, or a link to an appli-
cation, a file, a Web site, or a device like your CD-ROM drive.

3 To arrange the icons on your desktop, right-click an empty space on the desktop
and select one of the options under Icons.

You can change the background colors of your desktop or select a picture to use as the
background. Because KDE offers virtual desktops, you can apply these changes to one
or all of your virtual desktops.

Prozedur 2.2 Changing the Desktop Background

1 Right-click an empty patch of the desktop and select Configure Desktop. A con-
figuration dialog appears.
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2 In Settings for Desktop select the virtual desktops to which the changes should
apply.

3 To change the picture on the background, click Picture and select one of the
pictures in the list. To use a custom picture, click the folder button beneath the
list and select an image file from the file system.

4 Click Slide Show to have multiple images appear in a slide show mode.

5 If you do not want a picture on the background, click No picture.

6 From the Options group, click the left button below Colors to select the color
for your background. For a multicolor background, set Colors to an option other
than Single Color and click the right button below to select a second color.

7 Click Apply then OK to close the configuration dialog.

openSUSE® comes with predefined screen saver settings that you can adjust.
Prozedur 2.3 Configuring the Screen Saver
1 Right-click an empty space on the desktop and select Configure Desktop.

2 In the dialog that opens, click Screen Saver.

3 In the list of screen savers, click a screen saver to see a preview in the right side
of the dialog.
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Screen Saver Settings
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Click Setup to adjust options like speed or shapes.

You can also choose to view a blank screen instead or to let KDE start a random
screen saver. Find these options at the end of the screen saver list.

Under Settings, determine after how long a time of inactivity the screen saver
should start and whether a password is required to unlock the screen after the
screen saver has started.

Click OK to apply the changes and close the configuration dialog.
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Some users might need more desktops than provided by default.
Prozedur 2.4 Adding Additional Virtual Desktops

1 Right-click the desktop previewer in the panel and select Configure Desktops.
A configuration dialog appears where you can increase or reduce the number of
virtual desktops. You can also change the default names of the desktop.
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2 Click OK to apply the changes and close the configuration dialog.

3 For the names of the desktops to appear in the desktop previewer rather than the
number, right-click the desktop previewer and select Pager Options > Desktop
Name.

2.3 Configuring the Main Menu

There are several options how to customize your main menu. To change the overall
appearance of the menu, right-click the main menu button in the panel and select either
the new SUSE Menu Style or the traditional KDE Menu Style.

Prozedur 2.5 Changing the SUSE Menu Style

1 When the menu appears in SUSE style, it usually opens when you hover the
mouse over the main menu button.
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1a To change this default behavior, start the KDE control center from the main
menu or press Alt + F2 and enter kcontrol.

1b Click Desktop > Panels.

1c Click the Menus tab.
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1d Deactivate Open menu on mouse hover if you want the menu to open on
mouse click instead.

2 To add applications or files and folders to your menu favorites:

2a Select an application or file/folder from one of the other tabs in the main

menu.

2b From the context menu choose Add fo Favorites. The object appears in

Favorites and can be accessed from there.

2c Resort entries in Favorites per drag and drop.

2d To delete objects shown in Favorites, right-click the object and select
Remove From Favorites.

When the main menu appears in KDE style, you can configure further details, for
example, you can add, rename or remove menu items from the menu:
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Prozedur 2.6 Changing the KDE Menu Style

1 Start the KDE control center from the main menu or press Alt + F2 and enter
kcontrol.

2 Click Desktop > Panels.
3 Click the Menus tab.

4 When the Start menu style is set to KDE, you can define whether you want to
see the applications names or the descriptive text (or both) in the main menu.
Select from Name only, Name (Description), Description only, and Description
(name).

5 Ifyouwant to change a menu item, click Edit K Menu. The K Menu Editor shows
a list of menu items on the left.

5a Click the item in the list and change its options on the right.

5b You can add new menu items, submenus, or separators with the File menu
or the toolbar.

5¢ To cut, copy, paste, or delete objects in the main menu, use the Edit menu
or the icons in the toolbar.

5d To save your changes in the K Menu Editor, click File > Save.

5e Quit K Menu Editor with File > Quit.

6 To apply all of your changes in the Menus tab and close the KDE control center,
click Apply .

2.4 Configuring the Panel

You can add the following objects to your panel: applications, applets (mini-programs)
and further panels. Applications and applets can either be added to the quick launch
area or the system tray in the main panel or in additional panels. Panel elements and

KDE User Guide



additional panels can be moved to different places or be completely removed at any
time.

Prozedur 2.7 Adding and Removing Panel Elements

1 Right-click an empty patch of the panel.

2 To add a new application to the panel:

2a From the context menu, select Add Application to Panel.

2b Select the application to add from one of the categories of the submenu. The
application icon is inserted into the panel.

2c¢ To change the icon for the application, right-click the button and select
Configure Application Button. By clicking the application icon in the dialog
box that appears, open a new window in which to select a different icon.

2d To remove the icon from the panel, right-click the icon and select Remove
Button.
3 To add a new applet to the panel:

3a From the context menu, select Add Applet to Panel.

3b In the dialog box that appears, select the applet to add and click Add to Panel.
The applet is inserted into the panel.
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3c To remove the applet from the panel, right-click the icon and select Quit. If
the context menu of the applet does not provide a Quit menu item, hold the
mouse pointer over the left-side boundary of the area and right-click the
small black arrow displayed there. Select Remove.

4 You can also add additional panels of different types. To do so, right-click an
empty patch of the panel and select Add Panel. Choose the type of panel to add
from the submenu.

5 To remove the additional panel, right-click an empty patch of a panel, select
Remove Panel and choose the panel to remove from the desktop.

Prozedur 2.8 Moving Elements within Panels

1 To move an application icon to a different position in the panel, right-click the
icon and select Move. The mouse pointer changes into a cross-hair. Drag the
pointer to the place in the panel where you want to insert the icon then press the
left mouse button. The icon is inserted at the new position.

2 In the same way, you can also move areas of the panel, such as the desktop pre-
viewer, the taskbar, and the system tray: Hold the mouse pointer over the boun-
dary of the area and click the small black arrow displayed there. From the context
menu, select Move. Click again to insert the area at the new position.

You can configure many aspects of the main panel and of additional panels. For
example, you can change size, length, and position of a panel or activate transparency
effects. You can also influence the taskbar behavior.

Prozedur 2.9 Changing Panel Appearance and Behavior

1 Right-click an empty patch of the panel and select Configure Panel. A dialog
opens in which you can configure several aspects of the panel. To access the
different categories, click one of the icons at the left window pane. By default,
the dialog shows the options of the Arrangement category.
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If you added additional panels, a list appears at the top of the window, showing
the available panels. Select the panel to configure.

If desired, choose a different position on the desktop, adjust the panel length,
or increase or decrease the panel size and Apply your settings.

To activate or deactivate automatic hiding of the panel or change the default
hiding options, click Hiding on the left window pane. Set the options according
to your wishes and click Apply.

To change the color of the panel or to enable transparency or background
images for the panel, click Appearance.

Below Button Backgrounds, you can choose a background for different parts
of the panel. To color a part of the panel, choose Custom Color from the list
for the respective button and click the button on the right to choose a color.
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7 To make the panel appear transparent, activate Enable transparency. To
increase visibility of the transparent panel also for very dark or very light
backgrounds, click Advanced Options and set a color and the amount of tinting
for the panel. Apply your changes.

8 To change the default behavior of the taskbar, click Taskbar on the left window
pane.

9 To make the taskbar show only the applications from the currently active
desktop instead of all applications, deactivate Show windows from all desktops.

10 Change the other taskbar options, if desired, and click Apply.

11 When all panel options are set according to your preferences, leave the confi-
guration dialog with OK.

2.5 Configuring KDE Behavior

With the KDE control center you can not only modify the appearance of objects, but
also change the behavior of some components. In the following, find some examples.

Prozedur 2.10 Changing the Cursor Behavior

If you want to deactivate the bouncing cursor that shows when starting an application
from the graphical user interface, proceed as follows:

1 Open the KDE control center and select Appearance & Themes > Launch Feed-
back.

2 From the drop-down list, select another option for Busy Cursor.
3 Click OK to apply the changes and close the configuration dialog.

You can set a number of mouse options in the KDE control center, from cursor themes
to acceleration and double-click intervals. You can also change the default Linux
behavior (use single mouse-click to open files or folders) to a double-click option (like
in Microsoft Windows).
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Prozedur 2.11 Adjusting the Mouse Settings
1 Open the KDE control center and click Peripherals > Mouse.
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2 To switch to double-clicks to open files and folders, select the corresponding
option on the General tab.

3 To change the mouse pointer appearance, switch to the Cursor Theme tab and
select a different cursor theme.

4 To change the default values of double-click intervals or the distance that the
pointer moves over the screen on movement of the mouse, adjust the settings on
the Advanced tab.

5 Click OK to apply the changes and close the configuration dialog.
KDE comes with a set of predefined keyboard shortcuts. You can easily create more
keyboard shortcuts or change existing shortcuts, especially if they should conflict with

other application-specific shortcuts. KDE also allows you to store more than one scheme
of shortcuts.
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Prozedur 2.12 Modifying KDE Keyboard Shortcuts

1 Open the KDE control center and click Regional & Accessibility > Keyboard

Shortcuts.
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2 To switch from the default scheme to a Windows or Mac based scheme, for
example, click Current Scheme and select a different scheme.

Browse through the list of non-application-specific KDE shortcuts on the Global
Shortcuts tab. To filter for certain keywords, enter a search string in the search
field above.

For shortcuts for switching between different desktops or windows see the
Shortcut Sequences tab.

To view or change application-specific shorts, select the Application Shortcuts
tab.

To change or add a shortcut, select an action in the list and click Custom. A new
dialog opens.

To enter a shortcut, just press the desired key or key combination. If this shortcut
cannot be accepted or in case of conflict with another existing shortcut, a notifi-
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cation shows. If your input was successful, the new or modified shortcut appears
in the list.

8 To save the altered settings, click Apply. To reset all shortcuts to the default
values, click Defaults then Apply.

When you click a link to a Web page, KDE opens the Konqueror Web browser by
default, when you click an e-mail address, KMail starts.

Prozedur 2.13 Changing the Default Web or E-Mail Application
1 To change this behavior and set your preferred Web browser or e-mail client as
default, open the KDE control center and click KDE Components > Component
Chooser.

2 To change the Web browser:

2a In the list of components, select Web browser.

2b Select Open http and https URLSs in the following browser and click the
browse button beneath.

2c¢ A dialog opens, showing the main menu structure. Select the Web browser
to set as default and click OK. The component chooser now shows the
selected application in the display field.
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3 To change the e-mail client:
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3a In the list of components, select Email Client.
3b Select Use a different email client and click the browse button.

3c A dialog showing the main menu structure opens. Select the e-mail client to
set as default and click OK. The component chooser now shows the selected
application in the display field.

4 If desired, change other default applications for KDE, like the application for the
terminal window or the instant messenger client.

5 When all options are set according to your wishes, click Apply.

Similar to setting the default Web browser or e-mail application, you can change file
associations in KDE. File associations determine which application should be used to
open a file, for example, if you want to start a file from Konqueror.

1 Open the KDE control center and click KDE Components > File Associations.

2 To search for an extension, enter the extension in Find Filename Pattern. Only
file types with a matching file pattern appear in the list. For example, to modify
the application for *.png files, enter png in Find Filename Pattern.

3 Inthe Known Types list, click the file type to open the setting dialog for this file
type. You can change the icon, the filename patterns, description, and the order
of the applications.
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If your tool is not listed, click Add in Application Preference Order then enter
the command.

To change the order of the list entries, click the program to move then give it a
higher or lower priority by clicking Move Up or Move Down. The application
listed at the top is used by default when you click a file of this type.

If you need a file type that is not listed in the Known Types list, click Add to open
a dialog where you can select a group and enter a type name. The group determi-
nes the main type, for example, audio, image, text, or video. Your file type can
usually be assigned to one of these.

4a Click OK then determine the extensions of the filename.

4b Specify a description in the text field and select which application to use.

5 When all options are set according to your wishes, click Apply.
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2.6 Configuring 3D Desktop Effects

Configuring desktop effects (XGL) for your KDE desktop comes down to a few clicks
in YaST and the KDE control center (Personal Settings).

ANMERKUNG: Support of Desktop Effects in KDE

Note that the support of desktop effects in this release of KDE is still in experi-
mental state. Some features may not work.

Abbildung 2.2 3D Desktop Effects on KDE
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Before considering to use desktop effects, make sure the following requirements are
met:

+ Check whether your hardware supports desktop effects at all by reviewing http: //
gentoo-wiki.com/HARDWARE_Video_Card_Support_Under_XGL.

» Download and install missing drivers if needed by following the vendor's instructi-
ons.
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+ Install the following packages with YaST: xgl1, xgl-hardware-1ist and
compiz. For a description of how to install software packages with YaST, refer
to Kapitel 3, Installieren bzw. Entfernen von Software (1Start).

To enable 3D desktop effects on your desktop, proceed as follows:

1 Start YaST from the main menu or by pressing Alt + F2 and entering yast.
2 In YaST, select System > /etc/sysconfig Editor.

3 In the list on the left, unfold the Desktop > Display manager entries.

4 Select the DISPLAYMANAGER_XSERVER entry and set its value to Xgl.
5 Click Finish to apply the changes.

6 Reboot your machine.
Desktop effects should now be available to you.

These are the most prominent features available to you when using desktop effects and
their default keyboard shortcuts:

» Wrap your virtual desktops round a cube and rotate the cube to get to another vir-
tual desktop. Rotate the cube with Strg + Alt + — or Strg + Alt + « key combinati-
ons.

+ Fly through the range of virtual desktops without having to use the pager and select
the one you want to use. To change to this panel-like view, use the Strg + Alt + |
key combination. To scroll to a desktop left or right to the current one, keep holding
Strg + Alt and use the — and < keys.

+ Zoom into certain parts of the desktop. Select the area to which you want to zoom
in and use the Windows =+ right mouse button key combination to zoom into your
desktop.

+ Fit all windows opened on one virtual desktop to be displayed in full so you can
easily switch focus between them. Arrange the windows by using the Strg + Alt +
1 key combination. While holding down the Strg + Alt keys, use the arrow keys to
determine the focus.
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+ Create virtual raindrops on your desktop and use a virtual windscreen wiper to get
rid of them. Toggle the raindrops with Umschalttaste + F9 and toggle the windscreen
wiper with Umschalttaste + F8.

To disable desktop effects in a running session, proceed as follows:

1 Open the KDE control center and select KDE Components > Session Manager.
2 In the Advanced group, set Preferred Window Manager to kwin.
3 Apply your settings and leave the module.

To disable desktop effects permanently, proceed as follows:

1 Start YaST.

2 Select System > /etc/sysconfig Editor.

3 In the list on the left, unfold the Desktop > Display manager entries.

4 Select the DISPLAYMANAGER_XSERVER entry and set its value to Xorg.
5 Click Finish to apply the changes.

6 Reboot your machine.

2.7 Configuring System and Security
Aspects

To adjust settings such as time and date format, number format, or currency, select the
desired country as the default country in KDE. If more than one system language is
installed on your computer, you can also select different languages in which KDE
should show the graphical user interface and application interfaces.

Prozedur 2.14 Adjusting Regional Settings
1 To set your default country options, open the KDE control center and select

Regional & Accessibility > Country/Region & Language.
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2 From Country or Region, select the desired country. If the language of the
country is installed on your system, KDE automatically sets the language as the
default language and shows it at the top position in the Languages list.

3 Ifneeded, adjust the other country-dependent options, such as number or time
and date format, on the other tabs.

4 If more than one language is installed on your system (as secondary languages
with YaST) and you want to change the graphical interface of KDE to a different
language, click Add Language on the Locale tab.

5 Choose Other to open a list of other languages installed on your system. Select
the language for the graphical user interface. The new language is now shown
at the top position in the Language list.

6 To confirm the changes, click Apply. All newly started applications or desktop
objects now appear in the new language.

7 To switch to another language, re-sort the languages in the Languages list until
the desired language is at the top position and apply your changes.

If you often need to enter texts in various languages, you may want to add different
language layouts for your keyboard. You can then easily switch layouts when needed.

Customizing Your Settings



Prozedur 2.15 Adding Keyboard Layouts

1 To add additional keyboard layouts, open the KDE control center and select
Regional & Accessibility > Keyboard Layout.

2 Activate Enable keyboard layouts at the top.

3 In the list of Available layouts, select a layout. Click Add to transfer it to the list
of Active layouts.
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4 If you added several layouts, you can change the sorting order with the help of
the up and down arrow buttons.

5 Depending on the options you choose in the Switching Options tab an indicator
or country flag appears in the system tray. With a click on the icon you can change
between different keyboard layouts after you confirmed your changes with
Apply.

By default, openSUSE provides various fonts commonly available in different file
formats (Bitmap, TrueType, etc.). These are known as system fonts. Users can additio-
nally install their own fonts from various collections. Such user-installed fonts are,
however, only visible and available to the corresponding user.
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Prozedur 2.16 Installing New Fonts

To check which fonts are currently available, type the URL fonts: / into the address
field of a Konqueror session. This displays two windows: Personal and System.
User-installed fonts are installed to the folder Personal. Only root can install to
the System folder.

To install new fonts, proceed as follows:

1

Start the control center from the main menu or press Alt + F2 and enter
kcontrol.

Click System Administration > Font Installer.

To update system fonts, click Administrator Mode and enter the root password.
Then proceed as described below.

To install fonts as a user, click Add Fonts.

In the dialog that opens, select one or more fonts for installation. The marked
fonts are then installed to your personal font folder. Selecting a font shows a
preview.

KDE runs a session manager that lets you save the status of a certain session and return
to that status the next time you log in. For example, it can automatically start the appli-
cations that you were running in the most recent session or when you manually saved
a session.

Prozedur 2.17 Adjusting the Session Handling

1 To change the session handling options, open the KDE control center and click

KDE Components > Session Manager. The groups General and Default Shutdown
Option hold options for the confirmation dialog that usually appears on logout.

2 By default, Session Manager restores the applications that were running when

you logged out from the previous session, enabling an automatic start of these
applications.

To be able to save a certain session manually and restore this session each time
you log in to KDE, select Restore manually saved sessions. This adds a new
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menu item, Save Session, to your main menu. After a session is saved, KDE
automatically restores the saved session on each login.

3 To start with a ,,fresh“ session each time you log in, select Start with an empty
session.

4 Click Apply to confirm your changes.

By default, you define the settings for KWallet password manager with the help of a
wizard when you use KWallet for the first time. You can adjust the initial settings at
any time to increase security.

Prozedur 2.18 Adjusting KWallet Settings

1 If KWallet is already started, click the KWallet symbol in the panel and select
Configure Wallet. Otherwise, open KDE control center and click Security &
Privacy > KDE Wallet.

2 [f KWallet Manager is not yet enabled, activate the respective check box at the
top.

3 By default, a wallet is closed when the last application stops using it. To increase
security, you can set a more restrictive policy: to close a wallet automatically
after a period of inactivity or after start-up of the screen saver, activate the
respective check boxes.

File View Settings Help
i} KDE Wallet

©

E» Search:

76

ol Appearance & Themes
A Deskiop
&/ Internet & Network
KDE Gomponents
§ Peripherals
£ Regional & Accessibility
©- {1 Security & Privacy
4 Grypto
{1 Password & User A
2 Privacy
% Sound & Muttimedia
@y System Administration

Wallet Preferences | Access Control

%/ Enable the KDE wallet subsystem
~Glose Wallst

%/ Glose when unused for: 1min |5

Close when screensaver starts

%] Glose when last application stops using it

~Automatic Wallet Selection

Select wallet to use as default: || New

Different wallet for local passwords -

~Wallet Manager

%] Show manager in system tray

%/ Hide system fray icon when last wallet closes

Launch Wallet Manager

KDE User Guide

\} Help || Defautts v Appy ||4 Reset




4 To remove the KWallet icon from the panel, deactivate Show manager in system
tray. You can then only access KWallet from the main menu.

5 By default, KWallet stores all passwords in one wallet named kdewallet. To
store local and network-related passwords in different wallets, activate Different
wallet for local passwords. Click New to create an additional wallet, if needed.
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The OpenOffice.org Office
Suite

OpenOffice.org is a powerful open-source office suite that provides tools for all types
of office tasks, such as writing texts, working with spreadsheets, or creating graphics
and presentations. With OpenOffice.org, you can use the same data across different
computing platforms. You can also open and edit files in other formats, including Mi-
crosoft Office, then save them back to this format, if needed. This chapter covers infor-
mation about the Novell® edition of OpenOffice.org and some of the key features you
should be aware of when getting started with the suite.

Section 3.1, “Understanding OpenOffice.org” (page 82)

Section 3.2, “Word Processing with Writer” (page 91)

Section 3.3, “Using Spreadsheets with Calc” (page 102)

Section 3.4, “Using Presentations with Impress” (page 104)

Section 3.5, “Using Databases with Base” (page 107)

Section 3.6, “Creating Graphics with Draw” (page 111)

Section 3.7, “Creating Mathematical Formulas with Math” (page 112)

Section 3.8, “Finding Help and Information About OpenOffice.org” (page 112)

OpenOffice.org consists of several application modules (subprograms), which are de-
signed to interact with each other. They are listed in Table 3.1, “The OpenOffice.org
Application Modules” (page 82). A full description of each module is available in the

The OpenOffice.org Office Suite

81



82

online help, described in Section 3.8, “Finding Help and Information About OpenOf-
fice.org” (page 112).

Table 3.1 The OpenOffice.org Application Modules

Module Purpose

Writer Word processor application module

Calc Spreadsheet application module

Impress Presentation application module

Base Database application module

Draw Application module for drawing vector graphics

Math Application module for generating mathematical formulas

The appearance of the application varies depending on the desktop or window manager
you use. Regardless of the appearance, the basic layout and functions are the same.

3.

1 Understanding OpenOffice.org

This section contains information that applies to all of the application modules in
OpenOffice.org. Module-specific information can be found in the sections relating to
each module.

Section 3.1.1, “Using the Standard Edition of OpenOffice.org” (page 83)
Section 3.1.2, “Compatibility with Other Office Applications” (page 83)
Section 3.1.3, “Starting OpenOffice.org” (page 85)

Section 3.1.4, “Improving OpenOffice.org Load Time” (page 86)
Section 3.1.5, “Customizing OpenOffice.org” (page 86)

Section 3.1.6, “Finding Templates” (page 90)
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3.1.1 Using the Standard Edition of
OpenOffice.org

You can use the standard edition of OpenOffice.org rather than the Novell edition. If
you install the latest version of OpenOffice.org, all of your Novell Edition files remain
compatible. However, the standard edition does not contain enhancements made in the
Novell edition.

3.1.2 Compatibility with Other Office
Applications

OpenOffice.org can work with documents, spreadsheets, presentations, and databases
in many other formats, including Microsoft Office. They can be seamlessly opened like
other files and saved back to the original format. Because the Microsoft formats are
proprietary and the specifications are not available to other applications, there are occa-
sionally formatting issues. If you have problems with your documents, consider opening
them in the original application and resaving in an open format such as RTF for text
documents or CSV for spreadsheets.

TIP

For good information about migrating from other office suites to OpenOf-
fice.org, refer to the OpenOffice.org Migration Guide [http://
documentation.openoffice.org/manuals/ocococauthors2/
0600MG-MigrationGuide.pdf].

Converting Documents to the OpenOffice.org Format

OpenOffice.org can read, edit, and save documents in a number of formats. It is not
necessary to convert files from those formats to the OpenOffice.org format to use those
files. However, if you want to convert the files, you can do so. To convert a number of
documents, such as when first switching to OpenOffice.org, do the following;:

1 Select File > Wizard > Document Converter.

2 Choose the file format from which to convert.
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There are several StarOffice and Microsoft Office formats available.

3 Click Next.

4 Specify where OpenOffice.org should look for templates and documents to
convert and in which directory the converted files should be placed.

IMPORTANT

Documents from a Windows partition are usually in a subdirectory of
/windows.

5 Make sure that all other settings are appropriate, then click Next.

6 Review the summary of the actions to perform, then start the conversion by
clicking Convert.

The amount of time needed for the conversion depends on the number of files
and their complexity. For most documents, conversion does not take very long.

Sharing Files with Users of Other Office Suites

OpenOffice.org is available for a number of operating systems. This makes it an excellent
tool when a group of users frequently need to share files and do not use the same system
on their computers.

When sharing documents with others, you have several options.

If the recipient needs to be able to edit the file:  Save the document in the format
the other user needs. For example, to save as a Microsoft Word file, click File > Save
As, then select the Microsoft Word file type for the version of Word the other user
needs.

If the recipient only needs to read the document: Export the document to a PDF
file with File > Export as PDF. PDF files can be read on any platform using a viewer
like Adobe Acrobat Reader.

If you want to share a document for editing: Use one of the standard document
formats. The default formats comply with the OASIS standard XML format, making
them compatible with a number of applications. TXT and RTF formats, although limited
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in formatting, might be a good option for text documents. CSV is useful for spreadsheets.
OpenOffice.org might also offer your recipient's preferred format, especially Microsoft
formats.

If you want to e-mail a document as a PDF:  Click File > Send > Document as
PDF Attachment.Your default e-mail program opens with the file attached.

If you want to e-mail a document to a Microsoft Word user:  Click File > Send
> Document as MS-Doc Attachment. Your default e-mail program opens with the file
attached.

3.1.3 Starting OpenOffice.org

1 Start the application in one of the following ways:

On the menu bar, click :‘i‘t )

This opens Writer. To open a different module, click File > New from the
newly opened Writer document, then choose the module you want to open.

+ From the Computer menu, click Computer > More Applications > Olffice,
then click the name of the OpenOffice.org module you want to start.

* Inaterminal window, enter oof fice. The OpenOffice.org window opens.
Click File > New, then choose the module you want to open.

2 Select the module you want to open.

If any OpenOffice.org application is open, you can open any of the other applications
by clicking File > New > Name of Application.
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3.1.4 Improving OpenOffice.org Load Time

To speed up the load time of OpenOffice.org by preloading the application at system
startup:

1 Click Tools > Options > Memory.
2 Select Start at Startup.

The next time you restart your system, OpenOffice.org will preload. When you open
an OpenOffice.org application module, it will open faster.

3.1.5 Customizing OpenOffice.org

You can customize OpenOffice.org to best suit your needs and working style. Toolbars,
menus, and keyboard shortcuts can all be reconfigured to help you more quickly access
the features you use the most. You can also assign macros to application events if you
want specific actions to occur when those events take place. For example, if you always
work with a specific spreadsheet, you can create a macro that opens the spreadsheet
and assign it to the Start Application event.

This section contains simple, generic instructions for customizing your environment.
The changes you make are effective immediately, so you can see if the changes are

what you wanted and go back and modify them if they weren’t. See the OpenOffice.org
help files for detailed instructions.

Customizing Toolbars

Use the Customize dialog to modify OpenOffice.org toolbars.

1 Click the arrow icon at the end of any toolbar.
2 Click Customize Toolbar.
3 Select the toolbar you want to customize.

4 Select the check boxes next to the commands you want to appear on the toolbar,
and deselect the check boxes next to the commands you don’t want to appear.
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5 Select whether to save your customized toolbar in the OpenOffice.org module
you are using or in the document.

+ OpenOffice.org module
The customized toolbar is used whenever you open that module.
* Document filename

The customized toolbar is used whenever you open that document.

6 Repeat to customize additional toolbars.
7 Click OK.
You can quickly choose the buttons that appear on a particular toolbar.
1 Click the arrow icon at the end of the toolbar you want to change.
2 Click Visible Buttons to display a list of buttons.

3 Select the buttons in the list that appears to enable (check) or disable (uncheck)
them.

Customizing Menus

You can add or delete items from current menus, reorganize menus, and even create
new menus.

1 Click Tools > Customize > Menu.
2 Select the menu you want to change, or click New to create a new menu.
Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete menu items as desired.

4 Click OK.
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Customizing Keyboard Shortcuts

You can reassign currently assigned keyboard shortcuts and assign new shortcuts to
frequently used functions.

1 Click Tools > Customize > Keyboard.

2 Select the keys you want to assign to a function, or select the function and assign
the keys or key combinations.

Click Help for more information about the options in the Customize dialog.

3 Modify, add, or delete keyboard shortcuts as desired.

4 Click OK.

Customizing Events

OpenOffice.org also provides ways to assign macros to events such as application
startup or the saving of a document. The assigned macro runs automatically whenever
the selected event occurs.

1 Click Tools > Customize > Events.
2 Select the event you want to change.
Click Help for more information about the options in the Customize dialog box.

3 Assign or remove macros for the selected event.

4 Click OK.

Changing the Global Settings

Global settings can be changed in any OpenOffice.org application by clicking Tools >
Options on the menu bar. This opens the window shown in the figure below. A tree
structure is used to display categories of settings.
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Figure 3.1 The Options Window
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The following table lists the settings categories along with a brief description of each
category:

Table 3.2 Global Setting Categories

Settings Category  Description

OpenOffice.org Various basic settings, including your user data (such as your
address and e-mail), important paths, and settings for printers
and external programs.

Load/Save Includes the settings related to the opening and saving of sev-
eral file types. There is a dialog for general settings and several
special dialogs to define how external formats should be han-
dled.

Language Settings  Covers the various settings related to languages and writing
aids, such as your locale and spell checker settings. This is also

the place to enable support for Asian languages.

Internet Includes the dialogs to configure any proxies and to change
settings related to search engines.

Text Document Configures the global word processing options, such as the
basic fonts and layout that Writer should use.
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Settings Category

Description

HTML Document

Spreadsheet

Presentation

Drawing

Formula

Chart

Data Sources

Changes the settings related to the HTML authoring features
of OpenOffice.org.

Changes the settings for Calc, such as those related to sort lists
and grids.

Changes the settings that should apply to all presentations. For
example, you can specify the measurement unit for the grid
used to arrange elements.

Includes the settings related to the vector drawing module,
such as the drawing scale, grid properties, and some print op-

tions.

Provides a single dialog to set special print options for formu-
las.

Defines the default colors used for newly created charts.

Defines how external data sources should be accessed.

IMPORTANT

All settings listed in the table are applied globally. They are used as defaults
for every new document you create.

3.1.6 Finding Templates

Templates greatly enhance the use of OpenOffice.org by simplifying formatting tasks
for a variety of different types of documents. OpenOffice.org comes with a few tem-

plates, and you can find additional templates on the Internet. You can also create your
own. Creating templates is beyond the scope of this guide, but detailed instructions are
found in the OpenOffice.org help system and in other documents and tutorials available

online.
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In addition to templates, you can find other extras and add-ins online. The following
table lists a few of the prominent places where you can find templates and other extras.
(Because Web sites often close or their content changes, the information in the following
table might not be current when you read it.)

Table 3.3 Where to Find OpenOffice.org Templates and Extras

Location ‘What You Can Find

OpenOffice.org documentation Web site Templates for Calc spreadsheets, CD
[http://documentation cases, seed packets, fax cover sheets, and
.openoffice.org/Samples more
_Templates/User/template_2

_x/index.html]

Worldlabel.com [http: //www Templates for many types of labels
.worldlabel.com/Pages/
openoffice-template.htm]

For more information about templates, see Section 3.2.4, “Using Templates to Format
Documents” (page 97) and Section 3.3.2, “Using Templates in Calc” (page 103).

3.2 Word Processing with Writer

OpenOffice.org Writer is a full-featured word processor with page and text formatting
capabilities. Its interface is similar to interfaces for other major word processors, and

it includes some features that are usually found only in expensive desktop publishing

applications.

This section highlights a few key features of Writer. For more information about these
features and for complete instructions for using Writer, look at the OpenOffice.org help
or any of the sources listed in Section 3.8, “Finding Help and Information About
OpenOffice.org” (page 112).
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NOTE

Much of the information in this section can also be applied to other OpenOf-
fice.org modules. For example, other modules use styles similarly to how they
are used in Writer.

+ Section 3.2.1, “Creating a New Document” (page 92)

+ Section 3.2.2, “Sharing Documents with Other Word Processors” (page 93)
+ Section 3.2.3, “Formatting with Styles” (page 94)

+ Section 3.2.4, “Using Templates to Format Documents” (page 97)

+ Section 3.2.5, “Working with Large Documents” (page 98)

+ Section 3.2.6, “Using Writer as an HTML Editor” (page 101)

3.2.1 Creating a New Document

There are two ways to create a new document:
To create a document from scratch, click File > New > Text Document.

To use a standard format and predefined elements for your own documents, try a wizard.
Wizards are small utilities that let you make some basic decisions then produce a ready-
made document from a template. For example, to create a business letter, click File >
Wizards > Letter. Using the wizard's dialogs, easily create a basic document using a
standard format. A sample wizard dialog is shown in Figure 3.2, “An OpenOffice.org
Wizard” (page 93).
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Figure 3.2 An OpenOlffice.org Wizard
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Enter text in the document window as desired. Use the Formatting toolbar or the Format
menu to adjust the appearance of the document. Use the File menu or the relevant buttons
in the toolbar to print and save your document. With the options under /nsert, add extra
items to your document, such as a table, picture, or chart.

3.2.2 Sharing Documents with Other Word
Processors

You can use Writer to edit documents created in a variety of other word processors.
For example, you can import a Microsoft Word document, edit it, and save it again as
a Word document. Most Word documents can be imported into OpenOffice.org without
any problem. Formatting, fonts, and all other aspects of the document remain intact.
However, some very complex documents—such as documents containing complicated
tables, Word macros, or unusual fonts or formatting—might require some editing after
being imported. OpenOffice.org can also save in many popular word processing formats.
Likewise, documents created in OpenOffice.org and saved as Word files can be opened
in Microsoft Word without any trouble.

So, if you use OpenOffice.org in an environment where you frequently share documents
with Word users, you should have little or no trouble exchanging document files. Just
open the files, edit them, and save them as Word files.
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3.2.3 Formatting with Styles

OpenOffice.org uses styles for applying consistent formatting to various elements in a
document. The following types of styles are available:

Table 3.4 About the Types of Styles

Type of Style

‘What it Does

Paragraph

Character

Frame

Page

List

Applies standardized formatting to the various types of
paragraphs in your document. For example, apply a paragraph
style to a first-level heading to set the font and font size,
spacing above and below the heading, location of the heading,
and other formatting specifications.

Applies standardized formatting for types of text. For exam-
ple, if you want emphasized text to appear in italics, you can
create an emphasis style that italicizes selected text when
you apply the style to it.

Applies standardized formatting to frames. For example, if
your document uses sidebars, you can create frames with
specified graphics, borders, location, and other formatting
so that all of your sidebars have a consistent appearance.

Applies standardized formatting to a specified type of page.
For example, if every page of your document contains a
header and footer except for the first page, you can use a first
page style that disables headers and footers. You can also
use different page styles for left and right pages so that you
have bigger margins on the insides of pages and your page
numbers appear on an outside corner.

Applies standardized formatting to specified list types. For
example, you can define a checklist with square check boxes
and a bullet list with round bullets, then easily apply the
correct style when creating your lists.
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Opening the Styles and Formatting Window

The Styles and Formatting window (called the Stylist in earlier versions of OpenOf-
fice.org), is a versatile formatting tool for applying styles to text, paragraphs, pages,
frames, and lists. To open this window, click Format > Styles and Formatting.
OpenOffice.org comes with several predefined styles. You can use these styles as they
are, modify them, or create new styles.

TIP

By default, the Styles and Formatting window is a floating window; that is, it
opens in its own window that you can place anywhere on the screen. If you
use styles extensively, you might find it helpful to dock the window so that it
always present in the same part of the Writer interface. To dock the Styles and
Formatting window, press Ctrl while you double-click on a gray area in the
window. This tip applies to some other windows in OpenOffice.org as well, in-
cluding the Navigator.

Applying a Style

To apply a style, select the element you want to apply the style to, and then double-
click the style in the Styles and Formatting window. For example, to apply a style to a
paragraph, place the cursor anywhere in that paragraph and double-click the desired
style.

Using Styles Versus Using Formatting Buttons and
Menu Options

Using styles rather than the Format menu options and buttons helps give your pages,
paragraphs, texts, and lists a more consistent look and makes it easier to change your
formatting. For example, if you emphasize text by selecting it and clicking the Bold
button, then later decide you want emphasized text to be italicized, you need to find all
of your bolded text and manually change it to italics. If you use a character style, you
only need to change the style from bold to italics and all text that has been formatted
with that style automatically changes from bold to italics.

Text formatted with a menu option or button overrides any styles you have applied. If
you use the Bold button to format some text and an emphasis style to format other text,
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then changing the style does not change the text that you formatted with the button,
even if you later apply the style to the text you bolded with the button. You must man-
ually unbold the text and then apply the style.

Likewise, if you manually format your paragraphs using Format > Paragraph, it is
easy to end up with inconsistent paragraph formatting. This is especially true if you
copy and paste paragraphs from other documents with different formatting.

Changing a Style

Styles are powerful because you can change formatting throughout a document by
changing a style, rather than applying the change separately everywhere you want to
apply the new formatting.

1 In the Styles and Formatting window, right-click the style you want to change.
2 Click Modify.

3 Change the settings for the selected style.

For information about the available settings, refer to the OpenOffice.org online
help.

4 Click OK.

Creating a Style

OpenOffice.org comes with a collection of styles to suit many users’ needs. However,
most users eventually need a style that does not yet exist. To create a new style:

1 Right-click in any empty space in the Styles and Formatting window.

Make sure you are in the list of styles for the type of style you want to create.
For example, if you are creating a character style, make sure you are in the
character style list.

2 Click New.

3 Click OK.
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4 Name your style and choose the settings you want applied with that style.

For details about the style options available in any tab, click that tab and then
click Help.

3.2.4 Using Templates to Format Documents

Most word processor users create more than one kind of document. For example, you
might write letters, memos, and reports, all of which look different and require different
styles. If you create a template for each of your document types, the styles you need
for each document are always readily available.

Creating a template requires a little bit of up-front planning. You need to determine
what you want the document to look like so you can create the styles you need in that
template. You can always change your template, but a little planning can save you a
lot of time later.

NOTE

You can convert Microsoft Word templates like you would any other Word
document. See Section “Converting Documents to the OpenOffice.org Format”
(page 83) for information.

A detailed explanation of templates is beyond the scope of this section. However, more
information is found in the help system, and detailed how-tos are found at the
OpenOffice.org Documentation page [http://documentation.openoffice
.org/HOW_TO/index.html].

Creating a Template

A template is a text document containing only the styles and content that you want to
appear in every document, such as your address information and letterhead on a letter.
When a document is created or opened with the template, the styles are automatically
applied to that document.
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To create a template:

1 Click File > New > Text Document.

2 Create the styles and content that you want to use in any document that uses this
template.

3 Click File > Templates > Save.
4 Specify a name for the template.
5 In the Categories box, click the category you want to place the template in.

The category is the folder where the template is stored.

6 Click OK.

3.2.5 Working with Large Documents

You can use Writer to work on large documents. Large documents can be either a single
file or a collection of files assembled into a single document.

Navigating in Large Documents

The Navigator tool displays information about the contents of a document. It also lets
you quickly jump to different elements. For example, you can use the Navigator to get
a quick overview of all images included in the document.

To open the Navigator, click Edit > Navigator. The elements listed in the Navigator
vary according to the document loaded in Writer.
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Figure 3.3 Navigator Tool in Writer
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Click an item in the Navigator to jump to that item in the document.

Creating a Single Document from Multiple

Documents

If you are working with a very large document, such as a book, you might find it easier
to manage the book with a master document, rather than keeping the book in a single
file. A master document enables you to quickly apply formatting changes to a large

document or to jump to each subdocument for editing.

A master document is a Writer document that serves as a container for individual
Writer files. You can maintain chapters or other subdocuments as individual files col-
lected in the master document. Master documents are also useful if multiple people are
working on a document. You can separate each person’s portion of the document into
subdocuments collected in a master document, allowing multiple writers to work on
their subdocuments at the same time without fear of overwriting other people’s work.
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NOTE

If you are coming to OpenOffice.org from Microsoft Word, you might be ner-
vous about using master documents because the master document feature in
Word has a reputation for corrupting documents. This problem does not exist
in OpenOffice.org Writer, so you can safely use master documents to manage
your projects.

To create a master document:
1 Click New > Master Document.
or
Open an existing document and click File > Send > Create Master Document.

2 Insert subdocuments.
3 Click FileSave.
The OpenOffice.org help files contain more complete information about working with

master documents. Look for the topic entitled “Using Master Documents and Subdoc-
uments.”

TIP

The styles from all of your subdocuments are imported into the master docu-
ment. To ensure that formatting is consistent throughout your master document,
you should use the same template for each subdocument. Doing so is not
mandatory; however, if subdocuments are formatted differently, you will
probably need to do some reformatting to successfully bring subdocuments
into the master document without creating inconsistencies. For example, if two
documents imported into your master document include different styles with
the same name, the master document will use the formatting specified for that
style in the first document you import.
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3.2.6 Using Writer as an HTML Editor

In addition to being a full-featured word processor, Writer also functions as an HTML
editor. Writer includes HTML tags that can be applied as you would any other style in
a Writer document. You can view the document as it will appear online, or you can
directly edit the HTML code.

Creating an HTML Document
1 Click File > New > HTML Document.
2 Click the arrow at the bottom of the Formatting and Styles window.
3 Select HTML Styles.
4 Create your HTML document, using the styles to tag your text.
5 Click FileSave As.

6 Select the location where you want to save your file, name the file, and select
HTML Document (.html) from the Filter list.

7 Click OK.

If you prefer to edit HTML code directly, or if you want to see the HTML code created
when you edited the HTML file as a Writer document, click View > HTML Source. In
HTML Source mode, the Formatting and Styles list is no longer available.

NOTE

The first time you switch to HTML Source mode, you are prompted to save the
file as HTML, if you have not already done so.
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3.3 Using Spreadsheets with Calc

Calc is the OpenOffice.org spreadsheet application. Create a new spreadsheet with File
> New > Spreadsheet or open one with File > Open. Calc can read and save in Microsoft
Excel's format, so it is easy to exchange spreadsheets with Excel users.

NOTE

Calc can process many VBA macros in Excel documents; however, support for
VBA macros is not yet complete. When opening an Excel spreadsheet that
makes heavy use of macros, you might discover that some do not work.

In the spreadsheet cells, enter fixed data or formulas. A formula can manipulate data
from other cells to generate a value for the cell in which it is inserted. You can also
create charts from cell values.

» Section 3.3.1, “Using Formatting and Styles in Calc” (page 102)

+ Section 3.3.2, “Using Templates in Calc” (page 103)

3.3.1 Using Formatting and Styles in Calc

Calc comes with a few built-in cell and page styles to improve the appearance of your
spreadsheets and reports. Although these built-in styles are adequate for many uses,
you will probably find it useful to create styles for your own frequently used formatting
preferences.

Creating a Style
1 Click Format > Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click in the Formatting and Styles window, then click New.

4 Specify a name for your style and use the various tabs to set the desired formatting
options.
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5 Click OK.

Modifying a Style
1 Click Format > Styles and Formatting.

2 In the Formatting and Styles window, click either the Cell Styles or the Page
Styles icon.

3 Right-click the name of the style you want to change, then click Modify.
4 Change the desired formatting options.

5 Click OK.

3.3.2 Using Templates in Calc

If you use different styles for different types of spreadsheets, you can use templates to
save your styles for each spreadsheet type. Then, when you create a particular type of
spreadsheet, open the applicable template and the styles you need for that template are
available in the Formatting and Styles window.

A detailed explanation of templates is beyond the scope of this section. However, more
information is found in the help system and detailed how-tos are found at the OpenOf-
fice.org Documentation page [http://documentation.openoffice.org/
HOW_TO/index.html].

Creating a Template

A Calc template is a spreadsheet that contains styles and content that you want to appear
in every spreadsheet created with that template, such as headings or other cell styles.
When a spreadsheet is created or opened with the template, the styles are automatically
applied to that spreadsheet.
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To create a template:

1 Click File > New > Spreadsheet.

2 Create the styles and content that you want to use in any spreadsheet that uses
this template.

3 Click File > Templates > Save.
4 Specify a name for the template.
5 In the Categories box, click the category you want to place the template in.

The category is the folder where the template is stored.

6 Click OK.

3.4 Using Presentations with Impress

Use OpenOffice.org Impress to create presentations for screen display or printing, such
as slide shows or transparencies. If you have used other presentation software, you can
move comfortably to Impress, which works very similarly to other presentation software.

Impress can open and save Microsoft Powerpoint presentations, which means you can
exchange presentations with Powerpoint users, as long as you save your presentations
in Powerpoint format.

» Section 3.4.1, “Creating a Presentation” (page 104)

» Section 3.4.2, “Using Master Pages” (page 105)

3.4.1 Creating a Presentation
1 Click File > New > Presentation.

2 Select the option to use for creating the presentation.
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There are two ways to create a presentation:
+ Create an empty presentation

Opens Impress with a blank slide. Use this option to create a new presentation
from scratch, without any preformatted slides.

+ Create a presentation from a template

Opens Impress with your choice of template. Use this option to create a new
presentation with a predesigned OpenOffice.org template or a template you’ve
created or installed yourself, such as your company’s presentation template.
Impress uses styles and templates the same way other OpenOffice.org mod-
ules do. See Section 3.2.4, “Using Templates to Format Documents”

(page 97) for more information about templates.

3.4.2 Using Master Pages

Master pages give your presentation a consistent look by defining the way each slide
looks, what fonts are used, and other graphical elements. Impress uses two types of
master pages:

+ Slide master

Contains elements that appear on all slides. For example, you might want your
company logo to appear in the same place on every slide. The slide master also
determines the text formatting style for the heading and outline of every slide that
uses that master page, as well as any information you want to appear in a header
or footer.

* Notes master

Determines the formatting and appearance of the notes in your presentation.
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Creating a Slide Master

Impress comes with a collection of preformatted master pages. Eventually, most users
will want to customize their presentations by creating their own slide masters.

1 Start Impress, then create a new empty presentation.

2 Click View > Master > Slide Master.
This opens the current slide master in Master View.

3 Right-click the left-hand panel, then click New Master.
4 Edit the slide master until it has the desired look.

5 Click Close Master View or View > Normal to return to Normal View.

TIP

When you have created all of the slide masters you want to use in your presen-
tations, you can save them in an Impress template. Then, any time you want
to create presentations that use those slide masters, open a new presentation
with your template.

Applying a Slide Master

Slide masters can be applied to selected slides or to all slides in the presentation.

1 Open your presentation, then click View > Master > Slide Master.

2 (Optional) If you want to apply the slide master to multiple slides, but not to all
slides, select the slides that you want to use that slide master.

To select multiple slides, in the Slides Pane, Control-click on the slides you want
to use that slide master.

3 In the Task Pane, right-click the master page you want to apply.

If you do not see the Task Pane, click View > Task Pane.
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4 Apply the slide master by clicking one of the following:.
+ Apply to All Slides
Applies the selected slide master to all slides in the presentation.
« Apply to Selected Slides

Applies the selected slide master to the current slide, or to any slides you
select before applying the slide master. For example, if you want to apply a
different slide master to the first slide in a presentation, select that slide, then
change to Master View and apply a slide master to that slide.

3.5 Using Databases with Base

OpenOffice 2.0 introduces a new database module, Base. Use Base to design a database
to store many different kinds of information, from a simple address book or recipe file
to a sophisticated document management system.

Tables, forms, queries, and reports can be created manually or using convenient wizards.
For example, the Table Wizard contains a number of common fields for business and
personal use. Databases created in Base can be used as data sources, such as when
creating form letters.

It is beyond the scope of this document to detail database design with Base. More infor-
mation can be found at the sources listed in Section 3.8, “Finding Help and Information
About OpenOffice.org” (page 112).

3.5.1 Creating a Database Using Predefined
Options

Base comes with several predefined database fields to help you create a database. The
steps in this section are specific to creating an address book using predefined fields,
but it should be easy to follow them to use the predefined fields for any of the built-in
database options.
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The process for creating a database can be broken into several subprocesses:
+ Section “Creating the Database” (page 108)
+ Section “Setting Up the Database Table” (page 108)
+ Section “Creating a Form” (page 109)
+ Section “Modifying the Form” (page 110)

+ Section “What’s Next?” (page 110)

Creating the Database

First, create the database.

1 Click File > New > Database.
2 Select Create a new database, then click Next.

3 Click Yes, register the database for me to make your database information
available to other OpenOffice.org modules, select both check boxes in the bottom
half of the dialog, then click Finish.

4 Browse to the directory where you want to save the database, specify a name for
the database, then click OK.

Setting Up the Database Table
Next, define the fields you want to use in your database table.
1 In the Table Wizard, click Personal.

The Sample tables list changes to show the predefined tables for personal use.
If you had clicked Business, the list would contain predefined business tables.

2 In the Sample tables list, click Addresses.

The available fields for the predefined address book appear in the Available
fields menu.
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3 In the Available fields menu, click the fields you want to use in your address
book.

You can select one item at a time, or you can shift-click multiple items to select
them.

4 Click the single right-arrow to move the selected items to the Selected fields
menu.

To move all available fields to the Selected fields menu, click the double right-
arrow.

5 Use the up-arrow and down-arrow to adjust the order of the selected fields.
The fields appear in the table and forms in the order in which they are listed.

6 Click Next.

7 Make sure each of the fields is defined correctly.

You can change the field name, type, whether the entry is required, and the
maximum length of the field (the number of characters that can be entered in
that field. For this example, leave the settings as they are.

8 Click Next.

9 Click Create a primary key, click Automatically add a primary key, click Auto
value, then click Next.

10 Accept the default name for the table, select Create a form based on this table,
then click Finish.

Creating a Form

Next, create the form to use when entering data into your address book.

1 In the Form Wizard, click the double right-arrow to move all available fields to
the Fields in the form list, then click Next twice.

2 Select how you want to arrange your form, then click Next.
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3 Select the option to use the form to display all data and leave all of the check
boxes empty, then click Next.

4 Apply a style and field border, then click Next.
For this example, accept the default selections.

5 Name the form, select the Modify the form option, then click Finish.

Modifying the Form

After the form has been defined, you can modify the appearance of the form to suit
your preferences.

1 Close the form that opened when you finished the previous step.

2 In the main window for your database, right-click the form you want to modify
(there should be only one option), then click Edit.

3 Arrange the fields on the form by dragging them to their new locations.

For example, move the First Name field so it appears to the right of the Last
Name field, and then adjust the locations of the other fields to suit your preference.

4 When you have finished modifying the form, save it and close it.

What’s Next?

After you have created your database tables and forms, you are ready to enter your data.
You can also design queries and reports to help sort and display the data.

Refer to OpenOffice.org online help and other sources listed in Section 3.8, “Finding
Help and Information About OpenOffice.org” (page 112) for additional information
about Base.
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3.6 Creating Graphics with Draw

Use OpenOffice.org Draw to create graphics and diagrams. You can save your drawings
in today’s most common formats and import them into any application that lets you
import graphics, including the other OpenOffice.org modules. You can also create Flash
versions of your drawings.

The OpenOffice.org documentation contains complete instructions on using Draw. See
Section 3.8, “Finding Help and Information About OpenOffice.org” (page 112) for more
information.

To use a Draw graphic in a document:

1 Open Draw, then create the graphic.
2 Save the graphic.

3 Copy the graphic and paste it into the document, or insert the graphic directly
from the document.

One particularly useful feature of Draw is the ability to open it from other OpenOf-
fice.org modules so you can create a drawing that is automatically imported into your
document.

1 From an OpenOffice.org module (for example, from Writer), click Insert > Object
> OLE Object > OpenOlffice.org 2.0 Drawing > OK.

This opens Draw.

2 Create your drawing.

3 Click in your document, outside the Draw frame.

The drawing is automatically inserted into your document.

The OpenOffice.org Office Suite

111



112

3.7 Creating Mathematical Formulas
with Math

It is usually difficult to include complex mathematical formulas in your documents.
The OpenOffice.org Math equation editor lets you create formulas using operators,
functions, and formatting assistants. You can then save those formulas as objects that
can be imported into other documents. Math functions can be inserted into other
OpenOffice.org documents like any other graphic object.

NOTE

Math is not a calculator. The functions it creates are graphical objects. Even if
they are imported into Calc, these functions cannot be evaluated.

3.8 Finding Help and Information
About OpenOffice.org

OpenOffice.org contains extensive online help. In addition, a large community of users
and developers support it. As a result, it is seldom hard to find help or information about
using the OpenOffice.org. The following table shows some of the places where you
can go for additional information. (Because Web sites often close or their content
changes, the information in the following table might not be current when you read it.)

Table 3.5 Where to Get Information About OpenOffice.org

Location What You Can Find
OpenOffice.org online help menu Extensive help on performing any task in
OpenOffice.org

Official OpenOffice.org support page Manuals, tutorials, user and developer
[http://support.openoffice forums, users@openoffice.org mailing
.org/index.html] list, FAQs, and much more
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Location ‘What You Can Find

OpenOffice.org Migration Guide Information about migrating to OpenOf-
[cocauthors.org/en/authors/ fice.org from other office suites, including
userguide2/migration/ Microsoft Office
OtherMSOFiles_25_June_PK

. SXW]

Taming OpenOffice.org [http://www Books, news, tips and tricks
.taming-openoffice-org.com/

]

OpenOffice.org Macros [http://www Extensive information about creating and
.pitonyak.org/oo.php] using macros
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Kontact: E-Mailing and
Calendaring

Kontact combines the functionality of a number of KDE applications into a convenient,
single interface for personal information management. These applications include KMail
for e-mail, KOrganizer for the calendar, KAddressBook for contacts, KNode for
newsgroups, and KNotes for notes. It is also possible to sync data with external devices,
such as handheld device. Kontact integrates easily with the rest of the KDE desktop
and connects to a variety of groupware servers. It includes extra features, such as journal
entries, Spam and virus filtering, and an RSS reader.

Start Kontact from the main menu. Alternatively, enter kontact in a command line
or in the Run Command dialog. You can also open the individual components instead
of the combined application if you only need partial functionality.

4.1 Kontact Overview

The default window view is shown in Abbildung 4.1, ,,The Kontact Summary View*
(S. 116). Use the icons in the left section to access the different components. The
Summary provides basic information, including upcoming birthdays and to-dos and the
number of new mail messages. The news section can access RSS feeds to provide
updated news of interest to you. Use Settings > Configure Summary View to configure
the information displayed.
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Abbildung 4.1 The Kontact Summary View
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2 messages, 0 unread.

Mail

The folder area to the left contains a list of your mail folders (mail boxes) indicating
the total number of messages and how many are still unread. To select a folder,
simply click it. The messages in that folder appear in the top right frame. The
number of messages in that folder is also shown in the status bar at the bottom of
the application window.

The subject, sender, and time of receipt of each message are listed in the header
area to the right. Click a message to select it and display it in the message window.
Sort the messages by clicking one of the column headers (subject, sender, date,
etc.). The contents of the currently selected message are displayed in the message
frame of the window. Attachments are depicted as icons at the end of the message,
based on the MIME type of the attachment, or they can be displayed inline.

Contacts

The upper left frame of this component shows all addresses in the currently activated
address books. The lower left frame lists your address books and shows whether
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each one is currently active. The right frame shows the currently selected contact.
Use the search bar at the top to find a particular contact.

Calendar
The calendar view is divided into a number of frames. By default, view a small
calendar of this month and a week view of the current week. Also find a list of to-
dos, a detailed view of the current event or to-do, and a list of calendars with the
status of each. Select a different view from the toolbar or the View menu.

To-Do List
To-do List shows your list of tasks. Click the field at the top to add a new item to
the list. Right-click in a column of an existing item to make changes to the value
in that column. An item can be broken into several subitems. Right-click and select
New Sub-to-do to create a subitem. You can also assign to-dos to other people.

Journal
The Journal provides a place for your reflections, occurrences, or experiences.
Choose a date in the calendar frame and click Add Journal Entry to add a new
entry. If a journal entry already exists for the chosen date, edit it in the right frame.

Notes
Use the Notes component to keep sticky notes to yourself. If you are using KDE,
use the KNotes icon in the system tray to make your notes visible on the desktop.

Feeds
The Feeds window is divided into three frames—a tree view with RSS feeds on
the left, an article list on the top right, and the article view on the bottom right side.
Click a feed in the tree view to display it. Right-click a feed to update, edit, or
delete it. Right-click a folder in the tree view to open a menu where you can add a
new feed or manipulate existing feeds within this folder.

4.2 Mail

Kontact uses KMail as its e-mail component. You can also start it separately with the
command kmai 1. To configure it, open the mail component then select Settings >
Configure KMail. KMalil is a fully-featured e-mail client that supports a number of
protocols.
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Abbildung 4.2 The Kontact Mail Component
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4.2.1 Configuring Identities

Kontact can manage multiple e-mail accounts, such as your private e-mail and your
business ones. Creating separate identities for your different e-mail accounts allows
you to associate different sender addresses, cryptography settings and signatures with
each of them. To create an identity, select Settings > Configure KMail and choose
Identities > Add. Determine whether to create a new identity from scratch, use the user
settings from Personal Settings > Password & User Account, or whether to duplicate
an existing identity.

To create a new identity from scratch, enter the name of the new identity and enter your
name, organization and e-mail address in the General tab. Optionally, configure one
or several of the following options:

Cryptography
Set the keys to use for signing and encrypting messages. For the encryption to
work, first create a key with KGpg, as described in Kapitel 9, Encryption with

KGpg (S. 169).
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Advanced
Enter a default reply-to and a default blind carbon-copy address, choose a dictionary,
select the folders for draft and sent messages, and define by which sending account
the messages should be sent.

Templates
Define templates to use for new messages, for default replies to senders and lists,
and for forwarded messages.

Signature
Decide how your messages should be signed. Use the input field below to configure
your signature or obtain it from a file or the output of a command.

Picture
Use this tab to include a picture in the X-Face format in your messages. X-Face
can only hold black and white images with a dimension of 48 x 48 pixels. You can
obtain the picture from an external source or of the input field below.

4.2.2 Creating Accounts

Before you can send or receive e-mails, create one or several accounts. The settings
under Accounts determine how Kontact receives and sends e-mail. Many of these settings
vary depending on the system and network in which your mail server is located. If you
are not sure about the settings or items to select, consult your ISP or system administra-
tor.

1 Start Kontact and select Settings > Configure KMail > Accounts.

2 Create an incoming account by clicking on the Receiving tab:

2a Click Add and choose the account type. The following dialog box shows
only the respective entries of your selected type.

2b If you have selected POP3, IMAP or disconnected IMAP, enter username,
password and hostname. Depending on the chosen account type, configure
additional parameters such as the mail checking interval, the hiding folders,
security settings, and others.

2c Ifyou selected local mailbox or maildir mailbox, enter the folder location.
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2d Proceed with OK.

3 Create an outgoing account by clicking on the Sending tab and click Add to
choose either SMTP or Sendmail.:

+ Ifyou select SMTP, enter an account name, the host name of the SMTP
server. Should the server require login and password, also check Server
requires authentication and enter the required credentials. Optionally, confi-
gure additional security settings using the Security tab.

+ Ifyou select Sendmail, no further configuration efforts are required.

4 Apply your settings and leave the account configuration dialog with OK.

4.2.3 Composing Messages

To compose new messages, select Message > New Message or click the corresponding
icon in the toolbar. To send messages from different e-mail accounts, select one of the
identities as described in Abschnitt 4.2.1, ,,Configuring Identities* (S. 118). In 7o, enter
an e-mail address or part of a name or address in your address book. If Kontact can
match what you enter to something in the address book, a selection list opens. Click
the desired contact or complete your input if none matches. To select directly from the
address book, click the ... button next to the Address field.

To attach files to your message, click the paper clip icon and select the file to attach.
Alternatively, drag a file from the desktop or another folder to the New Message window
or select one of the options in the Affach menu. Normally, the format of a file is reco-
gnized correctly. If the format is not recognized, right-click the icon. From the menu
that appears, select Properties. Set the format and filename in the next dialog and add
a description. In addition, decide whether the attached file should be signed or encrypted.

When you are finished composing your message, send it immediately with Message >
Send or move it to the outbox with Message > Queue. If you send the e-mail, the mes-
sage is copied to sent-mail after having been sent successfully. Messages moved
to the outbox can be edited or deleted.
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4.2.4 Managing Folders

Message folders help organize your messages. By default, they are located in the ~/
.kde/share/apps/kmail/mail directory. When starting KMail for the first
time, the program creates several folders. inbox is where new messages fetched from
a server are initially placed. outbox is used for temporary storage of messages queued
for sending. sent-mail is for copies of messages sent. t rash contains copies of all
e-mails deleted with Del or Edit > Delete. drafts is where you can save unfinished
messages. If you are using IMAP, the IMAP folders are listed below the local folders.
Each incoming mail server has its folders in the Folder list.

If you want to organize your messages in additional folders, create new folders by
selecting Folder > New Folder. This opens a window in which to specify the name and
format of the new folder.

Right-click the folder for a context menu offering several folder operations. Click
Expire to specify the expiration date for read and unread messages, what should happen
with them after expiration, and whether expired messages should be deleted or moved
to a folder. If you intend to use the folder to store messages from a mailing list, set the
necessary options under Folder > Mailing List Management.

To move one or several messages from one folder to another, drag them from the upper
window and drop them into the appropriate folder in the left window. Messages can
also be moved by highlighting the messages then pressing M or selecting Message >
Move to. In the list of folders that appears, select the folder to which to move your
messages.

4.2.5 Signing and Encrypting E-Mails

E-mail is an insecure medium as anyone could theoretically read your e-mails or send
some in your name. By signing your e-mails you enable the recipient of your e-mails
to verify the sender of the messages as the key used to sign is only available to you. By
encrypting the contents of your e-mails make sure that they can only be read by the
recipient. KMail supports both the signing and encryption of e-mails.

Set up KMail for signing and encrypting e-mails:
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1 Generate a key pair as described in Abschnitt 9.2, ,,Generating a New Key Pair®
(S. 170) and export your public key as described in Abschnitt 9.3, ,,Exporting the
Public Key*“ (S. 171).

2 Configure the details of the encryption procedure in KMail:

2a Start KMail and go to Settings > Configure KMail > Identities.

2b Select the identity under which to send encrypted and signed messages. Click
Modify... and proceed to Cryptography.

2c¢ Change the OpenPGP signing key by clicking on Change... and selecting
your key from the dialog box.

2d Change the OpenPGP encryption key by clicking on Change... and selecting
your key from the dialog box.

3 Apply your settings and leave the configuration dialog with OK.

Sending Signed Mails

Sign your e-mails to allow the recipient to verify whether these have really been sent
by you. KMail uses your private key to sign your messages and the recipient can verify
the signature using your public key available on key servers. To sign an e-mail, proceed
as follows:

1 Compose your e-mail as usual.
2 Select Options > Sign Message.

3 Select Attach > Attach My Public Key to create an attachment to your e-mail
containing your public key.

4 Send your message as usual via Message > Send Mail and enter your key's
passphrase when prompted. KMail signs your message using your private key
and the recipient can verify the signature by the public key attached to your
message.
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Sending Encrypted Mails

Use encryption on your e-mails whenever you want to make sure that only the recipient
can read the contents. To be able to exchange encrypted e-mails with another party, get
the appropriate public key and use it to encrypt your message. At the other end, the
private key is then used to decrypt the contents of your message. Of course, you can
use both signatures and encryption on your messages.

To send an encrypted e-mail, proceed as follows:
1 Start KGpg with Alt + F2 and entering kgpg.
2 Get the recipient's public key:

+ Ifyou get it directly from the recipient, import the key with KGpg via Keys
> Import Key.

+ Access a public key server and import it from there. Select in KGpg File >
Key Server Dialog, and search for the key. Select the respective key and
import it into your keyring.

3 Compose a new message.

4 Select Options > Encrypt Message. If you want additionally sign it with your
key, select the respective menu entry.

5 Send the mail.
6 Check whether all keys are correct.

7 Enter your passphrase.

4.2.6 Importing E-Mail from Other Mail
Programs

To import e-mail from other applications, select File > Import Messages from the mail
view in Kontact. It currently features import filters for Outlook Express, the mbox for-
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mat, e-mail text format, Pegasus Mail, Opera, Evolution, and more. The import utility
can also be started separately with the command kmailcvt.

Select the corresponding application and confirm with Continue. A file or a folder must
be provided, depending on the selected type. Kontact then completes the process.

4.2.7 Filters

Filters are a convenient method of automatically processing incoming mail. They use
aspects of the mail, such as sender or size, to move mail to certain folders, delete
unwanted mails, bounce mails back to the sender, or perform a number of other actions.

Setting Up a Filter

To create a filter from scratch, select Settings > Configure Filters. To create a filter
based on an existing message, right-click the desired message then select Create Filter
and the desired filter criteria.

Select the match method for filter criteria (all or any). Then select criteria that applies
only to the desired messages. In Filter Actions, set what the filter should do to the
messages that meet the criteria. Advanced Options provides control over when the filter
is applied and whether additional filters should be considered for these messages.

Applying Filters

Filters are applied in the order listed in the dialog accessed with Settings > Configure
Filters. Change the order by selecting a filter and clicking the arrow buttons. Filters
are only applied to new incoming messages or sent messages as specified in the filter's
advanced options. To apply filters to existing messages, right-click the desired messages
and choose Apply Filter and the desired filter.

If your filters do not act as expected, monitor them with Tools > Filter Log Viewer.
When logging is enabled in this dialog, it shows how messages are processed by your
filters and can help locate the problem.
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4.3 Contacts

The contacts component uses KAddressBook. You can also start it separately with the
command kaddressbook. Configure it with Settings > Configure KAddressBook.
To search for a particular contact, use the search bar. With Filter, select to display only
contacts in a certain category. Right-click a contact to open a menu in which to select
from a variety of options, such as sending the contact information in an e-mail.

Abbildung 4.3 The Kontact Address Book
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4.3.1 Adding Contacts

To add a contact with the name and e-mail address from an e-mail, right-click the
address in the mail component and select Open in Address Book. To add a new contact
without using an e-mail, select File > New Contact in the address component. Both
methods open a dialog in which to enter information about the contact.

In the General tab, enter basic contact information, such as name, e-mail addresses,
and telephone numbers. Categories can be used to sort addresses. Details contains more
specific information, such as birthday and spouse's name.

If your contact uses an instant messenger, you can add these identities in /M Addresses.
If you do this and have Kopete or another KDE chat program running at the same time
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as Kontact, view status information about these identities in Kontact. In Crypto Settings,
enter the contact's encryption data, such as public key.

Misc has additional information, such as a photograph and the location of the user's
Free/Busy information. Use Custom Fields to add your own information to the contact
or address book.

Contacts can also be imported in a variety of formats. Use File > Import and select the
desired format. Then select the file to import.

4.3.2 Creating a Distribution List

If you frequently send e-mail messages to the same group of people, a distribution list
enables you to store multiple e-mail addresses as a single contact item so that you do
not need to enter each name individually in every e-mail you send to that group. First,
click Settings > Show Extension Bar > Distribution List Editor. In the new section that
appears, click New List. Enter a name for the list then click OK. Add contacts to the
list by dragging them from the address list and dropping them in the distribution list
window. Use this list like you would an individual contact when creating an e-mail.

4.3.3 Adding Address Books

WICHTIG: Groupware Address Books

The best way to add groupware resources is with the Groupware Wizard, a
separate tool. To use it, close Kontact then run groupwarewizard in a
command line or from the Office group of the KDE menu. Select the server
type, such as SLOX, GroupWise, or Exchange, from the list offered then enter
the address and authentication data. The wizard then adds the available
resources to Kontact.

Kontact can access multiple address books, such as shared ones offered by Novell
GroupWise or an LDAP server. Select Settings > Show Extension Bar > Address Books
to view the current address books. Press Add to add one then select the type and enter
the required information.

KDE User Guide



The check boxes in front of the address books show the activation status of each address
book. To prevent the display of a book without deleting it, uncheck it. Remove deletes
the selected book from the list.

4.4 Calendar

Kontact uses KOrganizer as its calendar component. You can also start it separately
with the command korganizer. To configure it, use Settings > Configure KOrganizer.
With the calendar, enter appointments and schedule meetings with others. If desired,
you can be reminded of upcoming events. You can also import, export, and archive
calendars with the options in File.

Abbildung 4.4 The Kontact Calendar
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4.4.1 Scheduling an Event

Add a new event or meeting with Actions > New Event. Enter the desired details. Under
Reminder, specify the exact time (minutes, hours, or days in advance) when the atten-
dees should be reminded of the event. If an event recurs, specify the appropriate interval.
Another way to create an event at a specific point in the calendar is to double-click the
corresponding field in one of the program's calendar views. This opens the same dialog
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window as that available from the menu. Alternatively, select a time range in the
Calendar view and right-click.

Specify the attendees of an event by entering their data manually in the dialog or by
inserting data from the address book. To enter data manually, select New. To import
data from the address book, click Select Addressee then select the corresponding entries
from the dialog. To schedule the event based on the participants' availability, go to
Free/Busy and click Pick Date.

Use the Recurrence tab to configure an event that happens on a regular basis. Attach-

ments can be convenient for linking other information with the event, such as an agenda
for a meeting.

4.4.2 Adding Calendars

WICHTIG: Groupware Calendars

The best way to add groupware resources is with Groupware Wizard, a separate
tool. To use it, close Kontact then run groupwarewizard in a command line
or from the Office group of the KDE menu. Select the server type, such as
SLOX, GroupWise, or Exchange, from the list offered then enter the address
and authentication data. The wizard adds the available resources to Kontact.

The calendar module can connect to multiple calendars simultaneously. This is useful,
for example, to combine a personal calendar with an organizational one. To add a new
calendar, click Add then select the calendar type. Complete the necessary fields.

The check boxes in front of the calendars show the activation status of each. To prevent
the display of a calendar without deleting it, uncheck it. Remove deletes the selected
calendar from the list.

4.5 Kontact for GroupWise Users

If you are used to working in GroupWise, you should have very little trouble adjusting
to Kontact. The two programs share many concepts and provide many of the same
services. This section discusses notable terminology differences, as well as some tips
to help GroupWise users make the most of Kontact.
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Tabelle 4.1 Kontact and GroupWise Terminology Differences

GroupWise Kontact

Appointments Events

Busy search Free/Busy

Notes Journal entries

Posted, nonposted items An event without attendees is posted. If an

event has attendees, it is a Sent item.

Tasks To-dos

4.5.1 Accessing GroupWise Mail Account

Accessing your GroupWise server is not very different from accessing an IMAP or
POP3 server. Proceed as follows:

1 Start Kontact and select the mail component (KMail).

2 Choose Settings > Configure KMail from the menu.

3 Select Accounts.

4 Create an new account with Add.

5 Choose your account type. In most cases your GroupWise account is IMAP.

6 Enter your login, password and hostname and proceed with OK.

4.5.2 Accessing GroupWise Calendar

To access your GroupWise calendar through Kontact, proceed as follows:

1 Start Kontact and open the calendar view (KOrganizer).
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2 Click on Add. You find this button on the lower left corner.
3 Choose Novell GroupWise Server and proceed with OK.

4 Enter your name, URL, user and password. The URL is your GroupWise server,
for example https://groupwise.example.com:7191/soap.

5 Apply your settings with OK and leave the configuration dialog. The calendar
view now includes your GroupWise calendar entries.

4.5.3 Tips for GroupWise Users

This section contains hints to help GroupWise users work with some of the differences
between GroupWise and Kontact:

Contact Information
You can add your GroupWise Messenger and e-mail contacts to your Kontact
contact information. Then you can create an e-mail or open an instant messaging
session with that contact by right-clicking the name in the Contact view.

Color Coding
It is helpful to color code GroupWise items, as well as items from other sources.
Color coding makes it easy to scan your e-mails, contacts, and other information
for items from a particular source.

Inviting Attendees to Events
Unlike GroupWise, Kontact does not automatically enter you as an attendee for
events you schedule. Make sure that you remember to invite yourself.

4.6 For More Information

Kontact includes help for itself and its various components. Access it with Help >
Kontact Handbook. The project's Web page, http://www.kontact .org, is also
informative.
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Kitchensync

Although mobile devices most of the times have a specialized purpose, they often pro-
vide common functionalities like address books or personal organizers. A common task
is to synchronize different utilities to have access to the same data.

Kitchensync is a graphical front-end to OpenSync. It enables you to synchronize
several different devices like mobile phones, organizers, address books or just plain
files by creating and configuring synchronization groups.

WARNUNG: Kitchensync is Experimental Software

Kitchensync and OpenSync are under heavy development. They are tested with
some devices that are available to the developers, but might behave different
with untested devices. Please do a backup of all data with the utilities provided
by the manufacturer of your device before proceeding.

Before you start to configure kitchensync, you must install several packages that are
needed for this application.

kitchensync
This is the main graphical front-end that is used for the configuration. This package
is required.

libopensync-plugin-evolution2
Use this plug-in if you intend to synchronize with Evolution 2.

libopensync-plugin-file
If you need plain file access to your data, use this plug-in.
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libopensync-plugin-gnokii
This is the Gnokii Synchronization plug-in to synchronize with Nokia mobile
phones.

libopensync-plugin-google-calendar
Google Calendar Synchronization Plug-In

libopensync-plugin-irmc
Open sync plug-in for mobile devices that support the infra red mobile communi-
cation standard.

libopensync-plugin-kdepim
Plug-in to synchronize with the KDE address book (kaddressbook).

libopensync-plugin-moto
Plug-in to synchronize Motorola mobile phones.

libopensync-plugin-opie
Plug-in to synchronize with Opie/OpenZaurus and Zaurus devices.

libopensync-plugin-palm
This plug-in supports Palm handheld devices.

libopensync-plugin-python-module
OpenSync module for Python plug-ins.

libopensync-plugin-syncml
This plug-in allows applications using OpenSync to synchronize to and from Syn-
cML based devices.

libopensync-plugin-vformat
Plug-in to support vCalendar, iCalendar and vCard formats.

All plug-in packages have their own documentation packaged. You can find this
documentation in the directory /usr/share/doc/packages/<package_name>.

To get started, run the application kit chensync. The first thing you have to do is
creating a synchronization group. In kitchensync, all devices that belong to a certain
synchronization group are updated when you run the synchronization process. For

example, a group that contains the file plug-in, the KDE pim plug-in and the plug-in
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for Motorola mobile phones could look like in Abbildung 5.1, ,,OpenSync Default

Group“ (S. 133).

Abbildung 5.1 OpenSync Default Group
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Several of the plug-ins have to be configured before synchronization can take place.
Abbildung 5.2, ,,OpenSync File Plugin® (S. 133) shows the configuration dialog of the

file plug-in that needs a directory to store all synchronization data.

Abbildung 5.2 OpenSync File Plugin
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Note, that in some cases you first must configure your device to provide the correct
interface to the computer. For example, if you want to synchronize a device with USB
storage enabled, you first have to switch to the modem interface before the device can
be used.

More detailed information about Kitchensync can be found in the Internet:

http://en.opensuse.org/OpenSync
Main information base for users of the SUSE OpenSync implementation.

http://www.opensync.org
The project page of OpenSync.

http://www.opensync.org/wiki/FAQ
Many common questions are answered here.

https://lists.sourceforge.net/lists/listinfo/opensync-users
Users mailing list for OpenSync.
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Instant Messaging with
Kopete

Kopete is an online messenger application allowing multiple partners connected to the
Internet to chat with each other. Kopete currently supports all common messenger
protocols, such as AOL* Instant Messenger (AIM), GroupWise® Messenger, ICQ,
IRC, Jabber*, Lotus* Sametime, MSN, SMS, and Yahoo!*.

6.1 Configuring Kopete

Before you can chat with your friends, you need to configure an account:

1 Open Kopete by pressing Alt + F2 and entering kopete. If Kopete does not
start, check if the package kdenetwork3-InstantMessenger isinstalled.

2 When starting Kopete for the first time, a configuration wizard appears that assists
you in creating your user profile. Otherwise, select Settings > Configure.

3 Choose Accounts and either select an account from the list to Modify or click
New to create a new account.

4 Select your messaging service. Generally, this is mostly determined by what
service your friends are using.

5 If the messaging services requires registration but you do not have an account
for this service yet, click Register New Account. In the browser window that
opens, enter your user data to register.
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6 Switch back to Kopete and enter the data received on registration with the mes-
saging service. This usually consists of the nickname or e-mail address and a
password. Complete the configuration of your account by clicking Finish.

After you have configured your account you need to add contacts to chat with them. If
you have already created an account on another PC this data is imported and automati-
cally added to your contact list. To manually create a contact entry, click File > Add
Contact. A new assistant appears to help with creation. However, you must be online
and connect with Kopete to the selected messaging service to add a contact to your list.

6.2 Chatting with Friends

It is necessary to be connected to the Internet to be able to chat with other participants.
When this is done, you should set your status by clicking File > Set Status > Online.
This establishes a connection between Kopete and the selected messaging service. After
the successful login, you are visible to others.

The main application windows features a list of contacts. You must have contacts to
chat with others. When you right-click a contact marked as online, a menu opens with
various options. Send that person a message or start a chatting session. A chat allows
invitation of additional participants for real-time discussion. Connection to all partici-
pants is closed when the creator of the chat session closes it.
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Abbildung 6.1 Chat Window
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If you want to see your previous chat session, select a contact and go to Edit > View
History. This menu item opens a dialog where you can search and view your chat ses-
sions with this person.

You can view other options by right-clicking a username. A pop-up menu opens. An
important option is Start Chat to start a chatting session. With Rename Contact and
Remove Contact, you can run the respective action. The pop-up menu also contains a
submenu item with the username where you can block the user or get user information.

TIPP: Scrolling Through Old Chat Sessions

If you want to know what you wrote during one of the last chat sessions with
a person, click a contact to open the chat window again and press Alt + « or
Alt + — to scroll through your sessions. Alternatively, use the arrow icons in
the toolbar to scroll back and forth.
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6.3 Customizing Kopete

Kopete offers numerous options to customize it according to your needs. Find some
examples in the following sections.

6.3.1 Adding Groups

Grouping contacts in your list can give a better overview. Click File > Create New
Group. Name the group and confirm this with OK. A new folder appears in the contact
list that can be used to store the desired contacts. Drag and drop contacts into the desired
folder.

Abbildung 6.2 The Main Kopete Window
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Empty groups can be disabled by activating Settings > Hide Empty Groups.
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6.3.2 Using a Global Identity

Kopete can manage several accounts which is helpful if you have friends using different
messenger protocols. Instead of creating several identities for various protocols, you
can also set up a ,,global identity*:

1 In Kopete, select Settings > Configure.
2 In the configuration window, select /dentity and activate Enable global identity.
3 Click New Identity and enter a name for your global identity.

4 Specify some details for your identity such as nickname or photo.

4a On the Nickname tab, decide if you want to use a Custom nickname or a
nickname already specified in another Kopete account.

4b If you want to add a photo, select one of the options on the Phototab.

4c In order to use data that you have already specified in KAdressbook, go to
the Address Book Link tab first. Click Change..., select your entry from the
list and click OK. Now you can switch back to the Nickname or Photo tab
and activate the address book options there.

6.3.3 Changing the Appearance

Kopete lets you install new themes, change the style of the chat window or modify
colors and fonts. To change the appearance, select Settings > Configure and click
Appearance. Find two examples below:

Installing a New Icon Theme
On the Emoticons tab, click Get New Themes... for a list of themes available from
the Internet. To download one or several themes, select an entry in the list and click
Install. The new theme is added to your list on the Emoticonstab. From there,
choose the desired theme and click Apply.
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Changing the Style of the Chat Window
Choose one of several Kopete styles available from the Chat Window tab or down-
load new styles with Get New....

6.3.4 Configuring Notifications

Kopete allows you to configure notifications for events such as contacts coming online
or going offline or an incoming message for you.

If you want to be notified if a certain contact has come online, proceed as follows:

1 Make sure all your contacts are shown in the Kopete window (otherwise select
Settings > Show offline users).

2 Right-click your preferred contact and select Properties.
3 Go to the Custom Notification tab and select A contact has gone online.

4 Decide which action should be executed for this event: Play a Sound, Display a
Message, Start a Chat or Suppress Standard Notifications.

5 Click OK to confirm your settings.

To modify the default notification options, select Settings > Configure Notifications.
Select which event is important for you and change the notification settings. For
example, if you want to be informed by a sound when any of your contacts has come
online, select A contact has come online and activate Play a sound. Select the sound
and click OK to close the configuration dialog.

6.3.5 Configuring Kopete Plug-ins

Kopete offers some nice extensions for you chat sessions which can be accessed from
Settings > Configure Plugins. For example, you can auto replace text, encrypt outgoing
messages, highlight text if the message contains some interesting words, render LaTeX
formulas, or translate messages.

KDE User Guide



6.4 For More Information

More information about Kopete and chats can be found on the following Web sites:
» Kopete Home Page [ http://kopete.kde.org/ ]

+ Common Abbreviations Used in Chat Sessions [ http://www.webopedia
.com/quick_ref/textmessageabbreviations.asp ]

+ KDE ,Internet & Network” Forum [ http://www.kde—-forum.org/board
.php?boardid=34 ]
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Using Voice over IP with Ekiga

Modern telecommunication means far more than just doing a phone call. It is also about
exchanging text messages and sometimes even video conferencing. Roaming enables
you to be reachable under one phone number all across the world. Ekiga brings these
features to your Linux desktop allowing you to communicate over broadband Internet.

Before you start, make sure the following requirements are met:
* Your sound card is properly configured.
* A headset or a microphone and speakers are attached to your computer.

+ For dialing in to regular phone networks you have created a SIP account. SIP
(Signaling protocol for Internet Telephony) is the protocol used to establish sessions
for audio and video conferencing or call forwarding. For a list of providers refer
tohttp://www.voipproviderslist.com/. Free trials are provided by
http://www.voipbuster.com.

+ For video conferencing you have attached a Web cam to your computer.

7.1 Configuring Ekiga

On first start, Ekiga comes up with a configuration assistant that requests you to enter
all data needed to configure your instance of Ekiga. To configure Ekiga, proceed as
follows:

Using Voice over IP with Ekiga
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1 Enter your user name (name and surname).

2 Enter your ekiga.net account data or choose not to sign up to ekiga
.net.

To add other accounts later on, configure them using Edit > Accounts.

3 Determine your connection type.
4 Determine the type of firewall to use to enable you to perform calls with Ekiga.

5 Choose the audio manager to use. Accept the default setting ALSA, as it gua-
rantees the best sound quality and other sound systems like OSS are not
available on openSUSE.

6 Choose the audio input and output devices and test your settings.
7 Accept the video manager selection, V4L.

8 Choose the video input device and test your settings.

9 Check the summary of your settings and apply them.

10 If registration fails after you made changes to your configuration, just restart
Ekiga.

Ekiga allows you to maintain multiple accounts. To configure an additional account,
proceed as follows:

1 Open Edit > Accounts and select Add.
2 Choose an Account Name.

3 Select an appropriate Protocol depending on what type of account you use.
Normally, you would select SIP here.

4 Enter the Registrar to which you want to register. This is usually an IP address
or a host name that will be given to you by your Internet Telephony Service
Provider. Enter User and Password according to the data provided by your pro-
vider.
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5 Leave the configuration dialog with OK and activate the account.

The status of your account displayed in the Ekiga main window changes to
Registered.

7.2 The Ekiga User Interface

All functions of Ekiga are available via the menu bar. Shortcuts to the most important
functions are provided by means of a toolbar to the left and by special key combinations.

Abbildung 7.1 Ekiga User Interface
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The user interface has different modes. To switch between views, use View > View
Mode and View > Control Panel or select the view mode icon on the left side of the
GUI and the different tabs at the bottom. The Full View is shown in Abbildung 7.1,
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,,Ekiga User Interface® (S. 145). All icons in the toolbar provide a tool tip that is activated
on hovering over the icon with your mouse pointer.

At the bottom of the user interface, several tabs provide the functionality for Dialpad,
Audio, Video and Statistics. Some settings like the Audio settings may only be changed

during a phone call.

Many of functions of Ekiga are available via keyboard shortcuts. Tabelle 7.1, ,,Keyboard
Shortcuts for Ekiga“ (S. 146) summarizes the most important ones.

Tabelle 7.1 Keyboard Shortcuts for Ekiga

Ctrl Sequence

Description

Ctrl+ 0O
Ctrl+D
Ctrl+ G
Ctrl+T
Ctrl+S
Ctrl+W
Ctrl+Q
Ctrl+E

Ctrl+P

Ctrl + +

Ctrl + -

Ctrl+ =
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Initiate a call with the current number.

Hang up.

Hold the current call.

Transfer the current call to another party.

Save the current picture to hard disk.

Close the Ekiga user interface.

Quit Ekiga.

Start the Accounts manager.

Open the Ekiga Preferences overview. This dialog
allows you to do some fine-tuning to your Ekiga set-
tings.

Zoom in to the picture of the Web cam.

Zoom out or the picture of the Web cam.

Return to the normal size of the Web cam display.



Ctrl Sequence Description

Ctrl+F Use full screen for the Web cam.

Ctrl+H Display the history of your calls.

7.3 Making a Call

Once Ekiga is configured appropriately, making a call is straightforward.

1

2

3

4

Start Ekiga using the menu or the command line.

Enter the SIP address of the other party at the SIP address prompt. The address
should look like:

« for direct local calls: sip:username@Rdomainnameor
username@hostname

« for proxied calls or calls using the service of a SIP provider:
username@sipserver oruserid@sipserver

If you have a SIP provider who accepts real phone calls, you may just enter the
number like sip:<call number>

Click Call or type Ctrl + O and wait for the other party to pick up the phone.

Once you are done or wish to end the call, click Hang up or type Ctrl + D.

If you need to tweak the sound parameters during a call, click View > View Mode >
Full View to show four tabs holding more options. The second one holds the Audio
options for Playback level and Recording level. Use the sliders to adjust both volumes
to fit your needs.
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7.4 Answering a Call

Ekiga can receive calls in two different ways. First, the user may be called directly with
sip:user@host. Alternatively, make your calls via a SIP provider. Most SIP provi-
ders enable you to get calls from a normal land line to your VoIP account. Depending
on the mode Ekiga is run, there are several ways in which you would notice an incoming
call:

Normal Application
Incoming calls can only be received and answered if Ekiga is already running. You
hear the ring sound on your headset or your speakers. If Ekiga is not running, the
call cannot be received.

Panel Applet
Normally, the Ekiga panel applet would run silently without giving any notice of
its existence. This changes as soon as a call comes in. The main window of Ekiga
opens and you hear a ring sound on your headset or speakers.

Once you have noticed an incoming call, just click Accept to pick up the phone and
start talking. If you do not want to accept this call, click Reject. It is also possible to
transfer the call to another SIP address.

7.5 Using the Address Book

Ekiga offers to manage your SIP contacts. Start the address book with 7ools > Address
book. An empty list window opens. To add a contact, first select Personal with your
mouse. Then right-click into the address window and select New Contact. Alternatively,
just press Ctrl > N.

The following entries need to be made for a valid contact:

Name
Enter the name of your contact. This may be a full name, but you can also use a
nickname here.

SIP Address
Enter a valid SIP address for your contact.
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Email
Enter the e-mail address of your contact for your own reference.

Speed Dial
With a Speed Dial you may access often used numbers more easily. However,
this is optional as well.

Categories
Add your own categories if you have many different contacts.

Local Address Book
By default, you have a local address book with the name Personal available. If you
need more address books, create them with File > New Address Book or use the
keyboard shortcut Ctrl + B.

To call any contact from the address book, double-click this contact with the mouse.
The call will be directly initiated.

7.6 For More Information

The official home page of Ekigais http://www.ekiga.org/. This site offers the
frequently asked questions as well as a more detailed documentation.

For information about the support of the H32 3 teleconferencing protocol in Linux, see
http://www.voip-info.org/wiki/view/H.323. Thisisalsoagood starting
point when searching for projects supporting VoIP.

If you intend to set up your private telephone network, you might be interested in the
PBX software Asterisk http://www.asterisk.org/. Information about this
project can also be found at http://www.voip-info.org/wiki-Asterisk.
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Accessing Network Resources

From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
openSUSE® offers various different ways of accessing and creating network shared
resources:

Network Browsing
Your file manager, Konqueror, lets you browse your network for shared resources
and services. Learn more about this in Abschnitt 8.2, ,,Accessing Network Shares*
(S. 153).

Sharing Folders in Mixed Environments
Using Konqueror, configure your files and folders to share with other members of
your network. Make your data readable or writable for users from any Windows
or Linux workstation. Learn more about this in Abschnitt 8.3, , Sharing Folders in
Mixed Environments* (S. 154).

Managing Windows Files
openSUSE can be configured to integrate into an existing Windows network. Your
Linux machine then behaves like a Windows client. It takes all account information
from the Active Directory domain controller, just as the Windows clients do. Learn
more about this in Abschnitt 8.4, ,,Managing Windows Files“ (S. 157).

Configuring and Accessing a Windows Network Printer
You can configure a Windows network printer through the KDE Control Center.
Learn how to configure this in Abschnitt 8.5, ,,Configuring and Accessing a Win-
dows Network Printer* (S. 160).
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Configuring Shortcuts to Network Folders
By creating shortcuts to remote network folders (FTP, WebDAV, Windows Network
Drives, and SSH), interacting with them can be greatly simplified. Learn how to
configure this in Abschnitt 8.6, ,,Configuring Shortcuts to Network Folders™ (S. 162).

Configuring a Small Web Server
If you need a simple way to share information with others, set up a lean Web server.
Learn how to do this in Abschnitt 8.7, ,,Configuring and Using a Small Web Server*
(S. 164).

8.1 General Notes on File Sharing and
Network Browsing

Whether and to which extent you can use file sharing and network browsing on your
machine and in your network highly depends on the network structure and on the con-
figuration of your machine. Before setting up either of them, contact your system
administrator to make sure that your network structure supports this feature and to check
whether your company's security policies permit it.

Network browsing, be it SMB browsing for Windows shares or SLP browsing for
remote services, relies heavily on the machine's ability to send broadcast messages to
all clients in the network. These messages and the clients' replies to them enable your
machine to detect any available shares or services. For broadcasts to work effectively,
your machine must be part of the same subnet as all other machines it is querying. If
network browsing does not work on your machine or the detected shares and services
do not match with what you expected, contact your system administrator to make sure
that you are connected to the appropriate subnet.

To allow network browsing, your machine needs to keep several network ports open
to send and receive network messages that provide details on the network and the
availability of shares and services. The standard openSUSE is configured for tight
security and has a firewall up and running that protects your machine against the
Internet. To adjust the firewall configuration, you would either need to ask your system
administrator to open a certain set of ports to the network or to tear down the firewall
entirely according to your company's security policy. If you try to browse a network
with a restrictive firewall running on your machine, Konqueror warns you about your
security restrictions not allowing it to query the network.
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8.2 Accessing Network Shares

Networking workstations can be set up to share folders. Typically, files and folders are
marked to let remote users access them. These are called network shares. If your system
is configured to access network shares, you can use your file manager to access these
shares and browse them just as easily as if they were located on your local machine.
Whether you have only read access or also write access to the shared folders depends
on the permissions granted to you by the owner of the shares.

To access network shares, click the Network Browsing icon on your desktop or open
Konqueror and enter remote : / in the location bar. Konqueror then opens a virtual
folder that displays the network share types that you can access. Click a network
resource type then click the network share to access. You might be required to authen-
ticate to the resource by providing a username and password.

Abbildung 8.1 Network Browsing
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8.3 Sharing Folders in Mixed
Environments

Sharing and exchanging documents is a must-have in corporate environments. Konqueror
offers you file sharing with Samba, which makes your files and folders available to
both Linux and Windows users. To configure Samba file sharing with Konqueror,
proceed as follows:

1 Open Konqueror.

2 Select Home Folder, right-click the window background and then select Properties
from the context menu.

3 Inthe Properties dialog, click the Share tab. When file sharing is not yet generally
enabled, you are informed about this on the tab. To enable file sharing or select
the files to share, click Configure File Sharing and enter the root password.

4 To enable or disable file sharing, select or deselect Enable Local Network File
Sharing.

Abbildung 8.2 Enabling File Sharing
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5 Select the appropriate sharing option: Simple sharing or Advanced sharing.
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6 To limit the number of users allowed to share folders to certain groups, click
Allowed Users, select Only users of a certain group are allowed to share folders,
click Choose Group, and select the appropriate group from the list in the window
that opens.

7 Add the folder to share to the list of shared items at the bottom of the dialog by
clicking Add and specifying the folder's exact path.

Abbildung 8.3 Detailed Sharing Options
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8 Activate Share with Samba to enable Samba file sharing. If needed, apply some
fine-tuning to the Samba options:

Name
Specify a name other than the preset default.

Public/Writable
Determine which kind of access to grant others to your share. You can grant
users full read and write access or limit their access to just reading your
shares.
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More Samba Options
These contain basic settings like name, an optional comment, and basic
access rights as well as user and security settings and an option to hide par-
ticular files and subfolders in the shared folder.

9 Apply your settings and leave the file sharing dialog with OK.
The folder icon now appears in Konqueror with a plug.

Abbildung 8.4 Shared Folder
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To revoke the share, enter the file sharing dialog again and remove the folder
from the list of shared items. The folder icon then appears without a plug.

Other members of your network can reach your share by entering smb: / in the location
bar of Konqueror and clicking the appropriate workgroup icon and hostname.

WICHTIG: Samba Domain Browsing

Samba domain browsing only works if your system's firewall is configured
accordingly. Either disable the firewall entirely or assign the browsing interface
to the internal firewall zone. Ask your system administrator about how to
proceed.
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8.4 Managing Windows Files

With your openSUSE machine being an Active Directory client as described in Kapi-
tel 27, Unterstiitzung fiir Active Directory (1Referenz), you can browse, view, and
manipulate data located on Windows servers. The following examples are just the most
prominent ones:

Browsing Windows Files with Konqueror
Use Konqueror's smb : / browsing option to browse your Windows data.

Viewing Windows Data with Konqueror
Use Konqueror to display the contents of your Windows user folder just as you
would for displaying a Linux directory. Create new files and folders on the Windows
server.

Manipulating Windows Data with KDE Applications
KDE applications, such as the Kate text editor, allow you to open files on the
Windows server, manipulate them, and save them to the Windows server.

Single-Sign-On
KDE applications, including Konqueror, support Single-Sign-On, which means
that to access other Windows resources, such as Web servers, proxy servers, or
groupware servers like MS Exchange, you do not need to reauthenticate. Authenti-

cation against all these is handled silently in the background once you provided
your username and password on login.

To access your Windows data using Konqueror, proceed as follows:
1 Press Alt + F2 and enter smb: //

This opens a Konqueror window displaying all Samba workgroups and domains
that could be found in your network.

2 Click the icon of the workgroup or domain of your AD server.
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Abbildung 8.5 Browsing Data on the AD Server
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3 Click the Users folder and select your personal user folder icon. The contents of
your My Documents folder are displayed.

To create folders in your Windows user folder using Konqueror, proceed as you would
when creating a Linux folder:

1 Right-click the background of the Konqueror folder view to open the menu.
2 Select Create New > Folder.
3 Enter the new folder's name when prompted to do so.

To create a file on the AD server, proceed as described in the following example for
the Kate text editor.

1 Press Alt + F2 and enter kate.

2 Enter your text.
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Abbildung 8.6 Editing a Text File with Kate
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3 To save the newly created text, select Save as.

4 Click the Network Folders icon to the left and select SMB Shares.

Abbildung 8.7 Saving a File to a Remote Windows Folder
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5 Navigate to your Windows folder.
6 Enter the filename and click Save.
The file is saved on the Windows server.

Make use of Konqueror's Single-Sign-On support, as in the following example—Web
access to your MS Exchange mailbox:
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1 Make sure that you have a valid MS Exchange account under your current Win-
dows user identity.

2 Request the Exchange server's address from your system administrator.

3 Press Alt + F2 and enter konqueror
http://address_exchange_server.

You are logged in to your Exchange account without having to reauthenticate.

Abbildung 8.8 Accessing MS Exchange through Konqueror
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4 Write or read your e-mails and log out as usual.

8.5 Configuring and Accessing a
Windows Network Printer

Being part of a corporate network and authenticating against a Windows Active
Directory server, you can access corporate resources, such as printers. KDE allows you
to configure printing from your Linux client to a Windows network printer.

To configure a Windows network printer for use through your Linux workstation, pro-
ceed as follows:

1 Start the KDE Control Center from the main menu.
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2 Select Peripherals > Printers.

Abbildung 8.9 Adding a Printer
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3 Select Add > Add Special (pseudo) Printer.

Abbildung 8.10 Adding Printer Details
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4 Enter the printer's name, a short description, and its location.
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5 Enter a command line similar to the following example in Command Settings:
smbclient //domain/printer -k -d 0 -c 'put %in' > /dev/null 2>&l
Replace domain and printer with the exact values matching your setup.

6 Check Enable output file and select application/postscript to pipe all your print
jobs to a postscript file.

7 Leave the printer configuration with OK.
8 Leave the KDE Control Center with File > Quit.
The printer is ready for use.

To print to the Windows network printer configured above, just select it from the list
of available printers in KPrinter.

8.6 Configuring Shortcuts to Network
Folders

With KNetAttach, you can also add new network folders to this view by clicking Add
a Network Folder in a Konqueror remote : / view. A wizard opens where you can
select the type of network folder to access and enter the details, such as a name for the
network folder, the address of the server (either the IP address or domain name), the
login name, the port, and the path to folder to access.
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Abbildung 8.11 Adding a Network Folder
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After finishing, you can access the network share in Konqueror by clicking the newly
created link instead of entering a lengthy URL for this share in the location bar.

Abbildung 8.12 New Network Folder
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If you add a network folder in this way, you can also access this folder easily when
opening or saving a file from a KDE application. If you click Network Folders in the
left-hand bar of an Open File or a Save File dialog, the network folder you added
appears.
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Abbildung 8.13 Opening a File from a Network Share
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TIPP: Linking to Network Shares on the Desktop

For quick access to network shares you need very often, you can also create
links to these resources on your desktop. To do so, select the desired resource
in Konqueror and drag it onto your desktop while keeping the left mouse
button pressed. From the context menu, select Link Here. A new icon appears
on your desktop. If you click that icon, Konqueror opens and displays the
content of this directory.

8.7 Configuring and Using a Small
Web Server

The kpf utility provides simple file sharing using HTTP (Hyper Text Transfer Protocol),
which is the same protocol used by Web sites to provide data to your Web browser.
kpf'is strictly a public file server, which means that there are no access restrictions to
shared files. Whatever you select for sharing is available to anyone.
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WICHTIG: Security Considerations

Before setting up a file server with kpf, check with your system administrator
whether your company's security policies allow this. You should never set up
a file server in a corporate or private environment if you are not entirely sure
that your network is protected by an outer firewall. Otherwise you might risk
accidentally leaking sensitive information to the Web. In addition to that, any
Web server is a potential target for hacker's exploits. Setting up a Web server
in a secure way is a very hard job and kpf was not designed to act as such a
Web server.

kpf is designed to be used for sharing files with friends, not to act as a fully-fledged
Web server like Apache. kpf was primarily conceived as an easy way to share files with
others while chatting on IRC (Internet Relay Chat, or chat rooms).

kpfis typically set up to serve files from a public_html folder in your home direc-
tory. For example, if you want to make a file available to some people with whom you
are chatting online, you can use kpf to copy the file into your public_html folder

and announce to those listening that your file is availableatht tp: //www.mymachine
.net:8001/thefile (rather than send them each an e-mail with the file attached).

1 Right-click the bottom panel in KDE then click Add Applet to Panel and select
Public File Server.

A new icon depicting a small globe appears on the bottom panel.

2 Right-click the icon then click New Server.

3 Specify the directory containing the files you want to share then click Next.
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Abbildung 8.14 Selecting the File Server Root Directory
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All files in the folder and its subfolders, including hidden files (files that start
with a dot) and symbolic links, are made publicly available, so be careful not to
share sensitive information, such as passwords, cryptographic keys, your address
book, or documents private to your organization. Make sure that any symbolic
links included do not point outside your published folder, because that would
give others access to areas of your system that are not intended for public viewing.

4 Complete the remainder of the New Server wizard to share the folder specified
in Schritt 3 (S. 165).

The directory icon now appears in Konqueror with a world icon at the bottom
right side.

Other parties wishing to connect to this server should just enter a URL like http://
hostname: 8001 into their browsers. An overview of the published content is dis-
played.
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Abbildung 8.15 Published Contents
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On the hosting machine, you can monitor the network traffic on your file server by
right-clicking the globe icon and selecting Monitor. A short set of statistics similar to
the following is given.

Abbildung 8.16 File Server Statistics
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Encryption with KGpg

KGpg is an important component of the encryption infrastructure on your system. This
program helps you to generate and manage all needed keys. Use its editor function for
the quick creation and encryption of files or use the applet in your panel to encrypt or
decrypt by dragging and dropping. Other programs, such as your mail program (Kontact
or Evolution), access the key data to process signed or encrypted contents. This chapter
covers the basic functions needed for daily work with encrypted files.

9.1 Why Signing and Encrypting?

Signing
Signing means attaching electronic signatures to mails or even software to prove
its correct derivation. To avoid that someone writes mails using your name and to
protect both you and the people you send them to, you should sign your mails.
Signatures help you to easily check the sender of the mails you receive and to dis-
tinguish good-natured mails from malicious.

Software developers sign their software so you are able to check its integrity. Even
if you have the software from an unofficial server, you can verify the package with
the signature.

Encrypting
You might have sensitive information you want to protect from other parties.
Encrypting helps you to transform data and make it unreadable for others. This is
important for companies it is important to protect internal information as well as
their employees' privacy.
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9.2 Generating a New Key Pair

To be able to exchange encrypted messages with other users, first generate your own
key pair. One part of it—the public key—is distributed to your communication partners,
who can use it to encrypt the files or e-mail messages they send. The other part of the
key pair—the private key—is used to decrypt the encrypted contents.

WICHTIG: Private Key versus Public Key

The public key is intended for the public and should be distributed to all your
communication partners. However, only you should have access to the private
key. Do not grant other users access to this data.

Start KGpg from the main menu or press Alt + F2 and enter kgpg. When you start the
program for the first time, an assistant appears to guide you through the configuration.
Follow the instructions up to the point where you are prompted to create a key. Enter
a name, an e-mail address, and, optionally, a comment. If you do not like the default
settings provided, also set the expiration time for the key, the key size, and the
encryption algorithm used. See Abbildung 9.1 .

Abbildung 9.1 KGpg: Creating a Key
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When you start KGpg in later sessions, only a small icon with a padlock appears in the
system tray. Click that icon to display the main KGpg window on your desktop.

Confirm your settings with OK. The next dialog prompts you to enter a password twice.
The relative strength of your chosen password is measured and displayed by the Pass-
word strength meter. The program generates the key pair and displays a summary. Save
and print this revocation certificate right away and keep it in a save place. You will
need the certificate to revoke your password if you forgot it. After you confirm with
OK, KGpg displays its main window. See Abbildung 9.2, ,,The Key Manager* (S. 171).

Abbildung 9.2 The Key Manager
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9.3 Exporting the Public Key

After generating your key pair, make the public key available to other users. This enables
them to use it to encrypt or sign the messages or files they send you. To make the public
key available for others, select Keys > Export Public Key(s). The dialog that opens
offers four options:

Email
Your public key is sent to a recipient of your choice by e-mail. If you activate this
option and confirm with OK, the dialog for creating a new e-mail message with
KMail appears. Enter the recipient and click Send. The recipient receives your key
and can then send you encrypted contents.

Clipboard
You can place your public key here before continuing to process it.
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Default Key Server
To make your public key available to a wide audience, export it to one of the key
servers on the Internet. For more information, refer to Abschnitt 9.5, ,, The Key
Server Dialog® (S. 173).

File
If you prefer to distribute your key as a file on a data medium instead of sending

it by e-mail, click this option, confirm or change the file path and name, and click
OK.

9.4 Importing Keys

If you receive a key in a file (for example, as an e-mail attachment), integrate it in your
key ring with /mport Key and use it for encrypted communication with the sender. The
procedure is similar to the procedure for exporting keys already described.

9.4.1 Signing Keys

Keys can be signed like every other file to guarantee their authenticity and integrity. If
you are absolutely sure an imported key belongs to the individual specified as the owner,
express your trust in the authenticity of the key with your signature.

WICHTIG: Establishing a Web of Trust

Encrypted communication is only secure to the extent that you can positively
associate public keys in circulation with the specified user. By cross-checking

and signing these keys, you contribute to the establishment of a web of trust.
For these reasons, make really sure you only sign keys you personally checked.

Select the key to sign in the key list. Select Keys > Sign Keys. In the following dialog,
designate the private key to use for the signature. An alert reminds you to check the
authenticity of this key before signing it. If you have performed this check, click Con-
tinue and enter the password for the selected private key in the next step. Other users
can now check the signature by means of your public key.
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9.4.2 Trusting Keys

Normally, you are asked by the corresponding program whether you trust the key, or
rather, whether you assume it is really used by its authorized owner. This happens each
time a message needs to be decrypted or a signature has to be checked. To avoid this,
edit the trust level of the newly imported key. By default, the newly imported key is
listed in a white box, meaning that no concrete value has been assigned for the trust
level. To trust a key, do the following;:

1 Right-click the newly imported key to access a small context menu for the key
management.

2 Select Sign Keys. KGpg opens a dialog that asks the user to recheck the fingerprint
of the key.

3 Use Continue to access the key signing dialog.

4 Select your trust level, for example, select / Have Done Very Careful Checking.
Finish this dialog.

5 Enter your passphrase to finish the key signing process. The imported key now
appears green in the trust column.

The lower the trust level is, the less you trust the signer of the key to have checked the
true identity of the keys signed. You may be entirely sure about the signer's identity,
but he may not check other people's identities properly before signing their keys. The-
refore, you could still trust him and his own key, but assign lower trust levels to the
keys signed by him. Notice that the trust level does not trigger any automatic actions
by KGpg.

9.5 The Key Server Dialog

Several Internet-based key servers offer the public keys of many users. To engage in
encrypted communication with a large number of users, use these servers to distribute
your public key. For this purpose, export your public key to one of these servers.
Similarly, KGpg enables you to search one of these servers for the keys of certain
people and import their public keys from the server. Open the key server dialog with
File > Key Server Dialog.
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9.5.1 Importing a Key from a Key Server

By means of the /mport tab in the key server dialog, import public keys from one of
the Internet-based key servers. Select one of the preconfigured key servers and enter a
search string (e-mail address of the communication partner) or the ID of the key to find.
When you click Search, your system connects to the Internet and searches the specified
key server for a key that matches your specifications. Refer to Abbildung 9.3 .

Abbildung 9.3 Search Screen for Importing a Key

Importieren | Exportieren
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If your search on the key server is successful, a list of all retrieved server entries is
displayed in a new window. Select the key to include in your key ring and click Import.
See Abbildung 9.4 . Confirm the following message with OK then exit the key server
dialog with Close. The imported key then appears in the main overview of the key
manager and is ready for use.

Abbildung 9.4 Hits and Import
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9.5.2 Exporting Your Keys to a Key Server

To export your key to one of the freely accessible key servers on the Internet, select
the Export tab in the key server dialog. Designate the target server and the key to export
by means of two drop-down menus. Then start the export with Export.

Abbildung 9.5 Exporting a Key to a Key Server
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9.6 Text and File Encryption

KGpg also offers the possibility to encrypt text or clipboard contents. Right-click the
padlock icon and find the options Encrypt clipboard and Decrypt clipboard as well as
the option for opening the integrated editor.

9.6.1 Encrypting and Decrypting the
Clipboard

Files copied to the clipboard can easily be encrypted with a few clicks. Open the func-
tion overview by right-clicking the KGpg padlock icon. Select Encrypt Clipboard and
designate the key to use. A status message about the encryption procedure is displayed
on the desktop. The encrypted contents can now be processed from the clipboard as
needed. The decryption of clipboard contents is just as easy. Simply open the menu on
the panel, select Decrypt Clipboard, and enter the password associated with your private
key. The decrypted version is now available for processing in the clipboard and in the
KGpg editor.
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9.6.2 Encrypting and Decrypting by
Dragging and Dropping

To encrypt or decrypt files, click the icons on the desktop or in the file manager, drag
them to the padlock in the panel, and drop them there. If the file is not encrypted, KGpg
asks for the key to use. As soon as you select a key, the file is encrypted without any
further messages. In the file manager, encrypted files are designated with the suffix

. asc and the padlock icon. These files can be decrypted by clicking the file icon,
dragging it to the KGpg symbol in the panel, and dropping it there. If the original
filename already exists, a dialog opens that asks how to name the file or if it should be
overwritten.

9.6.3 The KGpg Editor

Instead of creating contents for encryption in an external editor then encrypting the file
with one of the methods described above, you can use the integrated editor of KGpg
to create the file. Open the editor (Open Editor from the context menu), enter the desired
text, and click Encrypt. Then select the key to use and complete the encryption proce-
dure. To decrypt files, use Decrypt and enter the password associated with the key.

Generating and checking signatures on documents is just as easy as encrypting directly
from the editor. Select a file in the file manager and copy it to the clipboard. Right-click
the padlock icon in the panel and select Sign/Verify Clipboard. Then choose the private
key to use and enter the associated password. KGpg informs about the successful
generation of the signature. Files can also be signed from the editor by simply clicking
Sign/Verify. To check a signed file, go to File > Open Editor, load the file to check in
the editor, and click Sign/Verify.
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9.7 For More Information

For theoretical background information about the encryption method, refer to the brief
and clear introduction on the GnuPG project pages at http://www.gnupg.org/
documentation/howtos.html.en. This document also provides a list of further
information sources.
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Searching with Kerry

Kerry is a KDE front-end for the Beagle search tool, which indexes your personal
information space to help you find whatever you need. You can use Kerry to find
documents, e-mails, Web history, IM/ITC conversations, source code, images, music
files, applications, and much more.

Because Kerry is a front-end to Beagle, it needs the beagle daemon to be functional.
Kerry and Beagle can now index many KDE-specific sources of information, such as
Kopete conversations, Konqueror history, or KMail messages. The result is a smooth
integration into the KDE environment through the Kerry interface. Find more about
Beagle in GNOME User Guide.

10.1 Searching Using Kerry

To find data using the Kerry tool, follow these steps:

1 Press Alt + Space to open the Kerry Beagle Search window. Alternatively, open
the search window by left-clicking on the Kerry applet icon (a dog's head) in the
system tray.

2 Enter the term to find in Search. To quickly clear the previously entered text,
press the black arrow on the left.

The search is case insensitive. It does not matter whether you use uppercase or
lowercase characters. To search for optional terms, use the OR keyword (in
uppercase). For example, Mars OR Venus finds all data containing any occurrence
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of Mars, Venus, or both. To exclude search terms, use a minus symbol (-) in
front of them. For example, Mars -Venus finds all data containing any
occurrence of Mars but without any occurrence of Venus. To search for an exact
phrase, enclose the phrase in quotes. If you want to include only certain file type
in results, specify the filename extension with ext:. For example, Mars

ext : xml finds xml files containing Mars.

3 Select the scope of the search in the Show section of the right panel. To search
all the indexed content, choose Everything. However, you can limit the search
only to indexed Applications, Contacts, Olffice documents, instant messenger
Conversations, Images, Media files, Web pages, or File/Path names by clicking
the appropriate item in the panel. You can change the scope before or after the
search is performed.

Change the sort order of results in the Sort By section of the right panel. To sort
results by type, click Type. Sorting by Date, Name, and Relevance is also possible.
You can change the sort order before or after the search is completed.

You can limit the results by date of last modification. To show all results
regardless of the date of the last modification, click Any Date in the right panel.
You can show items modified today, since yesterday, this week, month, or year
by clicking the appropriate item in the right panel. You can change this before
or after the search is performed.

4 Press Enter or click the icon to the right of the search field to start the search.
Results are displayed in the main area of the window.

Results are displayed in a window, sorted according to your settings. Click any item to
activate it. To open a folder containing a found file instead of the file itself, click the
name of the folder to the right of the filename. To display more information about an
item, click the icon with the i on the left.

You can change the scope of the search, sort order, or limitation by date at any time by
clicking appropriate item in the panel on the right.

Use Previous results and Next results to move between pages of the result list. The
number of items found is shown in the bottom part of the window.
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10.2 Configuring Kerry

You can configure Kerry by right-clicking its icon in the tray and choosing Configure
Kerry or by clicking Configure in Kerry's main window. The configuration dialog has
four tabs.

On the Search tab, you can change the Default result sort order, Maximum number of
results displayed on one page, or shortcuts for activating Kerry Beagle Search.

On the Indexing tab, set whether the Beagle indexing service should be started automa-
tically and whether data should be indexed while the computer is operating on battery
power. You can also determine which folders should be indexed by Kerry Beagle Search
and which folders should not be indexed at all. See Abschnitt 10.2.1, ,,Indexing More
Directories“ (S. 181) and Abschnitt 10.2.2, ,,Preventing Files and Directories from Being
Indexed” (S. 182) for detailed instructions.

On the Backends tab, choose which of the available Beagle back-ends should be enabled.
To disable a back-end, uncheck it. For example, if you do not want your Kopete con-
versations be indexed by Kerry Beagle, uncheck the Kopete back-end.

On the Daemon Status tab, check the status of Beagle daemon. You can stop or start
the daemon manually here. To use Kerry Beagle Search functionality, the daemon must
be running.

10.2.1 Indexing More Directories

By default, Kerry indexes your home folder only. If you do not want your home folder
to be indexed, uncheck the Index my home folder option on the Indexing tab of the
Kerry configuration. To index more folders, follow these steps:

1 Ifthe Kerry Beagle configuration dialog is not open yet, right-click the Kerry
icon in the tray and choose Configure Kerry.

2 Click the Indexing tab.
3 Click the Add button in the middle part (/ndex) of the tab.

4 In the dialog that opens, choose the folder to index and click OK.
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5 Press OK.

10.2.2 Preventing Files and Directories from
Being Indexed

To exclude some folders or files from being indexed by Kerry, follow these steps:

1 Ifthe Kerry Beagle configuration dialog is not open yet, right-click the Kerry
icon in the tray and choose Configure Kerry.

2 Click the Indexing tab.
3 Click Add in the bottom part (Privacy) of the tab.

4 In the dialog that opens, choose a folder not to index by selecting the Folder
option. Specify the path to the folder in the text field or press the folder button
and choose the folder in a file dialog.

You can also specity files not to index by selecting File name pattern and spe-
cifying the file pattern.

5 Press OK.
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Getting Started with BasKet

BasKet is a note-taking application that allows you to collect and sort all kind of data.
It helps with writing down your ideas, making to do lists, and allocating your contacts.
You can sort the data in hierarchies and share it with other people. If needed, you can
even protect some of your baskets with passwords.

11.1 Creating Baskets

A basket is a document in which you can place notes. Create baskets that include diffe-
rent topics, contents, or projects and give each its own layout.

1 To start BasKet, open a shell with Alt + F2 and enter basket.
2 To create a basket, select Basket > New > New Basket.
3 Enter a name for your basket and select a template for its column structure.

4 The basket tree on the left side shows all your baskets.

Right-click a basket in the tree and select Properties to give it a special appearance
(background color or image and text color), change its disposition (column for-
mat), or create a shortcut for it.
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Abbildung 11.1 Basket in Use
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ANMERKUNG: Saving your Baskets

There is no need to save your work. It is saved automatically.

To assure a clearly arranged structure, you may want to create sibling baskets or sub-
baskets as well. You can do this by selecting Basket > New > New Sub-Basket. The
sub-basket appears one level down the parent basket. By selecting Basket > New > New
Sibling-Basket you create a basket in the same level as the parent basket. In both cases
the new baskets inherit the appearance and disposition from their parent baskets.

11.2 Working with Baskets

After creating your baskets and sub-baskets, fill them with different notes. Notes can
include different types of data, for example text, images, URLs, application launchers
as well as links, e-mail addresses, files and colors.
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11.2.1 Filling and Personalizing your Baskets

To insert notes into baskets, just right-click the area on the right side and choose the
type of data you need to add. You can import screen shots or colors picked from the
screen into your baskets. For a screen shot, select Insert > Grab from screen. To select
a screen color, use Insert > Color from Screen.

You may want to assign tags to your notes to structure them. Tags are marks that
represent the priority, preference, or progress of a note. Select 7ags and simply check
or uncheck the tags to assign or remove them from the selected notes. Customize the
available tags by selecting Tags > Customize.

Abbildung 11.2 Customizing Tags
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To group notes that belong together select the ones you want to group, right-click on
them and select Group. To break up a group of notes, make sure you selected the
whole group of notes, then right-click and select Ungroup.
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You can move a note within a group of notes by selecting Note > Move Up. If you want
to move a note from within a group of notes outside it, select Note > Move On Top.

11.2.2 Importing and Exporting Baskets

If you worked with other note-taking applications in the past and do not want to lose
the collected information, import these files to BasKet. You can import data from the
applications KNotes, KJots, and StickyNotes. To do that, right-click either in the tree
structure on the left side or directly on the basket into which you want to import the
notes and select Import.

After collecting and sorting a lot of data, you might want to share it with other people.
There are two ways to prepare your notes for sharing:

» Export a basket into HTML files by right-clicking the basket you want to export
and selecting Export > HTML Web Page.

+ For others to be able to open and modify your baskets, export them into basket
archives. Right-click the basket you want to export and select Export > Basket
Archive.

11.2.3 Protecting Baskets

There might be baskets that you want to protect with a password so you are the only
person who can access them. To protect a basket using a password or private and public
keys Right-click the basket and select Password.

11.2.4 Finding Data

Once you have several baskets, finding specific data can be challenging. You have
different possibilities to find the information you are looking for very quickly even
without remembering its exact title:

+ Find notes by simply typing a word or two in the filter box.

+ Ifyou are searching for notes with a certain tag assigned to them, select the desired
tag in the tag box.
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+ The icon on the right applies a filter to every basket.

The numbers in the basket tree on the left indicate how many notes match your search
options. The lock icon indicates that the basket is currently locked, so has not been
searched. For more information, see Abschnitt 11.2.3, , Protecting Baskets® (S. 186).

Baskets E¥ Filter: |mike address| I Tag: h I."%.
"I General
o My Welcome
EX': Research Mike address:
\J Tips © 245 East 47th Street. 44th Floor,

New York, NY 10017

4 4

14 notes, 1 match, O selected

11.3 For More Information

The official home page of BasKetis http://basket.kde.org/index.php.
This site offers a tour through the application, news of the latest versions, and a collec-
tion of screen shots showing different use cases.
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Browsing with Konqueror

Konqueror is not only a versatile file manager. It is also a modern Web browser. If you
start the browser with the icon in the panel, Konqueror opens with the Web browser

profile. As a browser, Konqueror offers tabbed browsing, the possibility of saving Web
pages with graphics, Internet keywords, bookmarks, and support for Java and JavaScript.

Abbildung 12.1 The Browser Window of Konqueror

Location Edit View Go Bookmarks Tools Seftings Window Help

Q QOO =KINA e,

E Location: IB http:/konqueror.kde.org/ “] ﬂ[

e

Konqueror Homepage

Konqueror - Web Browser, File Manager - and

B

[

D}

more!
Home
KDE Home Konqueror is the file manager for the K Desktop Environment. It
Announcements £ supparts basic file management on local UNIX filesystems, from simple
News L cut/copy and paste operations to advanced remote and local network file
Features browsing.
Konqueror Embedded Konqueror is the canvas for all the latest KDE technology, from KIO

slaves (which provide mechanisms for file access) to component
embedding via the KParts object interface, and it is one of the most
customizable applications available

Konqueror is an Open Source web browser with HTML 4.01 compliance,

Konqueror FAQ .
Java HOWTO 4% supporting Java applets, JavaScript, CSS 1, CSS 2.1, as well as
X

€55 Support Netscape plugins (for example, Flash or RealVideo plugins).

Download Konqueror is a universal viewing application, capable of embedding
E | read-only viewing compaonents in itself to view documents without ever

launching ancther application.

Download Konquerar

| ~dnmd RlAiars

Page loaded.

Start Konqueror from the main menu or by entering the command konqueror. To
load a Web page, enter its address in the location bar, for example, http: //www
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.opensuse.org. Konqueror now tries to reach the address and display the page.
Entering the protocol at the beginning of the address (http:// in this case) is not

strictly required. The program is able to complete the address automatically, but this
only works reliably with Web addresses. For an FTP address, always enter ftp://
at the beginning of the input field.

12.1 Tabbed Browsing

If you often use more than one Web page at a time, tabbed browsing may make it easier
to switch between them. Load Web sites in separate tabs within one window. The
advantage is that you keep more control over your desktop because you only have one
main window. After logout, the KDE session management allows for saving your Web
session in Konqueror. The next time you log in, Konqueror loads the exact URLSs visited
last time.

To open a new tab, select Window > New Tab or press Strg + Umschalttaste + N. To
change the behavior of tabs, go to Settings > Configure Konqueror. In the dialog box
that opens, select Web Behavior > Tabbed Browsing. To open new tabs instead of
windows, enable Open links in new tab instead of in new window. You can also hide
the tab bar with Hide the tab bar when only one tab is open. To see more options, press
Advanced Options.

12.2 Automatic Scrolling

In general, scrolling with the mouse is the normal way to view information farther down
a Web page. However, there are sometimes occasions when it is preferable not to use
a mouse. It can be very convenient to use key combinations instead of removing hands
from the keyboard.

To scroll down automatically, use Umschalttaste + | . This scrolls down the page without
further intervention. Increase the speed by pressing Umschalttaste + | again. Pressing
Umschalttaste + 1 slows down. To stop scrolling, use |.
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12.3 Profiles

Abschnitt 12.1, ,,Tabbed Browsing™ (S. 192) described how to handle tabs in Konqueror.
You can save your tabs with URLs and the position of the window in a profile. This
differs from the session management already mentioned. With profiles, your saved tabs
are at hand without the intensive start-up time of session management.

To create a profile, do the following:

1 Go to Settings > Configure View Profiles.

2 In the dialog box that appears, insert a name in Profile name.

3 To save your URLs, select Save URLs in profile.

4 To freeze the position and size of the windows, select Save window size in profile.
5 Approve with Save.

The next time you need your tab collection, go to Settings > Load View Profile and find
the name listed in the menu. After you select it, Konqueror restores your tabs.

12.4 Saving Web Pages and Graphics

As in other browsers, you can save Web pages. To do this, select Location > Save as
and specify a name for your HTML file. However, images are not saved. To archive
an entire Web page including the images, select Tools > Archive Web Page. Konqueror
suggests a filename that you can usually accept. The filename ends with . war, the
extension for Web archives. To view the saved Web archive later, simply click the
respective file and the Web page is displayed in Konqueror along with its images.

12.5 Searching with Konqueror

Searching with Konqueror is very convenient. You can use the search bar or Web
shortcuts.
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12.5.1 Using the Search Bar

Konqueror contains a search bar where you can choose from many search engines. If
you want to search for a specific term, proceed as follows:

1 Locate the search bar in Konqueror. It is on the right side after the location bar.

2 Click the icon inside the search bar. Choose a search engine from the pop-up
menu.

3 Insert your search term and press Eingabetaste. The result is displayed in Kon-
queror.

If you need a search engine that is not listed in the pop-up menu, add it as follows:
Prozedur 12.1 Adding More Search Engines

1 In Konqueror, click the icon in the search bar.
2 Choose Select Search Engines.
3 Make sure that Enable Web shortcuts is activated.

4 FEnable the respective search engine and close the dialog with Ok. You can see
your selected search engine if you click the icon in the search bar.

12.5.2 Using Web Shortcuts

Each search engine defined is attached to a web shortcut. This shortcut can be entered
in the location bar.

To see which are already defined, go to Settings > Configure Konqueror > Web Short-
cuts. You can see the names of the search providers and the shortcuts. Konqueror
defines many search engines: Google, Yahoo, and Lycos, and a number of less common
resources, like an acronym database, the Internet movie database, and KDE application
searches.

KDE User Guide



If you do not find your preferred search engine here, you are able to define a new one
very easily. For example, to search our home page for some interesting articles, go to
http://en.opensuse.org/,enter your query and look for the appropriate results.

Prozedur 12.2 Creating New Web Shortcuts
1 Go to the search bar, click the icon, and select Select Search Engines.
2 Make sure that Enable Web Shortcuts is activated.
3 Click New.
4 Create a new Web shortcut:

4a Assign your Web shortcut a name in Search provider name.

4b Enter the search URI. For example, if you want to search in openSUSE, use
http://en.opensuse.org/Special:Search?search=\{@Q}.
The search query is specified as \ { @ }. Get more information by clicking in
the text field labeled with Search URI and pressing Umschalttaste + F1.

4c Enter your abbreviations in UR/ shortcuts. There can more than one, separated
by commas.

5 Proceed with Ok.

After creating a new Web shortcut, you can use it in the location bar. The result is dis-
played in the current window.

TIPP: Using Shortcuts Directly without Opening Konqueror

You do not need to open Konqueror and enter the Web shortcut. You can use
it directly: select Run command from the main menu or pressAlt + F2. After
the dialog box appears, enter your shortcut, a colon (;) and your search term.
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12.6 Bookmarks

Instead of remembering and reentering addresses for sites visited often, you can book-
mark these URLs using the Bookmark menu. As well as Web page addresses, you can
also bookmark any directories of your local disk in this way.

To create a new bookmark in Konqueror, click Bookmarks > Add Bookmark. Any
bookmarks added previously are included as items in the menu. It is a good idea to
arrange the bookmark collection by subjects in a hierarchical structure, so that you do
not lose track of the different items. Create a new subgroup for your bookmarks with
New Bookmark Folder. Selecting Bookmarks > Edit Bookmarks opens the bookmark
editor. Use this program to organize, rearrange, add, and delete bookmarks.

If you are using Netscape, Mozilla, or Firefox as additional browsers, it is not
necessary to recreate your bookmarks. File > Import > Import Netscape Bookmarks in
the bookmark editor enables you to integrate your Netscape and Mozilla bookmarks
into your most current collection. The reverse is also possible via Export as Netscape
Bookmarks.

Change your bookmarks by right-clicking the entry. A pop-up menu appears in which
to select the desired action (cut, copy, delete, etc.). When you are satisfied with the
result, save the bookmarks with File > Save. If you only want to change the name or
link, just right-click the entry in the bookmark toolbar and select Properties. Change
the name and location and confirm with Update.

To save your bookmark list and have instant access to it, make your bookmarks visible
in Konqueror. Select Settings > Toolbars > Bookmark Toolbar (Konqueror). A bookmark
panel is automatically displayed in the current Konqueror window.

12.7 Java and JavaScript

Do not confuse these two languages. Java is an object-oriented, platform-independent
programming language from Sun Microsystems. It is frequently used for small programs
(applets), which are executed over the Internet for things like online banking, chatting,
and shopping. JavaScript is an interpreted scripting language mainly used for the
dynamic structuring of Web pages, for example, for menus and other effects.
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Konqueror allows you to enable or disable these two languages. This can even be done
in a domain-specific way, which means that you can permit access for some hosts and
block access for others. Java and JavaScript are often disabled for security reasons.
Unfortunately, some Web pages require JavaScript for correct display.

12.8 Enabling Advertisement Blockers

Some Web pages open annoying advertisements. With the help of Konqueror, these
windows can be blocked. Proceed as follows:

Prozedur 12.3 Blocking Advertisements
1 Select in Konqueror Settings > Configure Konqueror > AdBlock Filter.
2 Activate Enable filters.
3 Click Insert.

4 Enter an expression for the Web page to filter. For example:

http://www.example.com/*

This filters everything that comes from that URL.

12.9 For More Information

For any questions or problems that arise when working with Konqueror, refer to the
application's handbook, which is available from the Help menu. Konqueror also has a
Web page, located at http://www.konqueror.org.
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Browsing with Firefox

Included with your openSUSE® is the Mozilla Firefox Web browser. With features
like tabs, pop-up window blocking, and download and image management, Firefox
combines the latest Web technologies. You can view more than one Web page in a
single window. You can suppress annoying advertisements and disable images that
only slow you down. Its easy access to different search engines helps you find the
information you need. Start the program from the main menu or by entering the command
firefox. The main program features are described in the following sections.

13.1 Navigating Web Sites

Firefox has much the same look and feel as other browsers. It is shown in Abbil-
dung 13.1, ,,The Browser Window of Firefox* (S. 200). The navigation toolbar includes
Forward and Back and a location bar for a Web address. Bookmarks are also available
for quick access. For more information about the various Firefox features, use the Help
menu.
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Abbildung 13.1 The Browser Window of Firefox
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13.1.1 Tabbed Browsing

If you often use more than one Web page at a time, tabbed browsing may make it easier
to switch between them. Load Web sites in separate tabs within one window.

To open a new tab, select File > New Tab. This opens an empty tab in the Firefox
window. Alternatively, right-click a link and select Open link in new tab. Right-click
the tab itself to access more tab options. You can create a new tab, reload one or all
existing tabs, or close them. You can also change the sequence of the tabs by dragging
and dropping them on a requested position.

13.1.2 Using the Sidebar

Use the left side of your browser window for viewing bookmarks or the browsing his-
tory. Extensions may add new ways to use the sidebar as well. To display the Sidebar,
select View > Sidebar and select the desired contents.
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13.2 Finding Information

There are two ways to find information in Firefox: the search bar and the find bar. The
search bar looks for pages while the find bar looks for things on the current page.

13.2.1 Finding Information on the Web

Firefox has a search bar that can access different engines, like Google, Yahoo, or
Amazon. For example, if you want to find information about openSUSE using the
current engine, click in the search bar, type openSUSE, and hit Enter. The results
appear in your window. To choose your search engine, click the icon to the left of the
search bar. A menu opens with a list of available search engines.

13.2.2 Installing a Different Search Engine

If you favorite search engine is not listed, Firefox gives you the possibility to configure
it. Try the following steps:

1 Establish an Internet connection first.

2 Click the icon to the left of the search bar.

3 Select Manage Search Engines from the menu.
4 Click Get more search engines.

5 Firefox displays a Web page with available search engines. You can choose from
Wikipedia, IMDB, Flickr, and others. Click the desired search plug-in.

6 Install your search plug-in with Add or abort with Cancel.

13.2.3 Searching in the Current Page

To search inside a Web page, click Edit > Find in This Page or press Ctrl + F. The find
bar opens. Usually, it is displayed at the bottom of a window. Type your query in the
input field. Firefox finds the first occurrence of this phrase. You can find other occur-
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rences of the phrase by pressing F3 or Next button in the find bar. You can also highlight
all occurrences by pressing the Highlight all button. Checking the Match case option
makes the query case sensitive.

13.3 Managing Bookmarks

Bookmarks offer a convenient way of saving links to your favorite Web sites. To add
the current Web site to your list of bookmarks, click Bookmarks > Bookmark This Page.
If your browser currently displays multiple Web sites on tabs, only the URL on the
currently selected tab is added to your list of bookmarks.

When adding a bookmark, you can specify an alternative name for the bookmark and
select a folder where Firefox should store it. To bookmark Web sites on multiple tabs,
select Bookmark All Tabs. Firefox creates a new folder that includes bookmarks of each
site displayed on each tab. To remove a Web site from the bookmarks list, click Book-
marks, right-click the bookmark in the list, then click Delete.

13.3.1 Using the Bookmark Manager

The bookmark manager can be used to manage the properties (name and address loca-
tion) for each bookmark and organize the bookmarks into folders and sections. It
resembles Abbildung 13.2, ,,Using the Firefox Bookmark Manager® (S. 203).
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Abbildung 13.2 Using the Firefox Bookmark Manager
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To open the bookmark manager, click Bookmark > Organize Bookmarks. A window
opens and displays your bookmarks. With New Folder, create a new folder with a name
and a description. If you need a new bookmark, click New Bookmark. This lets you
insert the name, location, keywords, and also a description. The keyword is a shortcut
to your bookmark. If you need your newly created bookmark in the sidebar, check Load
this bookmark in the sidebar.

13.3.2 Importing Bookmarks from Other
Browsers

If you used a different browser in the past, you probably want to use your old bookmarks
in Firefox, too. Firefox allows to import bookmarks from other browsers installed on
your system such as Netscape or Opera. It also allows to import bookmarks from a file
exported from a browser on different computer.

To import your settings, click File > Import. Select the browser from which to import
settings and click Next or choose a file. Find your imported bookmarks in a newly
created folder, beginning with From.
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13.3.3 Live Bookmarks

Live bookmarks display headlines in your bookmark menu and keep you up to date
with the latest news. This enables you to save time with one glance at your favorite
sites.

Many sites and blogs support this format. A Web site indicates this by showing an
orange icon in the right part of the location bar. Click it and choose Subscribe to NAME
OF THE FEED. Click Subscribe now in the page that opens. A dialog box opens in
which to select the name and location of your live bookmark. Confirm with Add.

Some sites do not tell Firefox that they support a news feed, although they actually do.
To add a live bookmark manually, you need the URL of the feed. Do the following;:

Prozedur 13.1 Adding a Live Bookmark Manually

1 Open the bookmark manager with Bookmarks > Organize Bookmarks. A new
window opens.

2 Select File > New Live Bookmark. A dialog box opens.

3 Insert a name for the live bookmark and add your URL in the Feed Location, for
example, http://www.novell.com/newsfeeds/rss/coolsolutions
.xml. Firefox updates your live bookmarks.

4 Close your bookmark manager.

13.4 Using the Download Manager

With the help of the download manager, keep track of your current and past downloads.
To open the download manager, click Tools > Downloads. Firefox opens a window
with your downloads. While downloading a file, see a progress bar and the current file.
If necessary, pause a download and resume it later. To open a downloaded file, click
Open. With Remove, remove it from the list. If you need information about the file,
right-click the filename and choose Properties.
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If you need further control of the download manager, open the configuration window
from Edit > Preferences and go to the Main tab. Here, determine the download folder
and how the manager behaves.

13.5 Customizing Firefox

Firefox can be customized extensively. You can install extensions, change themes, and
add smart keywords for your online searches.

13.5.1 Extensions

Mozilla Firefox is a multifunctional application, which means that you can download
and install add-ons, known as extensions. For example, add a new download manager
and mouse gestures. This has the advantage that Firefox itself stays small and lean.

To add an extension, click Tools > Add-ons > Extensions. In the bottom-right corner,
click Get Extensions to open the Mozilla extensions update Web page where you can
choose from a variety of available extensions. Click the extension to install then click
the install link to download and install it. When you restart Firefox, the new extension
is functional. You can also look at the various extensions at http://addons
.mozilla.org/.

Abbildung 13.3 Installing Firefox Extensions
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13.5.2 Changing Themes

If you do not like the standard look and feel of Firefox, install a new theme. Themes
do not change the functionality, only the appearance of the browser. When installing a
theme, Firefox asks for confirmation first. Allow the installation or cancel it. After a
successful installation, you can enable the new theme.

1 Click Tools > Add-ons > Themes.

2 In the new dialog that appears, click Get Themes. If have you already installed
a theme, find it in the list, as in Abbildung 13.4, , Installing Firefox Themes®

(S. 206).

Abbildung 13.4 Installing Firefox Themes
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3 Anew window appears with the Web site ht tps: //addons.mozilla.org.

4 Choose a theme and click Install Now.

5 Confirm the download and installation.

6 After downloading the theme, select the theme from the list of themes then click

Use Theme.

7 Close the window and restart Firefox.
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You can always switch between installed themes by clicking Tools > Add-ons > Themes
and then Use Theme. However, Firefox has to be restarted for the change to take effect.
If you do not use a theme anymore, you can delete it in the same dialog with Uninstall.

13.5.3 Adding Smart Keywords to Your
Online Searches

Searching the Internet is one of the main tasks a browser can perform for you. Firefox
lets you define your own smart keywords: abbreviations to use as a ,,command* for
searching the Web. For example, if you use Wikipedia often, use a smart keyword to
simplify this task:

1 Gotohttp://en.wikipedia.org.

2 After Firefox displays the Web page, see the search text field. Right-click it then
choose Add a Keyword for this Search from the menu that opens.

3 The Add Bookmark dialog appears. In Name, name this Web page, for example,
Wikipedia (en).

4 For Keyword, enter your abbreviation of this Web page, for example, wiki.

5 With Create in, choose the location of the entry in your bookmarks section. You
can put it into any folder.

6 Finalize with Add.
You have successfully generated a new keyword. Whenever you need to look into

Wikipedia, you do not have to use the entire URL. Just type wiki Linux to view an
entry about Linux.

13.6 Printing from Firefox

Configure the way Firefox prints the content it displays using the Page Setup dialog.
Click File > Page Setup then go to the Format & Options tab to select the orientation
of your print jobs. You can scale or make it adjust automatically. To print a background,
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select Print Background (colors & images). Click the Margins & Header/Footer tab
to adjust margins and select what to include in the headers and footers.

After you configured your settings, print a Web page with File > Print. Select the
printer or a file in which to save the output. With Properties, set the paper size, specify
the print command, choose grayscale or color, and determine the margins. When satisfied
with your settings, approve with Print.

13.7 For More Information

Get more information about Firefox from the official home page at http://www
.mozilla.com/firefox/. Refer to the integrated help to find out more about
certain options or features.
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Transferring Data from the

Internet

KGet is the download manager for KDE. It manages your transfers in a window. You
can stop, resume, delete, queue, and add transfers. Start KGet from the main menu or
by pressing Alt + F2 then entering kget.

When KGet is started for the first time, you can choose to have it integrated with Kon-
queror. If you integrate KGet with Konqueror, KGet is added to the system tray as an
icon with a downward arrow. Click this arrow to view KGet transfers.

Abbildung 14.1 KGet
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14.1 Adding Transfers to the List

To add a transfer, click File > Paste. Specify a URL then click OK. Finally, select

where to save the downloaded file. The entry for the transfer is added to the main window
of KGet and the download starts. Another way to add a transfer is to simply drag a file
(for example, from an FTP server) from Konqueror and drop it in the main KGet window.

TIPP: Using the Drop Target

To occasionally add transfers to the list while not leaving the KGet window on
the desktop all the time, select Settings > Show Drop Target and minimize the
KGet window. Now you can drag and drop transfers to the blue arrow displayed
instead.

Modify the preferences for your downloads by clicking Settings > Configure KGet.

14.2 Adding Transfers from a File

If you want to download several files from a number of different locations, you can
collect the download links in a text file to be imported in KGet. This is very convenient
because you do not have to add each URL separately to the transfer list. KGet can parse
the URLs in the text file, provided they start at the left margin of the file. Select File >
Import Text File... to use this feature. For each URL, you need to specify a location
where to save the downloaded file. After this, KGet starts the download.

14.3 Timer-Controlled Transfers

You can configure KGet to perform transfers at a specific time.

1 Start KGet.

2 Click Options > Offline Mode. All transfers inserted from this point are not started
immediately but are queued.

3 To start the clock, double-click the entry then click Advanced.

KDE User Guide



4 Enter the day, month, year, and time to start the transfer, click the Timer icon,
then close the dialog.

5 After making the desired settings for all your transfers, click Options > Offline
Mode to set KGet back in online mode.

The transfers should start at the specified times.

TIPP: Export Transfer Lists

If you have added a number of downloads to the file transfer list and need this
list for another computer, select Options > Offline mode. Select the list entries
you want to export and choose File > Export Transfer List. KGet saves the entries
to a *. kgt file which you can then import from another computer.
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Reading News Feeds with
Akregator

If you want to get the latest news, get your information with a news feed reader. One
reader is Akregator. It connects to a server that contains a newsticker file and downloads
it then shows the headlines and sometimes a small text to give an overview. See
Abbildung 15.1, ,,Akregator Showing Some News* (S. 213). If interested in this news,
click it and view it in a separate tab.

Abbildung 15.1 Akregator Showing Some News
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Akregator contains some predefined news feeds for KDE. You can add news feeds
manually or some Web sites announce it. For example, a Web site with feed support
contains in Konqueror an orange rectangle in the bottom right corner. Click it to open
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a pop-up menu where you can select Add Feed to Akregator. Sometimes a Web site
does not announce that it supports a news feed. Then you can search this site with some
keywords like feed or rss. Sometimes you are successful and can obtain a link.

To add a news feed, do the following:
Prozedur 15.1 Adding a News Feed to Akregator

1 Determine the URL of your news feed. Normally this can be found on your pre-
ferred Web site. More links can be found in the KNewsticker tool, an applet for
the KDE panel.

2 Open Akregator by pressing Alt + F2 and entering akregator. It opens a new
window with the list of all feeds in your configuration. If you close this window,
it docks in the system tray.

3 Create a new folder with Feed > New Folder. This gives you the opportunity to
group your feeds in categories.

4 Name your new folder.
5 Click this folder and choose Feed > Add Feed.

6 Insert the feed URL, for example, http: //www.novell.com/newsfeeds/
rss/coolsolutions.xml. A new window opens where you can change
the feed name, URL, or the update interval. With the Feed Archive tab, change
how long articles should be stored.

7 Proceed with Ok. Akregator downloads the latest articles.

After the download of the latest headers is finished, you can click an entry. Depending
on the feed, this can list a small summary or just a link. With Complete Story, read the
entire article.

Check for new news manually with Fetch Feed. Another option is to specify an update
interval. Configure this by clicking Settings > Configure Akregator. A window opens
where you can select the interval in General > Use interval fetching. Confirm with Ok.

You can read the complete story in Akregator or an external browser. Clicking Complete
Story lets you select which.
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Manipulating Graphics with
The GIMP

The GIMP (The GNU Image Manipulation Program) is a program for creating and
editing raster graphics. In most aspects, its features are comparable to those of Adobe
Photoshop and other commercial programs. Use it to resize and retouch photographs,
design graphics for Web pages, create covers for your custom CDs, or almost any other
graphics project. It meets the needs of both amateurs and professionals.

Like many other Linux programs, The GIMP is developed as a cooperative effort of
developers worldwide who volunteer their time and code to the project. The program
is under constant development, so the version included in your system may vary
slightly from the version discussed here. The layout of the individual windows and
window sections is especially likely to vary.

The GIMP is an extremely complex program. Only a small range of features, tools, and
menu items are discussed in this chapter. See Abschnitt 16.7, ,,For More Information®
(S. 232) for ideas of where to find more information about the program.

16.1 Graphics Formats

There are two main types of graphics—raster and vector. The GIMP is intended for
working with raster graphics, which is the normal format for photographs and scanned
images. Raster graphics consist of pixels—small blocks of color that together create
the entire image. The files can easily become quite large because of this. It is also not
possible to increase the size of a pixel image without losing quality. The GIMP supports
most common formats of raster graphics.

Manipulating Graphics with The GIMP

217



218

Unlike raster graphics, vector graphics do not store information for all individual pixels.
Instead, it uses geometrical primitives such as points, lines, curves, and polygons.
Vector images can be scaled very easily. There are many specialized applications for
vector graphics, for example Inkscape. The GIMP has only a very limited support for
vector graphics. For example, the GIMP can open and rasterize vector graphics in SVG
format or work with vector paths.

16.2 Starting The GIMP

Start The GIMP from the main menu. Alternatively, enter gimp & in a command line.

16.2.1 Initial Configuration

When starting The GIMP for the first time, a configuration wizard opens for preparatory
configuration. The default settings are acceptable for most purposes. Press Continue in
each dialog unless you are familiar with the settings and prefer another setup.

16.2.2 The Default Windows

Three windows appear by default. They can be arranged on the screen and, except the
toolbox, closed if no longer needed. Closing the toolbox closes the application. In the
default configuration, The GIMP saves your window layout when you exit. Dialogs
left open reappear when you next start the program.

The Toolbox

The main window of The GIMP, shown in Abbildung 16.1, ,, The Main Window*

(S. 219), contains the main controls of the application. Closing it exits the application.
At the very top, the menu bar offers access to file functions, extensions, and help. Below
that, find icons for the various tools. Hover the mouse over an icon to display informa-
tion about it.
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Abbildung 16.1 The Main Window
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The current foreground and background color are shown in two overlapping boxes. The
default colors are black for the foreground and white for the background. Click the box
to open a color selection dialog. Swap the foreground and background color with the
bent arrow symbol to the upper right of the boxes. Use the black and white symbol to
the lower left to reset the colors to the default.

To the right, the current brush, pattern, and gradient are shown. Click the displayed one
to access the selection dialog. The lower portion of the window allows configuration
of various options for the current tool.

Under the toolbox, a dialog shows options for the currently selected tool. If it is not
visible, open it by double-clicking the tool's icon in the toolbox.

Layers, Channels, Paths, Undo
In the first section, use the drop-down box to select the image to which the tabs refer.

By clicking Auto, control whether the active image is chosen automatically. By default,
Auto is enabled.
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Layers shows the different layers in the current images and can be used to manipulate
the layers. Information is available in Abschnitt 16.5.6, ,,Layers® (S. 230). Channels
shows and can manipulate the color channels of the image.

Paths are a vector-based method of selecting parts of an image. They can also be used
for drawing. Paths shows the paths available for an image and provides access to path
functions. Undo shows a limited history of modifications made to the current image.
Its use is described in Abschnitt 16.5.5, ,,Undoing Mistakes* (S. 230).

16.3 Getting Started

Although The GIMP can be a bit overwhelming for new users, most quickly find it
easy to use once they work out a few basics. Crucial basic functions are creating, ope-
ning, and saving images.

16.3.1 Creating a New Image

To create a new image, select File > New or press Ctrl+ N. This opens a dialog in which
to make settings for the new image. If desired, select a predefined setting called a
Template. To create a custom template, select File > Dialogs > Templates and use the
controls offered by the window that opens.

In the /mage Size section, set the size of the image to create in pixels or another unit.
Click the unit to select another unit from the list of available units. The ratio between
pixels and a unit is set in Resolution, which appears when the Advanced Options section
is opened. A resolution of 72 pixels per inch corresponds to common screen display.
It is sufficient for Web page graphics. A higher resolution should be used for images
to print. For most printers, a resolution of 300 pixels per inch results in an acceptable
quality.

In Colorspace, select whether the image should be in color (RGB) or Grayscale. For
detailed information about image types, see Abschnitt 16.5.7, ,,Image Modes* (S. 230).
In Fill With select the color the image is filled with. You can choose between Foreground
Color and Background Color set in the toolbox, White or Transparency for a transparent
image. Transparency is represented by a gray checkerboard pattern. Enter a comment
for the new image in Comment.
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When the settings meet your needs, press OK. To restore the default settings, press
Reset. Pressing Cancel aborts creation of a new image.

16.3.2 Opening an Existing Image

To open an existing image, select File > Open or press Ctrl+ O. In the dialog that opens,
select the desired file. You can also press Ctrl + L and type directly the path to the
desired image. Then click Open to open the selected image or press Cancel to skip
opening an image.

16.3.3 Scanning an Image

Instead of opening an existing image or creating a new one, you can scan one. To scan
directly from The GIMP, make sure that the package xsane is installed. To open the
scanning dialog, select File > Acquire > XSane: Device dialog.

Create a preview when the object to scan is smaller than the total scanning area. Press
Acquire preview in the Preview dialog to create a preview. If you want to scan only
part of the area, select the desired rectangular part with the mouse.

In the xsane dialog, select whether to scan a binary (black and white without shades of
gray), grayscale, or color image and the required scan resolution. The higher the reso-
lution you choose, the better is the quality of the scanned image. However, this also
results in a correspondingly larger file and the scanning process can take a very long
time at higher resolutions. The size of the final image (both in pixels and bytes) is shown
in the lower part of the dialog.

In the xsane dialog, use the sliders to set desired gamma, brightness, and contrast values.
These sliders are not available in binary mode. Changes are visible in the preview
immediately. Once all settings have been made, click Scan to scan the image.

16.3.4 The Image Window

The new, opened, or scanned image appears in its own window. The menu bar in the
top of the window provides access to all image functions. Alternatively, access the
menu by right-clicking the image or clicking the small arrow button in the left corner
of the rulers.
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File offers the standard file options, such as Save and Print. Close closes the current
image. Quit closes the entire application.

With the items in the View menu, control the display of the image and the image window.
New View opens a second display window of the current image. Changes made in one
view are reflected in all other views of that image. Alternate views are useful for
magnifying a part of an image for manipulation while seeing the complete image in
another view. Adjust the magnification level of the current window with Zoom. When
Shrink Wrap is selected, the image window is resized to fit the current image display
exactly.

16.4 Saving Images

No image function is as important as File > Save. It is better to save too often than too
rarely. Use File > Save as to save the image with a new filename. It is a good idea to
save image stages under different names or make backups in another directory so you
can easily restore a previous state.

When saving for the first time or using Save as, a dialog opens in which to specify the
filename and type. Enter the filename in the field at the top. For Save in folder, select
the directory in which to save the file from a list of commonly used directories. To use
a different directory or create a new one, open Browse for other folders. It is recommen-
ded to leave Select File Type set to By Extension. With that setting, The GIMP determines
the file type based on the extension appended to the filename. The following file types
are frequently useful:

XCF
This is the native format of the application. It saves all layer and path information
along with the image itself. Even if you need an image in another format, it is
usually a good idea to save a copy as XCF to simplify future modifications. Infor-
mation about layers is available in Abschnitt 16.5.6, ,,Layers® (S. 230).

PAT
This is the format used for The GIMP patterns. Saving an image in this format
enables using the image as a fill pattern in The GIMP.

JPEG
JPG or JPEG is a common format for photographs and Web page graphics without
transparency. Its compression method enables reduction of file sizes, but informa-
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tion is lost when compressing. It may be a good idea to use the preview option
when adjusting the compression level. Levels of 85% to 75% often result in an
acceptable image quality with reasonable compression. Saving a backup in a lossless
format, like XCF, is also recommended. If editing an image, save only the finished
image as JPG. Repeatedly loading a JPG then saving can quickly result in poor
image quality.

GIF
Although very popular in the past for graphics with transparency, GIF is less often
used now because of license issues. GIF is also used for animated images. The
format can only save indexed images. See Abschnitt 16.5.7, ,,Image Modes* (S. 230)
for information about indexed images. The file size can often be quite small if only
a few colors are used.

PNG
With its support for transparency, lossless compression, free availability, and
increasing browser support, PNG is replacing GIF as the preferred format for Web
graphics with transparency. An added advantage is that PNG offers partial transpa-
rency, which is not offered by GIF. This enables smoother transitions from colored
areas to transparent areas (antialiasing).

To save the image in the chosen format, press Save. To abort, press Cancel. If the image
has features that cannot be saved in the chosen format, a dialog appears with choices
for resolving the situation. Choosing Export, if offered, normally gives the desired
results. A window then opens with the options of the format. Reasonable default values
are provided.

16.5 Editing Images

The GIMP provides a number of tools for making changes to images. The functions
described here are those most interesting for home users.

16.5.1 Changing the Image Size

Once an image is scanned or a digital photograph is loaded from the camera, it is often
necessary to modify the size for display on a Web page or for printing. Images can
easily be made smaller either by scaling them down or by cutting off parts of them.
Making an image larger is much more problematic. Because of the nature of raster
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graphics, quality is lost when an image is made larger. It is recommended to keep a
copy of your original image before scaling or cropping.

Cropping an Image

Cropping an image works like cutting the edges off a piece of paper. Select the crop
tool from the toolbox (it resembles a scalpel) or with Tools > Transform Tools > Crop
& Resize. Click a starting corner and drag to outline the area to keep.

A small window opens with information about the starting point and the size of the
selected area. Adjust these values by clicking and dragging a corner of the crop box or
by adjusting the values in the window. From Selection adjusts the crop to fit the current
selection (selections are explained in Abschnitt 16.5.2, ,,Selecting Parts of Images*
(S. 225)). Auto Shrink makes the crop smaller based on color changes in the image.

Press Cancel to abort the crop. Press Crop to crop the image. The results of Resize are
identical to those of Change Canvas Size, described in ,,Changing the Canvas Size*
(S.224).

Scaling an Image

Select Image > Scale Image to change the overall size of an image. Select the new size
by entering it in Width or Height. To change the proportions of the image when scaling
(this distorts the image), click the chain icon to the right of the fields to break the link
between them. When those fields are linked, all values are changed proportionately
when the value in one of the fields is changed. Adjust the resolution with X resolution
and Y resolution.

Interpolation is an expert option that controls the scale method. When finished adjusting
the size, press Scale to scale the image. Reset restores the original values. Cancel aborts
the procedure.

Changing the Canvas Size

Changing the canvas size is like putting a mat around an image. Even if the mat is
smaller, the rest of the image is there, but you can only see part of it. If the mat is larger,
you see the original image with extra space around it. To do this, select Image > Canvas
Size.
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In the dialog that opens, enter the new size. By default, the width and height maintain
the same proportions as the current image. To change this, click the chain icon.

After adjusting the size, determine how the existing image should be positioned in
comparison to the new size. Use the offset values or drag the box inside the frame at
the bottom. When satisfied with the changes, click Resize to change the canvas size.
Click Reset to restore the original values or Cancel to cancel the canvas resize.

16.5.2 Selecting Parts of Images

It is often useful to perform an image operation on only part of an image. To do this,
the part of the image with which to work must be selected. Areas can be selected using
the select tools available in the toolbox, using the quick mask, or combining different
options. Selections can also be modified with the items under Select. The selection is
outlined with a dashed line, called marching ants.

Using the Selection Tools

The main select tools are rather easy to use. The paths tool, which can also be used for
more than selecting, is more complicated so is not described here. In the tool options
for the other select tools, use one of the icons in the Mode row to determine whether
the selection should replace, be added to, be subtracted from, or intersect with an existing
selection.

Rect Select
This tool can be used to select rectangular or square areas. In the tool options, select
among Free Select, Fixed Size, and Fixed Aspect Ratio to control the shape and
size of the selection. To make a square selection in the free select mode, hold Shift
while selecting a region.

Ellipse Select
Use this to select elliptical or circular areas. The same options are available as with
rectangular selection. Holding Shift during selection produces a circle.

Free Select (Lasso)
Draw a selection area freehand with this tool by dragging the mouse over the image
with the left mouse button pressed. The end points will be connected with a straight
line when you release the tool. The area inside is then selected.
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Fuzzy Select (Magic Wand)
This tools selects a continuous region based on color similarities. Set the maximum
difference between colors in the tool options dialog in Threshold.

By Color Select
With this, select all the pixels in the image with the same or similar color as the
clicked pixel. The maximum difference between colors can be set in the tool options
dialog in Threshold.

Intelligent Scissors
Click a series of points in the image. As you click, the points are connected based
on color differences. Click on the first point to close the area. Convert it to a regular
selection by clicking inside it.

Using the Quick Mask

The quick mask is a way of selecting parts of an image using the paint tools. A good
way to use it is to make a rough selection using the intelligent scissors or the lasso
(freehand selection tool). Then activate the quick mask by pressing the small icon with
the dashed box in the lower left corner.

The quick mask displays the selection using an overlay of red. Areas shaded with red
are not selected. Areas appearing as they did before the mask was activated are selected.
To modify the selection, use the paint tools. Painting with white selects the painted
pixels. Painting with black deselects pixels. Shades of gray (colors are treated as shades
of gray) are a partial selection. Partial selection allows smooth transitions between
selected and unselected areas.

To use a different color for displaying the quick mask, right-click the quick mask button
then select Configure Color and Opacity from the menu. Click the colored box in the
dialog that opens to select a new color.

After using the paint tools to adjust the selection as desired, convert from the quick
mask view back to the normal selection view by clicking the icon in the lower left corner
of the image window (currently displaying a red box). The selection is again displayed
with the marching ants.

KDE User Guide



16.5.3 Applying and Removing Color

Most image editing involves applying or removing color. By selecting a part of the
image, limit where color can be applied or removed. When you select a tool and move
the cursor onto an image, the cursor's appearance changes to reflect the chosen tool.
With many tools, an icon of the current tool is shown along with the arrow. For paint
tools, an outline of the current brush is shown, allowing you to see exactly where you
will be painting in the image and how large an area will be painted.

Selecting Colors

Paint tools use the foreground color. To select the color, first click the display box of
the foreground color. A dialog with four tabs opens. These tabs provide different color
selection methods. Only the first tab, shown in Abbildung 16.2, ,, The Basic Color
Selector Dialog™ (S. 227), is described here. The new color is shown in Current. The
previous color is shown in Old.

Abbildung 16.2 The Basic Color Selector Dialog
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The easiest way to select a color is using the colored areas in the boxes to the left. In
the narrow vertical bar, click a color similar to the desired color. The larger box to the
left then shows available nuances. Click the desired color. It is then shown in Current.
If that color is not what you want, try again.

The arrow button to the right of Current enables saving a number of possible colors.
Click the arrow to copy the current color to the history. A color can then be selected
by clicking it in the history. A color can also be selected by directly entering its hexa-
decimal color code in HTML Notation.
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The color selector defaults to selecting a color by hue, which is usually easiest for a
new user. To select by saturation, value, red, green, or blue, select the corresponding
radio button to the right. The sliders and number fields can also be used to modify the
currently selected color. Experiment a bit to find out what works best for you.

When the desired color is shown in Current, click OK. To restore the original values
shown when the dialog was opened, click Reset. To abort changing the color, click
Cancel.

To select a color that already exists in your image, use the color picker tool, the icon
for which resembles an eye dropper. With the tool options, set whether the foreground
or background color should be selected. Then click a point in the image that shows the
desired color. When the color is right, click Close to close the tool's dialog.

Painting and Erasing

To paint and erase, use the tools from the toolbox. There are a number of options
available to fine-tune each tool. Pressure sensitivity options apply only when a pressure-
sensitive graphics tablet is used.

The pencil, brush, airbrush, and eraser work much like their real-life equivalents. The
ink tool works like a calligraphy pen. Paint by clicking and dragging. The bucket fill
is a method of coloring areas of an image. It fills based on color boundaries in the image.
Adjusting the threshold modifies its sensitivity to color changes.

Adding Text

With the text tool, easily add text to an image. With the tool options, select the desired
font, font size, color, justification, indent, and line spacing. Then click a starting point
in the image. A small dialog opens in which to enter your text. Enter single or multiple
lines of text then press Close.

The text tool creates text on a special layer. To work with the image after adding text,
read Abschnitt 16.5.6, ,,Layers* (S. 230). When the text layer is active, it is possible to
modify the text by clicking in the image to reopen the entry dialog. Change the settings
by modifying the tool options.
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Retouching Images—The Clone Tool

The clone tool is ideal for retouching images. It enables you to paint in an image using
information from another part of the image. If desired, it can instead take information
from a pattern.

When retouching, it is usually a good idea to use a small brush with soft edges. In this
way, the modifications can blend better with the original image.

To select the source point in the image, press and hold Ctrl while clicking the desired
source point. Then paint with the tool as usual. When you move the cursor while pain-
ting, the source point, marked by a cross, moves as well. If the Alignment is set to Non
Aligned (the default setting), the source resets to the original when you release the left
mouse button.

16.5.4 Adjusting Color Levels

Images often need a little adjusting to get ideal print or display results. In many programs
designed for inexperienced users, the brightness and contrast levels are modified. This
can work and is also available in The GIMP, but better results can be obtained by
adjusting the color levels.

To do this, select Layer > Colors > Levels. A dialog opens for controlling the levels in
the image. Good results can usually be obtained by clicking Auto. To make manual
adjustments to all channels, use the dropper tools in All Channels to pick areas in the
image that should be black, neutral gray, and white.

To modify a channel individually, select the desired channel in Channel. Then drag the
black, white, and middle markers in the slider in Input Levels. Alternatively, use the
dropper tools to select points in the image that should serve as the white, black, and
gray points for that channel.

If Preview is checked, the image window shows a preview of how the image would
look with the modifications applied. When the desired result is achieved, press OK to
apply the changes. With Reset, restore the original settings. Cancel aborts level adjust-
ment.
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16.5.5 Undoing Mistakes

Most modifications made in The GIMP can be undone. To view a history of modifica-
tions, use the undo dialog included in the default window layout or open one from the
toolbox menu with File > Dialogs > Undo History.

The dialog shows a base image and a series of editing changes that can be undone. Use
the buttons to undo and redo changes. In this way, you can work back to the base image.
If you undo a modification then make a new one, the undone modification cannot be
redone.

Changes can also be undone and redone with the Edit menu. Alternatively, use the
shortcuts Ctrl + Z and Ctrl + .

16.5.6 Layers

Layers are a very important aspect of The GIMP. By drawing parts of your image on
separate layers, change, move, or delete those parts without damaging the rest of the
image. To understand how layers work, imagine an image created from a stack of
transparent sheets. Different parts of the image are drawn on different sheets. The stack
can be rearranged, changing which parts are on top. Individual layers or groups of layers
can shift position, moving sections of the image to other locations. New sheets can be
added and others set aside.

Use the Layers dialog to view the available layers of an image. The text tool automati-
cally creates special text layers when used. The active layer is highlighted. The buttons
at the bottom of the dialog offer a number of functions. More are available in the menu
opened when a layer is right-clicked in the dialog. The two icon spaces before the image
name are used for toggling image visibility (eye icon when visible) and for linking
layers. Linked layers are marked with the chain icon and moved as a group.

Only layers with transparency (an alpha channel) can be placed above other layers in
a stack. To add this to a layer, right-click and select it from the menu.

16.5.7 Image Modes

The GIMP has three image modes—RGB, Grayscale, and Indexed. RGB is a normal
color mode and is the best mode for editing most images. Grayscale is used for black-
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and-white images. Indexed limits the colors in the image to a set number. It is mainly
used for GIF images. If you need an indexed image, it is normally best to edit the image
in RGB then convert to indexed right before saving. If you save to a format that requires
an indexed image, The GIMP offers to index the image when saving.

16.5.8 Special Effects

The GIMP includes a wide range of filters and scripts for enhancing images, adding
special effects to them or making artistic manipulations. They are available in Filters
and Script-fu. Experimenting is the best way to find out what is available. Xzns in the
toolbox includes a number of items for creating buttons, logos, and other things.

16.6 Printing Images

To print an image, select File > Print from the image menu. If your printer is configured
in the system, it should appear in the list. In some cases, it may be necessary to select
an appropriate driver with Setup Printer. Select the appropriate paper size with Media
Size and the type in Media Type. Other settings are available in the Image / Output
Settings tab.

Abbildung 16.3 The Print Dialog
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In the bottom portion of the window, adjust the image size. Press Use Original Image
Size to take these settings from the image itself. This is recommended if you set an
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appropriate print size and resolution in the image. Adjust the image's position on the
page with the fields in Position or by dragging the image in Preview.

When satisfied with the settings, press Print. To save the settings for future use, instead
use Print and Save Settings. Cancel aborts printing.

16.7 For More Information

The following resources are useful for users of The GIMP, even if some of them apply
to older versions.

* Help provides access to the internal help system. This documentation is also
available in HTML and PDF formats at http://docs.gimp.org.

+ Find many tutorials explaining basic or advanced image manipulation techniques
with The GIMP at http://gimp.org/tutorials/.

+ The GIMP User Group offers an informative Web siteathttp://gug.sunsite
.dk.

* http://www.gimp.orq is the official home page of The GIMP.

» Grokking the GIMP by Carey Bunks is an excellent book based on an older version
of The GIMP. Although some aspects of the program have changed, it can provide
excellent guidance for image manipulation. An online version is available at
http://gug.sunsite.dk/docs/Grokking-the-GIMP-v1.0/.
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Managing Your Digital Image
Collection

Managing digital photographs in Linux is very straightforward. KDE's digiKam down-
loads your images directly from your camera. It helps you organize and manipulate
your images to get the best possible result to present to others. The application includes
several useful plug-ins that can convert your images to various different formats. Image
improvement plug-ins also include red eye reduction, speck removal and hot pixel
removal. Various filter and effect plug-ins help create little works of art from your
digital images.

Start digiKam from the main menu or by pressing Alt + F2 and entering digikam. On
start-up, digiKam shows a window with two main areas: a list of your albums to the
left and the images in the current album to the right. See Abbildung 17.1, ,,The Main
Window of digiKam* (S. 234). The rightmost edge of the window has a number of tabs
attached which can be used to display important information about your images or to
manipulate certain image-related data:

Properties
Use this tab to access properties assigned to your images, such as file properties
(permissions, ownership, modification date, etc.), image properties (dimensions,
file format, etc.), and photograph properties (basic model, exposure and aperture
information).

Metadata
Use this tab to access various kinds of metadata associated with your images, such
as EXIF and GPS, for example.
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Colors

Use this tab to access color management-related data and to analyze the histograms

associated with your images.

Comments/Tags

Use this tab to assign comments, tags or ratings to your images.

Tag Filters

Use Tag Filter to filter the amount of images displayed in the main view using
tagging information. For details about tagging in digiKam, refer to Abschnitt 17.4,

»,2Managing Tags" (S. 238).

Abbildung 17.1 The Main Window of digiKam
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17.1 Configuring Your Camera

To download images from your digital camera, simply connect the camera to the USB
port of your computer using the USB cable provided by the camera manufacturer.
Depending on your camera model, you may need to switch your camera to a special

data transfer mode. Consult the camera's manual about this.
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There are three possibilities for accessing the pictures on the camera. USB mass storage
or PTP (also known as PictBridge) are the most widely used protocols. Some camera
models do not work with either one and need special drivers provided by gphoto2
(Abschnitt 17.9, ,,Troubleshooting™ (S. 253)).

If your camera can be switched to a USB mass storage device, select this option. After
you connect the camera to the USB port of your computer and turn the camera on, the
new USB device is automatically detected and mounted. KDE lets you select the action
to take in the event of any such device being mounted. You can choose to start digiKam
or any other image viewing or processing application whenever a device of this type
is mounted.

To set up a camera in digiKam, select Camera > Add Camera. First, try to detect the
camera automatically with Auto-Detect. If this fails, browse the list of supported
cameras for your model with Add. If your camera model is not included in the list, try
an older model or use USB/IEEE mass storage camera and confirm with OK.

17.2 Downloading Pictures from the
Camera

To download images from a camera that has been correctly configured, attach the
camera to your computer and select the camera from the Camera menu. digiKam opens
a window and begins to download thumbnails and display them as in Abbildung 17.2,
,2Downloading Pictures from a Camera“ (S. 236). Right-click an image to open a pop-
up menu with the options to View the image, to Download, or Delete the image. Select
the Settings tab to the right of the download window to rename the image files using
Renaming Options. Review the EXIF data associated with the selected image using the
Metadata tab.
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Abbildung 17.2 Downloading Pictures from a Camera
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TIPP: Renaming Images

Mass renaming of your images comes in handy if your camera's filenames are
not meaningful enough for your purpose. Provide a unique prefix, add an
optional date, and let digiKam provide a sequence number.

Select all images to download from the camera by pressing the left mouse button or by
clicking individual images with Strg pressed or by using one of the select modes provided
by the Images menu at the bottom of the download window. Click Download and select
the destination from the list or create a new album with New Album, which automatically
suggests a filename with the current date. Confirm with OK to start the download pro-
cess.
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TIPP: Downloading Images from the Storage Medium

To save your camera's battery power, you can also attach a USB hub to your
computer providing an appropriate slot for your storage medium and download
the files from there. Once the USB hub is connected to your computer, the
KDE media handler dialog opens and offers to download the images from the
medium you attached.

17.3 Managing Albums

digiKam creates a folder called My Albums by default to hold all of your images. You
can move your images to subfolders later. The albums can be sorted by directory layout,
by collection name set in the album properties, or the date that the albums were first
created (this date can also be changed in the properties of each album).

To create a new album, use one of these methods:

+ Upload new images from the camera and create the target album on-the-fly during
the download.

+ Create a new album by selecting Album > New Album in the toolbar.

+ Import an existing folder of images from your hard disk (select Album > Import >
Import Folders).

+ Right-click My Albums and select New Album.

Once you have chosen to create a new album, provide some basic administrative
information about the new album, such as an album title. Optionally, choose a collection,
insert some comments, and select an album date. Collections are a way of organizing
your albums by a common label. This label is used when you select View > Sort Albums
> By Collection. The comment is shown in the banner at the top of the main window.
The album date is used when you select View > Sort Albums > By Date.

digiKam uses the first photograph in the album as the preview icon in the My Albums
list. To select a different one, right-click the respective photograph and select Set as
Album Thumbnail from the context menu.
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17.4 Managing Tags

Managing lots of different images across various albums can be a nightmare. To
manage your images by custom categories and across albums, digiKam provides the
My Tags system. Tags categorize images and more than one tag can be assigned to an
image.

For example, assume that you took several pictures of your friend, Joe, and distributed
them across various albums. Now you are looking for an easy way to generate an
overview of all pictures ever taken of Joe. Using digiKam's tags, proceed as follows
for this scenario:

1 Select 7Tags > New Tag in the upper menu bar and enter a name for the new tag,
in this case Joe. Provide an optional icon and leave this dialog with OK.

2 Go to each album and tag all images showing Joe by right-clicking the image
and selecting Assign Tag > Joe.

If you need to process a huge number of images, an easier way to do the tagging would
be using the Comments/Tags tab from the tab bar at the right edge of the main window.
This interface allows you to assign tags to this image, enter an optional descriptive
comment, and rate this image. When you are done with the first image, stay in this
dialog, click Forward, and proceed with all the other images of this album. When
finished, click Apply and OK to apply your settings. Proceed similarly with all other
albums and images.

To retrieve all images in your entire collection that carry a certain tag (in this case Joe),
proceed as follows:

1 Open the 7ags tab in the left tab bar.
2 Unfold the My Tag item.

3 Select the Joe tag.

As a result, all images in your entire collection carrying this tag are displayed.
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Abbildung 17.3 Display Tagged Images Only
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The Tag Filter in the rightmost edge of the main window limits the number of images
displayed for the current album to those marked by the tag or tags selected here.

17.5 Creating Powerful Search Filters

Any image collection soon becomes unmanageable if you do not find a means to search
for the images you need and find them without much of a hassle. To help you organize
your collection, digiKam offers you two search options:

Simple Search
A basic search. Just enter a text string that might be associated with your image
(image or tag name or comment) and hit OK. You can save this search for future
use and edit other existing searches listed under My Searches.

Advanced Search
Complex search filter. Set up complex rules using any image property (album, tag,
rating, date, etc.) and combine these options as needed. You can save your search
filter for future use and edit other existing searches listed under My Searches.
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The following example illustrates how to create an Advanced Search using rating or
tag information to search for images:

1 Select the Searches tab to the left of the main window.
2 Right-click the My Searches area and select Add New Advanced Search.

3 Select the first search criterion. In this case, select Rating+Equals+5 Stars
to search for all images that have been rated with five stars.

4 In the Add/Delete Option section, select Or and click Add. A new search rule is
added below the existing one.

5 Select the second search criterion. In this case, select Tag+Equals+Filters
to search for all images that have been tagged with a tag named Filters.

6 Add other search criteria if needed, group criteria, or delete them. The results of
your search are displayed in the search window.

7 To save the search for future use, specify a name for this search and leave the
Advanced Search dialog with OK.

Abbildung 17.4 Creating an Advanced Search Filter
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17.6 Exporting Image Collections

digiKam provides several export options that help archive and publish your personal
image collections. It offers archiving to CD or DVD (with k3b), HTML export, and
export to a remote gallery.

To save your image collection to CD or DVD, proceed as follows:

1

Select File > Export > Archive to CD/DVD.

2 Make your adjustments in the Create CD/DVD Archive dialog using its various

submenus. After that, click OK to initiate the burning process.

2a With Album Selection, determine which part of your collection should be
archived by selecting albums and tags.

2b In HTML Interface, decide whether your image collection should be accessi-
ble through an HTML interface and whether automatic run functionality
should be added to your CD or DVD archive. Set a selection title and image,
font, and background properties.

2c¢ Change the settings for the volume description in Media Volume Descriptor,
if necessary.

2d Adjust the burning options to your needs in Media Burning, if necessary.

To create an HTML export of your image collection, proceed as follows:

1

2

Select File > Export > HTML Gallery.

Determine which part of your collection should be archived by selecting albums
and tags in Collection and click Next.

Use Theme dialog to set the title and appearance of your HTML gallery and click
Next.

Specify size, compression and file type for the thumbnails used for gallery navi-
gation in /mage Settings and click Next.
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5 Determine the location of the gallery on disk with Output and click Finish.

To export your collection to an external image gallery on the Internet, proceed as
follows:

1 Get an account for an external Web site to host your gallery.

2 Select File > Export > Remote Gallery Sync and provide URL, username, and
password for the external site when asked for them. digiKam establishes a
connection to the site specified and opens a new window called Gallery Export.

3 Determine the location of your new album in the gallery.
4 Click New Album and provide the information requested by digiKam.

5 Upload the images to the new album with Add Photos.

17.7 Viewing and Editing Images

digiKam comes with a comprehensive image viewing and editing suite consisting of
various plug-ins. To enter digiKam's viewing or editing mode, right-click an image
thumbnail and select View or Edit from the context menu. To use the plug-ins, you need
to install the digikamplugins package.

Use View to zoom in and out of your image or to start a slide show with a selection of
images or all images in your album/collection. Use Edit to open the selected image in
editing mode and to use all the editing options introduced below.

The toolbar in the image editing mode of digiKam contains some of the most frequently
used basic editing options:

+ Use the back/forward buttons to browse your album without having to go back to
the full album view.

+ Use the undo/redo menus to selectively undo or redo certain operations.

+ Use the zooming options to zoom in or out or to fit the image view to the window
size you are using. Use the looking glass icon to selectively zoom into a particular
area of the image.
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+ Flip the image clockwise or counter-clockwise.

+ Activate a slide show or full screen view of the selected image.

17.7.1 Applying Image Decorations

Use the Decorate menu to superimpose various kinds of graphics and text effects on
your images without having to bother about filters and their fine-tuning:

Apply Texture
Select the type of texture you want to apply to your image and determine how
prominent this texture should be (Relief). digiKam applies the texture and saves
the changes to the original copy of your image.

Add Border
Select the type of border. Depending on the type of border you have selected,
choose one or two colors to be used for the border and set the width of the border
around your image. digiKam creates the border and saves the changes to the original
copy of your image.

Insert Text
Enter the text you want to superimpose on the image, choose font, font style and
size. Select the text justification and decide whether the text should be rotated and
to what degree. Add an optional border and semi-transparency. digiKam adds your
text layer to the original image.

Template Superimpose
Just as you can superimpose any text on your image, you can also apply ready-
made templates to create funny greeting cards, posters and the like.

17.7.2 Manipulating Color Settings

The Color menu allows you to manage all kinds of different color-related settings. Its
capabilities range from simple auto correction mechanisms to full-blown color manage-
ment via color profiles:
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Auto Color Correction

If aiming for a straightforward color and exposure correction of your image, try
this option. Choose from various preset modes and apply the one that matches best.
Use the histograms to determine whether the result matches your needs.

Brightness/Contrast/Gamma

This tool offers a simple way of fixing over or underexposed images.

Hue/Saturation/Lightness

This tool helps you to optimize images that have been taken under very bright
lighting conditions and appear somewhat washed out. Bring color saturation back
to these images by manipulating the hue and saturation sliders. Depending on the
level of color, you might also want to adjust the lightness to prevent the image from
registering too dark. Of course, you can also use this tool to achieve the opposite
effect if you need to brighten up an image that has been taken at low light conditions
and contains far too much color saturation.

Color Balance

Depending on the lighting conditions under which an image was taken or the qua-
lity of an image scan, the colors may appear somehow out of balance. Using the
color balance tool, you can try to shift the balance towards another end of the color
spectrum.

Invert

Invert the color values.

Black & White

Transform your color image into a black and white one. Use the Film, Lens Filters,
Tone, and Lightness to tweak the end product. The Film tab offers you to emulate
the effects various black and white films. To emulate color filters used with the
camera lens, use the Lens Filters tab. Note that you can only apply one filter at a
time. Using the Tone tab you can have your black and white image tinted in a par-
ticular way (sepia, for example).

Depth

Determine the color depth (in bit). Transform 8-bit into 16-bit images and vice
versa.

Color Management

Color management via ICC color profiles helps you maintain color fidelity across
multiple output devices (camera, display, printer).
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Levels Adjust
Use this option to control multiple levels and to check the resulting image in just
one tool. It lets you save the level settings you chose and thus enables you to apply
the same corrections to multiple images if needed. This comes in handy if you
know that your camera tends to use the same faulty color settings all the time and
you would like to be able to correct them with just a single click.

Color Effects
This tool offers a selection of color effects like edge finding, solarizing, etc.

White Balance

Every source of light registers differently on your digital camera's chip. Depending
on the light source, the color temperature tends to register either warmer (towards
the red end of the spectrum) or cooler (towards the blue end of the spectrum) than
standard daylight. Most cameras ship with preset white balance schemes that try
to compensate these effects. If the resulting images registers faulty, use the white
balance adjustment provided by digiKam. Either manipulate the color temperature
directly by using the Kelvin slider or choose one of the preset white balance sche-
mes.

Curves Adjust
This tool allows you to basically perform any operation available through the
Brightness/Contrast/Gamma and the Levels Adjust tools, but in one tool and using
free-function mapping. Therefore this tool is more powerful and flexible than the
other two, but it may take some time to get used to its handling.

Channel Mixer
The channel mixer tool provides an alternative way of converting colored images
to black and white. Using the Monochrome option and the channel sliders, you can
selectively determine how much each of the color channels contributes to the
overall image. The channel mixer option is much more flexible than the standard
conversion to black and white, because you can manage each color channel separa-
tely.

17.7.3 Fixing and Tweaking Your Images

Use the Enhance menu to address a number of common defects related to digital
imagery:
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Blur/Sharpen
Tweak the sharpness of your image or smooth it.

Red Eyes
Reduce or eliminate red eyes caused by use of a flash.

Inpainting
,Heal“ defective areas of your image.

Noise Reduction
Remove artifacts, such as those caused by dust on your lens or sensor. Compensate
for pixel noise caused by high ISO settings of your digital camera and reduce noise
and artifacts in low quality scans.

Hot Pixels
Detect and erase problem pixels of your image caused by defective pixels of your
camera's SEnsor.

Lens Distortion Correction
Compensate for barrel and pincushion distortion of your images caused by the use
of strong wide-angle or telephoto lenses.

Restoration
Provides an all-inclusive treatment to images suffering from all sorts of digital
defects, such as noise and scratches.

Anti Vignetting
Compensates circular shades (vignettes) at the edges or in the center of your image

that were caused by the use of strong wide-angle or telephoto lenses.

To observe the functionality of the Fix options, look at /npainting, for example. Assume
some dust or scratch on your lens ruined an image. To remove this kind of artifact,
proceed as follows:

1 Open your image.
2 Use the mouse cursor to select the area to which to apply the fix.
3 Select Enhance > Inpainting or press Strg + E.

4 Determine the method to use to remove the artifact:
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+ Choose one of the preset options (Remove Small Artifact, Remove Medium
Artifact, or Remove Large Artifact) and proceed with Schritt 6.

+ Set the filter parameters on your own. Proceed with Schritt 5.
5 If you opted against using any of the preset filters (in the Preset tab), open the
General and Advanced Settings tabs and adjust the settings to your needs.

6 Click OK to apply your settings and modify the image accordingly.

TIPP: Creating and Reusing Your Own Filter Settings

If you need to use the same set of settings more than once, for example,
if a scratch on the lens ruined an entire series of images, create your set
of filter settings. Save them for later use by clicking Save As and saving
them to a text file. For subsequent images, open the Image Inpainting
dialog, click Load, then select the text file and apply the filter settings
with OK.

Abbildung 17.5 Using Inpainting to Remove Artifacts
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17.7.4 Applying Image Transformations

To scale or rotate an image, use the Transform menu:

Rotate, Flip, Free Rotation
Rotate your image to a certain degree. Rotate rotates by multiples of 90 degrees.
With Free Rotation, specify any angle you want.

Crop, Aspect Ratio Crop
Crop your image. Crop cuts to any rectangular selection on top of your image.
Aspect Ratio Crop crops the image following various sophisticated design principles.

Perspective Adjustment
Adjust the perspective of an image. For example, if you notice some odd angles in
shots containing vertical or horizontal lines, use this tool to set them right. Grab
any of the four handles to the corners of your image and move them as much as
needed. Use the Crop tool to remove the resulting black edges of your image and
to trim it down.

Shear
Shift one part of your image to one direction and the other to the opposite direction,
either horizontally or vertically. Specify the angles for vertical and horizontal shear
and use Crop to trim the resulting image.

Resize
Scale your image. Resize offers a simple interface allowing you to manipulate your
image size by pixel or percentage. Select whether to keep the aspect ratio. If you
select Restore photograph, you can fine-tune the algorithms used to on your resized
image and improve the quality of the end product. Note that this option might be
considerably slower than a simple resize operation.

Assuming you have an image that is otherwise perfect, but you are not entirely satisfied
with the composition yet or need to crop your image to match a certain paper format
for reproduction. In this case, use Aspect Ratio Crop and proceed as follows:

1 Open your image.

2 Select Transform > Aspect Ratio Crop.

3 Determine the orientation and aspect ratio to use:
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None
Specify a free crop of the image using the X, Width, and Y, Height sliders.

Custom
Select a custom ration of width versus height instead of using one of the
preset values.

X:Y Ratio
These ratios match most of the common paper sizes used to print photographs.
Pick the one that suits your purpose best.

Golden Ratio
A ratio (1:1.618) that is traditionally used by artists and architects to create
harmonious results.

Use Max. Aspect to set the crop area to the maximum possible size of the ratio
specified.

4 After determining the size of your crop selection, optionally apply compositional
rules to it. The Composition Guide helps to create a crop selection that results in
a visually pleasing image. Dotted lines are displayed that guide you to a better
composition of your image.

TIPP: For More Information

For a comprehensive description of the options, refer to http://docs
.kde.org/stable/en/extragear—graphics/digikam/
using-kapp-imageeditor.html.

5 Ifthe position of your crop does not follow the compositional rule to your satis-
faction, move it.

6 Click OK to apply your crop selection and trim your image.
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Abbildung 17.6 Creating a Custom Crop Using Aspect Ratio Crop
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17.7.5 Applying Filters and Effects

You can select from a variety of basic effects and filters to apply to your images to give
them a more artistic or over-the-top look:

Raindrops
Apply raindrop effects to your image. Determine the size and number of the drops
and finally specify the degree of distortion caused by the drops (Fish eyes).

Infrared Film
Simulate the use of infrared film to achieve a slightly surreal effect. The result is
strikingly different from the original image. Add additional film grain and tweak
the sensitivity (ISO) to achieve a more artistic feel.

Oil Paint
Simulate an oil painting. Determine the brush size and the degree of smoothing to
apply to your image.

Emboss
Pretend your image had been embossed to a sheet of paper. Choose an appropriate
depth.
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Distortion Effects
Apply various strange distortion effects, such as fish eyes, to your image. Determine
type, level, and repetition.

Add Film Grain
Add film grain to your image to give it a rough look.

Blur Effects
Blur your image to simulate the image being out of focus or to mimic any kind of
movement that was not there when you took the image.

Charcoal Drawing
Transform your image into a black and white charcoal drawing. Choose an appro-
priate pencil size and determine the degree of smoothing to apply to the image.

Abbildung 17.7 Simulating IR Photography
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17.8 Useful Tools

digiKam offers several little helpers for organizing your image collection and for pro-
cessing your images. Find them in the 7o0ls menu:
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Find Duplicate Images
If you suspect your collection to contain a number of duplicates, use this option to
find and delete them. First, determine which album or tag to include in the scope
of your search. Click OK to initiate the search. If your collection contains any
duplicates, you get a split screen showing both images and can select one of them
for deletion to eliminate the duplicate.

Create Calendar
Create a simple calendar using a standard layout by just selecting the images to use
and by selecting paper size and fonts.

Slideshow
Present your image collection by means of a slide show. Determine the scope of
the slide show, the effects to use and what information to display along with the
images. Set the delay between images and start the slide show.

RAW Image Converter (Single)
digiKam supports converting images from various vendor-specific RAW formats
to common image formats such as JPEG or PNG. Using this option, convert single
images. If you need to convert several images, consider using a batch conversion
(Tools > Batch Processes > RAW Images Converter (Batch)). To find out whether
your camera's RAW format is supported by digiKam converter plug-in, check
http://www.cybercom.net/~dcoffin/dcraw/.

Batch Processes
Perform certain actions on a large number of files at once. Add borders, edit the
colors, apply various effects and filters, rename and resize images, recompress
them, or perform a RAW conversion.

An example batch processing of images could involve applying a solarizing effect to
a number of images. To queue images for batch processing and perform the actual
processing, proceed as follows:

1 Select Tools > Batch Processes > Image Effects or right-click the album's name
and select Batch Processes > Image Effects.

2 Set the effect to Solarize and click Options to determine the degree of the effect
to be applied and display an optional preview.

3 Determine whether to rename or overwrite the original images or even have them
removed after the transformation has taken place.
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4 Set the target folder to hold the resulting images. If you do not want the new
images to be written to the original folder, select New and add a new folder or
subfolder. Select the new folder with your mouse pointer.

5 Accept or modify the list of images queued for the transformation.
6 Click Start to initiate the transformation.
digiKam informs you about the progress and the success of the transformation.

Abbildung 17.8 Batch Processing: Solarizing Images
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17.9 Troubleshooting

Although openSUSE and digiKam support a broad range of cameras, you might occa-
sionally hit one of the following problems when using your digital camera with open-
SUSE:
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Downloading Images from Your Camera Fails
If downloading your images fails no matter which protocol you have chosen (PTP
or USB), try using the command line instead of digiKam. The gphoto2 --P
command initializes the camera and downloads the images if gphoto2 supports this
camera.

Your Camera is not Officially Supported by digiKam
Try gphoto2 --list-cameras and the information at http://www
.gphoto.org/ to obtain more information about the status of your camera's
support by Linux.

If the camera is not listed there, remove the storage medium from the camera and
use a card reader device (either an external or internal one). As soon as the medium
is detected, it is mounted automatically and you can import the images to your
digiKam collection with Albums > Import > Add Images or Albums > Import >
Import Folders.

17.10 For More Information

For more information about using digital cameras with Linux, refer to the following
Web sites:

* http://docs.kde.org/development/en/extragear—graphics/
digikam/index.html—The official digiKam Handbook

* http://www.gphoto.org—Information about gPhoto2

* http://www.gphoto.org/proj/libgphoto2/support.php—A
comprehensive list of supported cameras
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Playing Music and Movies

During installation, YaST normally identifies and configures the sound cards of your
computer automatically. Otherwise (or if you installed a new sound card), start YaST
and configure the sound card manually in the Sound module. When your sound card
has been configured, you can control the volume and balance with a mixer and start
other sound applications.

Linux includes a wide range of sound and multimedia applications. Some of these
applications are installed on your Linux system by default. With the applications des-
cribed here, control the volume and balance of playback and play CDs, music and movie
files. You can also record and compress your own audio data.

In case one of the listed applications is not installed by default on your system, use
YaST to install the missing packages. Use the search function of the YaST package
management tool (see Abschnitt ,Installieren der Software® (Kapitel 3, Installieren
bzw. Entfernen von Software, 1Start)) to find the package names.
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18.1 Mixers

Mixers provide a convenient means of controlling the volume and balance of the sound
output and input of computers. For a description of the default KDE mixer applet, refer
to Abschnitt 1.18, ,,Controlling Sound with KMix“ (S. 48).

The main difference between the various mixers is the outer appearance of the user
interface. However, there are a number of mixers that are designed for specific hardware.
From the mixers available, select the one that best suits your needs.

TIPP: Starting the Mixer

Generally, it is advisable to open a mixer application before opening other
sound applications. Use the mixer to test and adjust the control settings for
the input and output of the sound card.

18.2 Playing Music Files

In Linux, find a variety of programs for playing music files, such as Ogg Vorbis, or
WAV files. Ogg Vorbis is a free audio compression format that is now supported by
the majority of audio players and even portable MP3 players. The file types supported
by the applications depend on the engine used.

ANMERKUNG: Playing MP3 Files

openSUSE® also comes with MP3 support. If your music collection consists of
both MP3 and Ogg Vorbis files, you do not need to convert any files to a diffe-
rent format. Just open amaroK (KDE) or Banshee (GNOME) and start listening.

18.2.1 amaroK Media Player

The amaroK music player allows you to play various audio formats, create playlists,
import music from removable media such as portable MP3 players or external hard
disks (or upload files to removable media), and listen to streaming audio broadcasts of
radio stations on the Internet. The file types supported depend on the engine used.
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On first start, amaroK launches a First-Run Wizard, which helps set up amaroK. In the
first step, configure your preferred look and feel for amaroK. Choose to display player
and playlist in separate windows (see Abbildung 18.1, ,, The amaroK Media Player®
(S. 257)) or combine their functionality in one single window (default). In the second
step, determine where amaroK should look for your music collection. amaroK scans
these folders for playable media. By default, amaroK is configured to scan the selected
folders recursively (to include all their subdirectories in the scan), monitor changes to
the content of the selected directories, and import any playlists located there. All the
settings made with the wizard can be modified later in the configuration dialog by
selecting Settings > Configure AmaroK.

Abbildung 18.1 The amaroK Media Player
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Quick Start

On start-up, amaroK scans the folders that are part of your collection for music files.
Although you can use amaroK without building a collection, it is recommended to do
so, because most of the powerful, advanced features are only available with an existing
collection.
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The amaroK main window is divided into two parts. The sidebar on the left providing
different views: your music collection, a context browser, your playlists, a file browser,
etc. Change the browser by clicking a tab on the far left. The right part contains the
playlist window and, below it, the player (if you have not configured it to be shown in
a separate window).

To play music, just drag and drop items from any of the sidebar browsers to the playlist
area. Use Umschalttaste or Strg to select multiple items. Double-click an item in the
playlist to play it. You can add or delete items from the list during playback with the
context menu. Use the icons located above the playlist area to Clear the playlist, to
Save playlist as, to Undo and Redo changes or to Search for a certain track.

To manipulate play modes, either click the Repeat or Random icons in the amaroK
status bar several times to switch mode or select the desired Mode from the main amaroK
menu.

The Sidebar Browsers

Context
With this tab, view information and statistics related to the track currently being
played. Switch to different views within the Context browser by clicking the tabs
on top of the sidebar. For example, click Artist to make amaroK search for the
appropriate Wikipedia article, which is then displayed in the context browser. To
view a track's lyrics, click the Lyrics tab to start a search and display the results.
The Music tab shows the album cover, if available, (see ,,The Cover Manager"
(S. 260)) and the listening statistics related to the current track.

Collection
Use this view to manage and display your personal collection of titles. The toolbar
on top of the browser allows you to configure the way your collection is displayed
and to reorganize the collection. Define the order your titles are displayed in the
browser with Group By. You can choose between predefined criteria or create your
own sort criteria using Primary, Secondary, and Tertiary. The next four icons let
you toggle between tree view, flat view and iPod* view or Show dividers for better
overview in large music collections. Use the wrench icon to add or delete folders
amaroK should scan for music to add to your collection.

To search or filter your collection for a certain track or album, enter the title (or
part of it) in the search field at the top. Each character you enter narrows down the
search and the selection in the browser is adjusted as you type. To search for certain
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metadata such as Genre or Bitrate or to combine several search options, click the
button to the right of the search field to open the Edit Filter dialog.

Playlists
You can access different playlists with the playlist browser. Playlists holds your
personal playlists found in your collection folders. Every time you create and save
a new playlist from the playlist window, it appears here. Right-click the Playlist
folder to create or import a new playlist or to add a subfolder. To add new items
from the playlist window to an existing playlist, just drag and drop them on the
playlist in the browser window.

WICHTIG: Sharing Playlists with Other Players

Save playlists in m3u format, so you can share them with any other players
using this format.

Smart Playlists offer various views of your collection, such as tracks never played,
newest tracks, or tracks by genre. For example, to create a random playlist from
your collection, select 50 random Tracks and drag the entry to the playlist area.
Right-click the Smart Playlists folder to add subfolders or to create your own smart
playlists.

Radio Streams lets you listen to live radio streams from the Internet. An extensive
list is already shipped with amaroK. Right-click to add more or create subfolders.

Podcasts imports podcasts to amaroK. Right-clicking opens a menu where you can
add podcasts and subfolders, refresh all podcasts, or set the scan interval.

Files
This tab opens a file browser which corresponds to the standard KDE file manager
dialog. Use the icons at the top to navigate the file system, change the view or to
create bookmarks. Enter a URL or a path directly into the text input field. From
the contents displayed, drag elements to the playlist to include them.

Magnatune
On this tab, you can establish a connection to the Magnatune store where you can
purchase music online. Click Update to view the available albums and titles at
magnatune.com. Sort the album list by Genre and listen to some tracks with amaroK.
To buy music, click Purchase Album and enter your payment details.
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Devices
If you own portable MP3 players or external hard disks, use this browser to confi-
gure your portable device and to access it from amaroK.

The Cover Manager

With amaroK, you can assign a cover to each album of your collection. With the Cover
Manager, easily add, delete, and retrieve album covers.

Start the cover manager with Tools > Cover Manager. A tree view in the left part of
the window lists all artists in your collection. The main part of the window lists the
covers of all albums. To filter the covers displayed, click an individual artist in the tree
view or enter a term in the input field at the top of the window. Use View to toggle
between displaying all albums, albums with covers, or albums without covers.

There are three different methods for assigning covers to the albums:

Automatically Assign Covers
amaroK can automatically fetch all missing covers displayed in the main windows
from Amazon. Use Amazon Locale to determine from which Amazon Web server
the covers should be fetched then click Fetch Missing Covers.

WICHTIG: Proper Tagging Needed

amaroK fetches the covers from Amazon using the query string Artist
— Album. This information is extracted from the tags of your music files.
The better they are tagged, the better the hit rate is when automatically
fetching covers.

Manually Choose a Cover Fetched from Amazon
If you want more control over what image to use and what query string to use to
retrieve a cover, right-click an album in the main window and choose Fetch From
amazon.com. Next Cover lets you cycle through all images available. Save selects
the actual cover and assigns it to the album selected. If you are not satisfied with
the covers displayed, use New Search to refine the search. Use Amazon Locale
from the toolbar of the main window to determine from which Amazon Web server
the covers should be fetched.
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Manually Assign Covers
If you already have your own cover images, you can assign them by right-clicking
an album and choosing Set Custom Cover.

Visualizations

If visualizations for amaroK are installed, you can select various graphical effects for
the music played with Tools > Visualizations. Native amaroK visualizations are displayed
in the player window. Cycle through the various available display modes by clicking
the animation.

The amaroK Tray Icon

Like other KDE applications, amaroK adds an icon to the KDE system tray. You can
use this icon to control a large number of amaroK's features. Hovering the mouse
pointer over the icon displays information about the track currently played, by scrolling
the mouse wheel simultaneously you can reduce or increase the playback volume. A
single left-click closes the application window without affecting playback. Click again
to reopen the window. Clicking with the middle mouse button pauses playback—middle-
click again to resume playback. Right-clicking opens a context menu where you have
access to the player controls and can exit amaroK.

Using the Umschalttaste and Strg keys together with the mouse gives you access to
more advanced features. Holding Umschalttaste while scrolling the mouse wheel seeks
through the current track. Holding Strg while scrolling the mouse wheel skips through
tracks in the playlist.

You may also drag items and drop them on the tray icon to add them to the current
playlist. A pop-up menu opens, asking whether to append the track to the playlist,
append and play it, or queue it after the current track.

18.2.2 JuK Jukebox

JuK (kdemultimedia3-jukebox package) is a jukebox application that lets you
manage your music file collection and playlists. JuK maintains a list of all files it knows
about. This is called the collection list. The list is specific to JuK and is not shared with
other applications. Independent of the collection list are playlists. You can have as many
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playlists as you want and you can share your JuK playlists with other media players.
You can also edit the tags of your music files.

Start JuK with the main menu or press Alt + F2 and enter juk. Find more information
about JuK in the online help.

18.3 Handling Audio CDs

There are many ways to listen to your favorite music tracks. Either play a CD or play
digitized versions of them. The following section features some CD player applications
as well as some applications that can be used for digitizing audio CDs.

For information about how to create your own CDs, refer to Kapitel 19, Burning CDs
and DVDs (S. 267).

WICHTIG: CDDA and Analog CD Playback

There are two different ways of playing audio CDs. CD and DVD drives capable
of analog CD playback read the audio data and send it to the sound output
device. Some external drives connected via PCMCIA, FireWire, or USB need to
use CDDA (Compact Disk Digital Audio) to extract the audio data first then
play it as digital PCM. The players featured in the following sections do not
support CDDA. Use XMMS if you need CDDA support.

18.3.1 KsCD—Audio CD Player

KsCD is an easy-to-use audio CD player included in the kdemultimedia3-extra
package. If it is installed, press Alt + F2 and enter k scd to start the application. KsCD
integrates into your KDE panel and can be configured to start playing automatically
after a CD has been inserted. To access the configuration menu, select Extras > Confi-
gure KsCD. Fetch album and track information from a CDDB server on the Internet if
KsCD is configured accordingly. You can also upload CDDB information to share it
with others. Use the CDDB dialog for information retrieval and upload.
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Abbildung 18.2 The KsCD User Interface
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18.3.2 Compressing Audio Data: Ripping

Audio compression can be handled by various tools. The following sections feature a
command line approach to encoding and playing audio data as well as some graphical
applications capable of audio compression.

Command Line Tools for Encoding and Playback of
Audio Data

Ogg Vorbis (package vorbis—-tools)isa free audio compression format that is now
supported by the majority of audio players and even portable MP3 players. The Web
page of the projectis http://www.xiph.org/ogg/vorbis

Your system comes with several tools supporting Ogg Vorbis. oggenc is a command
line tool used for encoding WAV files to Ogg. Just run oggenc myfile.wav to
transform a given . wav file into Ogg Vorbis. The —h option displays an overview of
the other parameters. Oggenc supports encoding with a variable bit rate. In this way,
an even higher degree of compression can be achieved. Instead of the bit rate, specify
the desired quality with the parameter —q. —b determines the average bit rate. —m and
—M specify the minimum and maximum bit rate.

0ggl23 is a command line Ogg player. Start it with a command like cgg123
mysong.ogg.

Compressing Audio Data Using KAudioCreator

KAudioCreator is a lean CD ripper application (see Abbildung 18.3, , Ripping Audio
CDs with KAudioCreator® (S. 264)). Once started, it lists all the tracks of your CD in
the CD Tracks tab. Select the tracks to rip and encode. To edit the track information,
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use the Album Editor under File > Edit Album. Otherwise just start the ripping and

encoding with File > Rip Selection. Watch the progress of these jobs using the Jobs
tab. If configured accordingly, KAudioCreator also generates playlist files for your

selection that can be used by players like amaroK, XMMS, or Banshee.

Abbildung 18.3 Ripping Audio CDs with KAudioCreator
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Compressing Audio CDs Using Konqueror

Before you start the actual ripping process with Konqueror, configure the handling of
audio CDs and the Ogg Vorbis encoder in the KDE Control Center. Select Sound &
Multimedia > Audio CDs. The configuration module is divided into three tabs: General,
Names, and Ogg Vorbis Encoder. Normally, a suitable CD device is detected automati-
cally. Do not change this default setting unless the autodetection failed and you need
to set the CD device manually. Error correction and encoder priority can also be set
here. The Ogg Vorbis Encoder tab determines the quality of the encoding. To configure
online lookup of album, track, and artist information for your ripped audio data, select
Add Track Information.

Start the ripping process by inserting the CD into the CD-ROM drive and entering
audiocd:/ inthe Location bar. Konqueror then lists the tracks of the CD and some
folders (see Abbildung 18.4, , Ripping Audio Data with Konqueror® (S. 265)).
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Abbildung 18.4 Ripping Audio Data with Konqueror
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To keep uncompressed audio data on your disk, just select the . wav files and drag
them into another Konqueror window to copy them to their final destination. To start
the Ogg Vorbis encoding, drag the Ogg Vorbis folder or files from this folder to
another Konqueror window. The encoding starts as soon as you drop the Ogg Vorbis
folder at its destination.

18.4 Playing Movie Files

You can choose between several movie players shipped with your openSUSE. Kaffeine
is the default KDE movie player and can be run with several back-ends, such as Xine
and MPlayer.
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Abbildung 18.5 Kaffeine Main Window
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The formats you can view with Kaffeine depends on the back-end (by default, Xine is
used). Xine interprets many of the most common multimedia formats available. For
more information, refer to http://xinehqg.de/.

In case the format is not supported by the player's engine, openSUSE offers to search
for a suitable codec which you can then install with YaST.

Kaffeine can also play multimedia streamed over the Internet and can be used as a plug-
in for Konqueror. It provides the usual options for playing files in full screen mode,
navigating through files, and more. You can also take a snapshot of the video and save
it as an image.

Apart from Kaffeine, openSUSE also ships RealPlayer for Linux. RealPlayer supports
RealAudio, RealVideo, Ogg Vorbis, Theora, and more.
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Burning CDs and DVDs

K3b is a comprehensive program for writing data and audio CDs and DVDs. Start the
program from the main menu or by entering the command k 3b. The following sections
brief you on how to start a basic burning process to get your first Linux-made CD or
DVD.

19.1 Creating a Data CD or DVD

To create a data CD, go to File > New Project > New Data CD Project. To create a
data DVD, go to File > New Project> New Data DVD Project. The project view appears
in the lower part of the window, as shown in Abbildung 19.1, ,,Creating a New Data
Project™ (S. 268). Drag the desired directories or individual files from your home
directory to the project folder and drop them there. Save the project under a name of
your choice with File > Save as.
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Abbildung 19.1 Creating a New Data Project
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Then select Burn from the toolbar or hit Strg + B. A dialog with four tabs offering
various options for writing the CD or DVD opens. See Abbildung 19.2, ,,Customizing
the Burning Process® (S. 268).

Abbildung 19.2 Customizing the Burning Process
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The Writing tab has various settings for the burning device, the speed, and the burning
options. The following options are offered here:
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Burn Medium
The detected medium and writer are displayed under this pop-up menu. If you have
more than one writer installed, choose which one you want to use here. You can
select the speed here too.

WARNUNG: Select the Writing Speed with Care

Normally, you should select Auto, which chooses the maximum writing
speed possible. However, if you increase this value but your system is not
able to send the data fast enough, the likelihood of buffer underruns
increases.

Writing Mode
This option determines how the laser writes the CD or DVD. For CDs, there are
three modes available: DAO (disk at once), TAO (track at once), and RAW. In
DAO mode, the laser is not deactivated while the disk is written. This mode is
recommended for the creation of audio CDs. In the TAO mode, a separate write
process is used for each individual track. The RAW mode is not used very often,
because the writer does not perform any data corrections. For DVDs, auto or DAO
modes are available. Do not use DAO mode if you want to create multisession
DVD.

We recommend you to select Aufo, because it allows K3b to use the most suitable
settings.

Simulate
This function can be used to check if your system supports the selected writing
speed. The writing is performed with a deactivated laser to test the system.

Create image
If this option is enabled, an ISO image of the CD or DVD is created first. This
image file is subsequently written to the CD or DVD. This option should be used
on low performance systems. You can set the path for this file under Temporary
File on the Image tab. Checking this option also activates the Remove image option.
If you want the image to be not deleted after burning is finished, uncheck that
option.

Only Create Image
If this option is enabled, the ISO image file is created but it is not subsequently
written on CD or DVD. Use this option if you want to write the image on CD or
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DVD at a later time. To do this, use Tools > Burn CD Image or Tools > Burn DVD
IS0 Image. If this option is used, all other options in this section are deactivated.

Remove Image
Remove the temporary image file from hard disk when finished.

Verify Written Data
Check the integrity of the written data by comparing the MD5 sums of the original
and the burned data.

The Image tab is useful only if the Create image or the Only create image option is set.
In this case, determine the file on which you want to write the ISO.

In the Filesystem tab, set the Volume Name. If you click More fields, you can add more
information about the project, such as its publisher and preparer, copyright information
and the application and operating system used in the creation of this project. You are
able to set the used File System and determine how Symbolic Links and White Space
should be handled.

The Misc tab contains two options. The first one, Datatrack Mode is available only for
CDs. Here you can set up how data tracks should be written. In general, Auto is consi-
dered the best suited method. The Multisession Mode is used to append data to an
already written but not finalized medium.

After adjusting all settings to your needs, start the actual burning process using Burn.
Alternatively, save these settings for future use and adjustment with Save.

19.2 Creating an Audio CD

Basically, there are no significant differences between creating an audio CD and creating
a data CD. Select File > New Audio CD Project. Drag and drop the individual audio
tracks to the project folder. The audio data must be in WAV or Ogg Vorbis format.
Determine the sequence of the tracks by moving them up or down in the project folder.

With the help of CD Text, you are able to add certain text information to a CD, such

as CD title, artist name, and track name. CD players that support this feature can read
and display this information. To add CD Text information to your audio tracks, select
the track first. Right-click and select Properties. A new window opens in which to enter
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your information. You can also download track information from internet by clicking
Query Cddb.

The dialog for burning an audio CD is not very different from the dialog for burning a
data CD. However, the Disc at once and the Track at once modes have greater import-
ance. The Track at once mode inserts an intermission of two seconds after each track.

TIPP: Preserving Data Integrity

When burning audio CDs, choose a lower burning speed to reduce the risk of
burning errors.

After adjusting all settings to your needs, start the actual burning process using Burn.
Alternatively, save these settings for future use and adjustment by clicking on the
floppy disk icon.

19.3 Copying a CD or DVD

Select Tools > Copy CD or Tools > Copy DVD depending on your media. In the dialog
that opens, choose Source Medium and Burn Medium as shown in Abbildung 19.3,
,Copying a CD* (S. 271). The writing options discussed are also available here. An
additional function enables the creation of several copies of the CD or DVD.

Abbildung 19.3 Copying a CD
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Check Create Image to cache data to the hard disk before writing them on target
medium. Check Only create image to create an image in the path specified on the /mage
tab in the Write image files to option and burn the image later.

19.4 Writing ISO Images

If you already have an ISO image, go to 7ools > Burn CD Image or Tools > Burn DVD
15O Image. A window opens in which to enter the location of the Image fo Burn. K3b
calculates a check sum and displays it in MD5 Sum. Make sure to compare ISO files
you downloaded from the Internet with the MD5 sum provided by the source of the
image. If the sums are different, the image has not been downloaded correctly.

Choose the medium and writer to use in Burn Medium. Select the speed of writing. Set
your preferences, such as number of copies in Settings. Their meaning is the same as
if creating a new CD or DVD from sratch. To burn the disk, click Start.

19.5 Creating a Multisession CD or
DVD

Multisession discs can be used to write data in more than one burning session. This is
useful, for example, for writing backups that are smaller than the media. In each session,
you can add another backup file. The interesting part is that you are not only limited to
data CDs or DVDs. You can also add audio sessions in a multisession disc.

To start a new multisession disc, do the following;:

1 Create your data disc first and add all your files. You cannot start with an audio
CD session. Make sure that you do not fill up the entire disc, because otherwise
you cannot append a new session.

2 Burn your data with Project > Burn.

3 In the dialog box that appears, go to the Misc tab and select Start Multisession.
In the case of DVD, do not use the DAO writing mode, because it does not support
multisession.
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4 Configure other options if needed. See also Abschnitt 19.1, ,,Creating a Data CD
or DVD* (S. 267).

5 Start the burning session with Burn.

After a successful burning process, you have created a multisession disc. As long as
the media contains enough space, you can append more sessions if you like. Finish
discs with Finish Multisession only if you are sure you do not need any new sessions
or the space is occupied.

ANMERKUNG: About Storage Space on Multisession Discs

Be aware that multisession discs need space for bookkeeping all the entries
from your sessions. This leads to a smaller amount of available space on your
disc. The amount depends on the number of sessions.

19.6 For More Information

Apart from the functions described above, K3b offers other functions, such as ripping
music from audio CDs, rewriting CDs, and more. You can find more informations about
K3bathttp://k3b.org/.

Burning CDs and DVDs

273


http://k3b.org/




Moving from Windows to
Linux

If you are coming from Microsoft Windows*, take a look at how familiar elements of
Windows translate to openSUSE®. After logging in, you will notice that the desktop
has a well-known layout and recognizable icons, many of them similar to the Windows

and Macintosh desktops.

Abbildung A.1 KDE Desktop

O gm0 RueQ 22,
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A.1 Starting Applications from the
Main Menu

Similar to the Start menu on Windows, you can access all the programs installed on
your system from the main menu. To open the menu click the green SUSE icon in the
left corner of the panel. The function-oriented menu structure makes it easy to find the
right application for your purpose even if you do not know the application names yet.
Find more information about the main menu in Abschnitt 1.3.1, ,,Accessing the Main
Menu“ (S. 10).

Abbildung A.2 Main Menu in KDE

Alternatively, you can also start programs from the command line. Press Alt + F2 to
open a dialog where you can enter a command to start the application. The name of the
command is often (but not always) the application name written in lowercase.
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A.2 Managing Files

To start Konqueror, the default KDE file manager (and Internet browser), press Alt +
F2 and enter konqueror. To view the contents of your home directory, click Personal
Files. To open this view directly, use the quick start icon with a house in the panel.

Abbildung A.3 Windows Explorer and Konqueror
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For more information about Konqueror as a file manager, see Abschnitt 1.4, ,,Managing
Folders and Files with Konqueror® (S. 19).

A.3 Using the Command Line

To run commands in a command line environment, similar to a command prompt on
Windows, press Alt + F2 and enter konsole or use the quick start icon in the panel.
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Abbildung A.4 Windows Command Prompt and Konsole Terminal
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Read more about working with the command line in Kapitel 19, Arbeiten mit der Shell
(tReferenz).

A.4 Customizing Your Desktop

To change to the way your KDE desktops looks and behaves, press Alt + F2 and enter
kcontrol. Some of the settings you might want to change include the desktop back-
ground, screen saver, keyboard and mouse configuration, sounds, and file associations.
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Abbildung A.5 Windows Control Panel and KDE Control Center
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For more information, see Abschnitt 2.1, ,,The KDE Control Center” (S. 51).

A.5 Switching between Applications

Similar to the taskbar on Windows, the bottom panel in KDE lets you easily switch
between open windows. Unlike Windows, KDE lets you set up multiple desktops
where each one can run different programs. Switch between them with a single click.

TIPP: Using Shortcut Keys

You can also use shortcut keys to switch between your multiple desktops and
the applications running. Use the familiar Alt + —| to switch between applica-
tions. With Strg + F1, Strg + F2, etc., switch between desktops.
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Abbildung A.6 Windows Panel and KDE Panel
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For more information about Konqueror as a file manager, see Abschnitt 2.2, ,,Configuring
Desktop Objects™ (S. 54).

A.6 Accessing Network Resources

From your desktop, you can access files and directories or certain services on remote
hosts or make your own files and directories available to other users in your network.
openSUSE offers various different ways of accessing and creating network-shared
resources. Given that the network structure and the configuration of your computer
allow for it, you can easily browse your network for shared resources and services with
your file manager, Konqueror.

Abbildung A.7 Windows My Network Places and Konqueror Network Browsing
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To learn more about the various possibilities of accessing network resources, refer to
Kapitel 8, Accessing Network Resources (S. 151).
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GNU Licenses

This appendix contains the GNU General Public License and the GNU Free Documen-
tation License.

GNU General Public License

Version 2, June 1991
Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended
to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to
most of the Free Software Foundation’s software and to any other program whose authors commit to using it. (Some other Free Software Foundation
software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom
to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change
the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions
translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must
make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

‘We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute
and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the
software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems intro-
duced by others will not reflect on the original authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually
obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone’s
free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.
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GNU GENERAL PUBLIC LICENSE TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0.  This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the
terms of this General Public License. The ,,Program*, below, refers to any such program or work, and a ,,work based on the Program* means either the
Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifica-
tions and/or translated into another language. (Hereinafter, translation is included without limitation in the term ,,modification®.) Each licensee is
addressed as ,,you“.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program
is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been
made by running the Program). Whether that is true depends on what the Program does.

1.  You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any medium, provided that you conspicuously
and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License
and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

‘You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such
modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a)  You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

b)  You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to
be licensed as a whole at no charge to all third parties under the terms of this License.

c) Ifthe modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the
most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying
that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License.
(Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to
print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably
considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as
separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must
be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who
wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to
control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a
storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections
1 and 2 above provided that you also do one of the following:

a)  Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2
above on a medium customarily used for software interchange; or,

b)  Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing
source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above
on a medium customarily used for software interchange; or,

¢)  Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for
noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b
above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means
all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation
of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source
or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component
itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the
source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with
the object code.

4.  You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy,
modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have
received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.
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5.  You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the
Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the
Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distri-
buting or modifying the Program or works based on it.

6.  Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original
licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients’
exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7.  If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are
imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the condi-
tions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations,
then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the
Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to
refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the
section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this
section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many
people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that
system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that
choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8.  If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright
holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution
is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9.  The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and ,,any later
version®, you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foun-
dation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10.  Ifyou wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask
for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make
exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting
the sharing and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT
PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER
PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING,
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE
ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE
DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR
ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR
DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR
INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE
OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS),
EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software
which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion
of warranty; and each file should have at least the ,,copyright* line and a pointer to where the full notice is found.

one line to give the program’s name and an idea of what it does. Copyright (C) yyyy name of author
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This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License

as published by the Free Software Foundation; either version 2
of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author
Gnomovision comes with ABSOLUTELY NO WARRANTY; for details
type “show w’. This is free software, and you are welcome
to redistribute it under certain conditions; type "show c’
for details.

The hypothetical commands "show w’ and "show ¢’ should show the appropriate parts of the General Public License. Of course, the commands you use
may be called something other than “show w’ and "show c’; they could even be mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a ,,copyright disclaimer* for the program, if necessary.
Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright
interest in the program ' Gnomovision’

(which makes passes at compilers) written

by James Hacker.

signature of Ty Coon, 1 April 1989
Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may
consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Lesser General Public
License [http://www.fsf.org/licenses/lgpl.html] instead of this License.

GNU Free Documentation License

Version 1.2, November 2002
Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

PREAMBLE

The purpose of this License is to make a manual, textbook, or other functional and useful document “free” in the sense of freedom: to assure everyone
the effective freedom to copy and redistribute it, with or without modifying it, either commercially or noncommercially. Secondarily, this License pre-
serves for the author and publisher a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of ,,copyleft, which means that derivative works of the document must themselves be free in the same sense. It complements
the GNU General Public License, which is a copyleft license designed for free software.
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‘We have designed this License in order to use it for manuals for free software, because free software needs free documentation: a free program should
come with manuals providing the same freedoms that the software does. But this License is not limited to software manuals; it can be used for any
textual work, regardless of subject matter or whether it is published as a printed book. We recommend this License principally for works whose purpose
is instruction or reference.

APPLICABILITY AND DEFINITIONS

This License applies to any manual or other work, in any medium, that contains a notice placed by the copyright holder saying it can be distributed
under the terms of this License. Such a notice grants a world-wide, royalty-free license, unlimited in duration, to use that work under the conditions
stated herein. The ,,Document®, below, refers to any such manual or work. Any member of the public is a licensee, and is addressed as ,,you*. You
accept the license if you copy, modify or distribute the work in a way requiring permission under copyright law.

A , Modified Version“ of the Document means any work containing the Document or a portion of it, either copied verbatim, or with modifications
and/or translated into another language.

A ,Secondary Section“ is a named appendix or a front-matter section of the Document that deals exclusively with the relationship of the publishers or
authors of the Document to the Document’s overall subject (or to related matters) and contains nothing that could fall directly within that overall subject.
(Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any mathematics.) The relationship could be a matter
of historical connection with the subject or with related matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The ,Invariant Sections“ are certain Secondary Sections whose titles are designated, as being those of Invariant Sections, in the notice that says that the
Document is released under this License. If a section does not fit the above definition of Secondary then it is not allowed to be designated as Invariant.
The Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections then there are none.

The ,,Cover Texts* are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover Texts, in the notice that says that the Document
is released under this License. A Front-Cover Text may be at most 5 words, and a Back-Cover Text may be at most 25 words.

A | Transparent“ copy of the Document means a machine-readable copy, represented in a format whose specification is available to the general public,
that is suitable for revising the document straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or (for
drawings) some widely available drawing editor, and that is suitable for input to text formatters or for automatic translation to a variety of formats sui-
table for input to text formatters. A copy made in an otherwise Transparent file format whose markup, or absence of markup, has been arranged to thwart
or discourage subsequent modification by readers is not Transparent. An image format is not Transparent if used for any substantial amount of text. A
copy that is not ,, Transparent* is called ,,Opaque*.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input format, LaTeX input format, SGML or XML
using a publicly available DTD, and standard-conforming simple HTML, PostScript or PDF designed for human modification. Examples of transparent
image formats include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited only by proprietary word processors,
SGML or XML for which the DTD and/or processing tools are not generally available, and the machine-generated HTML, PostScript or PDF produced
by some word processors for output purposes only.

The ,,Title Page“ means, for a printed book, the title page itself, plus such following pages as are needed to hold, legibly, the material this License
requires to appear in the title page. For works in formats which do not have any title page as such, ,, Title Page“ means the text near the most prominent
appearance of the work’s title, preceding the beginning of the body of the text.

A section ,,Entitled XYZ* means a named subunit of the Document whose title either is precisely XYZ or contains XYZ in parentheses following text
that translates X'YZ in another language. (Here XYZ stands for a specific section name mentioned below, such as ,,Acknowledgements®, ,,Dedications®,
~Endorsements®, or ,,History“.) To ,,Preserve the Title“ of such a section when you modify the Document means that it remains a section ,,Entitled
XYZ* according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies to the Document. These Warranty Disclaimers
are considered to be included by reference in this License, but only as regards disclaiming warranties: any other implication that these Warranty
Disclaimers may have is void and has no effect on the meaning of this License.

VERBATIM COPYING

You may copy and distribute the Document in any medium, either commercially or noncommercially, provided that this License, the copyright notices,
and the license notice saying this License applies to the Document are reproduced in all copies, and that you add no other conditions whatsoever to
those of this License. You may not use technical measures to obstruct or control the reading or further copying of the copies you make or distribute.
However, you may accept compensation in exchange for copies. If you distribute a large enough number of copies you must also follow the conditions
in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

COPYING IN QUANTITY

If you publish printed copies (or copies in media that commonly have printed covers) of the Document, numbering more than 100, and the Document’s
license notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on
the front cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you as the publisher of these copies. The
front cover must present the full title with all words of the title equally prominent and visible. You may add other material on the covers in addition.
Copying with changes limited to the covers, as long as they preserve the title of the Document and satisfy these conditions, can be treated as verbatim
copying in other respects.
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If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed (as many as fit reasonably) on the actual cover,
and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either include a machine-readable Transparent copy
along with each Opaque copy, or state in or with each Opaque copy a computer-network location from which the general network-using public has
access to download using public-standard network protocols a complete Transparent copy of the Document, free of added material. If you use the latter
option, you must take reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will
remain thus accessible at the stated location until at least one year after the last time you distribute an Opaque copy (directly or through your agents or
retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing any large number of copies, to give them a
chance to provide you with an updated version of the Document.

MODIFICATIONS

You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and 3 above, provided that you release the Modified
Version under precisely this License, with the Modified Version filling the role of the Document, thus licensing distribution and modification of the
Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

A.  Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and from those of previous versions (which should, if
there were any, be listed in the History section of the Document). You may use the same title as a previous version if the original publisher of that ver-
sion gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of the modifications in the Modified Version, together
with at least five of the principal authors of the Document (all of its principal authors, if it has fewer than five), unless they release you from this
requirement.

C.  State on the Title page the name of the publisher of the Modified Version, as the publisher.

D.  Preserve all the copyright notices of the Document.

E.  Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

F.  Include, immediately after the copyright notices, a license notice giving the public permission to use the Modified Version under the terms of this
License, in the form shown in the Addendum below.

G.  Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given in the Document’s license notice.
H. Include an unaltered copy of this License.

1. Preserve the section Entitled ,History“, Preserve its Title, and add to it an item stating at least the title, year, new authors, and publisher of the
Modified Version as given on the Title Page. If there is no section Entitled ,,History* in the Document, create one stating the title, year, authors, and
publisher of the Document as given on its Title Page, then add an item describing the Modified Version as stated in the previous sentence.

J.  Preserve the network location, if any, given in the Document for public access to a Transparent copy of the Document, and likewise the network
locations given in the Document for previous versions it was based on. These may be placed in the ,History* section. You may omit a network location
for a work that was published at least four years before the Document itself, or if the original publisher of the version it refers to gives permission.

K.  For any section Entitled ,,Acknowledgements® or ,,Dedications“, Preserve the Title of the section, and preserve in the section all the substance
and tone of each of the contributor acknowledgements and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles. Section numbers or the equivalent are not considered
part of the section titles.

M.  Delete any section Entitled ,,Endorsements*. Such a section may not be included in the Modified Version.
N. Do not retitle any existing section to be Entitled ,,Endorsements* or to conflict in title with any Invariant Section.
O.  Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sections and contain no material copied from the
Document, you may at your option designate some or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the
Modified Version’s license notice. These titles must be distinct from any other section titles.

You may add a section Entitled ,,Endorsements*, provided it contains nothing but endorsements of your Modified Version by various parties--for
example, statements of peer review or that the text has been approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as a Back-Cover Text, to the end of the list of Cover
Texts in the Modified Version. Only one passage of Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made
by) any one entity. If the Document already includes a cover text for the same cover, previously added by you or by arrangement made by the same
entity you are acting on behalf of, you may not add another; but you may replace the old one, on explicit permission from the previous publisher that
added the old one.
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The author(s) and publisher(s) of the Document do not by this License give permission to use their names for publicity for or to assert or imply endor-
sement of any Modified Version.

COMBINING DOCUMENTS

You may combine the Document with other documents released under this License, under the terms defined in section 4 above for modified versions,
provided that you include in the combination all of the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant
Sections of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections may be replaced with a single copy. If there
are multiple Invariant Sections with the same name but different contents, make the title of each such section unique by adding at the end of it, in par-
entheses, the name of the original author or publisher of that section if known, or else a unique number. Make the same adjustment to the section titles
in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections Entitled ,,History* in the various original documents, forming one section Entitled ,,History*; like-
wise combine any sections Entitled ,,Acknowledgements®, and any sections Entitled ,,Dedications*. You must delete all sections Entitled ,,Endorsements*.

COLLECTIONS OF DOCUMENTS

You may make a collection consisting of the Document and other documents released under this License, and replace the individual copies of this
License in the various documents with a single copy that is included in the collection, provided that you follow the rules of this License for verbatim
copying of each of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License, provided you insert a copy of this License
into the extracted document, and follow this License in all other respects regarding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS

A compilation of the Document or its derivatives with other separate and independent documents or works, in or on a volume of a storage or distribution
medium, is called an “aggregate” if the copyright resulting from the compilation is not used to limit the legal rights of the compilation’s users beyond
what the individual works permit. When the Document is included in an aggregate, this License does not apply to the other works in the aggregate which
are not themselves derivative works of the Document.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the Document is less than one half of the entire aggre-
gate, the Document’s Cover Texts may be placed on covers that bracket the Document within the aggregate, or the electronic equivalent of covers if
the Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole aggregate.

TRANSLATION

Translation is considered a kind of modification, so you may distribute translations of the Document under the terms of section 4. Replacing Invariant
Sections with translations requires special permission from their copyright holders, but you may include translations of some or all Invariant Sections
in addition to the original versions of these Invariant Sections. You may include a translation of this License, and all the license notices in the Document,
and any Warranty Disclaimers, provided that you also include the original English version of this License and the original versions of those notices and
disclaimers. In case of a disagreement between the translation and the original version of this License or a notice or disclaimer, the original version will
prevail.

If a section in the Document is Entitled ,,Acknowledgements®, ,Dedications®, or ,History“, the requirement (section 4) to Preserve its Title (section 1)
will typically require changing the actual title.

TERMINATION

You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under this License. Any other attempt to copy,
modify, sublicense or distribute the Document is void, and will automatically terminate your rights under this License. However, parties who have
received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE

The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License from time to time. Such new versions will
be similar in spirit to the present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a particular numbered version of this License ,,or
any later version® applies to it, you have the option of following the terms and conditions either of that specified version or of any later version that has
been published (not as a draft) by the Free Software Foundation. If the Document does not specify a version number of this License, you may choose
any version ever published (not as a draft) by the Free Software Foundation.

ADDENDUM: How to use this License for your documents

To use this License in a document you have written, include a copy of the License in the document and put the following copyright and license notices
just after the title page:

Copyright (c) YEAR YOUR NAME.
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Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2

or any later version published by the Free Software Foundation;

with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts.
A copy of the license is included in the section entitled “GNU

Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” line with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples in parallel under your choice of free software
license, such as the GNU General Public License, to permit their use in free software.
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